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  i.   DipTrace tutoriál – úvodní slovo originálu
Tento dokument vám umožní snadno si osvojit práci s programem tím, že navrhnete 

jednoduché zapojení a jeho desku plošných spojů (DPS), položky do knihoven schématických 
značek a půdorysu součástek (kontaktních matric), a nakonec zkoušením různých funkcí tohoto 
programového balíku. Tutoriál vás provází krok za krokem procesem návrhu a na mnohých 
dalších odbočkách vám odhaluje další vlastnosti programu. Pokud máte jakékoliv nejasnosti při 
studiu této příručky, spojte se s naším osazenstvem: support@diptrace.com. Rádi vám 
poskytneme pomoc a odpovíme na vaše otázky. Tato verze tutoriálu byla napsána pro DipTrace 
ver. 2.0.01 (sestava 20. únor 2009). 

ii. Úvod k českému překladu
Sada programů DipTrace pro návrh a realizaci elektrických obvodů ve formě desek 

plošných spojů je specifická tím, že neoslovuje jen specialisty CAD/CAM, ale také běžné 
uživatele osobních počítačů s operačním systémem Windows, pro které zachovává návyky 
získané z jejich dosavadní práce s počítačem i pro tak specifickou činnost, jakou je komplexní 
počítačové zpracování podkladů pro výrobu DPS. Z toho současně vyplývá, že o tuto oblast se 
s úspěchem mohou zajímat i lidé, kteří z oblasti CAD/CAM nemají zkušenosti a neznají ani 
odborný slang, pocházející z anglické terminologie. Překlad se tedy snaží vyhýbat se takovým 
termínům a používat české výrazy i tam, kde se to odborníkům nebude asi líbit (via = spojka, 
route = trasa, pattern/footprint/decal = kontaktní/osazovací matrice, pad = ploška, net = síť 
apod.), ale třeba výrazy pin a netlist jsou v českém textu ponechány. 

Překlad tutoriálu se také musel vypořádat se situaci, kdy uživatel může mít sadu 
programů nainstalovanou s anglickým nebo (snad někdy) s českým prostředím. Aby vyhověla 
jedna společná verze tutoriálu, jsou všechny termíny z uživatelského prostředí většinou uváděny 
v obou jazycích, a to ve struktuře {anglický termín  ≡   český termín}. Časem to sice může jít na 
nervy, ale je to vlastně slovníček odborných výrazů i s častým opakováním, a tak se do té 
odborné terminologie nakonec snadno pronikne i začátečníkovi. Pokud je ve struktuře možnost 
volby jedné z několika možností, jsou tyto možnosti oddělené svislou linkou - { Show | Hide  ≡ 
Ukázat | Skrýt}.

 iii.  Rychlý přehled
Programová sada DipTrace se skládá ze čtyř samostatných programů:

Název souboru: Cesta a   název programu  :  
ComEdit.exe {Start → Všechny programy → DipTrace → Pattern Editor}

-tvorba kontaktní matrice osazení součástky (výstupní knihovna *.lib)
SchemEdit.exe {Start → Všechny programy → DipTrace → Component Editor}

-  tvorba schematických značek součástek (výstupní knihovna *.eli)
Schematic.exe {Start → Všechny programy → DipTrace → Schematic}

-  tvorba schémat zapojení (výstupní soubor *.dch)
PCB.exe {Start → Všechny programy → DipTrace → PCB Layout}

-  tvorba spojů a výrobních podkladů DPS (výstupní soubor *.dip)

Tyto programy na sebe navazují strukturou dat, nad kterými navzájem pracují v tomto 
logickém sledu: 
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1. Pro součástku se vytvoří kontaktní matrice osazení, což představuje definici fyzického 
rozmístění vývodů, jejich vlastností a obrysu pouzdra součástky. Matrice se pojmenuje a uloží do 
knihovny, to vše pomocí programu ComEdit.exe. Velké množství matric se už nachází 
v standardně dodávaných knihovnách.
2. Pro součástku se vytvoří schematická značka součástky, definující všechny elektrické 
vývody a jejich charakteristiky, mohou být zadány i parametry pro počítačovou simulaci obvodu. 
K součástce se může přiřadit kontaktní matrice osazení, vytvořená v kroku 1. Schematická 
značka se pojmenuje a uloží do knihovny, to vše pomocí programu SchemEdit.exe. Velké 
množství schematických značek se už nachází v standardně dodávaných knihovnách.
3. Pro zadaný projekt se navrhne schéma obvodového zapojení, do které se z knihoven 
schématických značek přenášejí schematické symboly použitých součástek. Pomocí dostupných 
nástrojů se vykoná potřebné propojení elektrických vývodů a kontrola výskytu případných chyb. 
To vše pomocí programu Schematic.exe.
4. Schéma zapojení se otevře programem PCB.exe, provede se rozmístění součástek 
(automaticky a manuálně), ohraničení desky, vzájemné propojení součástek (automaticky 
a manuálně), kontrola zapojení a kontrola návrhových pravidel. Po opravách zjištěných 
nedostatků je potom možné exportovat další datové soubory ve formátech standardních pro 
výrobce DPS.

 iv.  Instalace české lokalizace uživatelského prostředí
Jazyková lokalizace programové sady DipTrace je soustředěná do čtyř souborů ve složce 

C:\Program Files\DipTrace\Data pro jednotlivé programy: comedit.lng, schemedit.lng, 
schematic.lng a diptrace.lng, pokud jste pro instalaci nezvolili jiné umístění. Na stránce 
www.diptrace.com/language.php  jsou uvedeny jazykové mutace k dispozici pro uživatele. 
Regionální verzi stáhnete z této stránky ve formě instalačního programu a jeho spuštěním na 
počítači s instalací sady DipTrace se provede změna uživatelského jazykového prostředí. 
Rozsáhlá funkce nápovědy „Help“ zůstává však nadále v anglickém jazyce.

 v.  Čím začít?
Instalaci programů máte ukončenou, zřejmě se nevyskytly žádné problémy. Než začnete 

navrhovat obvodové schéma a měnit ho na tištěný spoj, navrhujeme vám stručné seznámení 
s uživatelskou plochou jednotlivých programů a s možnostmi jejího přizpůsobení skrýváním 
a zobrazováním jednotlivých prvků rozhraní. Na konci tutoriálu v části IV máte pro tento účel 
grafickou pomůcku, možná nebude zbytečné těchto pár stran si vytisknout a mít je po ruce pro 
případ rychlé orientace.

Pokud přijmete tento návrh, nebudete zaskočeni situací, kdy obrázek tutoriálu vypadá 
jinak než vaše obrazovka.

S bezplatnou verzí můžete (ne za účelem zisku!) produkovat podklady pro výrobu DPS 
do dvou vrstev a 250 pinů. Zkušební verze (na 30 dní) taková omezení nemají.
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I Návrh jednoduchého zapojení a DPS
Tato část tutoriálu má za cíl vás naučit vytvořit jednoduché zapojení astabilního 

multivibrátoru a jeho desku plošných spojů (DPS) pomocí programů DipTrace.

Uvedené zapojení budete vytvářet s použitím DipTrace programu pro návrh schémat 
(schematic.exe). Program spusťte běžným postupem:

{Start → Všechny programy → DipTrace → Schematic}
Při prvním spuštění programu Schematic po instalaci může se objevit dialogové okno pro 

výběr grafického modu a zabarvení:
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Vyberte si grafický mód, který vám nejlépe vyhovuje:
1.   Mód Direct3D je nejrychlejším pro typické PC s OS Windows a doporučuje se používat ho, 
pokud na vašem počítači pracuje správně a nemáte vysoce kvalitní grafický systém 
a hardwarovým řešením systému OpenGL. Tento mód však též závisí na verzích hardwaru 
a ovladačů, takže malé procento počítačů (většinou ty s úplně novými/neodladěnými nebo 
zastaralými operačními systémy či ovládači) může mít s ním potíže (pozůstatky na obrazovce 
nebo zmizení některých objektů).
2.   Mód OpenGL běžně pracuje o trochu pomaleji než Direct3D, ale je více univerzální pro 
různé operační systémy a méně závislý na grafických kartách a ovladačích. Bude též nejlepší 
volbou pro vysoce kvalitní grafické/inženýrské stanice s profesionálními OpenGL grafickými 
kartami. V každém případě můžete zkoušet oba systémy na rozsáhlých projektech a vybrat si ten, 
který vám lépe vyhovuje.
3.   Mód Windows GDI může být jako vhodná alternativa pokud Direct3d ani OpenGL nepracují 
správně s vaším typem grafické karty. Je o hodně pomalejší, ale nezávisí na vlastnostech 
ovladačů/hardwaru/operačního systému. Tento mód je postačující pro pohodlnou práci na 
malých a středně velkých projektech.

V našich lekcích budeme používat bílé pozadí jako vhodnější pro tisk tohoto tutoriálu, vy 
si však můžete volit barevné schéma podle libosti. Můžete ho také kdykoliv změnit nebo upravit 
výběr barev použitím voleb {View →  Colors  ≡  Zobrazit → Barvy}, stejné tak jako grafický 
mód {View → Grafic Mode → Open GL | Direct 3D | Windows GDI   ≡  Zobrazit → Grafický 
mód → Open GL | Direct 3D | Windows GDI}.

Stejné dialogové okno možno vyvolat i v programu PCB Layout. Programové moduly 
Component Editor a Pattern Editor používají nastavení z modulů Schematic resp. PCB Layout.

Zůstává ještě volba jednotek pro vyjádření délky. Ve všech programech DipTrace je na to 
stejný postup – zvolit jednotku délky z nabídky hlavního menu {View → Unit → Inch | mil | mm 
≡   Zobrazit → Jednotka → palec | palec/1000 | mm}. Zvolenou jednotku je možné kdykoliv 
v průběhu práce změnit, pro soulad s textem tohoto návodu zvolte vždy jednotku [mm].

Když budete později otevírat v programu „Schematic“ (nebo i „PCB Layout“) soubor, 
může se objevit toto hlášení:

To vás upozorňuje, že v popisu součástek jsou použity „True Type“ fonty, méně vhodné 
v případech jako tento, když v aplikaci dochází k zvětšování a zmenšování obrazu. Vhodnější je 
tedy zvolit vektorový typ fontů postupem {View → Part Marking → Font → Vektor ≡   Zobrazit 
→ Značení součástky → Font → Vektorový} z hlavního menu.

1 Volba velikosti listu schématu a umístění názvů

Nastavte velikost strany schématu a vložte orámování: {File → Title and Sheet Setup...  ≡ 
Soubor → Nastavení listu a stránky}, v teď otevřeném okně zvolte velikost listu v poli {Sheet 
tempate  ≡  Předloha listu} např. na ANSI-A. Potom se přesuňte na spodek okna a zaškrtněte 
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volby {Display Titles  ≡  Ukázat názvy} a {Display Sheet  ≡  Ukázat list}.

Na závěr stlačte tlačítko {Close  ≡  Zavřít}.
Uvědomte si, že zobrazení či skrytí zobrazení listu nebo titulu můžete vykonat 

i z hlavního menu postupem: {View → Display Titles  ≡  Zobrazit → Ukázat názvy} nebo {View 
→ Display Sheet  ≡  Zobrazit → Ukázat list}.

Stláčením klávesy „-“ dosáhnete zmenšování zobrazeného listu, až bude nakonec vidět 
celý. Zapamatujte si, že pomocí kláves „+“, „-“ nebo rolovacím kolečkem na myši můžete měnit 
měřítko zobrazení schématu – „Zoom“. Když kurzor myši ukazuje na součástku nebo vybranou 
oblast, klávesy „+/-“ nebo kolečko myši ovládají zoom. Měřítko zobrazení však můžete též 
změnit výběrem příslušné hodnoty z rozbalovacího seznamu měřítka na standardní liště nebo 
tam zapsat svou vlastní hodnotu.

Možná, že na ploše obvodového zapojení vidíte souřadnicový systém jako vodorovnou 
a svislou čáru, který v této chvíli působí rušivě. Můžete ho vypnout stlačením klávesy „F1“ nebo 
výběrem položky menu {View → Display Origin  ≡  Zobrazit → Ukázat počátek}.

Souřadnicová soustava je na ploše znázorněna i rastrem bodů s pravidelnými rozestupy. 
Velikost těchto rozestupů si můžete zvolit v poli seznamu rastrů na standardní liště, nebo přes 
položku menu {View → Grid Size → # | Custom  ≡  Zobrazit →  Rozestup rastru → č. | 
Přizpůsobit}, položka {Custom  ≡  Přizpůsobit} vám umožní stanovit si svůj vlastní rastr mřížky. 
Hustotu bodů na obrazovce pochopitelně ovlivňuje i velikost zvětšení zobrazeného listu. Když 
měřítko zmenšujete, jsou body hustější. Pokud by však zobrazení vycházelo příliš husté, začne se 
zobrazovat jen jeden z deseti bodů, takže zobrazený rastr bude 10x větší než nastavený rozestup. 
Možná usoudíte, že dokážete kreslit schéma bez zobrazeného rastru, potom vypněte jeho 
zobrazení klávesou „F11“ nebo výběrem {View → Grid  ≡  Zobrazit → Rastr} z hlavního menu.
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Text do rohové tabulky vložíme tak, že kurzorem myši najedeme na příslušné pole (mělo 
by se vysvítit zeleně) , potom klikneme levým tlačítkem, odezvou je otevření dialogového okna 
{Field Properties  ≡  Vlastnosti pole}. Do tohoto dialogového okna můžete teď napsat text, zvolit 
zarovnání {Left | Center | Right  ≡  vlevo | na střed | vpravo} a font. V tomto případě napište 
„Astabilní multivibrátor“, stlačte {Font} a nastavte velikost písma na 12. Potom klikněte „OK“, 
aby se změny projevily a okno se zavřelo. Všimněte si, že do pole se může zapsat i víceřádkový 
text.
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Zobrazení rohové tabulky se dá zvětšit tak, že na ní najedeme kurzorem myši a buď 
tlačítky „+/-“ nebo kolečkem myši měníme velikost zobrazení. Zkuste si, že jiným možným 
způsobem je použít {Zoom Window  ≡  Zvětšení okna} tlačítko na standardní  liště (12.  tlačítko 
zleva). Klikněte naň, potom přesuňte kurzor myši na levý horní roh oblasti kterou chcete zvětšit, 
stlačte a přidržte stlačené levé tlačítko myši, přesuňte kurzor do úhlopříčného rohu a tam 
uvolněte tlačítko. Pro návrat na velikost předchozího měřítka použijte nástroj {Undo Zoom  ≡ 
Zvětšení zpět} (tlačítko hned nalevo od pole měřítka).
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Běžte na položku hlavního menu {File → Save As ..  ≡  Soubor → Uložit jako..}, napište 
vámi zvolený název souboru (třeba „Multivibrátor“), ujistěte se, že máte nastavený vámi 
zvolenou složku  a kliknete na tlačítko {Uložit}.

2 Konfigurace knihoven

Před prvním použitím programu Schematic nebo PCB Layout bude asi chtít nastavit 
svoje knihovny. Běžte tedy na položku menu {Library → Library Setup  ≡  Knihovny → 
Nastavení knihovny} :

Je možné, že na pravé straně uvidíte text {No Library File  ≡ Není soubor knihovny}, to 
však ignorujte a zobrazte spodní část obsahu okna tažením posuvníku na pravé straně rámu {All 
Libraries  ≡  Všechny knihovny}. Při přesunu dolu uvidíte všechny knihovny, které byly spolu se 
softwarem dodány.
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Sada programů DipTrace poskytuje dva způsoby na aktivaci knihoven:
1. Otevření knihoven ze specifikované složky:

Tento způsob je zvolen zaškrtnutím volby {Get Libraries from Folder  ≡  Získat knihovny 
ze složky} v horním levém rohu okna {Library Setup  ≡  Nastavení knihoven}. Pro výběr složky 
s knihovnami stlačte tlačítko „...“ napravo od políčka s cestou ke složce. Ujistěte se, že jste 
zvolili složku  'Lib', která byla nainstalována spolu s programem. Později můžete vyhledávat 
jakékoli jiné cesty (například vámi vytvořenou cestu pro vaši vlastní knihovnu 'Cvičná 
knihovna'), ale teď na samém začátku, kdy nejste ještě obeznámeni s koncepcí knihoven, 
dodržujte prosím tyto pokyny.

2. Aktivace knihoven s použitím seznamu
Tento způsob je použit pokud volba {Get Libraries from Folder  ≡  Získat knihovny ze 

složky} není zaškrtnutá. Ovládací prvky na pravé straně seznamu aktivních knihoven jsou nyní 
funkční: „<<“ - přidá mezi aktivní knihovnu  označenou v seznamu {All Libraries  ≡  Všechny 
knihovny}, „ … „ -  přidá mezi aktivní knihovnu  vyhledanou na disku, „▲“ - posouvá knihovnu 
v seznamu nahoru, „▼“ - posouvá knihovnu v seznamu dolu, „Del“ - vymaže označenou 
knihovnu ze seznamu aktivních.

Způsob podle bodu 1 je standardně nastaven po spuštění programu.
Všechny známé knihovny jsou automaticky umístěny do seznamu {All Libraries  ≡ 

Všechny knihovny} na pravé straně dialogového okna. Pomocí tlačítek {Add  ≡  Přidat} nebo 
{Delete  ≡  Odebrat} můžete tento seznam upravovat.

Ukončete dialog s nastavením knihoven kliknutím na tlačítko {Close  ≡  Zavřít} 
a všechny změny, které jste případně udělali, se odrazí na liště knihoven.

Když budete chtít přesunout některé součástky z vašeho schématu do knihovního 
souboru, vyznačte tyto součástky (třeba přidržením klávesy „Ctrl“ a postupným levým klikáním 
na každou z těchto součástek), potom přesuňte kurzor myši nad jednu z nich, klikněte pravým 
tlačítkem a vyberte nabídku {Save to Library  ≡  Uložit do knihovny}. Z další zobrazené 
podnabídky si vyberete, zda přidat vybrané součástky do aktivní knihovny nebo do jiné.

3 Návrh zapojení multivibrátoru

Pokud program Schematic pro návrh schémat není spuštěn, udělejte to už známým 
postupem:  {Start → Všechny programy → DipTrace → Schematic}. Pokud máte aktivované 
dodané knihovny, vidíte jejich názvy na liště knihoven nad plochou pro schéma, v opačném 
případě aktivujte knihovny podle popisu v předcházející části. Zobrazení lišty může být 
i vypnuté/zapnuté klávesou „F5“. Nyní na liště knihoven klikněte na tlačítko {Transistor}. Názvy 
knihoven na liště můžete posouvat tlačítky „◄“ a „►“, až dokud tu hledanou neuvidíte, nebo 
pomocí rohové značky „“ vpravo otevřete posouvač lišty knihoven a pracujete rychleji – 
stejnou značkou zase posouvač skryjete.

 Vertikálním posouvačem panelu symbolů na levé straně obrazovky vyhledejte tranzistor 
2N4401 a klikněte naň. Tím je zvolena jeho schématická značka, kterou dále můžete přesunout 
na plochu schématu a jedním kliknutím levým tlačítkem ho uložíte na plochu. Funkci ukládání 
součástky ukončíte pravým kliknutím na volnou plochu.
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Jak posouvat schematickou značku po ploše? S kurzorem myši nad značkou přitlačte levé 
tlačítko a táhněte značku do zamýšlené pozice (někdy popisované jako „Drag and drop“). Pokud 
potřebujete přesunout více značek najednou, musíte je nejprv vyznačit, potom uchopit a tahat. 
Vyznačení značek jednu po druhé dosáhneme kliknutím levým tlačítkem nad každou z nich při 
současně stlačeném klávesu „Ctrl“. Také je možné vybrat skupinu značek jiným způsobem: 
přesuňte kurzor do místa horního levého rohu skupiny, stlačte a podržte levé tlačítko myši, 
přesuňte kurzor do místa pravého dolního rohu skupiny a tlačítko myši uvolněte – značky 
v načrtnutém obdélníku se vyznačí (pokud nejdřív stlačíte klávesu „Ctrl“, výběr v obdélníku se 
invertuje).

Jak jste si snad už všimli, identifikační označení tranzistoru je Q1. Pokud byste to raději 
změnili na T1, posuňte kurzor nad značku tranzistoru, klikněte pravým tlačítkem a následně 
levým na horní položku nabídky s Q1. Zobrazí se dialogové okno, do kterého můžete zapsat 
nové označení, v tomto případě T1, a klikněte „OK“:

V našem zapojení potřebujeme dva tranzistory, vyberte proto opět „2N4401“ v seznamu 
součástek knihovny (levá strana obrazovky) a umístěte ho na ploše schématu. Pokud chcete 
značkou otáčet před jejím umístěním, stlačte mezerník nebo klávesu „R“. Jestli jste prvý 
tranzistor přejmenovali, změňte identifikátor i druhého na „T2“
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Na liště knihoven zvolte nyní knihovnu {Discrete} a vyhledejte vhodný rezistor. Zvolte 
RES400, což znamená rezistor s roztečí vývodů 400 mils (tisícin palce; 0,4“; 10,16 mm). 
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Do našeho zapojení potřebujeme 4 rezistory. Už víte, že je můžete jednoduše vybrat ze 
součástkového panelu vlevo, stejně jako předtím tranzistory, ukažme si ale i jinou metodu. 
Vyznačte rezistor jako v obrázku výše a třikrát ho okopírujte na další místa. Jsou dva způsoby na 
kopírování značky:
1.  Z hlavního menu zvolte {Edit → Copy  ≡  Úpravy → Kopírovat}, potom třikrát {Edit → 
Paste  ≡  Úpravy → Vložit} a  přesuňte kopie značek na požadovaná místa, nebo na 
požadovaném místě klikněte pravým tlačítkem a z otevřené nabídky zvolte {Paste  ≡ Vložit}, 
a podobně na dalších místech.

2.  Druhá metoda se nazývá {Copy Matrix  ≡   Kopírovat matici}. Vyznačte rezistor a pokračujte 
výběrem {Edit → Copy Matrix...  ≡  Úpravy → Kopírovat matici} v hlavním menu (nebo 
jednoduše stlačte „Ctrl + M“).

V dialogovém okně „Matrix“ definujte počet sloupců {Columns} a řádků {Rows} 
(v našem případe 2 sloupce a dva řádky, abychom dostali 4 rezistory) a vzájemné rozestupy 
(třeba 25 mm pro sloupce a 10 mm pro řádky) a klikněte na „OK“. Teď spatříte výslednou matici 
rezistorů:
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Přesuňte rezistory na požadovaná místa v schématu a otočte je o 90° stlačením mezerníku 
nebo klávesy „R“. Další možností jak otočit značku je zvolit nabídku {Edit → Rotate  ≡  Úpravy 
→ Točit}, anebo kliknout pravým tlačítkem nad příslušnou značkou a z otevřené nabídky si 
vybrat {Rotate}. Pro posouvání značky striktně jen v horizontálním nebo vertikálním směru (jen 
podél jedné souřadnice) stlačte a přidržte klávesu {Shift} před zahájením a v průběhu posouvání.

Při pohybu kurzorem přes značku součástky se tato značka vysvítí a v levém dolním rohu 
okna (v informačním koutě) se současně zobrazí identifikátor součástky a souřadnice její polohy. 
Pokud se kurzorem zastavíme na některé vývodu, uvidíme v levém dolním rohu navíc 
i identifikátor vývodu a elektrické sítě, ve které je vývod zapojen. Navíc budou červeně 
vysvíceny všechny vývody zapojené v této síti. Při přechodu kurzoru přes čáry spojů  se vysvítí 
celá síť stejného elektrického signálu a v levém dolním rohu okna se zobrazí identifikátor této 
sítě.

Vyzkoušejte si, že můžete posouvat celou plochu vašeho obvodového návrhu pomocí 
pravého tlačítka nebo kolečka myši. Posuňte kurzor na schéma, potom stlačte a přidržte buď 
pravé tlačítko myši nebo střední kolečko a posuňte plochu schématu do nové polohy.
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Teď si zobrazíme typovou charakteristiku tranzistorů: vyznačte tranzistory T1 a T2 (Q1 
a Q2 , pokud jste označení nezměnili) potom klikněte pravým tlačítkem na jeden z nich 
a z nabídky zvolte položku {Properties...  ≡   Vlastnosti...}. V dialogovém okně {Component 
Properties  ≡   Vlastnosti součástky} klikněte na záložku {Marking   ≡  Značení}
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V nabídce {Additional Marking / Show  ≡  Přídavné značení / Ukázat} zvolte položku 
{Type  ≡  Typ}. Tímto se v schématu zobrazí typy vyznačených součástek. Jistě jste si všimli, že 
indexové značení je už zobrazeno, protože {Default  ≡  Standardní} volba znamená zobrazení 
všeobecných vlastností součástek v schématu, a zobrazení {RefDes  ≡  Identifikátor} je 
v programu považován za standardní volbu. Klikněte na „OK“, dialogové okno se zavře a typ 
tranzistorů se ukáže na schématu. Pokud není zobrazeno označení vývodů tranzistorů, můžete to 
zařídit výběrem položky menu {View → Pin Numbers → Show  ≡  Zobrazit → Čísla pinů → 
Ukázat}. Změnit zobrazení pinů je možné i tak, že kliknutím pravým tlačítkem nad zvolenou 
součástkou se zobrazí kontextové menu a v něm se vybere položka {Pin Numbers → Show | 
Hide | Default  ≡  Čísla pinů → Ukázat | Skrýt | Standardní}.

Označení typu tranzistoru a jeho vývodů se překrývá s grafickým symbolem součástky, 
takže by se mělo trochu posunout. Pro tento účel zvolte nabídku {View → Part Marking → 
Move Tool  ≡  Zobrazit → Značení prvku → Nástroj posuvu}, anebo jednoduše stlačte klávesu 
„F10“, potom kurzorem na dané označení, které se nyní obklopí rámečkem. Přidržením levého 
tlačítka a pohybem myši dopravíte označení na požadované místo.  V době, kdy levé tlačítko je 
přidržené, možno označení i rotovat (s výjimkou označení pinu), a to stláčením mezerníku nebo 
klávesy „R“. Hned můžete přejít na další označení a pohybovat s nimi. Režim ukončíte 
opětovným stlačením „F10“ nebo „Esc“. 

Mimochodem, v nabídce možností položky {View → Part Marking   ≡  Zobrazit → 
Značení prvku} můžete definovat všeobecné vlastnosti  zobrazovaného označení k součástkám. 
Takto nastavené vlastnosti se potom týkají všech součástek s výjimkou těch, které měli označení 
nastavené individuálně (v našem případě tranzistory mají individuální nastavení).
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Upozornění: pomocí nabídky {Edit → Undo ≡  Úpravy → Zpět} anebo kliknutím na příslušné 
tlačítko standardní lišty se můžete vrátit o krok zpět k předcházející verzi zapojení. Program si 
uchovává až 50 učiněných kroků. A můžete také použít {Edit → Redo ≡  Úpravy → Znovu} 
nebo odpovídající tlačítko na návrat opačným směrem. Nezapomeňte schéma zapojení uložit 
přes menu {File → Save  ≡  Soubor → Uložit} nebo kliknutím na tlačítko uložení standardní 
lišty. Když je schéma ukládáno poprvé, zobrazí se dialogové okno {Save as  ≡  Uložit jako} pro 
určení jména souboru. Potom už pro opakované uložení netřeba nic psát, stačí nám tlačítko pro 
uložení nebo „Ctrl+S“ na klávesnici. Pokud byste však chtěli uložit soubor pod jiným jménem, 
například za účelem zálohování, prostě zopakujte postup s dialogem {File → Save as  ≡  Soubor 
→ Uložit jako}.
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Připojme teď rezistor R1 na bázi tranzistoru T1: umístěte kurzor na spodní vývod 
rezistoru R1, ten se vysvítí dočervena (pokud ne, nejste v standardním režimu, stlačte tedy „Esc“ 
nebo tlačítko {Default Mode  ≡  Standardní režim} na liště objektů), a klikněte levým tlačítkem 
myši. Posuňte kurzor dolu a vpravo na vývod báze tranzistoru T1, a opětovným kliknutím levým 
tlačítkem se vodičem propojí rezistor R1 a báze T1. Teď se opět vraťte do standardního režimu 
(např. „Esc“) a zrcadlově otočte tranzistor T2 tak, že s kurzorem nad jeho symbolem kliknete 
pravým a v kontextové nabídce zvolíte {Flip → Horizontal  ≡  Překlopit → Horizontálně}:
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Na přemístění tranzistoru ukažte naň kurzorem, přidržte levé tlačítko a pohybem myši 
posouvejte značku pod R4. Stejným postupem jakým jste připojovali R1, spojte teď R4 s bází 
T2, R2 s kolektorem T1 a R3 s kolektorem T2.
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Možná, že spoje mezi R2 a T1 nebo R3 a T3 vám vyjdou zalomené, to napravíte 
posunutím příslušné značky doleva nebo doprava už známým postupem: nad symbolem přidržet 
levé tlačítko, potáhnout a na správném místě uvolnit. Zalomený spoj není pro elektrické 
propojení nijak významný,  takže jeho srovnání je jen otázkou estetiky.

Nyní vyhledejte nalevo v seznamu kondenzátor CAP100RP, vyberte ho levým kliknutím, 
přejděte na plochu obvodového návrhu a kliknutím na dvou zvolených místech uložte dvě 
značky elektrolytického kondenzátoru, C1 a C2. Ukládání ukončíte klávesou „Esc“ nebo pravým 
kliknutím na volné ploše. Můžete pro umístění druhé značky použít funkci kopírování, jak bylo 
nedávno popsáno u rezistorů, bude to trochu zdlouhavější.

Možná jste si všimli, že pod seznamem prvků knihovny se zobrazil náhled osazovací 
matrice posledně zvolené součástky. Nebudeme však předbíhat události, jen zmiňujeme, že už v 
této fázi návrhu můžete (ale nemusíte) volit součástku s ohledem na její mechanické provedení.

Obraťte teď kondenzátor C2, aby plusový symbol byl na jeho pravé straně – pravý klik 
a {Flip → Horizontal  ≡  Překlopit → Horizontálně} v kontextové nabídce. Přemístěte oba 
kondenzátory mezi tranzistory s přihlédnutím na polaritu (horní plusem doleva). Pokud je mezi 
tranzistory a rezistory málo místa, posuňte rezistory o trochu nahoru. Všímejte si, že spoje se 
pohybují se součástkami. Tedy: kurzor myši nad rezistor R1, stlačit levé tlačítko, tahat R1 nahoru 
(všimněte si, že z původní polohy se tahá tenká linka informující o tom, kde se pohyb začal) 
a uvolnit tlačítko v požadované poloze. Posunout možno najednou celou skupinu značek. 
Vyberte R3, R4, a Q2 tak, že v jednom rohu této skupiny přidržíte levé tlačítko a táhnete kurzor 
do opačného rohu tak, že skupina značek je uvnitř nakresleného obdélníku – provedli jsme 
skupinový výběr. Uvolněte tlačítko a všechny tyto značky se vyznačí na tmavomodrou barvu. 
Teď běžte kurzorem nad jednu z těchto značek, její barva se změní na světlemodrou – vysvítí se. 
V tomto stavu se dá přidržet levé tlačítko a pohybovat najednou s celou vyznačenou skupinou 
a připojenými vodiči. 
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Všechny značky aktuálně vyznačené jsou obklopeny modrými čtverečky. Když chcete 
výběr zrušit, stačí levý klik na volnou plochu, pokud je návrh v standardním modu, nebo nejprv 
pravý klik   (nebo „Esc) na návrat do standardního modu a až potom levý klik na volné ploše.

Spojte +pól C1 s kolektorem T1:  kurzor na (+) C1 (zčervená, jinak „Esc“), kliknout 
levým tlačítkem, přesunout na vodič mezi T1 (C) a R2 (A), a opětovným levým kliknutím 
propojit. Obdobně propojte +pól C2 s kolektorem T2, a zůstávající póly C1 a C2 s bázemi 
opačných tranzistorů. Na návrat z modu propojování do standardního opět např. „Esc“.
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V seznamu součástek knihovny {Discrete  ≡  Diskrétní} na levé straně okna vyhledejte 
položku LED, zvolte ji levým kliknutím a umístěte dvě tyto diody do zapojení – dvakrát kliknout 
levým tlačítkem na zvolená místa, ukládání ukončit pravým kliknutím nebo „Esc“. Otočte 
značky už známým způsobem a připojte je k tranzistorům.
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Vložte do navrhovaného obvodu baterii z knihovny diskrétních symbolů 'Disc-Sch'. Snad 
jste si všimli, že značka baterie nemá v knihovně přiřazenu osazovací matrici {Pattern} pod 
seznamem prvků knihovny. V této knihovně a některých dalších (*_Sch) jsou jen obvodové 
symboly. Připojte vývody baterie do obvodu a tím také dokončíte celé zapojení (na následujícím 
obrázku). 

Když chcete posunout existující vodič, položte naň kurzor (spoj by se měl automaticky 
vysvítit a oboustranná šipka ukázat možný směr posouvání), potom přidržte levé tlačítko 
a posouvejte vodič do nové polohy. Pozor – pokud je aktivní mód kladení vodičů (tlačítko {Place 
Wire  ≡  Položit vodič} na liště objektů je zobrazeno stlačené) a kliknete na existující vodič, 
začne se z tohoto místa tahat nový vodič. Mód {Place Wire  ≡  Položit vodič} se zvolí vždy když 
kliknete na nezapojený vývod některé součástky, nebo ho zvolíte záměrně volbou položky menu 
{Object → Circuit → Place Wire  ≡  Objekt → Obvod → Položit vodič}, nebo stlačením již 
zmíněného tlačítka {Place Wire  ≡  Položit vodič} na liště objektů. Z toho vyplývá, že když se 
objekt nevyznačí v době kdy se na něm vyskytuje kurzor, standardní mód není aktivní, což 
změníte tlačítkem „Esc“ nebo pravým kliknutím do volné plochy.

Když chcete stávající spoj (mezi nejbližšími uzly) zrušit, posuňte naň kurzor, pravým 
kliknutím otevřete kontextovou nabídku a zvolte {Delete Wire  ≡  Zrušit spoj}. Pokud místo toho 
zvolíte {Delete Line  ≡  Zrušit úsek}, bude zrušen jen jeden přímý úsek spoje. I tady platí, že 
jakoukoliv akci můžete vrátit zpět pomocí tlačítka {Undo  ≡  Zpět}.

Nyní přidáme hodnoty součástek: klikněte pravým tlačítkem na „R1“, zvolte z otevřené 
nabídky {Properties  ≡  Vlastnosti}, do pole {Value  ≡  Hodnota} zapište 47k. Klikněte levým na 
záložku {Marking  ≡  Označení} a v rozbalovacím seznamu {Main Marking / Show  ≡  Hlavní 
označení / Ukázat} zvolte položku {Value  ≡  Hodnota}, potom v rozbalovacím seznamu 
{Additional Marking / Show  ≡  Doplňkové označení / Ukázat} zvolte položku {RefDes  ≡ 
Identifikátor}, a klikněte na „OK“. Tímto způsobem zobrazíme v zapojení hodnotu součástky 
i její identifikátor.
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Stejným způsobem vložte hodnoty ostatních součástek včetně 3 V baterie. Také můžete 
vyznačit několik symbolů najednou, pro jeden z nich otevřít kontextovou nabídku a tak nastavit 
označení hromadně pro celou vyznačenou skupinu.
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Použitá baterie byla zvolená v knihovně 'Disc_Sch'. Jak jsme už zmínili, všechny 
knihovny se zakončením *Sch obsahují jen schematické značky bez osazovacích matric 
s rozložením vývodů. Předtím, než budeme chtít proměnit obvodové zapojení do  návrhu 
plošných spojů, musíme nejdřív  přiřadit vhodnou osazovací matrici, jinak konverze do DPS sice 
proběhne, ale ukáží se chyby, které stejně budeme muset opravovat. Proto přesuňte kurzor nad 
symbol baterie, pravým kliknutím otevřete nabídku a zvolte položku {Attached Pattern  ≡ 
Připojená matrice} – otevře se dialogové okno. Do pravé plochy okna 'Library  ≡  Knihovna' 
musíme přidat knihovnu , která obsahuje námi požadovaný motiv pro osazení, v tomto případě 
knihovnu 'misc.lib'. Klikněte proto na tlačítko {Add  ≡  Přidat}, a v následně otevřeném okně 
'Otevřít' navigujte zobrazení souborů do  složky  C:\Program Files\Diptrace\Lib (mimochodem, 
všechny standardní knihovny programů DipTrace se nacházejí v této složce). Zvolte soubor 
'misc.lib', klikněte 'Otevřít' a název souboru i s cestou k němu máme teď v ploše 'Library ≡ 
Knihovna'. Levým kliknutím na tento řádek se cesta s názvem knihovny vyznačí a v dolním 
pravém rohu se vypíše seznam matric v této knihovně. Zvolte BAT-2, náčrt matrice se objeví 
ve střední části okna.

Nyní je ještě nutné k jednotlivým vývodům (pinům) vybrat správnou pájecí plošku (pad): 
Klikněte na název vývodu v tabulce pinů na levé straně dialogového okna, a potom buď napište 
číslo plošky do pole {Pad Number  ≡  číslo plošky}, nebo jednoduše klikněte levým tlačítkem na 
plošku v grafickém vyobrazení osazovací matrice  (střední pole dialogového okna).

Když jsou všechny piny přiřazeny k ploškám, klikněte na „OK“ , dialogové okno se zavře 
a vykonané změny se uplatní v návrhu.
Poznámka:  Některé značky ještě nemusí mít přiřazen osazovací  vzor (např. VCC, GND nebo 
logická připojení {Net Ports  ≡  }, a ty se objeví v seznamu chyb v průběhu konverze do DPS.

Naše obvodové zapojení je teď připravené na konverzi do plošných spojů. Nezapomeňte 
ho nejdřív uložit na disk výběrem „Soubor → Uložit“ z hlavního menu nebo tlačítkem {Save  ≡ 
Uložit} v horní levé části okna, anebo jednoduše stlačením kláves „Ctrl+S“.

Pokud chcete, můžete si obvodový návrh vytisknout nebo uložit jako obrázek do souboru 
BMP nebo JPG. Za tímto účelem vyberte položku „Soubor → Náhled“ z hlavního menu, 
následně {Print All  ≡  Tisknout vše} pro tisk všech stránek obvodového návrhu, {Print Current 

DipTrace 2.0 tutoriál  (CZ)  27

file:///C:/Program


Sheet  ≡  Tisk aktuální stránky} pro tisk zvolené stránky, nebo tlačítko {Save  ≡  Uložit} na 
vytvoření souboru BMP/JPG s definovanou rozlišitelností.

4 Konverze na DPS

Konverzi bychom mohli zahájit tím, že bychom otevřeli soubor obvodového zapojení 
*.dch pomocí programu PCB Layout (pcb.exe). Pro úsporu času je však rychlejší způsob – 
nabídka {File → Convert to PCB  ≡  Soubor → Konverze na DPS} nebo klávesy „Ctrl+B“ 
rovnou z programu pro obvodový návrh, a nové okno programu „PCB Layout“ se otevře 
automaticky.

Pro uživatele Windows 98/ME důrazně doporučujeme uložit soubor obvodového návrhu, 
zavřít program pro tvorbu schématu, potom spustit program pro tvorbu DPS a až z něho otevřít 
soubor zapojení *.dch. Nesprávné sdílení paměti ve Windows 9x/ME může způsobit zhroucení 
programu, pokud běží najednou více programů balíku. Uživatelé Win NT/2000/XP mohou 
spustit najednou více modulů DipTrace bez zmíněných problémů.

Je dobré si uvědomit, že v případě nekorektního ukončení programu nebo opomenutí 
hotový projekt uložit je stále možné obnovit poslední stav návrhu volbou nabídky {File → 
Recover Schematic  ≡  Soubor → Obnovit schéma} v návrhovém programu zapojení nebo {File 
→ Recover Board  ≡  Soubor → Obnovit DPS} v programu návrhu DPS.

Možná na svém monitoru nevidíte identifikátory součástek, v tom případě je všechny 
vyznačte (uzavřít do obdélníku s přidrženým levým tlačítkem myši), potom na jednu z nich 
klikněte pravým tlačítkem, v nabídce zvolte dole {Properties  ≡  Vlastnosti} a v dialogovém 
okně klikněte na záložku {Marking  ≡  Značení}. Rozbalte seznam {Show  ≡  Ukázat}, zvolte 
{RefDes  ≡  Identifikátor} a stlačte „OK“.

Pokud uvažujete s použitím jiného programu pro návrh DPS nebo postoupit schéma 
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někam na další zpracování, můžete využít funkci exportu seznamu spojů (netlistu) rovnou 
z programu obvodového návrhu. Zvolte položku {File → Export → Netlist  ≡  Soubor → Export 
→ Netlist} z hlavního menu, a potom formát netlistu. DipTrace podporuje mnohé populární 
formáty netlistů,  jako jsou Tango, PADS, P-CAD, apod. Tato funkce je též užitečná pro kontrolu 
struktury sítě.

Nyní použijeme programový modul DipTrace „PCB Layout“ na návrh DPS z našeho 
obvodového zapojení. Rozmístěte součástky v souladu s vašimi zvyklostmi a pravidly návrhu. 
Elektrické spojnice jsou automaticky znázorněny  modrými spojovacími čárami mezi 
příslušnými ploškami. Posouvání součástek po ploše se provede umístěním kurzoru na obrys 
součástky a při stlačeném levém tlačítku přetáhnutím na zvolené místo. Více součástek najednou 
je možné posunout hromadně tak, že nejdřív vyznačíme celou skupinu a potom táhneme 
libovolnou z nich. Vyznačenou součástku (nebo součástky) je také možné pootáčet o úhel 90° 
klávesou mezerníku nebo „R“. Když chcete pootočit o jinou velikost úhlu, vyznačíme výběr 
(jednu nebo více), klikneme pravým tlačítkem nad jednou z nich a zvolíme nabídku {Define 
Angle  ≡  Definovat úhel} nebo {Rotate Mode  ≡  Mód otáčení}. V módě otáčení můžete objekty 
libovolně pootáčet použitím myši.

Při pohybu kurzorem přes obrys součástky se tato součástka vysvítí a v informačním 
koutě okna se současně zobrazí identifikátor součástky a souřadnice její polohy. Pokud se 
kurzorem zastavíme na některé plošce, uvidíme v informačním koutě  navíc i identifikátor 
vývodu a elektrické sítě, ve které je vývod zapojen. Navíc budou vysvíceny všechny plošky 
zapojené v této síti.

Je dobrým zvykem soustředit napájecí prvky do jedné oblasti a funkční celky seskupovat 
k sobě. Pokud má zapojení vysokofrekvenční charakter, je třeba respektovat příslušné zásady 
rozmísťování. Můžete také použít funkci automatického rozmístění nebo rozložení podle 
seznamu po konverzi z obvodového zapojení, ale pro tento jednoduchý případ to není potřebné. 
Tyto funkce si předvedeme v III. části tutoriálu na složitějším zapojení.

Návrh DPS je možné aktualizovat podle dodatečně upraveného schématu, při čemž se 
zachovají pozice součástek a existující spoje. Za tímto účelem  zvolte {File → Renew Design 
from Schematic  ≡  Soubor → Obnovit ze schématu} a následně vyhledejte a otevřete soubor 
upraveného obvodového zapojení.  

5 Návrh DPS

5.1 Příprava na trasování

Pokud jste to ještě neudělali, v programu PCB Layout nastavte viditelnost referenčních 
označení – identifikátorů například takto: Zvolte {View → Pattern Marking → RefDes  ≡ 
Zobrazit → Značení matrice → Identifikátor}. Touto volbou dosáhnete hromadně viditelnost 
identifikátorů na monitoru (mimo těch, které by to snad měly nastavené individuálně jinak). 
Pokud zarovnání identifikátorů nevypadá dobře, v nabídce {View → Pattern Marking → Main 
→ Justify  ≡  Zobrazit → Značení matrice → hlavní → zarovnat} zvolte Auto nebo cokoliv jiné 
z možností {Center | Top | Bottom | Left | Right | Corner | Auto  ≡  Střed | Vrch | Spodek | Vlevo | 
Vpravo | Roh | Auto}. Pro program návrhu DPS je důrazně doporučeno použití vektorového typu 
fontů, ale můžete použít i „True Type“ fonty pro jiné než anglické znaky {View → Pattern 
Marking → Font Type  ≡  Zobrazit → Značení matrice → Typ fontu}.

Individuální parametry pro vyznačené součástky se definují takto: kliknutí pravým 
tlačítkem na jednu z vyznačených součástek a výběr položky {Properties → Marking  ≡ 
Vlastnosti → Značení}. Dále můžete použít „F10“ nebo {View → Pattern Marking → Move 
Tool  ≡  Zobrazit → Značení matric → Nástroj posunu} k úpravě polohy jednotlivých 
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identifikátorů.
Rozložení součástek po konverzi zapojení na DPS s ohledem na jejich propojení asi 

nebude vyhovovat pro další manuální návrh spojů, proto změníme jejich polohu tažením 
s přidrženým levým tlačítkem a rotací vyznačené součástky klávesou „R“ nebo mezerníkem do 
finálního rozmístění jako v následujícím obrázku. Po přesunu součástek se spojnice  mohou 
křižovat více než je nutné, a tak je teď vhodné položkou menu {View → Connections → 
Optimize  ≡  Zobrazit → Spojnice → Optimalizovat} nebo rychleji klávesou „F12“ síť spojnic 
optimalizovat.

Cvičení:
Ukažme si ještě jak změnit strukturu propojovací sítě a jak přidat/odstranit spoje. Tento 

krok není právě nutný pro zpracovávanou ukázku, ale je dobré vědět jaké možnosti jsou: 
přesuňte kurzor myši na jakoukoliv plošku (například R4 – B), klikněte pravým tlačítkem, potom 
zvolte položku {Delete from Net  ≡  Vynechat ze sítě} a ploška bude od spoje odpojena. 
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Libovolnou plošku můžete manuálně spojit s jinou ploškou tak, že jednu vysvítíte  
kurzorem, levým kliknutím nastavíte začátek spoje, táhnutím myši ke druhé plošce se zároveň 
tahá i nový spoj, a ten se ukončí levým kliknutím na druhé plošce. Spojení mezi ploškami je  
znázorněné modrou čárou mezi nimi. Pokud obě plošky už náleží do různých sítí, ukáže se na 
závěr propojování seznam možností, jak vzniknuvší konflikt řešit. Pokud spojujete plošky které již  
spojeny jsou, vede tento postup k jejich rozpojení, i tady se nejprv zobrazí výzva na potvrzení.

Pokud byste si přáli připojit nějakou plošku k síti bez tahání spoje (např. se vám nechce 
vyhledávat v projektu plošky této sítě), posuňte kurzor na tuto plošku, klikněte pravým tlačítkem 
a z nabídky vyberte položku {Add to Net → Select from List...  ≡  Přidat k síti → Zvolit ze  
seznamu}. Otevře se dialogové okno Net s rozbalovaným seznamem, ve kterém si vyberete síť pro 
připojení plošky podle jejího identifikátoru, a zakončíte tlačítkem „OK“.

Strukturu propojovacích sítí je také možné editovat pomocí manažéra spojů. Otevřete ho 
z menu {Route → Connection Manager...  ≡  Trasa → Manažér spojů} a v nově otevřeném 
dialogovém okně můžete vytvářet nové sítě a připojovat k ním či odpojovat od nich plošky 
součástek.

Pokud jste v tomto cvičení změnili strukturu sítě, vraťte prosím všechny změny stláčením 
tlačítka {Undo  ≡  Zpět} dokud se neobnoví původní stav. Mimochodem, když přijdete o návrh 
zapojení nebo spojů třeba tím, že jste nesprávně zakončili program, použijte nabídku {File → 
Recover Board  ≡  Soubor → Napravit desku} v programu návrhu DPS nebo {File → Recover 
Schematic  ≡  Soubor → Napravit schéma} v programu obvodového návrhu na opětovné 
vyvolání posledního stavu projektu.

Přistoupíme teď k návrhu obrysu desky. Pokud bychom použili autorouter, plocha pro 
trasování spojů (polygon desky, pro jednoduché desky obdélník) se vytvoří automaticky 
v závislosti na tolerancích určených v nastavení autorouteru.  Ve většině případů však 
požadujeme pevně stanovené rozměry DPS a musíme je tedy určit před definitivním rozložením 
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součástek a jejich propojováním. Zvolme tedy nabídku {Route → Place Board  Outline  ≡ 
Trasovat → Umístit obrys desky} nebo tlačítko se stejnou funkcí na liště trasování v horní pravé 
straně okna, a potom vytvořme čtyřrohý obrys desky postupným levým kliknutím zaměřovacího 
kříže na pomyslné 3 rohy desky, pravým kliknutím na poslední čtvrtý roh a potvrzením volby 
„Enter“. Souřadnice rohového bodu můžeme přečíst i informačním koutě okna v okamžiku, když 
je kontrolovaný bod vysvícen (plný modrý čtvereček) pod přítomným kurzorem.

Obrysy DPS mohou být i obloukové, pokud po pravém kliknutí zvolíte možnost {Arc 
Mode  ≡  Mód oblouku}. Potom, co dokončíte obrys DPS, můžete vkládat další rohy tak, že na 
spojnici dvou rohů kliknete levým. Každý roh je též možné uchopit a tahat s přidrženým levým 
tlačítkem. Pravým kliknutím na roh se zobrazí nabídka na další manipulaci s obrysem a pokud 
zvolíte možnost {Arc  ≡  Oblouk}, proloží se oblouk mezi zvoleným bodem a dvěma jeho 
sousedními rohy, možnost {Delete Point  ≡  Zrušit bod}zruší tento roh, {Delete Board  ≡  Zrušit 
desku} zruší kompletně obrys desky, {Lock  ≡  Zamknout} zamkne obrys a zamezí tak další 
změny.

A nakonec , volba {Board Points...  ≡  Body obrysu} otevře dialogové okno {Board  ≡ 
Deska}, v kterém je seznam  bodů obrysu spolu s jejich geometrickými souřadnicemi, a tu je 
možné stanovit rozměr desky úpravou souřadnic bodů obrysu. 
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V tomto dialogovém okně tlačítek {Add  ≡  Přidat}, {Insert  ≡  Vložit}, {Delete  ≡ 
Zrušit} přidávat, vkládat a rušit klíčové body obrysu desky. Souřadnice se mohou zobrazit 
a editovat v absolutním nebo inkrementálním (přírůstkovém) způsobu; ten druhý je obyčejně 
pohodlnější. Pokud zaškrtnete čtvereček {Arc  ≡  Oblouk} pro některý bod, tento bod se stane 
středem oblouku a jeho dva sousední body budou tvořit začátek a konec. Pro pravoúhlý obrys 
zaškrtněte čtvereček {Create Rectangular Board  ≡  Vytvořit pravoúhlou desku} a jednoduše 
určete prvý bod, šířku {Width  ≡  Šířka} a výšku {Height  ≡  Výška} DPS. Nakonec stlačte 
„OK“ aby se změny použily nebo {Cancel  ≡  Zrušit} na zavření okna bez aplikování udělaných 
změn. Zrušit celý návrh obrysu desky můžete také volbou menu {Route → Delete Board  ≡ 
Trasovat → Zrušit desku}.

Počátek souřadnicového systému nemáme zatím na monitoru zobrazen. Standardní funkcí 
programu je, že na počátku umístí počátek souřadnic do středu obrazovky a nezobrazí ho. 
Zobrazení můžete kdykoliv přepnout klávesou „F1“ nebo nabídkou {View → Origin  ≡  Zobrazit 
→ Počátek} z hlavního menu. Souřadnicový systém se takto zviditelní jako vodorovná a svislá 
čára, její počátek však asi nebude na vhodném místě ve vztahu k naší desce. Použijme tedy levé 
kliknutí na tlačítko {Define Origin   ≡  Určit počátek} na liště elementů blízko šipky, přesuňme 
kurzor myši (má teď tvar křížku) na dolní levý roh DPS a levým kliknutím tu vytvoříme nový 
počátek souřadné soustavy. 
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Všechny souřadnice v programu budou od této chvíle počítané a zobrazované od tohoto 
počátku. Jeho polohu můžete měnit kdykoliv se vám to hodí.

Později si ukážeme, že všechny osazovací matrice (i schematické značky) mají 
definovány své vlastní středy v příslušném programovém editoru. Souřadnice tohoto středu se 
ukáží v informačním koutě okna, pokud je značka nebo matrice vysvícena. Tyto středy se dají 
zobrazit nebo skrýt tím, že vyznačíme požadované prvky, vysvítíme jeden z nich a pravým 
kliknutím otevřeme nabídku, ze které zvolíme {Pattern Origin → Show | Hide  ≡  Počátek 
matrice → Ukázat | Skrýt}.

5.2 Automatické Trasování spojů – Autorouter

Teď nastal čas, abychom navrhli spojové cesty na naší desce. DipTrace obsahuje pro tuto 
práci kvalitní programový modul, tzv. router,  převyšující mnoho jiných routerů zahrnutých 
v balících pro návrh DPS, které jsou dnes k dispozici. Ve většině případů jednoduchých DPS, 
jako je ta naše cvičná deska, spoje mohou být trasované jen po jedné straně desky (spodní – 
vrstva spojů), což představuje zřejmou výhodu zejména pro prototypovou výrobu, hlavně 
z pohledu efektivnosti a rychlosti v získání dokončeného prototypu. Spojové cesty budou asi 
o něco delší v porovnání s dvojstrannou deskou, to však s velkou pravděpodobností nebude mít 
žádný vliv u většiny návrhů. 

Nejdříve je nutné provést nastavení parametrů routeru. Zvolte {Route → Autorouter 
Setup  ≡  Trasování → Nastavení autorouteru} a v záložce {Create Traces  ≡  Vytvořit trasy} 
zrušte volbu {Use All Layers  ≡  Použít všechny vrstvy} (prázdný čtvereček) a v poli {Number 
of Layers  ≡  Počet vrstev} nastavte číslo 1 – trasování spojů se odehraje na spodní straně desky. 
Mohli bychom také změnit kvalitu trasování spojů  výběrem parametru  Autoroutera ze seznamu 
{Auto Setup  ≡  Nastavení Auto}, vyšší kvalita však znamená delší dobu zpracování, více 
pokusů ve vedení spojů, ale také lepší výsledek návrhu. Je také možnost automaticky trasovat 
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spoje jednostranné desky s použitím drátových propojek – zaškrtnout volbu {Allow Jumper 
Wires  ≡  Dovolit drátové propojky}. V našem případě, kdy zapojení obvodu je jednoduché, se 
obejdeme bez drátových propojek, a kvalitu trasování nastavíme alespoň „Normal“. Zrychlený 
mód {Quick  ≡  Rychlý} se dá použít na jednoduché dvojstranné desky nebo když předběžně 
zkoušíte trasování na velkých multivrstvých deskách, kde finální trasování trvá velmi dlouho. 
Stlačte „OK“ a změny budou akceptovány.

Nyní nastavte šířku spojů i šířku mezer mezi spoji navzájem i ploškami v dialogovém 
okně, do kterého vstoupíte přes nabídku {Route → Route Setup  ≡  Trasování → Nastavení 
trasování} na hodnoty 0,5 mm. (Tato hodnota je zvolena s ohledem na případnou výrobu 
prototypu z výtisku obrazce na laserové tiskárně způsobem jeho přežehlení na stranu spojů DPS. 
Pokud je pro výrobu k dispozici technologie optické expozice UV lampou, přípustné šířky jsou 
0,3 mm i méně, v závislosti na schopnosti zaostření expozičního zařízení.)

V žádném případě mezera od plošky nemůže být menší než mezera mezi spoji, takže 
pokud definujete mezeru mezi ploškami 0,3 mm a mezi spoji 0,5 mm, všechny výsledné mezery 
ploška-ploška a ploška-spoj nebudou užší než 0,5 mm; definice opačného charakteru, například 
mezery mezi ploškami 0,5 mm a mezi spoji 0,3 mm budou respektovány.

Šířku spoje můžete definovat pro každou síť individuálně. Posuňte kurzor na některou 
plošku, která je součástí té sítě, a při vysvícených ploškách klikněte pravé tlačítko a zvolte {Net 
Properties...  ≡  Vlastnosti sítě}. V dialogovém okně teď můžete definovat šířku spoje a mezeru 
mezi spoji pro tuto konkrétní síť. Dialogové okno zavřete tlačítkem „OK“ na potvrzení změn, 
nebo „Close“- v tom případě se nové hodnoty ignorují. Abyste ušetřili čas, můžete si svoje 
kombinace šířky spoje a mezery uložit do tzv. předlohy a pak je vyvolat podle potřeby 
v dialogových oknech nebo v nabídkách menu (např. při manuálním trasování). Na takovou 
úpravu předlohy otevřete příslušné okno z nabídky {Route → Trace Templates...  ≡  Trasování 
→ Předloha trasy}.
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Poznámka pro kutily:
Mějte na paměti, že papírový list v laserové tiskárně podléhá rozměrovým změnám 

v důsledku tepelné roztažnosti. Míra těchto změn závisí na konkrétním typu tiskárny a kvalitě 
papíru. Ve většině případů mohou být tyto změny bezvýznamné, někdy však důležité. Jedním ze 
způsobů, jak se vyrovnat s tímto problémem je předehřev papíru průchodem tiskárnou bez tisku 
(nebo dáte vytisknout jedinou tečku). U inkoustových tiskáren takový problém neexistuje, protože 
tato technologie nevyhřívá papír do tak vysokých teplot. Tímto nechceme tvrdit, že laserové 
tiskárny vždy viditelně zkreslují obraz, jen vás chceme upozornit na možný zdroj rozměrových 
nesouladů. Úprava měřítka pro tisk může být jedním z možných řešení, jiným použití programu 
Adobe Postscript (někdo možná upřednostní GhostScript, protože je zdarma). 

Stručně řečeno, pro domácí výrobu DPS jsou vhodné hlavně dvě metody: přenosem 
toneru a UV expozicí. Pro přenos toneru je jediným prostředkem laserová tiskárna či kopírka, 
a pro podklad UV expozice lépe poslouží inkoustová tiskárna.

Nastal čas na trasování spojů vaší desky. Zvolte {Route → Run  Autorouter  ≡  Trasovat 
→ Spustit autorouter}, spoje se natahají. Pokud jeden nebo více spojů nemají navrženou trasu, 
zkuste trasování zopakovat: stlačte tlačítko {Undo  ≡  Zpět} nebo položku menu {Route → 
Unroute All  ≡  Trasovat → Odtrasovat vše}, potom spusťte autorouter znovu, případně 
s nastavenou lepší kvalitou trasování. Mimochodem, jestli jste měli nastavenou nejlepší („Best“) 
kvalitu trasování v dialogovém okně {Router → Autorouter Setup...  ≡  Trasovat → Nastavení 
autorouteru}, tak autorouter asi našel optimální výsledek. Pokud přece jen zůstaly nějaké 
nenatahané spoje znamená to, že musíte vhodně změnit povolené mezery nebo rozmístění 
součástek – součástky musí poskytnout více volného místa okolo sebe nebo i spoje mohou být 
příliš široké. 
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Jakmile autorouter skončí svoji práci, rozběhne se automatická kontrola návrhových 
pravidel DRC {Design Rule Check} a případné chyby zviditelní zakroužkováním (červené 
a fialové kroužky). Můžete chyby odstranit a spustit kontrolu DRC opět buď přes menu 
{Verification → Check Design Rules  ≡  Ověření → Kontroluj pravidla návrhu} nebo 
odpovídajícím tlačítkem na liště trasování v horní části okna. Návrhová pravidla si můžete 
přizpůsobit v dialogovém okně {Design Rules  ≡  Pravidla návrhu}, vyvolaném položkou menu 
{Verification → Design Rules...  ≡  Ověření → Pravidla návrhu}. V záložce {Clearances  ≡ 
Mezery} měníte povolené vzdálenosti (chyba indikovaná červeným kroužkem) a v záložce 
{Sizes  ≡  Rozměry} horní a dolní limity rozměrů (chyba indikovaná fialovým kroužkem). 
Automatickou kontrola návrhových pravidel po autorouteru můžete vypnout tím, že zrušíte 
zaškrtnutou volbu příslušného čtverečku v dialogu {Route Setup  ≡  Nastavení trasování} 
otevřeném položkou hlavního menu {Route → Route Setup...  ≡  Trasování → Nastavení 
trasování}.

Zvažte možnost přeskočit teď následující kapitoly až po 5.12 {Printing  ≡  Tisk}, jestli 
spěcháte s výrobou DPS našeho ukázkového projektu, protože už v této fázi návrhu se dají 
vygenerovat výrobní podklady. Ovšem pokud si chcete do hloubky osvojit další funkce 
programu pro návrh DPS (které se dají vysvětlit na tomto návrhu a budou jistě užitečné ve vašich 
dalších projektech), doporučujeme vám pokračovat v kapitolách 5.3 až 5.11.

5.3 Práce s vrstvami

Vrstvou v našem případě rozumíme rovinu, na které se nachází grafická informace 
určitého charakteru. Typickým představitelem u DPS jsou signálové vrstvy, ve kterých je 
znázorněno vedení plošných spojů. Druhou skupinou jsou podpůrné vrstvy, které znázorňují 
např. nepájitelnou ochrannou masku, sítotisk s obrysy osazovaných součástek, nebo i stínící 
vodivou vrstvu - pláň s připojeným potenciálem. Někdy hovoříme o jednostranné nebo 
oboustranné desce jako o jedno nebo dvojvrstvové, a máme na mysli jen signálové vrstvy; také 
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pojem čtyřvrstvá deska se týká jen počtu signálových a stínících vrstev a ignoruje případné další 
podpůrné vrstvy.

Bez ohledu na počet vrstev DPS hovoříme o straně součástek jako o horní straně – 
osazovací automaty kladou součástky jen shora – a dolní strana je potom strana spojů. Toto je 
úmluva sloužící pro naši orientaci, jinak pochopitelně můžeme mít spoje i nahoře a součástky 
i dole jako výjimku z pravidla. 

Na předchozím obrázku jste viděli trasy spojů vykreslené nevýraznou matnou barvou, 
protože tyto spoje jsou na spodní straně a aktivní zobrazená vrstva na na straně horní. Takové 
zobrazení je výsledkem tzv. kontrastního modu, který je po instalaci programu přednastaven. 
Změňte teď aktivní vrstvu: přesuňte kurzor na rozbalovací seznam v liště trasování {Top  ≡ 
Horní} a změňte výběr na {Bottom  ≡  Dolní}. Mimochodem, stejný rozbalovací seznam se 
nachází v liště elementů pro kladení součástek a slouží pro výběr strany pro umístění součástky; 
typ seznamu se ukáže v nápovědě když na jeho poli zastavíte kurzor.

Možná se vám kontrastní mód zobrazení nelíbí, tak ho teď změňme. Z hlavního menu 
vyberte položku {Layer → Display Mode  ≡  Vrstva → Mód zobrazení} a z další podnabídky 
{Contrast | Contrast Edit | Current Only | All Layers | Contrast Level  ≡  Kontrast | Kontrast 
a upravit | Jen aktuální vrstva | Všechny vrstvy | Úroveň kontrastu} si vyberte podle svého vkusu. 
My jsme zvolili {All Layers  ≡  všechny vrstvy}, takže všechny vrstvy návrhu budou vyobrazeny 
plným kontrastem. Jestli chcete pozorovat pouze aktuální vrstvu, zvolte {Current}.
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Pro změnu barvy spojů a jiných nastavení vrstvy zvolte položku {Layer → Layer Setup... 
≡  Vrstva → Nastavení vrstvy}. V dialogovém okně {Layer Setup  ≡  Nastavení vrstvy} zvolte 
vrstvu a stlačte tlačítko „...“, v paletě barev si zvolte tu svojí. My jsme změnili barvy horní 
vrstvy na červenou a spodní na modrou. Jistě jste si všimli, že v tomto okně si můžete 
přejmenovat vrstvy, další vrstvy přidat nebo odebrat (vrchní a spodní vrstvu není možné 
odebrat). Odebíraná vrstva nesmí obsahovat žádné spoje. Můžete přidat i stínící vrstvu – pláň 
(ani ta nesmí obsahovat další spoje) a definovat síť, se kterou bude spojena (obyčejně je to 
zemnící potenciál nebo napájení), a také metodu aplikovanou na vodivou zónu okolo 
prokovených otvorů na stínící vrstvě. Doporučujeme vytvořit signálové a stínící vrstvy včetně 
jejich parametrů ještě před spuštěním autorouteru. 
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Můžete zkontrolovat vzhled spodní vrstvy pohledem „odspodu“ použitím nabídky 
hlavního menu {View → Mirror  ≡  Zobrazit → Zrcadlově}

5.4 Měření délky trasy

Náš ukázkový projekt nevyžaduje takovéto měření, protože je jednoduchý 
a nízkofrekvenční, pokud však budete navrhovat velmi rychlé obvody jako videozařízení 
a podobně, délka trasy může být důležitá.  Nejprve si všimněte, že délka úseku sítě se ukáže 
v informačním koutu, jakmile je tato síť vysvícená – to může být nápomocné, ale není to 
dostatečné pro pohodlnou kontrolu všech úseků trasy v reálném čase.

Vysviťte jednu trasu a klikněte pravým tlačítkem, z kontextové nabídky zvolte položku 
{Show Trace Length  ≡  Ukázat délku trasy}.

DipTrace 2.0 tutoriál  (CZ)  40



Teď uvidíte malé okénka s uvedením délek úseků vybraných sítí. Tato okénka budou 
vysvícena spolu s příslušnou sítí, pokud budete přejíždět přes spoj kurzorem myši. Hodnoty jsou 
vyjádřeny v aktuálně zvolených jednotkách (v našem případě mm) a mění se v reálném čase 
v souladu s tím, jak editujete trasu.
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Teď prosím znovu skryjte zobrazení délek buď stejným postupem z kontextové nabídky, 
nebo tlačítkem {Undo  ≡  Zpět}.

5.5 Manuální trasování

V našem jednoduchém projektu jsme dosáhli finální verze trasování desky jen s použitím 
autorouteru, ale v složitějších projektech a v zájmu co nejlepších výsledků bude zřejmě nezbytné 
sáhnout k manuálním úpravám  návrhu z autorouteru. 

Zkuste nejdřív editovat existující trasy – možno se budete muset přepnout do vrstvy 
spojů, kterou chcete editovat, v poli seznamu vrstev v liště trasování. Posuňte kurzor myši nad 
úsek trasy až se vysvítí a přidržením levého tlačítka tahejte úsek do nové pozice. V tomto případě 
je možné úsek posouvat kolmo na jeho směr – buď 0°, 45° nebo 90°, můžete však i zešikmit 
zalomení do pravého úhlu přidáním dalšího úseku. Kurzorem vysvítíte (červeně) vrchol 
pravoúhlého zalomení (dále i „uzel“) a táhnutím vrcholu dovnitř úhlu se postupně rozšiřuje nový 
úsek. Táhnutím nazpět můžete nazpět vytvořit vrchol pravého úhlu.

DipTrace vám umožní editovat trasy bez omezení zvolením položky hlavního menu 
{Route → Tools → Free Edit Traces  ≡  Trasovat → Nástroje → Volně upravit trasy} nebo 
stlačením tlačítka {Free Edit Traces  ≡  Volně upravit trasy} na liště trasování. Tak můžete 
pohybovat úseky a uzly i přidávat nové uzly bez jakýchkoliv omezení.

Jistě jste si už všimli, že souřadnicová soustava je na ploše znázorněna rastrem bodů s 
pravidelnými rozestupy. Velikost těchto rozestupů si můžete zvolit v poli seznamu rastrů na 
standardní liště, nebo přes položku menu {View → Grid Size → # | Custom  ≡  Zobrazit → 
Rozestup rastru → č. | Přizpůsobit}, položka {Custom  ≡  Přizpůsobit} vám umožní stanovit si 
svůj vlastní rastr mřížky. Pokud se rozhodnete, že dokážete editovat trasy a objekty bez 
zobrazeného rastru, vypněte jeho zobrazení klávesou „F11“ nebo výběrem {View → Grid  ≡ 
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Zobrazit → Rastr} z hlavního menu.
Posuňte teď kurzor myši nad segment trasy spoje, až se síť vysvítí, a  klikněte pravým 

tlačítkem. Spatříte podnabídku sítě a v ní můžete změnit název sítě, přidat uzel na úsek trasy, 
změnit šířku úseku, trasy nebo celé sítě, změnit vrstvu, zrušit trasování, úsek nebo síť a vykonat 
některé další operace. Vyzkoušejte si, že DipTrace automaticky vloží prokovenou spojku („via“) 
mezi dvěma úseky ležícími v rozdílných vrstvách, pokud není úsek navázán na prokovený otvor 
s ploškou pro vývod součástky. Vyberte tedy v podnabídce {Switch Line Layer → Top  ≡ 
Přepnout vrstvu úseku → Horní} a uvidíte, že tento úsek trasy byl přesunut do horní vrstvy a dvě 
„via“ spojky byly přidány mezi konce tohoto úseku a navazujícími úseky.

Změňte aktuální vrstvu na {Top  ≡  Horní}, opět na tento úsek klikněte pravým tlačítkem 
a vraťte ho zpět do vrstvy {Bottom  ≡  Dolní}.

Teď si vyzkoušíme manuální trasování, a tak klikněte pravým tlačítkem na jednu z vašich 
sítí a zvolte v podnabídce {Unroute Net  ≡  Odtrasovat síť}. Tento povel na zrušení tras sítě se 
týká všech právě vybraných sítí; v našem případě teď nejsou žádné další sítě vybrané a tak bude 
zrušené trasování jen té sítě, na kterou jste klikli. Nyní zvolte nabídku hlavního menu {Route → 
Tools → Route Manual  ≡  Trasovat → Nástroje → Trasovat manuálně} nebo stlačte tlačítko 
s tímto významem na liště trasování – vstoupíte do režimu manuálního trasování. Posuňte kurzor 
nad plošku patřící k netrasovanému spoji (vysvítí se dočervena), levým kliknutím začněte 
s trasováním a postupně levým kliknutím určujte klíčové body vytvářené trasy krok za krokem. 
V průběhu kladení spoje zkuste kliknout pravým tlačítkem – ukáže se podnabídka manuálního 
trasování. Můžete si v ní zvolit ukončení trasy, její zrušení, vrácení o krok zpět, změnit mód 
trasování (90° a 45°, volný sklon nebo oblouk), změnit vrstvu ( spojka „via“ se sama umístí mezi 
vrstvy  a vy můžete pokračovat v trasování na nové vrstvě), nastavit šířku spoje následujícího 
úseku anebo položit drátovou propojku („jumper“).

Všimněte si, že povely podnabídky se dají alternativně vyvolat klávesovými zkratkami 
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(„hot keys“), což může vést k zjednodušení procesu manuálního trasování: „M“-přepnutí modu 
trasování, „W“-přepínání mezi vrstvami, „T“-přepnutí na horní vrstvu (Top), „B“-přepnutí na 
dolní vrstvu (Bottom), „J“-změna trasy na drátovou propojku (jumper) a naopak (když jste ve 
spodní vrstvě, propojka bude umístěna do horní, pokud jste aktuálně v horní, propojka bude 
umístěna do dolní vrstvy), „1“ až „0“ na horní řádce klávesnice – přepínání mezi vrstvami č. 1 až 
10.

Přepněte se teď v průběhu trasování do aktuální horní vrstvy.

Uvidíte, že od naposledy specifikovaného bodu bude trasa spoje pokračovat v nové 
vrstvě, potom posuňte myš trochu dolu a vpravo, Znovu změňte vrstvu, potáhněte trochu dolu, 
klikněte pravým tlačítkem a vyberte z podnabídky položku {Enter} anebo stlačte klávesu 
„Enter“. Teď se nacházíte v dolní vrstvě, trasa je položená, ale neukončená a tedy ani 
nepřipojená.
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Teď posuňte kurzor myši na konec trasy, který ještě není připojen, a natáhněte další 
segmenty trasy k poslední plošce této sítě (musíte mít samozřejmě zvolený mód trasování). Teď 
je trasa ukončena na poslední plošce:
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5.6 Práce se spojkami  (otvory „via“)

DipTrace rozlišuje dva druhy spojek: obyčejná spojka, která je součástí trasovaného 
plošného spoje a objevuje se automaticky tam, kde dva sousední na sebe navazující úseky trasy 
jsou rozmístěny v rozdílných vrstvách, a statická spojka, která funguje obdobně jako ploška. 
Statická spojka má více definovatelných vlastností a může být použitá na spojení trasy s plání 
apod. Jinou užitečnou vlastností statické spojky je možnost jejího skrytí nebo odstranění 
z některých vrstev, což umožňuje vytvářet slepé spojky (viditelné jen na jedné vnější straně DPS) 
nebo skryté spojky (neviditelné na vnějších stranách DPS). Obyčejná spojka může také být slepá 
nebo skrytá, ale tato je viditelná jen ve vrstvách obsahujících propojované úseky trasy a nedá se 
zviditelňovat a opět skrývat v ostatních signálových či stínících vrstvách. Pokud snad máte 
zkušenosti s jiným návrhovým systémem DPS, bude pro vás pohodlnější používat jen statické 
spojky. Dále si nejdříve ukážeme práci s obyčejnými spojkami, potom použijeme statické spojky 
a prošetříme některé z jejich vlastností.

V tomto okamžiku má náš projekt jen jednu spojku mezi horní a dolní vrstvou, musíme 
jich přidat víc, abychom mohli demonstrovat jejich používání. Proto se teď přepněte do aktivní 
dolní vrstvy v poli seznamu {Current Signal/Plane Layer → Top | Bottom   ≡  Aktuální 
vrstva/pláň → Horní | Dolní} na liště trasování, přesuňte kurzor na úsek nějaké trasy, klikněte 
pravým tlačítkem a podnabídky zvolte možnost {Switch Line Layer → Top   ≡  Přepnout vrstvu 
úseku → Horní}.

Teď už máme na DPS tři spojky. Zvolte položku hlavního menu {Layer → Via Properties 
≡   Vrstva → Vlastnosti spojky}. Otevře se dialogové okno {Via Properties  ≡  Vlastnosti 
spojky} a v něm můžete změnit přednastavené hodnoty, které zatím program používá. Změňte 
tedy průměry vnějšího kroužku a otvoru na hodnoty o něco větší. Teď se zamyslete nad tím, na 
které spojky tuto změnu aplikovat, v poli {Apply To  ≡  Aplikovat na} máte na volbu tři 

DipTrace 2.0 tutoriál  (CZ)  46



možnosti. Volba {Don't Apply  ≡  Neaplikovat} znamená, že nové hodnoty se netýkají už 
existujících spojek a bude použita jen pro spojky nové. Volba {Default Only  ≡  Jen standardní} 
říká, že na novou hodnotu budou změněny jen ty spojky, které mají rozměry původně 
přednastavených hodnot. Volba {All  ≡  Všechny} má za následek, že všechny původní i nové 
spojky budou mít nově zvolené rozměry. Vyberte si tedy {All  ≡  Všechny} a stlačte „OK“, 
změny se hned uplatní v návrhu a dialogové okno se zavře.

Teď prosím posuňte kurzor na jednu ze spojek (vysvítí se dočervena), klikněte pravým 
tlačítkem a zvolte položku {Via Properties...  ≡  Vlastnosti spojky}. V obdobném dialogovém 
okně můžete opět změnit nastavení spojky, tentokrát s účinkem na tuto jednu spojku {Current 
Point  ≡  Aktuální bod}, na všechny spojky trasy {Trace  ≡  Trasa} nebo všechny spojky sítě 
{Net  ≡  Síť}. Zvolte si nové hodnoty, třeba nějaké menší, a stlačte „OK“- změny se promítnou 
v návrhu.
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Pokud se vám nedaří vysvítit zamýšlenou spojku, zkuste změnit vrstvu (například 
klávesou „W“) nebo změnit mód na editování tras tlačítkem {Edit Traces} na liště trasování.

Vraťme se teď ke stavu návrhu, jaký byl po skončení práce autorouteru, a to tak, že 
budete opakovaně tlačit na tlačítko {Undo  ≡  Zpět} tolikrát, až budou všechny změny po 
autoroutování zrušeny. Potom znovu otevřete dialog {Layer → Via Properties  ≡  Vrstva → 
Vlastnosti spojky} a v okně {Via Properties  ≡  Vlastnosti spojky} se vraťte k normálním 
hodnotám, jaké hodláte používat.

Statická spojka je stejným objektem jako ploška a má obdobné vlastnosti. Podíváme se na 
jednu z nich. Z hlavního menu zvolte položku {Objects → Place Static Via   ≡  Objekty → 
Umístit statickou spojku} nebo použijte tlačítko s totožnou funkcí na liště elementů a rozmístěte 
po DPS několik spojek. Jejich barva bude stejná jako spoje aktuální vrstvy, tedy patrně červená, 
pokud máte jako aktivní zvolenou horní vrstvu.
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Tyto spojky můžete jednoduše připojovat do sítí, vést k ním trasy apod. stejným 
způsobem, jako kdyby šlo o plošky. Zvolte teď kontrastní mód zobrazení výběrem položky 
hlavního menu {Layer → Display Mode → Contrast   ≡  Vrstva → Mód zobrazení → 
Kontrastní}. A nyní klikněte pravým tlačítkem na na jednu z těchto spojek a v podnabídce zvolte 
položku {Via Layers...  ≡  Vrstvy spojky}.
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V dialogovém okně {Via Layers  ≡  Vrstvy spojky} můžete odstranit tvar a otvor spojky 
z některé vrstvy a tím třeba změnit tuto spojku na slepou nebo (u DPS aspoň čtyřvrstvé) na 
skrytou. Na zkoušku tedy klikněte na řádek {Top  ≡  Horní}, čímž ho deaktivujete, a stlačte 
„OK“. Na výkrese DPS vidíte, že tato spojka je z horní vrstvy odstraněná, ale stále existuje 
v dolní vrstvě.

Připomínáme, že úplně stejnou operaci je možné vykonat i s ploškou. Dokonce všechny 
vybrané plošky a spojky se dají změnit najednou, když v dialogovém okně {Via Layers  ≡ 
Vrstvy spojky} nebo {Pad Layers  ≡  Vrstvy plošky} před potvrzením změn zvolíte v poli 
{Apply To  ≡  Aplikovat na} možnost {Selected Components  ≡  Vyznačené součástky}. Pro 
svoje vlastní nastavení vlastností vrstev pájkové pasty nebo masky můžete použít položku {Mask 
/ Paste Settings   ≡  Nastavení masky / pasty} z podnabídky pro plošku, vyvolanou pravým 
kliknutím po této plošce.

5.7 Výběr objektů podle typu / vrstvy

Někdy je nutné vybrat všechny objekty určité vrstvy, někdy jen součástku, síť apod. Na 
naší současné DPS to jde velmi snadno s použitím myši a klávesy „Ctrl“, ale u složitých návrhů 
to může být tvrdý oříšek. Na jeho řešení tu máme dialogové okno {Edit Selection  ≡  Upravit 
výběr}, přístupné přes nabídku hlavního menu {Edit → Edit Selection...  ≡  Upravit → Upravit 
výběr}. Prosím, otevřete si ho.
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Nejdříve vybereme všechny součástky našeho návrhu, proto zaškrtněte volbu 
{Components   ≡  Součástky} a stlačte „OK“. To je jen jednoduchý příklad, ale často 
potřebujeme rafinovanější výběry. Teď bude naší úlohou vybrat jen nepřipojené spojky 
v definované oblasti. Nejdříve zrušte výběr součástek pravým kliknutím do volného místa. 
Položte na plochu DPS několik spojek a některé z nich připojte k sítím pomocí spojnic: 
V standardním módu klikněte nejprve levým tlačítkem na vysvícenou spojku, potom na plošku 
náležící ke zvolené síti. Metodou skupinového výběru (označení plochy výběru obdélníkem) 
vyberte část návrhu, ve které se nacházejí některé spojky, současně aby některé spojky zůstaly 
vně tohoto výběru. Všechno toto děláme v aktivní dolní vrstvě, která má plošné spoje modré 
barvy, pokud máte problém s připojováním spojek, ujistěte se, že máte aktivní spodní vrstvu 
a vyzkoušejte si, jak se projevuje vysvícení spojek červenou barvou.
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Všechny objekty v námi vyznačené oblasti jsou tedy vybrány, jenomže my chceme, aby 
to byly jen nepřipojené spojky. Přes menu {Edit → Edit Selection...  ≡  Upravit → Upravit 
výběr} otevřete opět dialog {Edit Selection  ≡  Upravit výběr}, ze seznamu {Mode} zvolte 
položku {Keep Selected  ≡  Zachovat vyznačené} a ze všech zaškrtávacích voleb zaškrtněte 
pouze {Vias  ≡  Spojky} a ze seznamu vedle vyberte {Not Connected  ≡  Nepřipojené}, všechny 
ostatní volby zůstanou prázdné.
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Stlačte „OK“ a vyznačené zůstanou jen nikam nepřipojené spojky. Dalším krokem by 
mohlo být jejich hromadné připojení k nějaké síti, obyčejně k zemnící pláni nebo rozlité mědi. 
V tom případě pravým kliknutím na jednu z vybraných spojek otevřete kontextovou nabídku, 
v ní zvolíte {Add to Net  ≡  Přidat k síti}, v následující podnabídce {Selected Vias...  ≡ 
Vyznačené spojky} a v následně otevřeném seznamu si vyberete název sítě.
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Síť jste si zvolili, stlačte tedy „OK“ a sledujte, že všechny nepřipojené spojky z výběru 
teď mají zobrazené spojnice k určené síti. Ve výběru jsme měli i spojky už připojené k jiným 
sítím, těch se tato operace nedotkla.

Odstraňte teď všechny statické spojky a vraťte svůj návrh k původnímu stavu.

5.8 Umístění textu a grafiky

Je téměř jisté, že někdy budete chtít na svoji desku přidat nějaký text nebo grafiku 
(s programem DipTrace můžete třeba přidat vaše logo ve formátu bmp nebo jpg a exportovat ho 
do výrobních podkladů Gerber nebo DXF). Zkusíme si tedy přidat nějaký text na DPS. Nejdříve 
je třeba zvolit si vrstvu, ve které budou umístěny tvary, text nebo loga. Pojďte kurzorem na pole 
seznamu s textem {Top Assy  ≡  Horní sestava} na liště kreslení a zvolte ze seznamu položku 
{Top Silk  ≡  Horní sítotisk}. Odteď tedy všechny grafické objekty budou ukládány ve vrstvě 
horního sítotisku. Už dříve jsme se seznámili s tím, že program má pole seznamu pro volbu 
aktuální signálové vrstvy nebo pláně, teď tu máme obdobné pole pro umístění grafiky. Pokud 
v tomto posledně jmenovaném poli zvolíme položku {Signal / Plane  ≡  Signál / Pláň} pro 
umístění grafiky, všechny tvary, texty a loga budou nasměrovány do té signálové vrstvy nebo 
pláně, která je právě aktuální podle svého pole. Může se to zdát složitější než mít pro všechny 
případy jedno pole, ale až si tuto funkci vyzkoušíte uvidíte sami, jak dokáže šetřit vaším časem.
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Teď by se hodilo mít vaší DPS o něco větší, aby se na ní vešly další objekty, a tak 
kurzorem myši vysviťte (plná modř) horní levý roh čtverce a potáhněte ho o kus výš. Stejně to 
zopakujte s pravým horním rohem. Také si můžete zkusit, jak snadné je přidat další vrchol 
mnohoúhelníku. Prostě uchopte stranu čtverce mimo roh a tahejte – nový vrchol se zjeví 
automaticky.
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Dá se také posouvat celý obrys desky jako celek. Vyberete ho tak, že při stlačeném 
klávesu „Ctrl“ kliknete na jednu ze stran obrysu desky, všechny její vrcholy se vysvítí. Teď 
můžete uchopit jednu stranu obrysu a při stlačeném levém tlačítku myši přesouvat obrys do nové 
polohy, tam tlačítko uvolnit. 

Připomínáme, že pokud se vám nedaří vysvítit některý objekt, asi nemáte zvolený 
standardní mód programu. Do něho se vrátíte pravým kliknutím na volnou plochu. Také se nedají 
editovat objekty, které se nacházejí v právě neaktivní vrstvě.

Na vložení textu nám poslouží tlačítko „Abc“ na liště kreslení. Levým tlačítkem myši 
klikněte na toto textové tlačítko, následně na místo v DPS, kam byste chtěli svůj text umístit. 
Nyní na klávesnici napište text a ukončete klávesou „Enter“ nebo kliknutím myší. S použitím 
myši (a po návratu do standardního módu) se dá text posouvat na požadované místo, případně 
z kontextové nabídky změnit velikost a typ fontu.

Pokud chcete změnit přednastavenou velikost a vzhled fontu pro budoucí texty, je to 
umožněné nabídkou hlavního menu {Objects → Drawing Properties → Font  ≡  Objekty → 
Vlastnosti kreslení → Font}. Podobně může být změněn typ fontu výběrem {Objects → 
Drawing Properties → Font Type → Vector | TrueType  ≡  Objekty → Vlastnosti kreslení → Typ 
fontu → Vektorový | True Type}. V tomto případě silně doporučujeme použít vektorový typ 
fontu, protože při generování výrobních podkladů ve struktuře Gerber se tento typ exportuje 
přímo. Fonty TrueType se mohou použít pro národní neanglické znaky, ale ty budou potom do 
podkladů Gerber exportovány jako krátké linky (generované rozpoznávacím algoritmem). 
Někteří výrobci dokonce nepřipouštějí výskyt takových textových objektů ve vrstvách signálů 
a plání.

Samozřejmě je možné kdykoliv změnit vrstvu pro text nebo grafický objekt. Jednoduše 
tento objekt vyznačte, klikněte naň pravým tlačítkem a zvolte {Properties  ≡  Vlastnosti} 
z podnabídky. V dialogovém okně {Shape Properties  ≡  Vlastnosti tvaru} si zvolte pole 
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v seznamech {Type  ≡  Typ} a {Layer  ≡  Vrstva}, aby odpovídaly vašemu záměru pro volbu 
vrstvy nebo dalších vlastností (např. {Route Obstacle  ≡  Překážka trasování} na zamezení 
trasování přes tento objekt autorouterem).

Všimněte si, že grafické útvary se mohou přidat i do vrstev {Mask  ≡  Maska}, {Paste  ≡ 
Pasta}, {Route Obstacle  ≡  Překážka trasování} a {Board Cutout  ≡  Výřez desky}. Tyto útvary 
se definují pomocí nástrojů na liště kreslení nebo v dialogovém okně stejným způsobem jako pro 
vrstvy sítotisku nebo signálů/plání.

5.9 Rozlévání mědi

Což tak vylít volnou plochu na straně spojů vaší DPS mědí?  Asi to není nutné (podobně 
jako text a některé další věci) v případě této jednoduché desky, ale ukážeme si, jak se to dělá 
a potom to opět zrušíme. Tedy, zvolte jako aktivní spodní vrstvu (stranu spojů) a zvolte položku 
{Objects → Place Copper Pour  ≡  Objekty → Rozlít měď} přes hlavní menu nebo krátce 
obdobným tlačítkem na liště elementů. Nyní můžete kurzorem (vzhledu křížku) rozmísťovat 
vrcholy polygonu, který bude ohraničovat rozlitou měď, vytyčování ukončíte pravým kliknutím 
a položkou {Enter}, nebo rovnou klávesou „Enter“. Objeví se následovné dialogové okno:

Program DipTrace má funkci rozlévání mědi založenou na ohraničení. Oblast mědi je 
vytvořena čarami pevné šířky. Parametr {Line Spacing  ≡  Mezery čar} se použije jen tehdy, 
když použijete vzorovanou výplň rozlité mědi. Všimněte si, že vyplněnou oblast můžete spojit 
s některou sítí a také si můžete zvolit typ připojení (záložka {Connectivity  ≡  Propojitelnost}), 
pro naši DPS to ale teď nepoužijeme. Stlačte „OK“ a je rozlito.

Na záložce {Border  ≡  Okraje} se nacházejí volby {Depending on Board  ≡  Závisí na 
desce} a {Snap to Board  ≡  Přichytit k desce}, pomocí kterých můžete ušetřit čas 
s vykreslováním hranice pro oblast rozlité mědi a nechat program vytvořit hranice automaticky. 
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Pomocí tlačítka {Undo  ≡  Zpět} zrušte už vytvořenou rozlitou měď a vyzkoušejte automatický 
způsob. Zvolte opět položku {Objects → Place Copper Pour  ≡  Objekty → Rozlít měď} přes 
hlavní menu nebo krátce obdobným tlačítkem na liště objektů. Nyní kurzorem (vzhledu křížku) 
klikněte levým tlačítkem na libovolné místo DPS a stlačte klávesu „Enter“. Opět uvidíte 
dialogové okno {Place Copper Pour  ≡  Rozlít měď}, zvolte záložku {Boarder  ≡  Obrys}, 
zaškrtněte volbu {Depending on Board  ≡  Závisí na desce} a stlačte „OK“ - měď je rozlitá. 
Tímto způsobem si ulehčíte práci zejména tehdy, když vaše DPS bude mít složitý obrys
i s případnými oblouky.

Objekt „Rozlitá měď“ má dva módy výplně: vylitý a nevylitý. Druhý mód je výhodnější 
v případech, kdy ještě editujete objekty ve vrstvě, kde se objekt „Rozlitá měď“ nachází, nebo ve 
vrstvách spodnějších. Na změnu módu nebo jinou úpravu tohoto objektu musíte být 
v standardním módu programu. Kurzorem myši ukažte na okraj ohraničení rozlité mědi, vrcholy 
se vysvítí. Teď pravým kliknutím vyvoláte kontextovou nabídku a v ní zvolíte možnost 
{Properties...  ≡  Vlastnosti}. Znovu se otevře dialogové okno {Place Copper Pour  ≡  Rozlít 
měď} a v poli {Current State  ≡  Současný stav} si zvolíte požadovaný stav {Poured | Unpoured 
≡  Rozlitý | Nerozlitý}, případně i jiné změny a stav aktualizujete tlačítkem „OK“.

Pokud máte jako aktivní zvolenou horní vrstvu, objekty této vrstvy jsou viditelné 
a můžete je editovat – signálovou vrstvu i vrstvy sítotisku. Zvolme tedy signálovou vrstvu {Top 
≡  Horní} jako aktivní:
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5.10 Zamykání objektů

Při editování schématu nebo DPS se stává, že některé objekty potřebujeme zabezpečit 
před nechtěnými změnami jejich polohy nebo vlastností. V programech DipTrace se dají vybrané 
objekty a součástky uzamknout všechny najednou. Vyzkoušejte si to. Vyznačte skupinu několika 
objektů, například v dolní polovině, vysviťte jeden z nich a pravým kliknutím vyvoláte nabídku, 
a v ní zvolíte položku {Lock Selected  ≡  Zamknout vyznačené} levým kliknutím.
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Všimněte si, že uzamknuté objekty, když jsou vybrané, mají nižší kontrast rohových 
značek, obklopujících vybraný objekt (v našem případě to bude stejný odstín jako prosvítající 
rozlitá měď ze spodní vrstvy, takže asi budete muset změnit mód objektu na nevylitý. Také 
nápověda v informačním koutě ukazuje text {(Locked)  ≡  (Zamknutý)}.

DipTrace 2.0 tutoriál  (CZ)  60



Uzamknutý objekt se nedá posouvat, zvětšit nebo zmenšit, editovat. Zkuste opět 
odemknout všechny objekty, třeba zrychleným postupem: stlačením kláves „Ctrl + A“ vyznačíte 
všechny objekty DPS, a stlačením kláves „Ctrl + Alt + L“ docílíte odemknutí všech zamknutých.

Je také možné uzamknout součástky jedné vrstvy potom, co je rozmístíte na uvažované 
straně desky. Z hlavního menu zvolte položku {Edit → Lock Components → Top | Bottom  ≡ 
Úpravy → Zamknout součástky → Horní | Dolní}. Takto se můžete zabezpečit před nechtěným 
posunem součástky v průběhu manuálního trasování desky. Pro odemknutí součástek použijete 
stejný postup  {Edit → Lock Components → Top | Bottom  ≡  Úpravy → Zamknout součástky 
→ Horní | Dolní} - uzamknutou stranu uvidíte zatrženou.

5.11 Ověření návrhu

Program DipTrace má několik funkcí na ověření správnosti návrhu, všechny jsou 
sdruženy pod položku hlavního menu {Verification  ≡  Ověření}. Pro kompletní ověření desky 
doporučujeme použít každou z nich: {Check Design Rules (DRC)  ≡  Ověřit zásady návrhu}, 
{Check Net Connectivity...  ≡  Ověřit propojitelnost sítí} a {Compare to Schematic...  ≡ 
Porovnat se schématem}.

Kontrola návrhových pravidel (DRC) je tou z nejdůležitějších, která umožňuje porovnat 
vzdálenosti mezi navrhovanými objekty s velikostí přípustných mezer. Je velmi pravděpodobné, 
že vaše současná DPS neobsahuje žádné chyby, protože je jednoduchá, ale i tak ji prověřte. 
Stlačte tlačítko „DRC“ na liště trasování nebo položku menu {Verification → Check Design 
Rules  ≡  Ověření → Ověřit zásady návrhu}, návrh bude zkontrolován a výsledkem snad bude 
hláška {No Errors Found  ≡  Chyby nenalezeny}. Vyzkoušejte si i změnu kritérií kontroly – 
zvolte položku {Verifications → Design Rules...  ≡  Ověření → Zásady návrhu} a tím vyvoláte 
okno s definicí návrhových pravidel.

V tomto dialogovém okně můžete stanovit 
dovolenou vzdálenost pro objekty různých 
typů. Zaškrtněte, pokud už není, volbu {Check 
Copper Pours  ≡  Ověřit rozlitou měď} a stlačte 
„OK“, okno se zavře. V návrhu DPS  přepněte 
jako aktivní spodní vrstvu ({Bottom  ≡ 
Spodní} na liště trasování), vypněte zobrazení 
rastru („F11“), a stav rozlité mědi změňte na 
vylitý, posuňte některý segment trasy tak, že se 
dostane do kontaktu s rozlitou mědí a nakonec 
spusťte kontrolu návrhových pravidel tlačítkem 
„DRC“.
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Teď už spatříte seznam chyb (v našem případě pouze s jednou). Po dvojitém kliknutí 
levým tlačítkem na řádek s chybou se poloha chybného místa posune do středu okna a k danému 
kroužku přibude záměrný kříž, aby se vadné místo dalo rychle najít. Bez toho, abyste okno 
{DRC – Errors found  ≡  DRC – Nalezené chyby} zavřeli, můžete dotyčný spoj odsunout do 
patřičné vzdálenosti a znovu spustit kontrolu tlačítkem {Run DRC  ≡  Spustit DRC} v tomto 
okně.

Test konektivity sítí ověřuje, zda všechny sítě jsou patřičně zapojené. Pro současný návrh 
to není tak důležité, později však můžete pracovat s návrhem, který má mnoho vrstev, vývodů, 
ploch s rozlitou mědí, vodivých útvarů a možná i překážek v signálových vrstvách, kde některé 
objekty není možné umístit. V tom případě kontrola celistvosti sítí bude určitě přínosem. 
Prověřuje se, zda všechny sítě  mají úplné trasy svých spojů a zobrazuje přerušené a překřížené 
spoje. K této funkci se ještě později vrátíme a probereme ji do větších detailů. Teď na zkoušku 
zvolte {Verification → Check Net Connectivity...  ≡  Ověření → Ověřit propojitelnost sítě} 
a stlačte „OK“ v dialogovém okénku. S největší pravděpodobností nebude žádná chyba zjištěna 
a v tom smyslu bude zobrazena příslušná hláška.

Funkce porovnání DPS se schématem dokáže zkontrolovat, zda návrh DPS zodpovídá 
souboru, ve kterém je uloženo zdrojové schéma. Dokáže poukázat na chyby ve struktuře spojů, 
chybující nebo neznámé součástky. Zvolte tedy  {Verification → Compare to Schematic...  ≡ 
Ověření → Porovnat se schématem} a v dialogovém okně vyhledejte soubor s obvodovým 
návrhem. Pokud jste nějak nezměnili strukturu sítí, nebude zjištěna žádná chyba a takto bude znít 
i zobrazená hláška {No errors have been found while comparing the schematic and the board.  ≡ 
Žádné chyby nenalezeny při porovnání schématu a desky}.

Jinak  má test konektivity sítí i  funkce porovnání DPS se schématem při zjištěných 
chybách obdobný výstup jako kontrola návrhových pravidel (DRC), jednotlivé chyby můžete ze 
seznamu zvýraznit.
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5.12 Informace o návrhu

 Jak spočítat všechny vývody nebo plochu desky našeho návrhu? Pro tentokrát to není 
těžká úloha, ale až přijde na stovky pinů a složité obrysy desky s oblouky, může to být 
neproveditelné. Máme však na to nabídku {File → Design Information...  ≡  Soubor → 
Informace o návrhu} v hlavním menu:

V dialogovém okně, které se otevřelo, můžete vidět počty různých objektů, vrstev, 
rozměrů desky a sortiment použitých otvorů. Přehled počtu otvorů podle velikostí můžeme 
uvidět po stlačení tlačítka „...“ vpravo od sortimentu otvorů {Number of Sizes  ≡  Počet 
rozměrů}.

Před dalším pokračováním odstraňte prosím plochu s vylitou mědí, už přece víte, jak to 
provést – aktivní vrstva spodní, pravé kliknutí na obrys rozlité mědi, kliknutí na položku {Delete 
≡  Odstranit}.

5.13 Multiplikace návrhu {Panelizing}

Když snad potřebujete několik kopií té samé DPS a chcete ušetřit čas i peníze, použijte 
funkci multiplikace návrhu, pomocí které dostanete několik kopií na jednu plochu – panel. 
Funkci vyvoláte z hlavního menu výběrem {Edit → Panelizing...  ≡  Úpravy – Multiplikace}.
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Udělejme si 4 kopie našeho návrhu, tedy jeho násobení v dvou sloupcích a dvou řadách. 
Mezery mezi DPS jsme zvolili 1 mm vodorovně i svisle. Šířku {Rail Edges  ≡  Orámování} jsme 
nastavili na 3 mm ke všem stranám obrysu panelu. Většinou není nutné, ale může být užitečné 
znát celkovou plochu panelu, z ukázaných rozměrů panelu to lehce vypočítáme. Někteří výrobci 
DPS vyžadují, aby obrys panelu byl zahrnut do své vlastní vrstvy, takže zaškrtneme volbu 
{Show Panel Boarder  ≡  Ukázat obrys desky}. Klikneme na „OK“ a obdržíme následující 
obrázek:
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Na ploše návrhu DPS vidíme další kopie jen jako obdélníky s textem {Copy #  ≡  Kopie 
č.}, ale v náhledu na tisk, při tisku anebo exportu souborů gerber/dxf/NC vrtání tam budou 
zahrnuty kompletní obrazy všech kopií.

Upozorňujeme na to, že multiplikace návrhu funguje jen tehdy, pokud DPS má definován 
svůj obrys.

Teď opět vyvolejte okno {Edit → Panelizing...  ≡  Úpravy → Multiplikace} a změňte 
počet sloupců i řad na 1. Tím se vrátíte k individuálnímu zobrazení návrhu.

5.14 Tisk

Navrhujeme vám teď použít dialogové okno náhledu na tisk DPS. Jeho otevření 
dosáhneme volbou {File → Preview...  ≡  Soubor → Náhled} z hlavního menu nebo 
odpovídajícím tlačítkem na standardní liště. Asi vás napadne, že jsme nehovořili o tom, jak v této 
sekci vytvořit rohová razítka pro výkres DPS. Jestli si přejete tuto informaci zobrazit, zavřete 
náhled, pokud je už zobrazen, zvolte {File → Titles and Sheet Setup..  ≡  Soubor → Nastavení 
titulků a listu} a v dialogovém okně {Titles and Sheet Setup  ≡  Nastavení názvů a listu} zvolte 
např. ANSI A v seznamu {Sheet Template  ≡  Šablona listu}, zaškrtněte {Display Titles  ≡ 
Ukázat titulky} a zavřete okno tlačítkem {Close  ≡  Zavřít}. Obdobný postup jsme už probrali 
v kapitole 1.  Po vyplnění zamýšlených informací otevřete opět okno náhledu na tisk.
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 V dialogovém okně náhledu můžete přizpůsobit vzhled DPS zaškrtáváním nebo rušením voleb 
ve skupině {Objects  ≡  Objekty}. Pokud chcete změnit měřítko pro tisk vašeho návrhu, vyberte 
ho ze seznamu {Print Scale  ≡  Měřítko tisku} nebo stlačte tlačítko „+“ pro přiblížení, „-“ pro 
vzdálení. Pro posouvání výkresu na tisknuté stránce je tu tlačítko „✥“ {Move Board  ≡  Posunout 
desku}, po jeho zvolení (na dolním obrázku) můžete desku uchopit myší a tahat. Dále toto 
dialogové okno umožňuje zvolit aktuální signálovou vrstvu nebo pláň {Current  ≡  Aktuální} 
a její způsob zobrazení {Show  ≡  Ukázat}. Když chcete dostat zrcadlové zobrazení desky 
s textem nebo samotného textu, použijte volby {Mirror  ≡  Zrcadlit} (a)nebo {Flip Text  ≡ 
Překlopit text}. Na spuštění tisku je tu tlačítko {Print  ≡  Tisk}. Místo vytisknutí můžete zvolit 
uložení do souboru *.bmp nebo *.jpg, použitím tlačítka {Save  ≡  Uložit}. Malé tlačítko 
s barevnou paletou slouží na nezávislou definici barev jen pro tisk. Jinak je pro tisk 
přednastavené standardní schéma bílého pozadí. Také barvy ve vrstvách budou změněné 
schématem {Printing Colors  ≡  Tiskové barvy} jen tehdy, pokud v návrhu mají standardní 
barevné schéma. Jakmile mají zvolené jiné barvy v nastaveních pro jednotlivé vrstvy, tyto barvy 
budou použité i pro tisk. V případě potřeby černo-bílého tisku zaškrtněte čtvereček {Print in 
Black Only  ≡  Tisk jen černě}.
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Zavřete opět okno náhledu tisku tlačítkem {Close  ≡  Zavřít} a použijte tlačítko {Undo  ≡ 
Zpět} na obnovení rozlité mědi. Místo zrušení a obnovení této oblasti mohli jste též zvolit její 
zneviditelnění přes mód {Unpoured  ≡  Nerozlité}, a teď byste ji obnovili změnou módu na 
{Poured  ≡  Rozlité}.

6 Výrobní podklady

6.1 DXF výstup

Strukturu výstupního souboru DXF můžete využít na export vašeho návrhu do mnohých 
CAD/CAM programů, které podporují DXF import. Pokud jste používali AutoCad před 
přechodem na DipTrace, možná budete chtít upravit některé části vašich návrhů v programu 
AutoCad. Funkce DXF exportu také umožňuje produkovat podklady pro frézování spojů 
automaticky. Frézované cesty mohou být zkonvertované z DXF do G-kódu volně šiřitelným 
ACE konvertorem (můžete si ho stáhnout i z web stránky DipTrace).

Otevřete teď položku hlavního menu {File → Export → Diptrace ASCII | DXF... | 
Gerber... | N/C Drill... | Mach 2/3 Drill... | OrCad TAP Drill... | Pick and Place... | P-CAD ASCII... 
| PADS PCB ASCII 2005... | Autorouter DSN...} a zvolte možnost DXF. V teď otevřeném 
dialogovém okně stlačte tlačítko {Select All  ≡  Vyznačit vše} a všechny vrstvy vašeho návrhu se 
vyznačí. Vidíte také, že vrstvy {Edge_Top  ≡  Horní hrana} a {Edge_Bottom  ≡  Dolní hrana} 
nejsou součástí vašeho návrhu. I tak by bylo možné je vyznačit pomocí klávesy „Ctrl“ a levým 
kliknutím, ale teď tyto vrstvy nepoužijeme. Pokud chcete, můžete upravit rozsah a vlastnosti 
exportovaných objektů volbami v pravé části dialogového okna a tak zobrazit nebo skrýt objekty, 
zrcadlově obrátit návrh nebo texty. Stlačte teď tlačítko „Export“ a tak uložte výstupní soubor. 
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Teď ho můžete otevřít programem AutoCad nebo jiným, který podporuje strukturu 
AutoCad DXF.
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A co si myslíte o metodě výroby DPS s frézováním mezer? Je to vhodná a laciná metoda 
pro výrobu nepříliš složitých desek. Pojďme se tedy podívat, jak na tento způsob použít 
DipTrace. Zvolte {File → Export → DXF } na otevření dialogového okna exportu. Potom zvolte 
vrstvu {Edge_Bottom  ≡  Dolní hrana}, všechny spoje vaší desky jsou přece ve spodní vrstvě, 
ne? Zaškrtněte čtvereček {Mirror  ≡  Zrcadlit}, obraz se převrátí tak, jako kdyby jste se na DPS 
dívali odspodu. Potom stanovte {Edge Width  ≡  Šířka záběru}, osa frézované dráhy bude 
v polovině stanovené šířky od navržených objektů a hloubka frézování závisí na šířce dráhy 
a úhlu nástroje. Stlačte tlačítko „Export“ a uložte soubor DXF pod vhodným názvem.

Teď můžete tento soubor otevřít například programem AutoCad a podívat se na výsledek.
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Dráhy exportované z programu DipTrace jsou vlastně souborem čar (multičáry) 
s definovanou šířkou. Před jejich exportem DipTrace prověří návrh a jestli některá vzdálenost od 
objektu k objektu je menší než šířka dráhy, program ukáže varovné a chybové hlášení, abyste 
mohli situaci opravit. Ještě zmíníme, že CAD programy často ukazují multičáry s ostrými úhly 
a někdy se obraz z CAD programu zdá problematickým, ale při frézování desky nebo simulaci 
frézování v CAM programu nebudou žádné problémy vzhledem na poloměr nástroje. 

Teď můžete konvertovat frézované dráhy z formátu DXF do G-kódu s použitím 
konvertoru ACE.

6.2 Výstup Gerber 

Z hlavního menu vyberte {File → Export → Gerber...}. V dialogovém okně {Export 
Gerber} vyznačte vrstvy (v případě potřeby před kliknutím stlačte „Ctrl“ nebo „Shift“ pro 
vícenásobný výběr) a další objekty k exportu, potom stlačte tlačítko {Preview  ≡  Náhled}. 
Můžete také vybírat vrstvy jednotlivě, tzn. pro každou vrstvu samostatný soubor. Dalším 
možným postupem je vybrat všechny vrstvy (vybrat jednu za druhou, určit nastavení/objekty 
a nahlédnout), potom kliknout na tlačítko {Export All  ≡  Exportovat vše} a všechny soubory se 
vytvoří najednou. Vyprodukujme spolu výstupy Gerber následujícím postupem:
1.  Vyznačte {Top Assy  ≡  Horní sestava} - toto je vrstva mechanické sestavy a obyčejně se 
nevyžaduje k výrobě DPS. Obsahuje všechny útvary a texty  uložené do této vrstvy a objekty 
definované v podnabídce {View →  Assembly Layers  → *  ≡  Zobrazit → Vrstvy sestav → *} 
hlavního menu. V našem případě tato vrstva obsahuje asi jen text DPS s.r.o., jak můžete vidět 
v náhledu (pokud  položky {View →  Assembly Layers  → *  ≡  Zobrazit → Vrstvy sestav → *} 
mají standardně přednastavené hodnoty).

2.  Vyznačte {Top Silk  ≡  Horní sítotisk} - tato vrstva obsahuje útvary, obrysy a texty zařazené 
do vrstvy {Top Silk  ≡  Horní sítotisk}. Neměňte přednastavené hodnoty a zobrazte {Preview  ≡ 
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Náhled}. V případě, že texty nevidíte nebo jsou zobrazeny nekompletně (záleží na typu fontu 
a jeho velikosti), měli byste trochu zmenšit hodnotu v poli {Recognize Accuracy  ≡  Přesnost 
rozeznání} , nenastavujte však zbytečně nízkou hodnotu.

3.  Vyznačte {Top Mask  ≡  Horní maska} - toto je vrstva nepájitelné ochranné masky. Obyčejně 
se generuje automaticky v závislosti na ploškách, jejich parametrech a na společném parametru 
{Solder Mask Swell  ≡  Nárůst pájkové masky} definovaném v tomto dialogovém okně, a dále 
obsahuje všechny objekty které byly do této vrstvy vložené.  Snad bychom pouze měli zrušit 
zaškrtnutí čtverečku „Vias“, spojky jsou obyčejně překryté maskou. Mohli jsme  také změnit 
hodnoty nastavené pro masku pájecích plošek pravým kliknutím na zvolenou plošku a volbou 
položky podnabídky {Mask/Paste Settings  ≡  Nastavení masky/pasty}.

4.  Vrstva {Top Paste  ≡  Horní pasta} se obyčejně používá jen pro plošky SMT součástek, takže 
můžeme zaškrtnout volbu {Paste Mask for SMT Pads Only  ≡  Maska pasty jen pro plošky 
SMT}.

5.  Vyznačte signálovou vrstvu, tedy {Top, Bottom  ≡  Horní, dolní} apod. - toto jsou naše vodivé 
vrstvy. Zaškrtněte volbu {Vias  ≡  Spojky} pro všechny tyto vrstvy a v náhledu se přesvědčte, 
jestli jsou všude správně zobrazené. Jestli se chystáte vrtat díry manuálně, můžete také 
zaškrtnout volbu {Pad/Via Holes  ≡  Otvory plošky/spojky} abyste si později usnadnili práci, ale 
tato volby se nedoporučuje v případě, že soubory chystáte pro výrobce DPS, při zaškrtnutí se 
také objeví okno s upozorněním. Tu si můžete všimnout, že pokud zvolíte {Pad/Via Holes  ≡ 
Otvory plošky/spojky}, pro každou signálovou vrstvu obsahující průchozí plošky nebo spojky 
budou vytvořené dva další podklady – pro umístění a vyčistění. Ten druhý podklad slouží pro 
odstranění zbytků na vrtaných dírách.

6.  Vrstvy {Bottom Paste, Bottom Mask, Bottom Silk, Bottom Assy  ≡  Dolní pasta, Dolní 
maska, Dolní sítotisk, Dolní sestava} mají standardně všechny textové objekty převráceně tím, 
že je aktivní volba {View → Flip Text Automatically  ≡  Zobrazit → Překlopit text 
automaticky}, pokud však toto nastavení zrušíte, můžete teď nastavovat zrcadlení textu pro 
jednotlivé vrstvy podle svých záměrů (volba {Flip Text  ≡  Překlopit text} vpravo).

7.  Vrstva {Board Outline  ≡  Obrys desky} obsahuje jen obrys desky čarou definované šířky. 
Vrstva {Board  ≡  Deska} znázorňuje desku jako vyplněný polygon.
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Zvolte nyní vrstvu {Bottom  ≡  Dolní} a v náhledu se podívejte na její vzhled:
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Termín {Offset} ve funkcích exportu DXF, Gerber, N/C Drill a "Pick and Place" znamená 
„vyosení“, vzdálenost mezi nulovým bodem vrstvy a dolním levým rohem desky. Místo 
nastavených hodnot X, Y se může aplikovat počátek souřadnic z návrhu DPS tak, že zaškrtnete 
čtvereček {Use Design Origin  ≡  Použít počátek z návrhu} v okně exportu.

DipTrace umožňuje exportovat do formátu Gerber jakýkoliv text a fonty (třeba i čínské 
znaky) nebo rastrové černobílé obrázky (např. logo), ale měli byste určit rozlišitelnost 
{Recognize Accuracy  ≡  Přesnost zjištění} pro takovéto objekty (přednastavená hodnota je 
0,076 mm). Můžete hodnotu snížit až k 0,013 mm (= zvýšená přesnost).

Teď prosím zavřete náhled a klikněte na {Export All  ≡  Exportovat všechno} (pokud 
nejsou definované optické clonky (apertury), program požádá o souhlas nastavit je automaticky) 
a uložte výstupní soubory Gerber do složky, jeden po druhém. Příponu názvu jste už mohli 
změnit v dialogovém okně exportu, nebo teď manuálně před uložením souboru.

V programu DipTrace můžete exportovat i vrtací symboly pro různé typy děr. 
V dialogovém okně exportu vyberte vrstvu {Bottom  ≡  Dolní} zaškrtněte jen volby {Pad/via 
Holes  ≡  Otvory plošky/spojky} a {Mt Holes  ≡  Montážní otvory} (pokud už nejsou), 
zaškrtněte volbu {Drill Symbols  ≡  Vrtací symboly} a klikněte na tlačítko {Set Symbols  ≡ 
Nastavit symboly}. V novém dialogovém okně {Drill Symbols  ≡  Vrtací symboly} můžete ke 
každému typu otvoru přiřadit tlačítkem {Assign  ≡  Přiřadit} symbol ze seznamu, určit jeho 
velikost a šířku čáry, a nakonec okno zavřít. Nyní otevřete náhled v okně exportu a uvidíte 
výsledek. Zapamatujte si, že když necháte volbu {Drill Symbols  ≡  Vrtací symboly} zaškrtnutou 
a pokusíte se exportovat vrstvy sestavy, sítotisku signálů apod., výsledný náhled nebo soubor 
bude prázdný.
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6.3 Výstup pro numericky řízené vrtání

Pro export současného návrhu do formátu numericky řízené vrtačky vyhledejte v hlavním 
menu nabídku {File → Export → N/C Drill  ≡  Soubor → Export → N/C vrtačka}. Potom stlačte 
„Auto“  pro automatickou definici nástrojů a „Export“ na vytvoření výstupního souboru, soubor 
pojmenujte a uložte. Tu jsme nemuseli vybírat vrstvy pro průchozí otvory, ale pokud by šlo třeba 
o slepý otvor (například interní spojka), tehdy byste museli vybrat vrstvy, ve kterých je otvor 
umístěn. I zde můžete použít tlačítko {Preview  ≡  Náhled} na prohlédnutí výsledku.
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Gratulujeme!  Dokončili jste návrh jednoduchého projektu s použitím programů DipTrace. 
Prosíme vás, uložte soubory obvodového zapojení a navržené DPS, použijeme je později 
v dalších cvičeních zahrnutých do tohoto tutoriálu. Více času zabere čtení než vlastní dokončení 
projektu.
P.S.:  Pokud plánujete pustit se do návrhu dvoj- a vícevrstvých desek, nezapomeňte v nastavení 
autoroutra {Grid Router Setup  ≡  Nastavení rastrového routeru} zaškrtnout volbu {Use All 
Layers  ≡  Použít všechny vrstvy} dříve, než spustíte autorouter v takovém projektu. 

II Tvorba knihoven

Tato část tutoriálu vás naučí, jak vytvářet knihovny schematických značek a kontaktních 
matric s použitím programů „Component Editor“ (SchemEdit.exe) a „Pattern Editor 
(ComEdit.exe). Knihovny jsou korunními klenoty každé společnosti působící v oblasti návrhů 
DPS a s takovou péčí by se s nimi mělo zacházet, a také je ZÁLOHOVAT. Opakujeme: 
nezapomínejte zálohovat své knihovny třeba i na několik míst současně, pocit bezpečí je daleko 
lepší než pozdní lítost.

Po nainstalování programů DipTrace se knihovny nacházejí ve složce \Program 
Files\DipTrace\Lib jako soubory s příponou *.lib pro knihovny kontaktních matric a *.eli pro 
knihovny schematických značek. Kromě jména souboru knihovny, které se použije při otevření 
knihovny z editoru matric nebo značek z okna operačního systému, existuje také název 
knihovny, pod kterým se tato ukazuje na liště knihoven v programech {Schematic} a {PCB 
Layout}, a navíc ještě nápověda, pomocí které můžeme podrobněji komentovat obsah knihovny. 
Název knihovny by neměl být delší než asi 8 znaků, jinak se nezobrazí celý v tlačítku na liště 
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knihoven. Text nápovědy není takto omezen, a slouží nám na podrobnější informaci o obsahu 
knihovny.

O dialogovém okně {Library Setup  ≡  Nastavení knihovny} jsme již hovořili na počátku 
obvodového návrhu. Teď jenom připomeneme, že v tomto okně je v seznamu  uveden jejich 
název (ne jméno souboru!) a v závorce je připojena nápověda pro bližší informaci. 

1 Návrh knihovny kontaktních matric  (pouzder)

Otevřete program sady DipTrace pro návrh kontaktních matric (Editor matric), a sice přes 
nabídku operačního systému Windows: Start → Všechny programy → DipTrace → Pattern 
Editor. Seznamte se s pojmenováním částí okna podle obrázku v části  IV.3.

1.1 Přizpůsobení Editoru matric

Po otevření programu pro návrh kontaktních matric budete možná chtít zobrazit nebo 
skrýt některé součásti okna – prostředky na to najdete pod nabídkou hlavního menu {View  ≡ 
Zobrazit}, přesto zatím navrhujeme pouze změnit jednotky délky na mm: {View → Units → mm 
≡  Zobrazit → Jednotky → mm} – pokud je nastavení jiné..

Panel {Pattern Properties  ≡  Vlastnosti matrice} v horní pravé části kreslicí plochy je 
určen na definování různých atributů a pro návrh nových matric na základě předloh anebo typů. 
Možná budete chtít získat víc volné plochy při kreslení matric, a tak je možné tento panel 
minimalizovat na titulní záhlaví (tlačítko „▼“ v horním levém rohu) nebo úplně zavřít (tlačítko 
„x“ v horním pravém rohu). Opětovné zobrazení skrytého panelu se provede přes menu {View 
→ Pattern Properties  ≡  Zobrazit → Vlastnosti matrice}. 

Na změnu zobrazovaného měřítka můžete použít klávesy „Ctrl +“ {Zoom In}, „Ctrl -“ 
{Zoom Out} nebo vybrat požadované měřítko přímo z pole příslušného seznamu.
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1.2 Návrh osazovací matrice odporu

Jako první přírůstek kontaktní formy do vaší knihovny teď navrhneme matrici pro 
osazení rezistoru s rozteči vývodů 10,16 mm. Zapišme proto „Rez 10mm“ do políčka {Name  ≡ 
Název} a „R“ jako identifikační předponu do políčka {RefDes  ≡  Identifikátor} do panelu 
vlastností matrice. Jak v editoru matric, tak i v editoru schematických značek se definuje textový 
základ identifikačního označení, takže v tomto našem případě při umísťování odporů úplná 
identifikace bude R1, R2, R3 atd. Když tento základ není definován, program automaticky 
přiřadí „U“ jako předponu identifikátoru při umístění značky nebo matrice.

Pozn.: Pro první matrici použijeme typ {Free  ≡  Volný}, ale později se ukáže jako rychlejší 
volba typu {Lines  ≡  Linie}. Později si to předvedeme na některých dalších matricích.

Nově umísťovaná ploška na DPS získává standardní přednastavené parametry. Můžeme 
je vidět a i změnit v nabídce {Pattern → Default Pad Properties...  ≡  Matrice → Standardní 
vlastnosti plošky}. Nastavte tedy {Shape  ≡  Tvar} na elipsu, {Width  ≡  Šířka} na 1,5 mm, 
{Height  ≡  Výška} na 1,5 mm, {Hole Diameter  ≡  Průměr otvoru} 0,9 mm a {On Board  ≡  Na 
desce} zvolte {Through  ≡  Skrz}, a aby jste na svém monitoru viděli to co v tutoriálu, nastavte 
také měřítko zvětšení 600% a rastr 1,27 mm – vždyť už víte kde. S přidrženým pravým tlačítkem 
posuňte plochu nárhu, aby počátek souřadnic byl zhruba uprostřed.

Minimalizujme teď panel vlastností matric (tlačítko „▼“). Zvolte nástroj {Place Pad  ≡ 
Umístit plošku} na liště plošek, pohybujte křížkem kurzoru do polohy, kde bude umístěna první 
ploška, a levým kliknutím ji položte; dalším kliknutím v druhé poloze umístěte druhou plošku. 
Potom pravým kliknutím ukončíte mód pokládání.
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Vizuální způsob pokládání je pohodlný, ale ne příliš přesný, tak bychom měli prověřit 
souřadnice plošek a případně je opravit (na předchozím obrázku vidíte, že rozteč plošek je asi 7,5 
mm, a my žádáme 10,16). Je několik způsobů, jak změnit souřadnice objektu, mimo uchopení 
a potáhnutí myší. V tomto případě použijeme dialogové okno {Layer Objects  ≡  Objekty 
vrstvy}. Na pravé straně okna vidíte panel {Layers  ≡  Vrstvy}. Uvědomte si, že tentokrát se 
jedná jen o grafické vrstvy pro editování jednotlivých částí obrázku (nejsou to signálové ani jiné 
vrstvy DPS). Vyznačte tedy tyto vrstvy: přidržte levé tlačítko na {Layer 0  ≡  Vrstva 0} a táhněte 
na {Layer 1}, tlačítko uvolněte. Zvolte položku menu {Layer → Merge Layers  ≡  Vrstva → 
Sdružit vrstvy} nebo tlačítko s touto funkcí nad panelem. Teď máte obě vrstvy spojené do jedné 
společné {Layer 0} s oběma ploškami. Klikněte na ni dvakrát levým a otevře se dialogové okno 
{Objects – Layer 0} (obdobně i menu {Layer → Objects...  ≡  Vrstva → Objekty}.

Vyznačte řádek s ploškou souřadnice které chcete opravit, změňte je v polích X1, Y1 
a kliknutím na tlačítko {Close  ≡  Zavřít} okno zavřete. Vidíte, že by nebyl problém nastavit 
rozteč vývodů přesně na 10 mm, ne na 10,16 mm, mnohé součástky na desce však mívají rozteče 
odvozené z palcových mír a je možná vhodnější použít obdobný rastr pro všechny součástky. To 
však hlavně kvůli vizuálnímu dojmu, program pracuje stejně dobře s libovolnými rozestupy.
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Možná byste rádi změnili parametry plošek, třeba tvar, velikost, průměr díry, typ SMD 
nebo průchozí a podobně. Plošky použité v návrhu matrice mají standardní přednastavené 
hodnoty, které mohou být aplikovány na všechny plošky v návrhu, nic však nebrání tomu, aby 
každá ploška měla svoje vlastní nastavení. Hromadnou změnu plošek matrice dosáhneme 
změnou standardních nastavení: zvolte {Pattern → Default Pad Properties...  ≡  Matrice → 
Standardní vlastnosti plošky} a v otevřeném dialogovém okně {Pad Properties  ≡  Vlastnosti 
plošky} můžete v poli {Shape  ≡  Tvar} změnit tvar plošky na elipsu, ovál, čtyřúhelník nebo 
polygon (klikněte na {Points  ≡  Body} a stanovte počet vrcholů a třeba i jejich rozložení). 
Průměr otvoru se určuje jen pro plošku s prokovenou dírou. Můžete také plošce přidělit 
parametry podle předlohy {Template  ≡  Šablona}, nebo můžete parametry aktuální plošky 
pojmenovat jako vlastní předlohu: klikněte na „>>“ a otevře se manažer předloh, tlačítkem „+“ 
zařadíte na konec seznamu novou položku, potom ji vyznačte a v poli {Name  ≡  Název} 
přejmenujte vámi určeným názvem. Předlohy tu vytvořené poslouží na rychlou změnu parametrů 
plošek v různých dialogových oknech editoru matric i v programu návrhu DPS.
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Teď ale zavřete manažera šablon, změňte tvar plošky na {Rectangle  ≡  Obdélník}šířku 
{Width} na 2,5 mm, výšku {Height} na 2 mm, v seznamu {On Board:} vyberte {Surface  ≡ 
Povrch} a klikněte na „OK“, čímž změny získají platnost.
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Všimněte si, že povrchovou plošku můžeme přemístit na opačnou stranu DPS, v tomto 
případě na spodní stranu spojů (objeví se na horní straně desky v případě, že součástka je 
osazena zespodu desky). Klikněte tedy pravým tlačítkem na jednu z plošek a v nabídce vyberte 
{Change Side  ≡  Změnit stranu}. Aktuální strana pro pokládání plošek a tvarů je ukázána v 
seznamu stran na konci lišty plošek (teď pole ukazuje {Top  ≡  Horní}).

Teď změníme nastavení pro jednu jedinou plošku. Přesuňte kurzor nad první plošku, 
klikněte pravým tlačítkem a zvolte {Properties...  ≡  Vlastnosti} (pokud se ploška s kurzorem nad 
sebou nevysvítí, nejste v standardním režimu, a tak klikněte pravým na volnou plochu nebo 
stlačte tlačítko se šipkou {Default Mode}.

V dialogovém okně {Pad 1} zrušte zaškrtnutí {Default for Pattern  ≡  Standardní pro 
matrici}, abyste umožnili plošce přidělit její vlastní nastavení, potom zvolte v seznamu {Shape 
≡  Tvar} obrys {Polygon}, rozměry {Width} a {Height} na 2,4 mm, a následně stlačte tlačítko 
{Points  ≡  Body} pro otevření dialogového okna {Polygon Points  ≡  Body polygonu}. V tomto 
okně máte možnost změnit typ pravidelného polygonu {Regular} na nepravidelný s uspořádáním 
vrcholů {Set Points  ≡  Nastavit body} pomocí jejich souřadnic. Uzavřete dialogové okno 
{Polygon Points}, potom změňte průměr otvoru {Hole} na 1 mm, volbu {On Board} na 
{Through  ≡  Skrz} a stlačte „OK“, okno se zavře a změny se uplatní.

V dialogovém okně {Pad  ≡  Ploška} bylo také možné zadat souřadnice plošky a její 
směr. Parametry nastavené v tomto okně se nemusí aplikovat jen na tu plošku, na kterou jste 
klikli, ale na všechny současně vyznačené.
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Teď prosím definujte pro své plošky následující parametry – První: 2,4 x 2,4 mm, 
pravoúhlá {Rectangle}, průchozí {Through}, průměr otvoru 1 mm; Druhá: 2,4 x 2,4 mm, elipsa, 
průchozí, průměr otvoru 1 mm. A ještě nakreslete obrys rezistoru: zvolte tlačítko {Rectangle} na 
liště kreslení, a umístěte obdélník na plochu tak, že kliknete na místo prvního vrcholu a potom na 
místo druhého. Pro kreslení zvolte vrstvu {Top Silk  ≡  Horní sítotisk}, jinak nezůstane odpor 
zelený jako tu:
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Změňte mód kreslení na standardní (pravé kliknutí na plochu nebo tlačítko se šipkou 
{Default Mode}).

Pokud si budete přát obrys odporu nějak upravit, máte na to několik možností: vyvolat 
dialogové okno z hlavního menu {Objects – Layer 1  ≡  Objekty → Vrstva 1}; dvojitým 
kliknutím na vrstvu 1 v panelu kreslicích vrstev {Layers}; použít dialogové okno {Shape 
Properties  ≡  Vlastnosti tvaru}, ke kterému se dopracujeme pravým kliknutím na obrys odporu 
a zvolením položky {Properties}; použít metodu {drag-and-drop  ≡  táhnout a pustit}, tedy 
uchopit kterýkoliv vrchol obdélníku přidržením levého tlačítka na vyznačeném modrém rohu 
a tahat tento roh na jiné místo – použijte teď tento způsob: Zavřete panel {Pattern Properties  ≡ 
Vlastnosti matrice} (tlačítko „X“ v jeho horním pravém rohu), přibližte obrázek použitím kláves 
„Ctrl +“, změňte velikost rastru na 0,64 mm (pole rastru je na standardní liště vpravo od pole 
měřítka). Teď tedy uchopte některý roh obdélníku a upravte jeho rozměr (kurzor myši vám 
ukazuje možnost tahání).

Osazovací matrice odporu je hotova! Ještě si vyzkoušejte rotovat a převracet prvního 
člena vaší knihovny: zvolte {Edit → Rotate Pattern  ≡  Upravit → Otočit matrici} nebo {Edit → 
Vertical Flip | Horizontal Flip  ≡  Upravit → Překlopit vertikálně | Překlopit horizontálně}, 
případně klávesové zkratky „Ctrl+Alt+R“, „Ctrl+Alt+V“,„Ctrl+Alt+H“.

1.3 Uložení knihovny

Přišel čas, abyste svoji knihovnu pojmenovali, okomentovali a dali také název souboru, 
pod kterým bude knihovna uložena na disku. Za chvíli přidáme do této knihovny další matrice, 
už jen pouhým stlačením tlačítka „Save“.

V hlavním menu tedy zvolte položku {Library → Library Name and Hint...  ≡  Knihovna 
→ Název knihovny a komentář}. V dialogovém okně do pole {Name  ≡  Název} zapište název 
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knihovny (ne dlouhé, nejlépe do 8 znaků, my jsme zvolili název „Pokusy“), do pole {Hint} váš 
komentář k obsahu knihovny (v našem případě „Cvičné matrice“) a klikněte na „OK“. Jméno 
vaší knihovny se příště objeví na liště knihoven programu {PCB Layout}, a komentář se ukáže 
formou nápovědy při najetí kurzorem na patřičné místo na té liště.

Teď zvolte v hlavním menu nabídku {Library → Save  ≡  Knihovna → Uložit} nebo 
tlačítko s touto funkcí na standardní liště, vyhledejte si složku, kam chcete knihovnu uložit nebo 
ji teď vytvořte (pravým kliknutím na plochu souborů, zvolit Nový → Složka, vepsat nové jméno 
složky, např. „Mé knihovny“, uložit ho klávesou „Enter“ a otevřít novou složku opět klávesou 
„Enter“), napište zvolené jméno souboru (teď může být i delší, aby přispělo k přehledu 
v knihovnách – my jsme zvolili „Cvičná knihovna matric“) a stlačte {Save  ≡  Uložit}. 
Nedoporučujeme použít standardní adresář knihoven (obyčejně  C:\Program 
Files\DipTrace\Lib\), aby nevznikl problém při reinstalaci programu s knihovnami. Znovu 
opakujeme, své knihovny si ZÁLOHUJTE i na jiném umístění!

Od této chvíle bude v záhlaví okna programu uveden i název aktivní knihovny, takže 
budete mít přehled, s jakou knihovnou právě pracujete - „Pattern Editor – Cvičná knihovna 
matric.lib“.
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1.4 Návrh osazovací matrice kondenzátoru

Kondenzátor má velmi podobnou osazovací matrici v porovnání s rezistorem, ale 
záměrně ji vytvoříme s odlišnou sadou funkcí programu Pattern Editor.

Bude snad užitečné předem si zadefinovat standardní nastavení plošky a potom ji přiřadit 
k nové matrici, proto zvolte {Objects → Placement Setup...  ≡  Objekty → Nastavení 
rozmístění} z hlavního menu. V otevřeném okně nastavte v skupině {Current Pads  ≡  Aktuální 
ploška} : {Shape → Ellipse  ≡  Tvar → Elipsa}, {Width  ≡  Šířka} = 1,5 mm, {Height  ≡  Výška} 
= 1,5 mm, {Hole  ≡  Otvor} = 0,9 mm, {On Board → Through  ≡  Na desce → Skrz}. Potom 
klikněte na „OK“.

Skupina parametrů {Pad to Pad Spacing  ≡  Rozestup ploška-ploška} v tomto okně slouží 
k nastavení mezer mezi ploškami, když se pokládají hromadně v linii, v kruhu nebo do čtverce 
(nástroj na toto se nachází v menu {Objects → Place Pads → Single | Line | Rectangle | Circle  ≡ 
Objekty → Umístit plošky → Jedna | Linie | Obdélník | Kruh} nebo jako tlačítka na liště plošek).

Ve skupině {Mt. Hole Diameter  ≡  Průměr montážního otvoru} definujeme průměry 
montážního otvoru. V programu DipTrace má montážní otvor dva průměry: vnější – ohraničuje 
oblast, ve které není dovoleno trasování; a průměr vyvrtaného otvoru.

Hodnoty nastavené v dialogovém okně {Placement Setup} nemají vliv na žádnou  plošku 
v existujících matricích, nová nastavení program použije jen při kladení plošek do nového 
návrhu osazovací matrice.

Přidejme tedy novou matrici do knihovny: zvolte {Pattern → Add New to Library  ≡ 
Matrice → Přidat novou do knihovny} a v panelu matric na levé straně okna klikněte na nově 
přidanou položku s dočasným názvem {Untitled  ≡  Bez názvu}. Tento panel je vlastně 
seznamem všech matric knihovny kterou vytváříte nebo editujete. Pokud nevidíte na ploše panel 
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{Pattern Properties  ≡  Vlastnosti matrice} ani minimalizovaný, zobrazte ho volbou {View → 
Pattern Properties  ≡  Zobrazit → Vlastnosti matrice}, jeho minimalizovanou formu otevřete 
kliknutím na tlačítko „►“ v levém kraji minimalizované řádky. Zapište název „Kondenzátor“ do 
pole {Name} a identifikátor „C“ do pole {RefDes}.

Ze seznamu {Type  ≡  Typ} zvolte {Lines  ≡  Línie}, potom zapište hodnotu 1 do pole 
{Number 1} (počet linií pro tento typ), číslo 2 do pole {Number 2} (počet plošek) a 10 do pole 
{Spacing 1} (rozteč plošek.). Parametr {Spacing 2} znamená rozteč linií mezi sebou – nás teď 
nezajímá, protože naše matrice má plošky v jedné jediné linii. Teď ještě zatrhněte políčko vpravo 
od {Spacing 1}, uplatní se tak {variable parameter  ≡  proměnný parametr}, což později umožní 
změnit na DPS rozteč vývodů i bez spuštěného editoru matric. 
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S použitím různých typů rozložení plošek {Lines | Square | Circle |....  ≡  Linie | Čtverec | 
Kruh} se většinou navrhují matrice s pevnými roztečemi, fixním počtem vývodů apod. (snad 95 
– 100% vašich matric nebude mít proměnné parametry). V těchto případech prostě nebudete ta 
políčka zatrhávat. 

Minimalizujte panel {Pattern Properties} (tlačítko „▼“) a změňte tvar první plošky na 
pravoúhlý: pravým kliknutím na plošku  {Properties...  ≡  Vlastnosti}, v dialogovém okně zrušit 
zaškrtnutí {Default for Pattern  ≡  Standardní pro matrici}, v seznamu {Shape  ≡  Tvar} zvolit 
{Rectangle  ≡  Pravoúhlý} a „OK“. V liště kreslení zvolte obdélník bez výplně a nakreslete obrys 
kondenzátoru (bude to první objekt ve vrstvě horního sítotisku), potom zvolte nástroj pro přímku 
a nakreslete dvě čárky jako symbol „+“
(před kreslením + změňte rozteč rastru na 0,64 mm, aby mohlo být znaménko přiměřeně malé).
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Kondenzátor je tedy hotov. Nezapomeňte knihovnu uložit na konci návrhu ale i průběžně 
kliknutím na tlačítko {Save Library  ≡  Uložit knihovnu} se symbolem diskety.

1.5 Návrh matrice pro pouzdro DIP14

Pouzdro DIP14 navrhneme s pomocí nástroje pro linii plošek. Přidejte novou položku do 
knihovny v menu {Pattern → Add New to Library  ≡  Matrice → Přidat novou do knihovny}, ta 
se objeví v levém panelu matric jako {Untitled  ≡  Bez názvu} - klikněte na ni.. Pokud máte 
panel {Pattern Properties} minimalizován, otevřete ho („►“) a vložte {Name  ≡  Název} DIP14, 
{RefDes  ≡  Identifikátor} IO. Už víte z předešlého příkladu, že bychom mohli snadno zvolit typ 
{Lines  ≡  Linie} a změnit počet plošek na 14 a linií na 2 (to je nejrychlejší cesta jak navrhnout 
takovou matrici), jak to ukazuje další obrázek, ale naším cílem je teď použít nástroj linie plošek, 
proto zvolte typ {Free  ≡  Volný} a panel minimalizujte.
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Vyberte položku {Objects → Placement Setup  ≡  Objekty → Nastavení ukládání} 
a zkontrolujte (případně nastavte) hodnotu {Pad to Pad Spacing  ≡  Rozteč ploška-ploška} ve 
směru x i y na 2,54 mm. Zavřete tento dialog a zvolte {Objects → Place Pads → Line  ≡ 
Objekty → Umístit plošky → Linie} nebo odpovídající tlačítko na liště plošek. Přesuňte kurzor 
+ do plochy návrhu a natáhněte dvě svislé linie plošek: levé kliknutí na začátku první linie, 
táhnutí dolu až do sedmé plošky v linii (máme plošky 1 – 7) a zakončit opět levým kliknutím; 
nyní kliknout napravo od plošky 7 a tahat směrem nahoru linii plošek 8 až 14, ukončit opět 
levým kliknutím. Když potřebujete posouvat celou linii, klikněte v panelu {Layers} na vrstvu 
s touto linií a můžete linii přetahovat do žádané pozice. Vidíte, že linie byly uloženy v 
samostatných grafických vrstvách (panel vpravo), a tak je jednoduché vybrat jakoukoliv vrstvu 
a posouvat ji na jiné místo. Na nastavení rozteče mezi liniemi použijte nástroj měření 
vzdálenosti: stlačte tlačítko {Measure  ≡  Měřit} na liště kreslení, kurzor + nastavte na výchozí 
bod měření, přidržte levé tlačítko a tahejte kurzor k druhému bodu. V informačním koutě okna 
vidíte aktuální délku kreslené čáry a její složky ve směru x a y; při pozastavení pohybu se tato 
informace zobrazí i jako nápověda u kurzoru. Pravým kliknutím na plochu ukončíte mód měření.
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Teď změňte tvar plošky 1 na čtvercový: pravým kliknutím zrušíte mód měření a druhým 
pravým kliknutím na plošku otevřete kontextovou nabídku, zvolíte {Properties  ≡  Vlastnosti}, 
potom zrušíte volbu {Default for Pattern  ≡  Standardní pro matrici}, v seznamu {Shape  ≡ 
Tvar} vyberete {Rectangle  ≡  Pravoúhlý} a zakončíte „OK“. Nastavte rastr na 0,64 mm 
a vytvořte symbol pouzdra a použitím nástrojů pro kreslení přímky a oblouku:
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Zvolte prosím tlačítko lišty kreslení {Define Origin  ≡  Určit počátek} a kurzorem + 
umístěte počátek matrice DIP14 do středu plošky č. 1.

Navrženou matrici můžete také otáčet buď cestou menu {Edit → Rotate Pattern  ≡ 
Upravit → Otočit matrici} nebo klávesovou zkratkou „Ctrl+Alt+R“.

Před chvílí jsme umístili počátek souřadnic matrice mimo její geometrický střed, ale 
můžeme ho tam kdykoliv vrátit volbou nabídky {Edit → Center Pattern  ≡  Upravit → Centrovat 
matrici}. Doporučujeme vám, abyste tuto funkci využili u každého nového návrhu matrice na 
vycentrování počátku souřadnic, pokud ovšem nesledujete nějaký specifický záměr. Uložte 
aktuální obsah knihovny, „Ctrl+S“.

1.6 Návrh pouzdra DIP s proměnným počtem vývodů

Vyzkoušejte si návrh matrice pro pouzdro  DIP s volitelným počtem kontaktních plošek. 
Přidejte do knihovny novou položku {Pattern → Add New to Library}, tlačítkem „►“ zobrazte 
panel {Pattern Properties}, zapište v něm {Name} „DIP n“ a {RefDes} „IO“, zvolte {Type → 
Lines  ≡  Typ → Linie}, nastavte {Number 2} na 20 a zaškrtněte volbu {variable parameter  ≡ 
proměnný parametr} v políčku vpravo od {Number 2}:
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Minimalizujte panel (tlačítko „▼“), zvětšete kresbu - „Ctrl +“. Nakreslete symbol 
pouzdra a změňte plošku 1 na čtvercovou:
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Zobrazte znovu panel vlastností („►“) a zkuste změnit hodnotu v poli {Number 1} 
například na 16. Okamžitě vidíte, že délka symbolu pouzdra sleduje počet vývodů, takže takto 
můžete získat osazovací matrici pouzdra DIP s roztečí 7,62 mm (0,3“) s libovolným počtem 
plošek pouhou změnou jednoho parametru. 

Dokonce můžete změnit tento parametr i v návrhu DPS (program PCB Layout) 
v dialogovém okně {Pattern Properties  ≡  Vlastnosti matrice}, i v editoru obvodových značek 
a obvodovém návrhu z kontextové nabídky a dialogového okna {Attached Pattern  ≡  Přiřazená 
matrice}.

Jakmile se při změně hodnoty v poli {Number 2} ocitne číslo 1, typ první plošky bude 
změněn na přednastavený, v našem případě na elipsovitý (v ostatních programech bude možné 
měnit počet tlačítky nahoru/dolu v dolní pravé části dialogu {Attached Pattern  ≡  Přiřazená 
matrice}).

Pro tentokrát jsme s knihovnou skončili. Uložte změny tlačítkem {Save Library  ≡  Uložit 
knihovnu} a ukončete editor kontaktních matric buď v menu {Library → Exit  ≡  Knihovna → 
Opustit} nebo tlačítkem červené „X“.

1.7 Pokládání osazovacích matric

Spusťte návrhový program DPS „PCB Layout“ z operačního systému, tedy Start → 
všechny programy → DipTrace → PCB Layout.  Abyste mohli pokládat do návrhu matrice, 
které jste nedávno navrhli, musíte nejdřív aktivovat příslušnou knihovnu. Zvolte proto v hlavním 
menu {Library → Library Setup...  ≡  Knihovna → Nastavení knihovny}, zrušte zaškrtnutí {Get 
Libraries from Folder  ≡  Získat knihovny ze složky}, čím zpřístupníte seznam aktivních 
knihoven. Klikněte na tlačítko „...“ vpravo od seznamu nad tlačítkem „▲“, vyhledejte v dialogu 
„Otevřít“ vaši knihovní složku („Mé knihovny“) a v ní soubor vaší cvičné  knihovny „Cvičná 
knihovna matric.lib“, vyznačte ji a stlačte tlačítko „Otevřít“. Jméno vaší knihovny „Pokusy“ 
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s komentářem „(Cvičné matrice)“ je zařazeno na konec seznamu aktivních knihoven. Pokud 
chcete, pomocí tlačítek „▲“ a „▼“ můžete změnit její pořadí v seznamu. Tlačítkem {Close  ≡ 
Zavřít} ukončete dialog {Library Setup  }.

Posuňte lištu knihoven, aby se zviditelnily krajní názvy vpravo (tlačítko „►“, nebo 
sousední „“.napravo otevře posouvač), tam uvidíte a můžete otevřít svoji knihovnu „Pokusy“. 
Z panelu matric postupně vyberte vaše prvky  uložte na plochu, výběr zrušíte pravým kliknutím 
nebo „Esc“. Upravte značení matric, aby byl viditelný identifikátor a typ –  hromadně z menu 
{View → Pattern Marking → Main → RefDes  ≡  Zobrazit → Značení matric → Hlavní → 
Identifikátor}, nebo individuálně pravým kliknutím na matrici a v kontextové nabídce 
{Properties...} a v dialogovém okně zvolit záložku {Marking}. I když hovoříme o individuálním 
nastavení, týká se to najednou všech právě vyznačených matric.
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Vidíme, že jsme zapomněli změnit tvar první plošky na čtvercový u matrice DIP14. 
Uděláme to tedy teď při návrhu DPS i bez editoru matric. S kurzorem na plošce č. 1 u matrice 
DIP14 (vysvícena dočervena) klikněte pravým tlačítkem, zvolte v nabídce {Pad Properties  ≡ 
Vlastnosti plošky}, v dialogu {Pad 1} zrušte {Default for Pattern} a v seznamu {Shape} zvolte 
{Rectangle} a ukončete na „OK“.  Teď je matrice DIP14 v obvyklém provedení.
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Stejně snadné by bylo změnit všechny plošky matrice – kliknete pravým nad vysvícenou 
matricí, z nabídky zvolíte {Pad Properties...  ≡  Vlastnosti plošky} a upravíte hodnoty 
v dialogovém okně.

Když je počátek souřadnic matrice v jejím těžišti, můžete ho vidět jako značku kříže 
v době pokládání na DPS, potom se ztratí, zůstane však viditelný když nebyl takto vycentrován 
v editoru matric. I tak se dá libovolně toto zobrazení přepínat u všech vyznačených matric: 
pravým kliknutím na matrici vyvoláte nabídku {Pattern Origin  ≡  Počátek matrice} a v ní volbu 
{Show | Hide  ≡  Ukázat | Skrýt}.

Zkuste rotovat některou matricí (klávesa „R“, „Ctrl+R“ nebo „mezerník“) a uvidíte, že 
počátek je současně středem rotace. A když putujete kurzorem přes matrici a ta je právě 
vysvícena, souřadnice zobrazené v tom okamžiku v informačním koutě jsou souřadnicemi právě 
toho počátku. 

Teď byste snad potřebovali pouzdra DIP 10, DIP20 a DIP24, ale nemusíte je zvlášť 
navrhovat. Vyznačte kurzorem matrici DIP n, klikněte pravým tlačítkem, zvolte {Properties...  ≡ 
Vlastnosti} a v dialogovém okně {Component Properties}* záložku {Variables  ≡  Proměnné}. 
K dispozici máte parametr {Number 2} (v editoru matric jste ho označili jako proměnný), 
můžete tedy tlačítky nahoru/dolu měnit počet vývodů na kolik potřebujete (v náhledu vidíte 
výsledek), potom stlačením „OK“ dostáváte novou matrici. Mimochodem, v záložce {Main  ≡ 
Hlavní} a poli {Type  ≡  Typ} můžete matrici přejmenovat třeba na DIP24.

Obdobnou operaci můžete provést s roztečí vývodů kondenzátoru. Jen prosím buďte 
pozorní při vytváření, umísťování a změnách rozměrů u matric s proměnnými parametry. 
Doporučujeme vám, abyste pokud možno používali matrice s fixními parametry.

2 Návrh knihovny schématických značek

Spusťte prosím program editoru schématických značek, tedy: Start → Všechny programy 
→ Diptrace → Component Editor. Navrhneme několik obvodových symbolů (včetně 
vícenásobných) a přiřadíme k nim osazovací matrice z těch, které už máte ve vaší knihovně. 

* Pozn. překl.: Výstižnější by bylo {Pattern Properties}
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2.1 Přizpůsobení Editoru schématických značek

Přizpůsobit si editor schématických značek je jen podobným opakováním toho, co jsme 
dělali u přizpůsobení editoru matric. Po otevření programu zvolte {View → Display Origin  ≡ 
Zobrazit → Ukázat počátek} z hlavního menu, pokud není zobrazen počátek souřadnic a osy x 
a y. Panel {Component Properties  ≡  Vlastnosti symbolů} v horní pravé straně návrhové oblasti 
se dá minimalizovat nebo zavřít pomocí tlačítek „▼“ a „X“. V tomto panelu si můžete vybrat ze 
tří typů schematických symbolů: {Free  ≡  Volný} (nemá žádné specifické vlastnosti), 
{Rectangle  ≡  Obdélník} a {ShapeRect  ≡  Obdélníkový tvar}. Jediným rozdílem mezi druhým 
a třetím typem je to, že ten třetí má obdélník ve vrstvě sítotisku. A ještě něco k parametrům {Part 
Type  ≡  Typ dílu} a {Part  ≡  Díl} (jako díl tu máme na mysli část součástky, jejíž funkci 
můžeme znázornit samostatným schematickým symbolem - např. logické hradlo). U prvního 
parametru jsou možné volby {Normal | Power and Gnd | Net Port  ≡  Normální | Napájení a zem | 
Síťový port}. Součástka může obsahovat jen jeden jediný symbol {Power and Gnd  ≡  Napájení 
a zem} (pokud máte ve zvyku nezobrazovat v obvodovém zapojení rozvod napájení, potom 
vložte napájecí vývody do tohoto symbolu). Volba {Net Port  ≡  Síťový port} slouží obyčejně 
jako jednoduchý symbol, pomocí kterého možno logicky spolu propojit vodiče bez viditelného 
zobrazení na schématu, obyčejně pro propojení napájecích vývodů nebo také pro schémata 
s flexibilní strukturou (zanedlouho se pokusíme navrhnout takový symbol a použít ho). 

Možná budete chtít zadefinovat vzhled vývodů ještě před vytvořením schématické 
značky. Zvolte v hlavním menu {Objects → Pin Placement Setup...  ≡  Objekty → Nastavení 
umísťování vývodů}. Teď ponecháme parametry zobrazené v okně {Placement Properties  ≡ 
Vlastnosti umístění} nezměněné, ale všimněte si, že hodnoty {Length  ≡  Délka}, {X Spacing  ≡ 
Rozestup x} a {Y Spacing  ≡  Rozestup y} by měly být dělitelné zvolenou roztečí rastru, aby 
všechny klíčové body symbolu ležely na bodech rastru.
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2.2 Návrh značky odporu

Navrhneme teď obvodový symbol rezistoru s použitím typu {Free  ≡  Volný} 
a rozvržením „podle oka“. Nastavte si zvětšení 400% a rastr 1,27 mm. V panelu {Component 
Properties  ≡  Vlastnosti součástky} nejprve zapište název symbolu a předponu identifikátoru do 
patřičných polí {Name  ≡  Název} a {RefDes  ≡  Identifikátor}. Potom můžete panel 
minimalizovat jeho tlačítkem „▼“.
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Zvolte tlačítko {Pin } na liště objektů, přesuňte kurzor „+“ do plochy návrhu 
a opakovaným levým kliknutím položte dva vývody na plochu; pravým kliknutím zakončete. 
Otočte jeden pin o 180° tak, že ho vyznačíte a dvakrát stiskem kláves „Ctrl+R“ převrátíte. Na 
liště objektů stlačte obdélník bez výplně, a na ploše dokončete symbol rezistoru.

DipTrace 2.0 tutoriál  (CZ)  99



Vývody součástek mají svoje čísla a mohou mít i názvy. Čísla vývodů rezistoru 
v zapojení obyčejně nepotřebujete, a tak je můžete skrýt výběrem z menu {View → Pin Numbers 
→ Show | Hide | Font  ≡  Zobrazit → Čísla pinů → Ukázat | Skrýt | Font}. Vyzkoušejte si, že 
vývody můžete volně přesouvat po ploše, stačí uchopit přidržením levého tlačítka a tahat. Pokud 
chcete tahat nebo rotovat víc vývodů najednou, nejprve je vyznačte. 

Schematická značka rezistoru je tedy hotova, ještě k ní však potřebujeme přiřadit 
osazovací matrici, abychom umožnili přeměnu schématu s tímto rezistorem na DPS. Zvolte 
proto v hlavním menu {Component → Attached Pattern  ≡  Součástka → Přiřazená matrice}. 
V dialogovém okně {Attached Pattern}klikněte na tlačítko {Add  ≡  Přidat}, vyhledejte v okně 
„Otevřít“ složku „Mé knihovny“ a v ní knihovnu „Cvičná knihovna.lib“, a stlačte tlačítko 
„Otevřít“. Cestu k této knihovně teď máte zobrazenou pod tlačítkem {Add  }. Klikněte levým na 
tuto cestu a obsah knihovny se zobrazí v pravé spodní ploše okna. Vyznačte v tomto obsahu 
matrici „R10mm“ a uvidíte tuto matrici zobrazenou vedle schematické značky v horní části 
okna, s modrými čarami propojujícími každý vývod značky s příslušnou nožičkou součástky, 
a tedy s pájecí ploškou matrice.   Takové propojení se dá vytvořit nebo změnit tak, že kurzorem 
ukážete na vývod značky nebo plošku matrice, pokud propojení existuje, vysvítí se oba tyto 
objekty. Pravým kliknutím takové propojení zrušíte. Nové propojení vytvoříte levým kliknutím 
na zvolený vývod a dalším levým kliknutím na odpovídající plošku. Kliknutím na „OK“ se 
změny stanou definitivní a okno se zavře.

 
Propojení vývodu značky s ploškou matrice se dá předepsat i v seznamu {Connection 

List  ≡  Seznam spojení} uvedeného okna, a tento způsob je vhodný především pro součástky se 
středním až velkým počtem vývodů. Čísla vývodů značky a další jejich přidružené vlastnosti je 
také možno upravit v manažeru vývodů (zvolit {Component → Pin Manager...  ≡  Součástka → 
Manažer pinů} v hlavním menu a použít otevřené dialogové okno) nebo z kontextové nabídky 
(pravým kliknutím na vysvícený vývod, zvolit položku {Pin Properties  ≡  Vlastnosti pinu} 
a upravit v dialogovém okně). 
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Rezistor máme teď celý hotov, má svoji schematickou značku i osazovací matrici.
Nezbývá než vytvořit knihovní soubor pro vaše cvičné schematické značky. V hlavním 

menu tedy zvolte {Library → Library Name and Hint  ≡  Knihovna → Název a komentář 
knihovny} a dejte své knihovně název {Name} třeba „Základy“ a komentář {Hint} například 
„Cvičné schematické značky“ (můžete samozřejmě použít vlastní návrhy, jen nezapomeňte, že 
název knihovny nemá být dlouhý, nanejvýš asi 8 znaků). Kliknutím na „OK“ skončíte tuto etapu.

Nyní je třeba pojmenovat a uložit na disk soubor s vaší knihovnou. Klikněte na tlačítko 
{Save Library  ≡  Uložit knihovnu} na standardní liště, v okně „Uložit jako“ najděte složku „Mé 
knihovny“, do pole „Název souboru“ zapište „Cvičné obvodové symboly“ a klikněte „Uložit“.

2.3 Návrh schematické značky kondenzátoru

Nastavte si zvětšení 800% a rastr 0,64 mm. V hlavním menu zvolte {Component → Add 
New to Library  ≡  Součástka → Přidat novou do knihovny} a vyberte v panelu symbolů 
knihovny novou položku {Untitled  ≡  Bez názvu}. Schematický symbol kondenzátoru 
navrhneme s použitím typu {Rectangle  ≡  Pravoúhlý}.

Tlačítkem „►“ otevřete panel {Component Properties}, do pole {Name} zapište 
„Kondenzátor elyt.“, do pole {RefDes} předponu „C“ a v seznamu {Type} zvolte položku 
{Rectangle}. Změňte rozměr {Width  ≡  Šířka} na 2,54 mm, počty {Left Pins  ≡  Levé piny} 
a {Right Pins  ≡  Pravé piny} na 1. Rozměr {Pin Spacing  ≡  Rozestup pinů} není teď podstatný, 
týká se většího počtu pinů v řadě než 1. 
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Znovu minimalizujte panel vlastností stlačením „▼“ a vytvořte symbol kondenzátoru 
použitím nástrojů lišty kreslení, a sice obdélníku bez výplně a obdélníku s výplní. Nástrojem pro 
kreslení čar vytvoříte znaménko „+“.
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Aby se zobrazily názvy vývodů na vaší značce:  vyznačte vývody (nebo třeba všechno - 
„Ctrl+A“), prvým tlačítkem vysviťte a klikněte na jeden pin a z nabídky vyberte {Pin 
Properties...}. V zobrazeném dialogovém okně zatrhněte {Show Name  ≡  Ukázat název} 
a klikněte „OK“ - změny se uplatní a okno se zavře.

Mohli jste si také všimnout, že všechny nově vytvořené vývody jsou bez určení typu 
{Type: None  ≡  Typ: žádný} a elektricky nespecifikované {Electric: Undefined  ≡  Elektricky: 
nedefinován}. Určení typu se použije především na grafickou podobu vývodu, můžete si sami 
ověřit, jak se různé typy zobrazují. Elektrická specifikace je použitá při kontrole zapojení ERC 
{Electrical Rules Check  ≡  Ověření elektrických zásad} v programu obvodového návrhu 
„Schematic“.

Názvy vývodů se nám tedy ukázaly, ale jsou pro kondenzátor v nezvyklé poloze a je 
nutné je posunout, a tak zvolte k tomu určený nástroj z menu {View → Move Tool  ≡  Zobrazit 
→ Nástroj posunu} nebo jednoduše klávesou „F10“. Přemístěním kurzoru nad číslo vývodu se 
toto číslo ohraničí modrým rámečkem a dá se uchopit a posouvat přidržením levého tlačítka 
myši. Mód posouvání ukončíte pravým kliknutím nebo klávesou „Esc“.

Právě uvedený způsob posouvání je použitelný i na přesun názvů vývodů a atributů 
součástek v obvodovém zapojení.
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Aby nedošlo k nedorozumění, u našeho kondenzátoru jsme zobrazili názvy vývodů, čili 
jak jsou vývody pojmenovány, ne očíslovány! Zobrazené jméno se nezmění, i když změníte číslo 
vývodu, například kontaktní plošky. Můžete si také zobrazit invertující linku v názvu vývodu: 
pravým kliknutím nad vysvíceným pinem otevřete nabídku a zvolte vrchní položku {Pin Name 
≡  Název pinu}. Do pole v okně {Pin Name} zapište text „normal/~invert“ a stlačte „OK“, potom 
nástrojem pro posun „F10“ dejte název na vhodné místo. Vidíte, že znak „~“ je použitý jako 
indikátor pro začátek (nebo i konec) textu s vrchní linkou znamenající logickou inverzi, můžete 
tak označit i části dlouhého názvu pinu. 
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Pro součástku jako je kondenzátor asi nepotřebujete zobrazovat názvy vývodů, nám tu 
posloužil jen pro demonstraci. Všeobecná pravidla pro očíslování vývodů jsou definována v 
programu obvodového návrhu „Schematic“ a tato pravidla se standardně použijí pro všechny 
přidávané součástky, ale individuálně můžete zobrazování čísel vývodů změnit pro jakoukoliv 
součástku v tomto editoru schematických značek.

Zvolte nabídku {Component → Pin Manager...  ≡  Součástka → Manažer pinů} a otevře 
se dialogové okno manažera vývodů. Vyznačte řádek 2 v tabulce a dole v poli {Name  ≡  Název} 
zapište 2. Zrušte zobrazení názvu pro oba vývody najednou: s kurzorem na první řádce přidržte 
levé tlačítko a tahejte do druhé řádky, a zrušte zaškrtnutí políčka {Show Name  ≡  Ukázat 
název}. Tlačítkem {Close  ≡  Zavřít} ukončete dialog.

Předcházející dialogové okno umožňuje také měnit čísla vývodů (tzn. čísla přiřazených 
plošek), hodnoty souřadnic, délky, typy a elektrické specifikace, všechny atributy pinů jsou tu 
tedy pěkně pohromadě.
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Editor součástek vám umožňuje měnit zobrazení čísel vývodů individuální součástky 
z menu {Component → Pin Numbers → Show | Hide | Default  ≡  Součástka → Čísla pinů → 
Ukázat | Skrýt | Standardně}, a všeobecné nastavení (stejně jako v programu obvodového návrhu 
„Schematic“) s použitím nabídek {View → Pin Numbers → Show | Hide | Font  ≡  Zobrazit → 
Čísla pinů → Ukázat | Skrýt | Font}.

Teď prosím použijte jednu z uvedených možností a zobrazte čísla vývodů kondenzátoru. 
Pamatujte si, že není možné změnit nastavení, která byla individuálně specifikována v programu 
„Schematic“. Pokud chcete změnit pozici čísel vývodů, použijte známý nástroj posunu „F10“.
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Následujícím krokem je přidružení kontaktní matrice ke kondenzátoru. Zvolte tedy 
{Component → Attached Pattern...  ≡  Součástka → Přiřazená matrice} v hlavním menu, potom 
v dialogovém okně vyznačte svojí knihovnu a v seznamu matric klikněte na „Kondenzátor“.
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Všimněte si prosím, že je možné měnit vzdálenost mezi  nožičkami, protože tento 
parametr {Spacing 1  ≡  Rozestup 1} jsme v editoru matric uvedli jako proměnný. Ovšem po 
konverzi obvodového zapojení do návrhu DPS jsou všechny proměnné parametry fixovány 
a rozmístěné matrice dále mají pevný počet vývodů i pevnou jejich rozteč. Stlačte „OK“ 
a symbol kondenzátoru máme hotov. Pro jistotu uložte knihovnu: „Ctrl+S“.

Proměnné parametry můžete s výhodou využít u jednoduchých projektů, kdy 
upřednostníte rychlé přiřazení a přizpůsobení osazovacích matric v editoru značek nebo 
v obvodovém návrhu. Tento postup vám však nedoporučujeme používat u složitých návrhů, 
protože je tu větší pravděpodobnost omylů při stanovení nebo změnách variabilních parametrů.

2.4 Návrh vícenásobných součástek

Přistoupíme k návrhu jedné vícenásobné součástky, kterou bude čtyřnásobné hradlo 
NAND a napájecí symbol. Přiřazenou osazovací matricí bude pouzdro DIP14.

Spusťte program editoru symbolů (pokud už neběží) a otevřete svou knihovnu, třeba 
takto: {Library → Open Recent →   „library“≡  Knihovna → Nedávno otevřené → „řádek s vaší 
knihovnou“}. Dalšími kroky je {Componet → Add New to Library  ≡  Součástka → Přidat 
novou do knihovny}, v panelu symbolů kliknout na novou {Untitled  ≡  Bez názvu} a v panelu 
{Component Properties} – otevřít kliknutím na „►“ zapsat název schematické značky 
a předponu identifikátoru.

Příští úlohou je vytvoření schematických symbolů. DipTrace umožňuje vytvořit oddělené 
schematické části a skupiny podobných částí v rámci jedné součástky. Všechny části ve skupině 
mají stejné vývody, zobrazení a podobně, s výjimkou čísel vývodů (tedy příslušných plošek). 
Typ části může být kvalifikován jako {Normal  ≡  Normální}, {Power and Ground ≡  Napájení 
a zem} a {Net Port  ≡  Síťový port}. Typy napájení/zemnění a síťový port se mohou skrýt, 
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v schématu potom nejsou zobrazeny; součástka může obsahovat jen jednu část typu 
napájení/zemnění.

Společně tedy navrhneme součástku se 4 obdobnými částmi NAND a jednu napájecí část. 
V nabídce hlavního menu zvolte {Component → Create Similar Parts  ≡  Součástka → Vytvořit 
podobné části}.

 Do dialogového okénka zapište počet 4 a klikněte „OK“. Násobné části budou 
samozřejmě tvořeny v rámci součástky, která je právě vybraná.

Nyní se v spodní levé části okna objevily záložky: Part 1 (1), Part 1 (2), Part 1 (3) a Part 1 
(4). všechny části mají stejný název součástky a mají i své jednotné jméno (teď Part 1), které 
můžete změnit v poli panelu vlastností symbolu {Part  ≡  Část} například na „Hr“ (jako Hradlo).

Další část součástky je ta napájecí. Zvolte v hlavním menu {Component → Add New 
Part  ≡  Součástka → Přidat novou část} a vedle záložek „Hr“ přibyla další – Part 1. Pokud není 
v popředí, klikněte na ni a v poli {Part} panelu vlastností ji přejmenujte například „Nap“ - jako 
napájení. Uvědomte si, že tato napájecí část je ojedinělou částí  a nepřísluší do skupiny hradel 
„Hr“.

Teď navrhněte svou napájecí část: v panelu {Component Properties  ≡  Panel vlastností} 
vyberte v seznamu {Type  ≡  typ} položku {ShapeRect  ≡  Pravoúhlý útvar} a upravte 
následující parametry: {Width  ≡  Šířka} na 7,62 mm, {Pin Spacing  ≡  Rozteč pinů} ponechte na 
2,54 mm, {Left Pins  ≡  Levé piny} změňte na 2 a {Right Pins  ≡  Pravé piny} na 0. Nakonec 
v seznamu {Part Type  ≡  Typ části} zvolte {Power and Gnd}.
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V hlavním menu zvolte {Component → Pin Manager  ≡  Součástka → Manažer pinů} 
a změňte název a čísla vývodů na {Name}VCC a {Number} 14, {Name} Gnd a {Number} 7, 
a hromadně (s vyznačením obou řádek) nastavte {Electric  ≡  Elektricky} na „Power“ 
a zaškrtněte volbu {Show Name  ≡  Ukázat název}. I pole {Length  ≡  Délka} a {Type  ≡  Typ} 
se dají hromadně měnit pro všechny vyznačené řádky, teď to však nepotřebujeme.
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Zavřete okno {Pin Manager}, minimalizujte panel {Component Properties} a vidíte první 
část vaší součástky. Můžete ji zvětšit třeba klávesy „Ctrl +“.

Navrhneme ostatní části této součástky: zvolte jednu ze záložek patřících hradlům, třeba 
Hr (1), a v panelu vlastností symbolu - podle potřeby otevřít „►“ - nastavte následující 
parametry: {Type} „ShapeRect“, {Width} 5,08 mm, {Left Pins} 2, {Right Pins } 1. Panel 
můžete opět minimalizovat.

Zvolte textový nástroj na liště kreslení „Abc“, kurzor přesuňte dovnitř hradla, klikněte na 
zvolené místo a napište znak „&“, potom klikněte pravím tlačítkem a případně opravte pozici 
znaku.
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Jak víte, plánujeme návrh hradla NAND, ne AND, takže pin na pravé straně má mít 
značku inverze – kroužek: pravým kliknutím na vysvícený pin otevřete nabídku, v ní položku 
{Pin Properties  ≡  } a v dialogovém okně v seznamu {Type} zvolte {Dot  ≡  Kroužek}. 
Ukončete na „OK“.
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Všimněte si, že symbol hradla nemusíte vytvářet v ostatních záložkách, vyberte si je 
postupně a uvidíte, že stejné hradlo je nakreslené v každé z nich. Všechny části skupiny mají 
identický návrh, jen čísla vývodů se budou muset lišit, ty musíme teď změnit. Jako předlohu si 
vybereme obvod CMOS typu 4011.

V hlavním menu zvolte {Component → Pin Manager...  ≡  Součástka → Manažer pinů}. 
V dialogovém okně zvolte nahoře vpravo {Part  ≡  Část}: Hr (1), definujte jeho čísla vývodů, 
zvolte další hradlo, až dokud všechny piny u všech hradel nebudou správně očíslované. Řádky 
vývodů nemusíte posouvat myší, na další pin se dostanete i klávesou „↓“ resp. „↑“. Potom 
tlačítkem{Close  ≡  Zavřít} zavřete okno.

Máte také možnost definovat elektrické vlastnosti jako {Input  ≡  Vstup} a {Output  ≡ 
Výstup} pro příslušné vývody. Tyto parametry mohou být použity pro elektrickou kontrolu 
zapojení „ERC“ v programu obvodového návrhu.

Dalším krokem je svázání odpovídající kontaktní matrice s vícenásobným logickým 
obvodem. Zvolte v hlavním menu {Component → Attached Pattern...  ≡  Součástka → Přiřazená 
matrice}. Vyznačte knihovnu „Cvičná knihovna matric.lib“ a její obsah se rozbalí ve spodním 
panelu. Můžete použít pouzdro DIP14 s pevnými parametry nebo pouzdro DIP_n a zadat počet 
nožiček 14 do pole {Number 2  ≡  Číslo 2}. Zvolme teď první případ, pouzdro DIP14. Vidíte, že 
nemusíme definovat spojení vývod – ploška, protože všechna tato spojení mezi vývody 
a příslušnými ploškami byla určena pomocí manažéru vývodů. Vybírejte si různá hradla 
v horním levém seznamu dialogu {Part  ≡  Díl} a přesvědčte se, že všechna spojení jsou správná 
pro CMOS provedení našeho obvodu. Klikněte na „OK“ a tím potvrdíte přiřazení pouzdra 
a ukončíte dialog.
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Vícenásobné hradlo je tím ukončeno a je k dispozici pro použití v obvodovém návrhu. 
Pro jistotu knihovnu uložte - „Ctrl+S“.

2.5 Návrh napájecích symbolů Vcc a Gnd

Pro návrh napájecích vývodů VCC a GND použijeme typ vývodu „síťový port“. 
Výběrem hlavního menu {Component → Add New to Library  ≡  Součástka → Přidat novou do 
knihovny} přidáte nový prvek „Untitled“ do panelu součástek – klikněte naň. V panelu 
{Component properties} – asi třeba kliknout „►“ – definujte název VCC v poli {Name} 
a v seznamu {Part Type  ≡  Typ části} zvolte možnost {Net Port}. Všimněte si, že v panelu 
symbolů nalevo se zjeví označení „Net Port“ v pravém horním rohu součástky VCC, a takové 
označení budou nést všechny síťové porty.
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Minimalizujte panel {Component Properties}, v liště objektů zvolte nástroj jednoho pinu 
a umístěte jeden na plochu, změňte mód na standardní pravým kliknutím, vyznačte pin a klávesy 
„Ctrl+R“ ho rotujte do polohy podle obrázku. Potom kreslicím nástrojem linky nakreslete čáru 
nad pinem:
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Skryjte číslo vývodu výběrem {Component → Pin Numbers → Hide  ≡  Součástka → 
Čísla pinů → Skrýt} a symbol napájení je hotov. Nyní zopakujte celý postup od začátku této 
kapitoly pro symbol ukostření. Začnete tedy přidáním nového symbolu do knihovny, jeho 
pojmenováním a otypováním. Nástrojem pro kreslení linky dokreslete symbol a nakonec 
výběrem {Edit → Center Symbol  ≡  Upravit → Vystředit symbol} vycentrujte značku hlavně 
proto, že pro vycentrované značky standardně není počátek souřadnic symbolu zobrazen na 
obvodovém zapojení.

Jistě si uvědomujete, že k síťovým portům nepřiřadíme žádné pouzdro, protože tyto porty 
slouží jen na elektrické propojení vývodů různých součástek bez viditelného spojení na 
schématu.

2.6 Použití přídavných polí

 Pro pojmenování a identifikaci součástek slouží v editoru symbolů standardní pole 
{Name, RefDes, Value  ≡  Název, Identifikátor, Hodnota}. Někdy však bývá zapotřebí uvést 
třeba výrobce, linku na katalogový list, popis prvku nebo jiná další pole k součástce. V tomto 
případě použijete seznam {Additional Fields  ≡  Přídavná pole} a jejich obsah si určíte sami.

Zvolte v hlavním menu položku {Component → Default Additional Fields  ≡  Součástka 
→ Standardní přídavná pole}. Zobrazené dialogové okno vám dovolí přidat další standardní 
veličiny a jejich hodnoty pro všechny nové součástky. Když například tvoříte knihovnu pro 
součástky LT, můžete doplnit pole výrobce a dát mu hodnotu „Linear Technology“ jako nový 
standard. 

Přidejme tedy výrobce a cestu ke katalogovému listu: Napište slovo „Výrobce“ do pole 
{Name  ≡  Název}, zvolte v seznamu {Type} možnost „Text“ , napište do pole {Default Value  ≡ 
Standardní hodnota} „Linear Technology“ a klikněte na tlačítko {Add  ≡  Přidat}; potom zapište 
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do pole {Name}„Katalog“, zvolte {Type} „Link“ a do spodního pole hodnotu 
„http://alldatasheet.com“, a znovu klikněte {Add}. Jestli stlačíte tlačítko {Add to All  ≡  Přidat 
ke všem}, všechny dosavadní součástky v knihovně dostanou tyto dodatečné charakteristiky; 
v našem konkrétním případě by to nebylo vhodné. Dodatečné hodnoty pro jednotlivou součástku 
můžete zadat obdobným způsobem přímo z panelu {Component Properties} po stlačení tlačítka 
{Additional Fields  ≡  Přídavná pole}.

Od této chvíle tedy všechny nové součástky obdrží hodnoty v uvedených přídavných 
polích. Zavřete dialogové okno. Zvolte {Component → Add New to Library} nebo rychleji 
klávesy „Ctrl+Ins“ a přidejte novou položku „Untitled“ do knihovny, vyznačte ji, maximalizujte 
panel  {Component Properties} a klikněte na tlačítko {Additional Fields  ≡  Přídavná pole} 
a uvidíte přídavná pole pro nově zadávanou součástku.
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Pravým kliknutím na položku „Untitled“ se otevře nabídka a z ní můžeme součástku 
zrušit – {Delete Component}
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Zvolte teď v panelu součástek váš kondenzátor. Přesvědčte se, že nemá v přídavných 
polích panelu {Component Properties} zapsány žádné hodnoty, protože kondenzátor byl 
vytvořen ještě předtím, než jsme přídavné standardní pole stanovili. Zkuste tedy přidat několik 
polí teď: klikněte na {Add  ≡  Přidat}, napište „Výrobce“, zvolte „Text“ a doplňte jméno výrobce 
a „OK“, a znovu pokračujte od {Add}. Celé zadávání můžete nejen tu, ale u všech dialogových 
oken zakončit klávesou „Enter“ nebo zrušit klávesou „Esc“.

2.7 Nastavení parametrů „Spice“

V sade programů DipTrace můžete exportovat vaše obvodové zapojení do simulačního 
programu LT Spice a prověřit tak, jak pracuje. Toto téma probereme bod po bodě v části III 
tohoto tutoriálu. Na tomto místě jen uvedeme, že náš kondenzátor je kapacitorem s určitou 
hodnotou a může být zařazen do netlistu pro program Spice. Vyznačte tedy kondenzátor v panelu 
součástek, potom zvolte nabídku {Component → Spice Settings...  ≡  Součástka → Nastavení 
Spice} a v dialogovém okně ze seznamu {Model Type  ≡  Typ modelu} vyberte položku 
„Capacitor“. Dvojitým kliknutím ve sloupci {Value  ≡  Hodnota} na buňku s hodnotou „1 uF“ 
dostanete možnost tuto hodnotu případně změnit – potom klikněte do jiného pole nebo stlačte 
klávesu „Enter“. Ve výše zobrazené řádce {Template  ≡  Šablona}uvidíte, jak bude tato součástka 
prezentována v netlistě pro simulátor Spice. V našem případě jsou spárování pin-signál správná, 
ovšem kdybyste je potřebovali změnit u jiné součástky, jednoduše vložte jména signálů do 
tabulky v levé části okna. Seznam dostupných signálů máte informativně uveden pod tabulkou.
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Kondenzátor je velmi jednoduchá součástka, a tak nemusíme specifikovat jeho model 
v textovém souboru nebo programu, abyste předvedli jeho funkci (stačí jen typ modelu 
a kapacitu). Pokud se jedná třeba o tranzistory, můžete si stáhnout jejich modely z externích 
souborů (obyčejně jsou modely Spice k dispozici na stránkách výrobců), nebo můžete textový 
model napsat sami, pokud se v tom vyznáte (viz  dokumentaci jazyka Spice). V dialogovém okně 
je také k dispozici typ modelu {SubCkt  ≡  Pod-obvod}, pomocí kterého můžete vložit model 
téměř libovolného prvku v podobě programu.

Tlačítko {Get Spice Model from Library  ≡  Získat model Spice z knihovny} vám umožní 
přenést nastavení parametrů Spice modelu z jiné součástky v programu DipTrace.

Poznamenáváme, že stejné dialogové okno je k dispozici také v programu obvodového 
návrhu „Schematic“, takže můžete definovat parametry modelu Spice po dokončení (nebo 
v průběhu) návrhu obvodového zapojení.

Práci s naší knihovnou jsme teď skončili, proto klikněte na „OK“ a uzavřete tak nastavení 
modelu Spice. Potom na tlačítko se symbolem diskety v standardní liště a tak uložíte poslední 
podobu vaší knihovny. A zavřít můžete i program editoru součástek.

2.8 Vkládání součástek

Spusťte nyní program editoru obvodového zapojeni, např. navigací „Start →  Všechny 
programy → DipTrace → Schematic“. Vaši cvičnou knihovnu schematických značek musíme 
nejdřív přidat do lišty knihoven, a tak zvolte {Library → Library Setup  ≡  Knihovna → 
Nastavení knihovny}, zrušte zaškrtnutí políčka {Get Library from Folders  ≡  Získat knihovnu ze 
složek}, stlačte tlačítko „...“ nad „▲“ a vyhledejte svou knihovnu (podle nás „Cvičné obvodové 
symboly.eli“), vyznačte ji a stlačte „Otevřít“. V seznamu aktivních knihoven na konci najdete 
vaši knihovnu se jménem a komentářem – Pokusy (Cvičné schematické značky). Dialogové 
okno můžete zavřít.
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Jestli jsou zobrazeny osy souřadnic, skryjte je klávesou „F1“. Pro návrh schématu 
obyčejně souřadný systém není potřebný. Funkce tohoto systému je však stejná ve všech 
programech sady DipTrace, můžete ji tedy využít kde chcete.

Nyní prosím posuňte lištu knihoven úplně vlevo a na konci najdete tlačítko své knihovny 
„Základy“ - klikněte naň. Z panelu symbolů vlevo vyznačte rezistor a umístěte ho na plochu 
levým kliknutím; podobně i kondenzátor; zakončete pravým kliknutím.

Mohli byste také vyhledat a ukládat symboly vyvoláním dialogového okna {Place Part  ≡ 
Umístit prvek} buď z hlavního menu {Objects → Place Part  ≡  Objekty → Umístit prvek} nebo 
tlačítkem s identickou funkcí na liště objektů se symbolem IO. V tomto případě není potřebná 
předcházející konfigurace knihoven, svou knihovnu však musíte přidat do seznamu {Libraries  ≡ 
Knihovny} po stlačení tlačítka {Add  ≡  Přidat}.

Teď si ukážeme, jak se dají využít přídavná pole vašeho kondenzátoru. Klikněte naň 
pravým tlačítkem a z nabídky vyberte „Links → Katalog“. Takto jednoduše otevřete webovou 
stránku, kterou jste si k součástce definovali.
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Můžete si také zobrazit přídavná pole z hlavního menu {View → Part Marking → 
Additional | Main → Additional}, nebo ho i změnit přes okno vlastností (pravé kliknutí na 
značku a zvolit položku {Properties}).
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V panelu symbolů teď vyznačte vícenásobný symbol NAND 4x. Tento symbol jste 
vytvořili jako čtyři identická hradla a napájecí část. Postupné vkládání jedné skupiny hradel (ze 
stejného IO) vyžaduje mít v hlavním menu položku {View → Group parts  ≡  Zobrazit → 
Skupina částí} aktivní - zatrhnutou. V tom případě hradla nejsou dostupná v rozbalovacím 
seznamu v záhlaví panelu symbolů jednotlivě. Při jejich postupném vkládání do zapojení se 
vystřídají všechna v jednom pouzdru, když budete pokračovat dál, načne se nové pouzdro. 
Napájecí část se vloží do zapojení automaticky, pokud zaškrtnete volbu „Auto VCC/GND“, jinak 
ji vložte manuálně ze seznamu. 

Každé z hradel můžete vložit do schématu i jednotlivě, pokud nemáte položku {View → 
Group parts  ≡  Zobrazit → Skupina částí} zatrhnutou: V záhlaví panelu symbolů otevřete 
rozbalovací seznam a vyznačte požadované hradlo - levým kliknutím na plochu ho vložíte do 
zapojení. Pokud uložení zopakujete na dalším místě bez zvolení jiného hradla, vloží se hradlo se 
stejnými čísly vývodů, ale náležící novému integrovanému obvodu.

Ještě si povšimněte, že aktivní část součástky a počet všech části  je ukázán v panelu 
symbolů. Zvolte tedy hradlo Hr(4) a umístěte několik hradel do plochy návrhu. Program 
automaticky zvolí hradlo které je na řadě a také automaticky přidá napájecí část – políčko „Auto 
VCC/GND“ jste přece zaškrtli.
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 Ukážeme si teď, jak použít síťové porty. Uložte na plochu další hradla, abychom získali 
dvě pouzdra NAND obvodů (IO1 a IO2) a dva symboly napájecích části. Potom vyberte 
v panelu symbolů značku VCC a umístěte dvakrát, stejně pak se značkou GND. Propojte 
s napájecími částmi. Povšimněte si, že u síťového portu program zobrazuje název typu (v editoru 
značek je to „Jméno“). Můžete sjednotit dva síťové porty definováním stejného typu a dva 
vodiče připojené k síťovým portům obdobného typu budou navzájem spojené. Posuňte kurzor 
myši nad spoj s VCC nebo GND a uvidíte, že se vysvítí i další spoj, který náleží do stejné sítě.

DipTrace 2.0 tutoriál  (CZ)  124



Můžete si přejmenovat síť, která propojuje piny VCC tak, že vysvítíte spoj (tyrkysově) , 
po pravém kliknutí zvolíte první položku a v dialogovém okénku přepíšete název, nejlépe také na 
VCC. Stejně tak můžete vysvítit pin (dočervena), po pravém kliknutí vybrat druhou položku 
{Net Name  ≡  Název sítě} a máte zas k dispozici dialog na změnu názvu.

Vícenásobné součástky je možno vytvářet a spájet je s vhodnou osazovací matricí i bez 
programu Editor symbolů. Jednoduše v dialogovém okně {Component Properties  ≡  Vlastnosti 
součástky} (kliknutí pravým tlačítkem na součástku, položka „Properties...“) zaškrtněte volbu 
{Enable Parts  ≡  Umožnit části} a pro všechny symboly částí potom definujte stejné 
identifikátory. Později v tomto dialogu stlačte tlačítko {Attached Pattern  ≡  Přiřazená matrice} 
a můžete propojit vývody částí s příslušnými piny matrice.

V obvodovém zapojení můžete propojovat vývody do sítě i bez viditelných „drátů“. 
Klikněte pravým tlačítkem na vysvícený pin, zvolte {Add to Net  ≡  Přidat k síti}, potom 
v dialogovém okénku vyberte správnou síť nebo napište její nové jméno, zaškrtněte políčko 
{Connect without Wire  ≡  Připojit bez vodiče} a stlačte „OK“. Můžete i propojit sítě navzájem 
tak, že je pojmenujete stejným jménem (v dialogovém okně {Net Properties  ≡  Vlastnosti sítě} 
zaškrtnete volbu {Connect Nets by Name  ≡  Spojit sítě názvem}), a také je možné spojit pin se 
sítí obdobného jména automaticky (zaškrtnout volbu {Connect to Pins by Name  ≡  Spojit s piny 
podle názvu}). Tato posledně jmenovaná metoda je nejrychlejší pro rozvody spojů Vcc, Gnd, Clk 
apod., když plánujete skrýt napájecí sítě a části. Tyto funkce budou detailně popsány později.

III Použití některých vybraných funkcí
Tato část tutoriálu obsahuje popis důležitých funkcí, kterých jsme se dosud nedotkli. 

Prosíme vás však o pochopení faktu, že tento tutoriál se detailně nezabývá všemi funkcemi, které 
sada programů DipTrace poskytuje, snažíme se ho postupně dále rozšiřovat.
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1 Propojování

1.1 Sběrnice a propojení listů

V této sekci vám ukážeme, jak se používají sběrnice a propojují listy v programu návrhu 
obvodových zapojení „Schematic“.

V hlavním menu zvolte {Objects → Circuit → Place Bus  ≡  Objekty → Obvod → 
Umístit sběrnici} nebo takto specializované tlačítko na liště objektů, a na plochu návrhu umístěte 
sběrnici kliknutím na místa klíčových bodů, zakončete klávesou „Enter“ a pravým kliknutím do 
volné plochy obnovíte standardní mód. Kurzorem myši vysviťte pin, klikněte levým, přesuňte na 
sběrnici (vysvítí se tyrkysově) a opět klikněte levým tlačítkem. Otevře se okno, ve kterém 
můžete pojmenovat novou síť ve sběrnici anebo spojit pin s existující sítí (která už je připojena 
ke sběrnici).

Spojení přes sběrnici se dá kdykoliv změnit; jednoduše vysvítíte segment spoje 
připojeného k sběrnici, kliknete pravým a zvolíte v nabídce možnost {Bus Connection...  ≡ 
Připojení k sběrnici}. Teď máme 4 sítě připojené ke sběrnici, změníme například „Net 3“ na 
připojení „Net 2“. Od této chvíle jsou piny „IO2.2:5“ a „IO1.4:12“ připojeny ke stejné síti 
prostřednictvím sběrnice.

Označení spoje ke sběrnici může být alfanumerické nebo čistě číselné. Zvolte si ho podle 
vlastního vkusu v hlavním menu {View → Connection to Bus → Net Name | Net Number in Bus 
≡  Zobrazit → Připojení ke sběrnici → Název sítě | Číslo sítě ve sběrnici}.
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Teď prosím přidejte k obvodovému návrhu další list: zvolte {Edit → Add Sheet  ≡ 
Upravit → Přidat list} v hlavním menu nebo nebo na klávesnici stlačte „Ctrl+Ins“.Ihned uvidíte 
záložku {Sheet 2  ≡  List 2} vykukovat zespodu návrhové plochy. Zvolte teď tuto záložku.
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Po pravém kliknutí na tuto záložku máte možnost list přejmenovat, zrušit ho nebo přidat 
další z kontextové nabídky.

Zvolte nyní nástroj na umístění konektoru listů na liště objektů (tlačítko „Place Page 
Connector“) a vložte konektor na prázdný list (bude mít označení „Port 0“), vraťte se pomocí 
záložky na list 1 a i sem vložte konektor listů (zde to bude „Port 1“). Propojte tento konektor se 
sběrnicí: stlačte tlačítko sběrnice na liště objektů, vysviťte sběrnici a klikněte levým tlačítkem, 
vysviťte kroužek síťového portu a klikněte levým – je propojeno.

Vraťte znovu kurzor na „Port 1“, klikněte pravým a zvolte vrchní nabídku ze seznamu, 
tedy jméno portu, a změňte ho na „Port 0“ a „OK“. Teď uvidíte, že barva spojovacího bodu portu 
se změnila na zelenou. Tím je znázorněné, že aktuální konektor listu je propojen s některým 
jiným. Uvědomte si také, že se dá navzájem propojit i víc konektorů jen tím, že je nazveme 
stejným jménem.
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Přejděte na druhý list (záložka „Sheet 2“) a i tu vytvořte úsek sběrnice jdoucí z konektoru 
„Port 0“. Všimněte si, že název této sběrnice „Bus 0“ je stejný jako sběrnice na předcházejícím 
listě, jde totiž o stejnou sběrnici. Teď můžete uložit nějaké prvky na druhý list a propojit některé 
vývody se sítí „Net 2“ nebo „Net 3“ s použitím sběrnice nebo navrhnout nové sítě společné pro 
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zapojení na obou listech.

1.2 Používání síťových portů

Už jsme si vlastně vyzkoušeli použití síťových portů, když jsme vytvářeli spoje „VCC“ 
a „GND“. Ve většině případů se používají právě tímto způsobem, ale dají se také vytvářet 
vícenásobné spoje s použitím síťových portů a několika pinů.

Vložte několik dalších značek na list 2, ale nepřipojujte jejich vývody ke sběrnici. Na 
liště knihoven vyhledejte a vyberte knihovnu „Port_Sch“  (budete muset jít po liště vlevo 
tlačítkem „◄“), v panelu symbolů vyhledejte „Port8“ a umístěte do plochy návrhu. 

Propojte součástky s piny „Port8“, potom vložte „Port8“ i na první list návrhu a připojte 
součástky na tomto listě také k síťovému portu „Port8“. Můžete se sami přesvědčit, že názvy sítí 
připojených ke stejně očíslovaným pinům „Port8“ a listě 1 i listě 2 jsou také stejné, tzn. že 
všechny vodiče připojené k pinu 1 jakéhokoliv portu „Port8“ jsou navzájem spojené. Můžete 
připojit nebo odpojit porty (tedy jednoduše měnit strukturu zapojení) jen změnou řetězce v poli 
„Type“ v dialogu „Component Properties“ (pravé kliknutí na vysvícený „Port8“, a zvolit 
„Properties...“).

1.3 Skryté spoje

Propojení vývodů se také dá uskutečnit bez viditelného kreslení vodičů. V tomto případě 
vůbec nezáleží na tom, na jakém listě nebo na které pozici se součástka nachází. Posuňte kurzor 
na pin, který není dosud nikam připojen, klikněte pravým tlačítkem a zvolte položku {Add to 
Net  ≡  Přidat k síti}, v dialogovém okénku vyberte síť a zaškrtněte políčko {Connect without 
Wire  ≡  Připojit bez vodiče}, a stlačte „OK“. Na spodním obrázku vidíte pin připojený k síti 
„Net 5“ bez nakreslených spojů, na dalším se pracuje.
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Teď prosím posuňte návrhovou plochu, abyste měli k dispozici volnou část – pokusíme se 
připojit piny k síti podle jména. Umístěte jeden symbol „Gnd“ (na liště knihoven se vraťte ke své 
knihovně), na jeho pin položte kurzor, klikněte levým tlačítkem pro start kreslení spoje, táhněte 
trochu nahoru a zakončete klávesou „Enter“.
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Klikněte pravým tlačítkem na segment vodiče připojeného k symbolu „GND“ a zvolte 
„Properties...“. V dialogovém okně {Net Properties  ≡  Vlastnosti sítě} přejmenujte pole {Name 
≡  Název} na GND  a zaškrtněte volbu {Connet to Pins by Name  ≡  Připojit k pinům podle 
názvu}. Stlačte „OK“, změny se akceptují a okno zavře.

Na lište knihoven si teď vyhledejte knihovnu „AD“ a hned první součástku položte 
několikrát na plochu. Když vysvítíte jeden z pinů GND tak uvidíte, že všechny piny označené 
GND jsou automaticky připojené k síti GND „bezdrátovou“ metodou, bez nakreslených vodičů. 
Stejného účinku dosáhnete, když takovou volbu zaškrtnete při editování některé sítě. Program 
zkontroluje volné piny všech použitých prvků a připojí (neviditelně) všechny piny, kterých název 
se shoduje s názvem té sítě.

Tato funkce poskytuje nejpohodlnější způsob na připojení pinů, které mají stejné názvy 
v celém obvodovém návrhu. Obyčejně to bývá napájení, taktovací signály, ale třeba i datové 
sběrnice.

1.4 Manažér spojů v programech „Schematic“ a „PCB Layout“

Zřejmě nejjednodušším způsobem návrhu spojů v programech „Schematic“ a „PCB 
Layout“ je využití manažéra spojů. Otevřete ho z hlavního menu programu „Schematic“ volbou 
{Objects → Connection Manager...  ≡  Objekty → Manažer spojů} nebo podobně v programu 
„PCB Layout“ volbou {Route → Connection Manager  ≡  Trasovat → Manažer spojů}.

Podle všeho máte dosud spuštěn program obvodového návrhu „Schematic“ i s pokusným 
zapojením, otevřete tedy v něm i manažéra spojů. Zvolte některou síť z pole seznamu „Net“ 
v horní části dialogového okna a uvidíte všechny vývody do této sítě připojené. Máte teď 
možnost přidávat nebo odebírat piny v této síti. Pro přidání pinu vyhledejte v seznamech na 
spodku okna součástku a pin, a stlačte tlačítko {Add  ≡  Přidat}. Všimněte si, že v seznamech 
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vidíte jen dosud nezapojené piny, takže pokud některý nedokážete najít, je asi už připojen (patrně 
do jiné sítě). Můžete také vytvořit novou síť pouhým stlačením tlačítka „+“ v horní části. 
Sousední tlačítka „...“ a „X“ slouží pro přejmenování resp. zrušení sítě.

Stlačte „OK“, zavedete tím všechny změny a uzavřete dialog, nebo tlačítkem „Cancel“ 
zavřete dialog s návratem do struktury sítě při jeho otevření.

2 Identifikátory

Od tohoto bodu dále budeme svůj výklad ilustrovat na schématech uložených ve složce 
C:\Program Files\DipTrace\Examples, u vás případně i na jiném místě, které jste si zvolili pro 
instalaci DipTrace. Otevřete tedy zapojení Schematic_2.dch z uvedené složky příkladů:
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V tomto zapojení najdete různé druhy propojení vývodů, jak je navrhl náš pracovník, 
ovšem naším současným cílem je pomocí některých experimentů ověřit, jak pracuje systém 
identifikátorů (RefDes je zkratka Reference Designation  ≡  Referenční označení, překládáme 
jako identifikátor).

Zobrazené zapojení má celkem 23 kondenzátorů s identifikátory od C1 po C24 (C19 
chybí), ale může se stát, že při změnách návrhu potřebujete někam přidat další kondenzátor s 
označením například C5. Otevřete tedy vaši nedávno vytvořenou cvičnou knihovnu „Základy“ 
a vložte kondenzátor na schéma. Toto má být nový C5, ale momentálně má identifikátor C19. 
Pravým kliknutím na tento kondenzátor vyvolejte nabídku a zvolte vrchní položku „C19“, 
v okénku {Component RefDes  ≡  Identifikátor součástky} změňte C19 na C5 a stlačte „OK“. 
Program vám ukáže varovné hlášení, ale také vám nabídne možnost vyřešit konflikt 
přečíslováním identifikátorů s postupnou inkrementací čísla. Na potvrzení zvolte {Yes  ≡  Ano}.

Přidaný kondenzátor je tedy přejmenován na C5 a původní C5 je teď C6, atd., až po C18-
C19. Teď už tedy C19 nechybí, jak se můžete přesvědčit v manažeru spojů, a to proto, že jste 
přidali další C5. Stejným způsobem můžete přidat jakoukoliv součástku a přejmenovat její 
identifikátor s následným přečíslováním všech ostatních se stejnou předponou.

Nyní prosím změňte označení C5 na C30, a prověřte identifikátory kondenzátorů 
v manažéru spojů  (seznam „Part:“) – chybí C5, C25 až C29. Můžete tuto situaci napravit tak, že 
pravým tlačítkem kliknete na kondenzátor (C30) a zvolíte položku {Optimize RefDes → RefDes 
„C“  ≡  Optimalizovat identifikátory → „C“} - C30 se změnil na C24, ale proč? Při optimalizaci 
identifikátorů program vyplní všechny mezery v řadě identifikátorů, takže C6 – C24 se změní na 
C5 – C23 a C30 na C24.
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Ukončete teď program „Schematic“ bez uložení změn a spusťte program návrhu DPS 
„PCB Layout“, a v něm otevřete soubor PCB_2.dip opět ze složky Examples. Pokud nevidíte 
identifikátory zobrazte je: {View → Pattern Marking → Main → RefDes  ≡  }. Přejmenujte C8 
a C10 v horní části DPS na C28 a C30 (zase pravým kliknutím a volbou první položky). Uložte 
změněný soubor například jako PCB_2A.dip: {File → Save As...   ≡  Soubor → Uložit jako..}.
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Ukončete program „PCB Layout“ a spusťte znovu návrhový prostředek zapojení 
„Schematic“ (on se dá otevřít i přímo z běžícího „PCB Layout“: {Programs → Schematic} 
z hlavního menu, uživatelům Windows 98/ME však tento způsob nedoporučujeme). 

Otevřete soubor Schematic_2.dch a vyhledejte kondenzátory C8 a C10 ….no jistě, někdy 
je opravdu těžké vyhledat součástku s daným identifikátorem na velkém zapojení nebo DPS, 
a tak stlačte „Ctrl+F“ (nebo {Edit → Find Object  ≡  Upravit → Najít objekt} z hlavního menu). 
V okně do pole „Parameter:“ zapište C8 a stlačte „Enter“ nebo {Find Now  ≡  Najít teď}, C8 se 
octne vysvícen uprostřed zobrazené plochy návrhu. 

Všimněte si, že okno {Find Object  ≡  Najít objekt} se dá minimalizovat tlačítkem „▼“, 
takže zabírá méně místa a je stále k dispozici při editování návrhu. Také si můžete zvolit 
podrobnější měřítko, abyste C8 a C10 lépe viděli.

Asi už tušíte, že soubor „PCB_2.dip“ je řešením tištěného spoje podle obvodového 
návrhu „Schematic_2.dch“, a my jsme v něm předtím přejmenovali ty kondenzátory. Můžeme je 
přejmenovat i tu ve schématu, ale co byste na to řekli, kdyby v rozsáhlém projektu došlo 
k přejmenování stovek součástek (pokud jde o jejich označení na DPS) a jejich původní značení 
by si nikdo nepamatoval! Pro tyto případy použijete funkci {Back Annotate  ≡  Zpětně označit}, 
takže zvolte v hlavním menu {File → Back Annotate} a vyhledejte předtím uložený soubor 
PCB_2A.dip v dialogovém okně a otevřete ho. Hned se můžete přesvědčit, že obvodové schéma 
teď má všechny identifikátory shodné s DPS (v tomto případě C28 a C30).
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3 Vyhledávání součástek v knihovnách

Příslušenstvím programů DipTrace je ohromné množství součástek ve standardních 
knihovnách (asi 50 000) a tyto knihovny se stále rozšiřují. Knihovny jsou vytvářeny pro 
jednotlivé výrobce a součástky jsou v nich utříděné. Někdy se však stane, že neznáme výrobce 
nějaké součástky nebo může být vyráběna více výrobci, anebo neznáme přesné označení, možná 
jen skupinu číslic na konci názvu, a podobně. Abychom si v takové situaci lépe poradili, 
programy DipTrace mají speciální vyhledávací funkci.

Máte stále běžící program „Schematic“, a tak v hlavním menu zvolte {Library → Search 
Components...  ≡  Knihovna → Vyhledat součástky}. Předpokládejme, že potřebujete součástku, 
která ve svém jménu obsahuje číslo 232, ale nepamatujete si ostatní znaky v jejím označení – je 
to už měsíc, kdy vám ji kolega doporučil. A tak napište „232“ do pole {Name  ≡  Název} 
a stlačte {Find Now  ≡  Najít teď}. 

Za několik (desítek) vteřin program najde snad víc než 180 součástek, které obsahují 
řetězec „232“ ve svém názvu. Jakoukoliv součástku si můžete vyznačit a v spodním náhledu 
uvidíte název knihovny, schematickou značku a když stlačíte tlačítko „Pattern“, tak i osazovací 
matrici. Vyhledanou součástku je také možné okamžitě přenést do obvodového návrhu stlačením 
tlačítka {Place  ≡  Umístit}.

V uvedeném příkladě bylo nastavené vyhledávání ve všech aktivních knihovnách, je však 
na vašem rozhodnutí, zda budete vyhledávat ve všech knihovnách (i neaktivních) nebo omezíte 
výběr jen na vyznačené knihovny, na základě volby v poli {Search In  ≡  Hledat v..}. V seznamu 
knihoven se dá vyznačovat (levým tlačítkem myši, eventuálně spolu s „Ctrl“ nebo „Shift“) jen 
při volbě „Selected“.

DipTrace 2.0 tutoriál  (CZ)  137



Je celkem logické, že vyhledávání v knihovnách schematických značek se dá uskutečnit 
v programech „Schematic“ a „Component Editor“ {Component → Search in Libraries...  ≡ 
Součástka → Hledat v knihovnách}, zatímco v knihovnách osazovacích matric se vyhledává 
z programů „PCB Layout“ a „Pattern Editor“ {Pattern → Search in Libraries...  ≡  Matrice → 
Hledat v knihovnách}.

Vyhledávací funkce je také zabudována do všech dialogových oken pro umisťování 
/vkládání matric či symbolů, kde se také vyskytne potřeba vyhledávat v knihovnách matric nebo 
značek, ovšem v takových dialogových oknech se vyhledávání provede jen v seznamu knihoven 
příslušného okna.

4 Zkouška dodržení elektrických zásad

Funkce ověření elektrických zásad (ERC – Electrical Rules Check) vám pomůže snížit 
pravděpodobnost výskytu chyb při návrhu obvodového zapojení. Otevřete teď (pokud už 
nemáte) soubor „Schematic_2.dch“ ve složce „Examples“ z programu „Schematic“. Nejdříve si 
musíme stanovit ty zásady, a proto zvolte v hlavním menu nabídku {Verification → Electrical 
Rule Setup...  ≡  Ověření → Nastavení elektrických zásad}.

V otevřeném dialogovém okně je možné stanovit nepatřičná propojení vývodů, která 
mohou vyvolat hlášení chyby nebo varování při použití funkce ERC. Klikáním na čtvereček 
v průsečíku různých typů vývodů definujete, zda propojení těchto pinů je normální (zelená), 
podezřelé (žlutá) nebo chybné (červená). Tato kritéria se vyhodnotí, pokud v oblasti okna {Rules 
to Check  ≡  Pravidla k ověření} máte zaškrtnutou volbu {Pin Type  ≡  Typ pinu}. Tam můžete 
zvolit i kontrolu nepřipojených vývodů {Not Connected  ≡  Nepřipojené}, upozornění na sítě jen 
s jedním připojeným pinem {Only One Pin in Net  ≡  Jen jeden pin v síti}, které zřejmě nemají 
smysl a představují asi chybu ve struktuře sítí; nakonec i {Short Circuit  ≡  Zkrat} - kontrolu na 
propojení napájecích sítí se zemnícími  – šablonu pro vyhodnocení názvů napájecích a zemnících 
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pinů si navrhnete v poli okna {Power Pins for SC  ≡  Napájecí piny v zkratu}; tu název 
napájecích pinů začíná na „V“, zemnících na „G“.

Nastavte volby podle obrázku a stlačte „OK“ pro zavření okna. Nyní zvolte v hlavním 
menu {Verification → Electrical Rule Check (ERC)}.  Zapojení v souboru Schematic_2.dch by 
mělo ukázat jedno varování pro spojení {Bidirectional to Output  ≡  Obousměrný s výstupem}. 
Pro lokalizaci problému v zapojení udělejte dvojitý klik na řádek s uvedeným hlášením – 
v závislosti na vašem zvětšení a rozlišení uvidíte vysvícené piny a aspoň část sítě na ploše 
návrhu. Chybu můžete opravit (třeba odpojit J7/2 od sítě) a znovu spustit test i bez zavření okna 
s předešlými výsledky.
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Pokud byste chtěli prověřit i nezapojené piny, musíte nejdříve specifikovat, které piny 
jsou záměrně volné (takže kontrola {Not Connected  ≡  Nepřipojeno} je musí ignorovat). 
Klikněte pravým tlačítkem na každý takový pin a z nabídky vyberte položku {Not Connected}, 
čím ho izolujete od všech sítí i od kontroly ERC.

5 Rozpiska materiálu (BOM – Bill of Materials)

Program obvodového návrhu má i funkci vyhotovení rozpisky materiálu; ta vám 
umožňuje přizpůsobení sloupců a řádek, přidat tabulky nebo stránky k existujícímu projektu, 
exportovat soubory do formátu Excel CSV (čárkou oddělované hodnoty) nebo je uložit do 
textového souboru s patřičným tabulkovým formátováním. 

Zvolte v hlavním menu {Objects → Bill of Materials  ≡  Objekty → Rozpiska materiálu}. 
V seznamu {Table Rows  ≡  Řádky tabulky} vyberte {Component Type  ≡  Typ součástky}, 
a přidejte sloupce podle spodního obrázku takto: V seznamu {Show  ≡  Ukázat} zvolte {RefDes 
≡  Identifikátor}, ponechte {Width  ≡  Šířka}=20 a {Align  ≡  Zarovnat}={Left  ≡  Vlevo}, 
a stlačte tlačítko {Add  ≡  Přidat} vpravo nahoře; v poli „Columns“ máme definici prvního 
sloupce. Obdobně zopakujte pro položky seznamu {Show} podle definic 2 až 5 na obrázku. 
Nakonec zvolte v seznamu {Create On:  ≡  Vytvořit na} položku {New Sheet(s)  ≡  Nový 
list(y)}; v seznamu {Sheet Templates:  ≡  Šablona listu} položku {ISO A4 (Portrait)  ≡  ISO A4 
(na stojato)}. Zaškrtněte volbu {Adjust by Width  ≡  Nastavit podle šířky}, aby se tabulka 
rozšířila na stránce. Nakonec stlačte tlačítko {Place Table  ≡  Umístit tabulku} a tím přidáte list 
rozpisky A4 se záhlavím ISO k vašemu projektu.
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Dialogové okno rozpisky se zavře a ve vašem projektu na spodku vidíte záložku s novou 
stranou 2. Klikněte tedy na „Sheet 2“, s použitím menu {View → Display Sheet  ≡  Zobrazit → 
Ukázat list} a {View → Display Titles  ≡  Zobrazit → Ukázat razítka} zobrazíte list a dále 
můžete editovat šířku, výšku a počet řádek v buňkách, kde text přesahuje za hranice sloupce; 
klikněte levým tlačítkem na buňku a v dialogovém okně změňte potřebné míry, a kurzorem 
v poli textu a klávesou „Enter“ rozdělte text do více řádek.
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Teď máme rozpisku materiálu na přídavné stránce, kterou můžeme vytisknout spolu 
s projektem.
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Možná jste si všimli, že tabulku rozpisky bylo možné umístit na společný list se 
schématem: stačilo zvolit {Create On:  Current Sheet  ≡  Vytvořit na: Aktuální list}, stlačit 
{Place Table  ≡  Umístit tabulku} a zvolit místo pro tabulku po uzavření dialogového okna 
(levým kliknutím v oblasti návrhu).

Pokud máte vícestránkový návrh se spoustou součástek, potom je možné vytvořit tabulky 
rozpisky pro každý list zvlášť a na tyto listy je přímo umístit.

Je také možné exportovat soubor rozpisky buď přímo z dialogového okna, nebo ze 
stránky kam jste ji umístili (například jste tabulku rozšířili o nějaké sloupce, které se nedali 
umístit v dialogovém okně). Tabulky v programech „Schematic“ a „PCB Layout“ mohou být 
jednoduše uložené jako CSV seznam (seznam hodnot oddělených čárkami) nebo text 
s formátováním: klikněte pravým tlačítkem na existující tabulku a zvolte z nabídky {Save to File 
→ Excel CSV... | Text File...}.

6 Import / Export netlistu

Sada programů DipTrace umožňuje generovat netlisty (seznamy sítí spojů) v různých 
formátech a použít je v jiných softwarových systémech, nebo naopak importovat netlisty z jiných 
programů. Vyexportované netlisty jsou také použitelné pro kontrolu struktury sítí z obvodového 
zapojení pomocí Notepadu nebo jiného textového editoru.

Pro export netlistu z obvodového návrhu zvolte v hlavním menu {File → Export → 
Netlist} a zvolte typ netlistu. Netlist bude vytvořen z výkresu právě otevřeného v aktuálním okně 
programu „Schematic“.

Pojďme se teď podívat, jak se importuje netlist ve formátu Tango vytvořený jiným 
programem. Za tímto účelem spusťte program „PCB Layout“ a zvolte {File → Import → Netlist 
→ Tango...  ≡   }, potom v okně pro otevření vyhledejte soubor „tango_1.net“ (ve složce 
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C:\Program Files\DipTrace\Exaples nebo v cestě, kam jste si nainstalovali DipTrace) a otevřete 
ho. Program se pokouší najít součástky a matrice zahrnuté v netlistě. Potom se ukáže okno se 
seznamem součástek, jejich identifikátory a názvy kontaktních matric.

Takže v prvním sloupci vidíme identifikátory součástek, ve druhém jejich osazovací 
matrice a ve třetím sloupci typy součástek. Kdyby program nenašel matrici pro zvolenou 
součástku, pod tabulkou v poli {Pattern ≡  Matrice} se ukáže {None ≡  Žádná}. Například, 
kondenzátor C41, který je jako první v seznamu, má matrici CAP 225, ta ale není obsažena 
v knihovnách DipTrace. V tomto případě musíte někde vyhledat knihovnu s touto matricí (asi 
budete nakonec muset vytvořit tu matrici sami), nebo použijete alternativní matrici, pokud to 
bude možné. 

Na přiřazení matrice k součástce stlačte tlačítko {Add  ≡  Přidat}. Ve zjeveném okně 
{Add Pattern  ≡  Přidat matrici} je vaším cílem najít knihovnu a v ní potřebnou matrici, 
a zakončit stlačením „OK“. Zvolená matrice se tak přiřadí k součástce C41. Její jméno a název 
knihovny se ukáží v polích {Pattern} a {Library} okna importu.

Ještě vám poradíme, že můžete provést hromadné přiřazení matric k součástkám podle 
typu nebo ke všem součástkám, které mají matrice stejných vlastností. Za chvíli si to vyzkoušíte 
se součástkami v importovaném seznamu. Ještě si povšimněte, že součástky s přidělenou matricí 
mají hvězdičku „*“ za názvem matrice. Když některý prvek nemá určenou matrici, jednoduše 
nebude dál importován. Z tohoto důvodu je důležité přesvědčit se, že všechny součástky mají 
přidělenou svojí matrici.

Také pamatujte na to, že čísla pinů a jejich počet pro součástku v netlistě musí souhlasit 
s očíslováním a počtem plošek přiřazené matrice.

Po všech uvedených krocích klikněte na „Import“ a tím proces importu zkompletujete. 
Pokud v importovaném netlistu zůstala součástka s nepřidělenou matricí, upozorní vás na to 
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příslušné hlášení. Stlačte „No“ v případě, že chcete přerušit import a dokončit přiřazení matric, 
nebo stlačte „Yes“ pro dokončení importu navzdory chybějící matrici.

7 Simulace „Spice“

DipTrace nemá svůj vlastní simulátor, ale umožňuje vám nastavit parametry simulace 
Spice a exportovat netlist do kteréhokoliv simulačního softwaru. Předvedeme tu simulaci 
astabilního klopného obvodu ze schématu probraného v části I. tohoto tutoriálu a s použitím 
programu LT Spice. Tento program doporučujeme použít proto, že je volně dostupný 
a porovnatelný (nebo dokonce lepší) s drahými profesionálními simulátory. Máte-li však 
k dispozici jiný program, klidně ho použijte.

Spusťte prosím program „Schematic“ a otevřete z něho soubor „c:\Program 
Files\DipTrace\Examples\Spice\Astable_Flip_Flop.dch“. Všechny parametry pro Spice simulaci 
jsou už v tomto souboru definovány, prohlídneme si však několik prvků abychom se naučili, jak 
se to dělá. Takže klikněte pravým tlačítkem na kondenzátor C2 a zvolte z nabídky {Spice 
Settings... ≡  Nastavení Spice}. Definice pro kondenzátor jsou velmi jednoduché: zvolíte {Model 
Type:  Capacitor}, vložíte hodnotu kapacity do tabulky parametrů (v našem případě 22 uF) 
a určíte kladný a záporný pin. Pro určení pinu se hodnoty vkládají do tabulky „Pin / Signal“ 
vlevo, seznam použitelných signálů je níže jako {Available Signals:  ≡  Disponibilní signály}. 
Parametry můžete také vkládat přímo do buněk v tabulce. Pole se šablonou {Template:} ukazuje, 
jak je součástka popsaná v netlistu pro Spice. Při dlouhém popisu můžete text v řádku posouvat.
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Zkuste teď zvolit jiný typ modelu, například proudový zdroj. Když zvolíte {Current 
Source  ≡  Proudový zdroj}, můžete také určit jeho funkci: vyberte {Function: PWL()}
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Vložte počet bodů pro PWL funkci {Piece Wise Linear  ≡   Po částech lineární} 
a klikněte „OK“. Teď je zřejmé, že body v tabulce parametrů můžete vkládat jeden za druhým. 
Různé funkce vyžadují i odlišné parametry (amplitudu, fázi apod.). Podrobnosti se dozvíte 
z dokumentace jazyka Spice. Vraťme se teď k původnímu kondenzátoru, zadejte jeho hodnotu 
a klikněte „OK“. Kondenzátor a jeho funkce nepotřebují žádný jiný popis modelu, stačí 
definovat parametry. Když teď kliknete pravým tlačítkem na tranzistor Q1 a zvolíte „Spice 
Settings...“, uvidíte záložku „Model“ vedle záložky parametrů; klikněte na „Model“. V tomto 
panelu můžete vložit text anebo ho zavést z externího souboru. Někteří výrobci součástek 
publikují modely „Spice“ pro svoje výrobky, tyto můžete použít.

Také stojí za povšimnutí, že další „Spice“ nastavení můžete získat z dalších knihoven 
DipTrace (tlačítko {Get Spice Model from Library  ≡  Získat Spice model z knihovny}. Stlačte 
„OK“ nebo „Cancel“ a tak uzavřete dialog „Spice Settings“.

Soubor, který jsme zavedli, nemá platný Spice model pro napájecí zdroj, budeme ho 
muset sestavit, a tak klikněte pravým tlačítkem na baterii B1 a vyberte „Spice Settings...“. 
Uvidíte, že v dialogovém okně máme uveden napěťový zdroj, ale žádnou platnou funkci. 
V seznamu „Function:“ vyberte řádek „PULSE()“ a upravte v tabulce hodnoty PULSE V2=5, 
PULSE PW=20s, PULSE PER=30s. Klikněte na „OK“, teď jsme určili napěťový zdroj, který 
dává 5 V po dobu 20 s, potom 10 s přestávka, atd. Všechno je teď připraveno.

V hlavním menu zvolte {File → Export → Spice Netlist...}. V dialogovém okénku 
vyberte ze seznamu „GND Net:“ položku „GND“ (to je náš nulový bod), a do pole {Commands 
≡  Příkazy} napište „.TRAN 0s 30s 0.1s“ - znamená to, že simulujeme přechodový stav od 0 s do 
30 s v intervalech 0,1 s (v příkaze pozor na desetinnou tečku!). Tento příkaz je možné zadat nebo 
změnit přímo v programu LT Spice. Klikněte „OK“ a v dialogu „Uložit jako“ zvolte název 
a umístě ní pro soubor *.cir.
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A teď spusťte program „LT Spice“. Pokud ho ještě nemáte, můžete si ho stáhnout 
a nainstalovat z umístění http://www.linear.com/designtools/software/switchercad.jsp .

V programu „LT Spice“ vyhledejte a otevřete soubor *.cir, který jste před chvílí uložili 
(v okně pro otevření nastavte správný typ souboru netlist *.cir). Uvidíte netlist souboru 
v textovém formátu. Zvolte {Simulate → Run  ≡   Simulovat → Spustit} a zavřete okno se 
záznamem chyb. Na liště stlačte tlačítko {Pick Visible Traces  ≡   Zvolit viditelné průběhy} 
a v okénku {Select Visible Waveforms  ≡   Vybrat viditelný průběh} zvolte I(D_led1). Teď už 
uvidíte něco takového:

To je průběh proudu přes diodu LED1. Na časové ose vidíme obvod pracovat po dobu 20 
s, a potom je 10 s pauza. Můžete si zvolit i další signály a dívat se, jak obvod pracuje.

8 Kontrola propojení sítí

Jednou z nejdůležitějších funkcí na ověření vašeho návrhu DPS ještě před zhotovením 
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prototypu je kontrola propojení sítí. Tato kontrola vás umožňuje prověřit, zda všechny sítě mají 
kompletní spoje, dostanete hlášení o všech izolovaných oblastech bez ohledu na to, či se jedná 
o spoje, tepelné plošky nebo tvary.

Spusťte prosím program „PCB Layout“ a otevřete v něm soubor PCB_2.dip z umístění 
C:/ProgramFiles/DipTrace/Examples nebo jiného místa, kam jste instalovali program. Zvolte 
položku {Verification → Check Net Connectivity...  ≡  Ověření → Zkouška konektivity sítí}. 
V dialogovém okénku můžete zvolit objekty, které budou použity jako prostředky propojování, 
typicky se však doporučuje ponechat všechny možnosti zaškrtnuté. Stlačte „OK“.

Uvidíte indikátor průběhu, a po skončení kontroly hlášení {No errors found  ≡  Bez 
zjištěných chyb}, takže návrh je v pořádku a my úmyslně zavedeme několik chyb abychom 
viděli, jak budou zobrazené.

Na liště trasování zvolte tlačítko {Edit Traces  ≡  Upravit trasy}, potom posuňte kurzor 
myši na spoj od C16:2 ke spojce na zemnící plochu, až se vysvítí a pravým kliknutím vyvolejte 
nabídku a zvolte {Unroute Trace  ≡  Zrušit trasu} (spoj bude v tomto případě skrytý kvůli rozlité 
mědi).

Druhou chybou bude izolovaná oblast v rozlité mědi. Přepněte pohled na spodní vrstvu 
a zobrazte pravý dolní roh návrhu. Nakreslete dvě čáry – rovné nebo oblouky – na signálovou 
vrstvu (položka Signal/Plane musí být zvolená v seznamu vrstev kreslení) a tím izolujte jednu ze 
spojek. Aktualizujte rozlitou měď (pravé kliknutí na její okraj a volba položky „Update“).
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Toto je jednoduchá situace, ve které byste chybu mohli objevit sami, ale pokud je návrh 
složitější s větším počtem vrstev a tisíci vývody, izolované části rozlité mědi a nezapojené piny 
mohou unikat pozornosti.

Opět zvolte položku {Verification → Check Net Connectivity...  ≡   Ověření → Zkouška 
konektivity sítí} a stlačte „OK“. Po chvíli uvidíte výslednou zprávu, která hlásí síť Net 7 jako 
přerušenou se třemi oblastmi. Klikněte na tuto chybu a zobrazí se detaily: první oblast („Area 1“) 
je rozlitá měď a všechny piny připojené k ní; druhá („Area 2“) je C16:2 (náš první zásah s 
odpojením plošky); třetí („Area 3“)je oddělená část rozlité mědi v rohu DPS.
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Výsledky kontroly se dají uložit do textového souboru, takže se k nim postupně můžete 
vracet v průběhu oprav.

9 Funkce rozmísťování

Od uvedení verze DipTrace 1.40 má program zabudovanou funkci ukládání součástek 
a integrovaný automatický systém rozmísťování součástek, aby po konverzi obvodového 
zapojení do DPS byla optimalizace rozmístění jednodušší. Na jednom z našich příkladů 
ukážeme, jak tyto funkce pracují. Spusťte prosím modul „PCB Layout“ a otevřete v něm 
obvodové schéma „Schematic_4.dch“ na obvyklé cestě „C:/Program   Files/DipTrace/Examples/  “. 
Uvidíte něco podobného jako na následujícím obrázku a určitě bude nutné věnovat dost času na 
manuální umístění všech součástek na plochu desky.
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Teď si importujeme obrys budoucí desky ze souboru struktury DXF. Zvolte tedy 
v hlavním menu {File → Import → DXF...} a v okně pro otevření vyhledejte a otevřete soubor 
„C:/ProgramFiles/DipTrace/Examples/outline.dxf“. V dialogovém okně, které se právě otevřelo, 
vidíte obraz souboru, který máme v pláně importovat. V tabulce {Layers  ≡   Vrstvy} zvolte 
{Board_Outline  ≡   Obrys desky} a v seznamu {Convert to:  ≡   Konvertovat na:} položku 
„Board Outline“.
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Mimochodem, uzavřené oblasti můžete vyplnit a vyřezat v nich otvory použitím 
obklopených uzavřených oblastí, pokud je to potřebné (návrhy DXF se obyčejně skládají 
z obrysů bez výplně). Volba {Fill closed area  ≡  Vyplnit uzavřené oblasti} je funkční jenom pro 
vrstvy s mědí a pájecí pastou/maskou.

Zvolte {Import mode: Add  ≡  Mód importu: Přidat}, čímž se obrys desky přidá 
k aktuálnímu návrhu, volbu  {DXF Units: Inches  ≡   DXF jednotky: Palce} ponechte 
nezměněnou a stlačte tlačítko „Import“ v horní části okna – teď už vidíte obrys DPS, ale 
součástky jsou stále chaoticky rozhozené. Nejdříve je musíme trochu uspořádat, zvolte proto 
v hlavním menu {Placement → Placement Setup...  ≡  Rozmístění → Nastavení rozmístění}:

Zaškrtnete volbu {Place Patterns Outside the Board Outline  ≡  Rozmístit matrice mimo 
obrys desky}, čím uvolníte plochu desky a součástky soustředíte při jejím okraji. Ostatní údaje 
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můžete také vyplnit podle obrázku. Klikněte na „OK“, nastavené parametry se akceptují, 
a stlačte tlačítko {Arrange Components  ≡  Uspořádat součástky} na liště rozmísťování nebo 
cestou menu {Placement → Arrange Components}.

Všechny součástky jsou teď soustředěny na jednom místě blízko obrysu DPS. Zvolte 
v hlavním menu položku {Placement → Placement by List  ≡  Umístit → Umístit podle 
seznamu} a zkuste si vybrat v seznamu některou součástku (levý klik) a přesunou kurzor dovnitř 
DPS (bez přidržení tlačítka), potom klikněte uvnitř desky a tak umístíte zvolenou součástku. 
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Vidíte, že součástka vypadle ze seznamu (seznam ukazuje jen ty prvky, které jsou zvenku 
obrysu DPS). Umístěte tímto způsobem U1, U2, U3, J1, J8, J12, RN1 a RN2. Předpokládáme tu, 
že tyto součástky mají pevné pozice, které není možné změnit. A proto je vyberte a uzamkněte 
(Ctrl+L), s výjimkou U3. Na U3 teď klikněte pravým tlačítkem, zvolte {Properties...  ≡ 
Vlastnosti}, potom v dialogovém okně záložku {Placement  ≡   Umístit}, a v poli {Spacing  ≡ 
Odstup} zvolte {Use: Custom  ≡   Použít: Přizpůsobit} a {Value:  ≡   Hodnota:} 20 mm  (to 
znamená, že jsme nastavili speciálně pro U3 prostor okolo a jiné součástky by tedy měli být ve 
vzdálenosti větší než 20 mm od něho). Klikněte na „OK“, a potom uzamkněte také U3.

Uzavřete seznam tlačítkem „Close“. Teď použijeme automatické rozmístění pro všechny 
ostatní součástky s mezerami 5 mm. Zvolte v hlavním menu {Placement → Placement Setup...}, 
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změňte „X Spacing“ a „Y Spacing“ na 5 mm, „Board Spacing“ na 2 mm. Jak vidíte, volba 
{Allow Pattern Rotation  ≡  Povolit otáčení matric} je aktivní (někdy je užitečné ji vypnout, 
třeba u jednovrstvových desek s drátovými propojkami, kde propojky mají mít jednotnou 
orientaci ). Zrušte volbu {Place Patterns Outside the Board Outline  ≡  Umístit matrice vně 
obrysu desky}, ale volba {Use Pattern Spacing  ≡  Použít rozestupy matric} by měla zůstat 
aktivní, aby byla dodržena mezera 20 mm od obvodu U3. Nedoporučujeme vám prozatím zvolit 
{Increase Placement Quality (reduces speed)  ≡  Zvětšit kvalitu rozmístění (redukuje rychlost)} 
(můžete si s tím pohrát později, když budete chtít). Klikněte na „OK“ pro zavedení změn 
a stlačte tlačítko {Run Auto-placement  ≡  Spustit auto-rozmístění} na liště rozmísťování nebo 
{Placement → Run Auto-placement} v hlavním menu. Obdržíte výsledek podobný tomuto 
obrázku (pokud by se objevilo hlášení {Unable to find valid placement variant. Please change 
placement settings or board outline.  ≡  Není možné najít platný variant rozmístění. Prosím 
změňte nastavení pro rozmísťování nebo obrys desky.}, musíte se vrátit k nastavení a připustit 
menší mezeru v některém parametru):

Možná to na pohled není vidět, ale modré spojnice mezi různými odpory, diodami apod. 
jsou optimalizovány z hlediska jejich délky (tedy později minimální délky tras). Jistě, některé 
spojnice se vyjímají z pravidla, protože velké součástky jsme nejdřív rozmístili manuálně. 
Kdybychom použili funkci automatického rozmístění skutečně na všechny součástky, dostali 
bychom ještě lepší výsledek, tento postup však je obyčejně nepoužitelný v reálných podmínkách. 
Také obvod U3 je oddělen od ostatních součástek, kvůli naší definici 20 mm mezery.

10 Fanout – „Rozevření“

Funkce Fanout pomáhá „rozevřít“ klubko vývodů z pouzder integrovaných obvodů jako 
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jsou BGA {Ball Grid Array  ≡   sada kuličkových vývodů}, kde vnější řady vývodů brání 
přístupu k vnitřním řadám a řešení tohoto problému se stává tak náročné na čas, že si vyžaduje 
svou specializovanou funkci.
 Typické použití funkce Fanout je ve dvou oblastech: automatické přidání spojek (via) 
k součástkám (jako pouzdra BGA, SOIC, QUAD) a automatické umístění spojek na připojení 
SMD plošek k napájecím/zemnícím pláním. Pokusíme se o demonstraci obou těchto cílů.

Spusťte (pokud už neběží) modul „PCB Layout“, v případě, že je v něm otevřen nějaký 
soubor, zvolte v hlavním menu {File → New  ≡   Soubor → Nový}, nebo stlačte tlačítko „New“ 
na standardní liště. 

Teď otevřete knihovnu SMT a uložte na plochu jedno pouzdro LLC20, potom z knihovny 
BGA dvě pouzdra BGA-100/15x15. Přidejte do návrhu (máte-li vyšší než volnou verzi 
programu) dvě vnitřní vrstvy ({Layer → Add Layer...  ≡  Vrstva → Přidat vrstvu}. Kurzor myši 
posuňte na pouzdro LLC a když se vysvítí, klikněte pravým tlačítkem a z nabídky zvolte 
„Fanout...“. V dialogovém okně „Fanout“ vyberte v seznamu {Pads: Left  ≡  Plošky: Levé} (tím 
určíme, že umístíme spojky jen na levou řadu vývodů LLC) a nechte nezaškrtnuté políčko {Use 
Connected Pads Only  ≡  Použít jen připojené plošky} (to znamená, že budeme připojovat 
všechny plošky, nejen ty spojené s nějakou sítí). Zapište 1,016 mm do pole {Outer Diameter  ≡ 
Vnější průměr} a 0,508 mm do pole {Hole Diameter  ≡  Průměr otvoru} pro spojky, a klikněte 
„OK“.

Nyní už vidíte spojky umístěné zvenku na levou řadu plošek našeho pouzdra. Znovu 
klikněte na pouzdro a zvolte „Fanout...“. Teď umístíme spojky cik-cak na horní plošky pouzdra. 
Zvolte tedy {Placement: Zig-Zag  ≡   Umístit: Cik-cak} a {Pads: Top  ≡   Plošky: Horní}, ostatní 
parametry ponechejte nezměněné a klikněte „OK“.
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Teď jsou na řadě dvě pouzdra BGA.  Pro jedno z nich navrhneme průchozí spojky a slepé 
spojky pro to druhé. Klikněte pravým tlačítkem na první pouzdro BGA, zvolte „Fanout...“ 
vyberte {Pattern Type:  BGA-Through vias  ≡  Typ matrice: BGA-Průchozí spojky}, nastavte 
velikosti spojky a otvoru na 0,762 mm a 0,381 mm, stlačte „OK“. Pro druhé BGA pouzdro 
udělejte to samé, jen výběr typu bude {Pattern Type: BGA – Blind vias  ≡  Typ matrice: BGA – 
slepé spojky}.

Teď už na dalším obrázku vidíme u první matrice, že všechny vývody budou zapojené 
prostřednictvím spojek, zatímco druhé pouzdro má dvě vnější řady bez spojek (tzn. mají být 
připojené na horní vrstvě), a až další vnitřní řady plošek mají spojky připojené k vrstvám (po dvě 
řady připojené ke každé vrstvě).

Můžeme rozmístit (jak ukazuje druhý obrázek na následující straně) na plochu několik 
dalších SMD pouzder, pár pouzder s nožičkami do prokovených otvorů a vytvořit síť, spojující 
několik vývodů těchto pouzder (předpokládáme, že tato síť je GND a máme jí připojit k zemnící 
pláni). Pravým tlačítkem klikněte na některou z těch plošek a zvolte „Fanout...“. Ponechte 
parametry bez změny a stlačte „OK“.
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Teď tedy všechny plošky této sítě mají spojky, které je připojují k vrstvě příslušné pláně.
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11 Hierarchické schéma

Na příkladě návrhu velmi jednoduchého hierarchického schématu si ukážeme, jak tato 
funkce pracuje. Spusťte program „Schematic“. V programu DipTrace jsou hierarchické bloky 
zapojení přidružené k listům obvodového návrhu, a tak první věcí v našem zatím prázdném 
návrhu bude přidání dvou dalších listů. Zvolte tedy {Edit → Add Sheet  ≡  Upravit → Přidat list} 
dvakrát za sebou. Teď musíme dát nějakým způsobem najevo, že námi přidané listy budou 
podřízenými bloky v hierarchické struktuře projektu. Kliknutím na záložku druhé strany „Sheet 
2“ dostaneme tento list do popředí a v hlavním menu ho označíme jako {Edit → Sheet type → 
Hierarchy Block  ≡  Upravit → Typ listu → Hierarchický blok}, a stejnou činnost provedeme 
s posledním listem „Sheet 3“.

Zvolte si teď jako aktivní první list „Sheet 1“ a umístěte naň několik součástek třeba C1, 
D1, D2, D3. To bude naše hlavní schéma, zatím bez podřízených bloků.

Zvolte jako aktivní druhý list „Sheet 2“. V hlavním menu zvolte položku {Objects → 
Hierarchy → Place Connector  ≡  Objekty → Hierarchie → Umístit konektor} nebo stlačte 
tlačítko „HC“ na liště objektů. Umístěte několik hierarchických konektorů na tento list 
(hierarchický konektor se nedá umístit na společnou nejvyšší stránku, jen na podřízené bloky). 
Tyto konektory tvoří vstupy/výstupy podřízených bloků, můžete je posouvat i rotovat, abyste 
umístili pin konektoru na potřebné místo. Rozložte na list 8 konektorů, po 4 na levé a pravé 
straně.  Dál přidejte dvě diody z knihovny „Discrete“ a připojte je ke konektorům.

Přejděte na list 3 a vytvořte další v hierarchii podřízený blok: vložte několik součástek, 
konektorů a spojte je. Zkuste si, že konektory se dají i přejmenovat pravým kliknutím a zvolením 
první položky. Jméno konektoru koresponduje se jménem pinu na hierarchickém bloku.
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DipTrace podporuje i víceúrovňovou hierarchii, takže můžeme vložit hierarchicky 
podřízený blok do jiných hierarchicky podřízených bloků vyšší úrovně. Zvolte list 2, v hlavním 
menu vyberte  {Objects → Hierarchy → Place Block  ≡  Objekty → Hierarchie → Umístit blok} 
nebo stlačte tlačítko „HB“ na liště objektů. V dialogovém okénku vyberte „Sheet 3“, stlačte 
tlačítko {Place  ≡  Umístit} a na list 2 umístěte dva bloky stejným způsobem jako součástku 
z knihovny. Nic vám nezabrání uložit i blok listu 2 na list 2 nebo vyrobit smyčku s více bloky, 
tedy chybu hierarchie. Na odhalení takové situace použijte kontrolu {Verification → Check 
Hierarchy  ≡  Ověření → Ověřit hierarchii} v hlavním menu. I program „PCB Layout“ 
kontroluje hierarchii na výskyt smyček když otevírá schéma, a zobrazí případně varovné hlášení. 
Teď nebudeme experimentovat se smyčkami, tak jen umístěte dvakrát blok listu 3 na list 2 
a propojte je s konektory listu 2.
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Zvolte hlavní list „Sheet 1“ a umístěte nějaké bloky (můžou to být listy 2 i 3) do hlavního 
zapojení. Propojte podřízené bloky s ostatními součástkami.
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Teď můžeme naše jednoduché (a nereálné) schéma konvertovat do DPS. Stlačte klávesy 
„Ctrl+B“. V programu „PCB Layout“ se součástky v původních hierarchických blocích 
překrývají, a tak použijte tlačítko {Arrange Components  ≡  Rozmístit součástky} (první na liště 
rozmísťování) pro jejich uspořádání. Klikněte pravým tlačítkem na součástku, která byla 
původně v podřízeném bloku a zvolte {Properties  ≡  Vlastnosti}. Uvidíte, že každá taková 
součástka má přídavné pole s informací o identifikaci bloku/bloků a identifikátoru součástky 
v bloku. Uvědomte si, že toto přídavné pole je použito pro aktualizaci DPS z hierarchického 
schématu, protože skrytý systémový identifikátor (při aktualizaci podle součástek) a referenční 
identifikátor se mohli při úpravě zapojení v podřízeném bloku rozejít.

Teď můžete spustit autorouter nebo změnit zapojení a zkusit aktualizovat DPS, atd.
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Tak to je prozatím všechno.

Děkujeme vám za váš zájem o náš programový produkt a studium tohoto tutoriálu! 
V budoucnosti se bude tutoriál dále rozšiřovat o popis funkcí, které tu zatím nejsou, a také při 
vydání novějších verzí balíku DipTrace s příslušným doplňkem tutoriálu.

DipTrace  Linky:
Pokud máte jakékoliv otázky nebo návrhy, kontaktujte prosím naši podporu zákazníků na 

adrese support@diptrace.com a náš personál vám ochotně odpoví na všechny vaše dotazy.

Máte-li zájem komunikovat s ostatními zákazníky DipTrace, navrhovat nové funkce 
a diskutovat o nich, připojte se ke komunitě DipTrace na serveru Yahoo!:  
http://finance.groups.yahoo.com/group/diptr/      .

Stáhněte si nejnovější verzi balíku DipTrace na http://www.diptrace.com/download.php .
Prověřte si vaši verzi a číslo sestavy ({Help → About} a porovnejte s aktuálními verzemi na naší 
webové stránce.

Objednejte si DipTrace on-line na stránce http://www.diptrace.com/order.php .
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IV  Užitečné přílohy

1 Okno programu „Schematic“ 

Prvky okna můžete skrýt/zobrazit pomocí kláves uvedených v ostrých závorkách , ve 
tvaru <Fn>.
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2 Okno programu „PCB Layout“

Prvky okna můžete skrýt/zobrazit pomocí kláves uvedených v ostrých závorkách , ve 
tvaru <Fn>.
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3 Okno programu editoru matric „Pattern Editor“

Některé prvky okna můžete skrýt/zobrazit pomocí kláves uvedených v ostrých 
závorkách , ve tvaru <Fn>.
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4 Okno programu editoru symbolů „Component Editor“

Některé prvky okna můžete skrýt/zobrazit pomocí kláves uvedených v ostrých 
závorkách , ve tvaru <Fn>.
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5 Klávesové zkratky – program „Schematic“

Klávesová zkratka:                     Funkce:  
Ctrl+N ~~~~~~~~~~~~~~~~ Nový projekt
Ctrl+O ~~~~~~~~~~~~~~~~ Otevřít projekt
Ctrl+S  ~~~~~~~~~~~~~~~ Uložit projekt
Ctrl+Alt+S  ~~~~~~~~~~~~ Uložit jako:
Ctrl+Alt+P  ~~~~~~~~~~~~ Náhled
Ctrl+P  ~~~~~~~~~~~~~~~~ Tisk 
Ctrl+B ~~~~~~~~~~~~~~~~ Konvertovat schéma zapojení na řešení DPS
Ctrl+Z ~~~~~~~~~~~~~~~~ Zpět
Ctrl+Y ~~~~~~~~~~~~~~~~ Znovu
Ctrl+X ~~~~~~~~~~~~~~~~ Vyjmout objekty
Ctrl+C ~~~~~~~~~~~~~~~~ Kopírovat objekty
Ctrl+V ~~~~~~~~~~~~~~~~ Vložit objekty
Del  ~~~~~~~~~~~~~~~~~~ Odstranit objekty
Ctrl+A  ~~~~~~~~~~~~~~~ Vyznačit všechny objekty
Ctrl+F ~~~~~~~~~~~~~~~~ Najít objekty v obvodovém zapojení
Ctrl+Ins  ~~~~~~~~~~~~~~ Přidat nový list k obvodovému zapojení
Ctrl+M  ~~~~~~~~~~~~~~~ Kopírovat matici
Ctrl+L  ~~~~~~~~~~~~~~~ Zamknout vyznačené
Ctrl+Alt+L   ~~~~~~~~~~~~ Odemknout vyznačené
Ctrl+R, R nebo mezerník  ~~ Otáčet vyznačené objekty
Ctrl+G  ~~~~~~~~~~~~~~~ Seskupit vyznačené objekty
Ctrl+Alt+G  ~~~~~~~~~~~~ Rozložit vyznačené objekty
F1 ~~~~~~~~~~~~~~~~~~~ Ukázat/skrýt počátek a souřadnice
F2  ~~~~~~~~~~~~~~~~~~ Ukázat/skrýt standardní panel
F3  ~~~~~~~~~~~~~~~~~~ Ukázat/skrýt manažer návrhu
F4  ~~~~~~~~~~~~~~~~~~ Ukázat/skrýt lištu objektů
F5  ~~~~~~~~~~~~~~~~~~ Ukázat/skrýt lištu knihoven
F6  ~~~~~~~~~~~~~~~~~~ Ukázat/skrýt panel symbolů
F10 ~~~~~~~~~~~~~~~~~~ Posouvat textové značky
F10 → R ~~~~~~~~~~~~~~ Otáčet textové značky v průběhu posouvání
F11 ~~~~~~~~~~~~~~~~~~ Ukázat/skrýt rastr
Ctrl+F1, „+“  ~~~~~~~~~~~ Přiblížit pohled
Ctrl+F2, „-“ ~~~~~~~~~~~~ Vzdálit pohled
R nebo mezerník ~~~~~~~~ Otáčet symboly před položením
Ctrl  ~~~~~~~~~~~~~~~~~~ Přidržet při vícenásobném vyznačování
Shift  ~~~~~~~~~~~~~~~~~ Posun vyznačených objektů ve směru souřadnic
Šipky ~~~~~~~~~~~~~~~~~ Posun vyznačených objektů
Shift+S  ~~~~~~~~~~~~~~~ Dovolit/zakázat auto-rolování
Enter ~~~~~~~~~~~~~~~~~ Při tahání spoje – dokončit spoj
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6 Klávesové zkratky – program „PCB Layout“

Klávesová zkratka:                     Funkce:  
Ctrl+N ~~~~~~~~~~~~~~~~~~~~ Nový projekt
Ctrl+O ~~~~~~~~~~~~~~~~~~~~ Otevřít projekt
Ctrl+S  ~~~~~~~~~~~~~~~~~~~~ Uložit projekt
Ctrl+Alt+S  ~~~~~~~~~~~~~~~~ Uložit jako:
Ctrl+Alt+P  ~~~~~~~~~~~~~~~~~ Náhled
Ctrl+P  ~~~~~~~~~~~~~~~~~~~~ Tisk 
Ctrl+B ~~~~~~~~~~~~~~~~~~~~ Konvertovat schéma zapojení na řešení DPS
Ctrl+Z ~~~~~~~~~~~~~~~~~~~~ Zpět
Ctrl+Y ~~~~~~~~~~~~~~~~~~~~ Znovu
Ctrl+X ~~~~~~~~~~~~~~~~~~~~ Vyjmout objekty
Ctrl+C ~~~~~~~~~~~~~~~~~~~~ Kopírovat objekty
Ctrl+V ~~~~~~~~~~~~~~~~~~~~ Vložit objekty
Del  ~~~~~~~~~~~~~~~~~~~~~~ Odstranit objekty
Ctrl+A  ~~~~~~~~~~~~~~~~~~~~ Vyznačit všechny objekty
Ctrl+F ~~~~~~~~~~~~~~~~~~~~ Najít objekty v obrazci spojů
Ctrl+Ins  ~~~~~~~~~~~~~~~~~~~ Přidat nový list k obvodovému zapojení
Ctrl+M  ~~~~~~~~~~~~~~~~~~~ Kopírovat matici
Ctrl+L  ~~~~~~~~~~~~~~~~~~~~ Zamknout vyznačené
Ctrl+Alt+L   ~~~~~~~~~~~~~~~~ Odemknout vyznačené
Ctrl+R, R nebo mezerník  ~~~~~~ Otáčet vyznačené objekty
Ctrl+G  ~~~~~~~~~~~~~~~~~~~~ Seskupit vyznačené objekty
Ctrl+Alt+G  ~~~~~~~~~~~~~~~~ Rozložit vyznačené objekty
F1 ~~~~~~~~~~~~~~~~~~~~~~~ Ukázat/skrýt počátek a souřadnice
F2  ~~~~~~~~~~~~~~~~~~~~~~~ Ukázat/skrýt standardní panel
F3  ~~~~~~~~~~~~~~~~~~~~~~~ Ukázat/skrýt manažer návrhu
F4  ~~~~~~~~~~~~~~~~~~~~~~~ Ukázat/skrýt lištu trasování
F5  ~~~~~~~~~~~~~~~~~~~~~~~ Ukázat/skrýt lištu knihoven
F6  ~~~~~~~~~~~~~~~~~~~~~~~ Ukázat/skrýt lištu elementů
F7  ~~~~~~~~~~~~~~~~~~~~~~~ Ukázat/skrýt panel kontaktních matric
F8  ~~~~~~~~~~~~~~~~~~~~~~~ Ukázat/skrýt lištu kreslení
F9  ~~~~~~~~~~~~~~~~~~~~~~~ Spustit auto-router
F10 ~~~~~~~~~~~~~~~~~~~~~~ Posouvat textové značky
F10 → R nebo mezerník ~~~~~~~ Otáčet textové značky v průběhu posouvání
F11 ~~~~~~~~~~~~~~~~~~~~~~ Ukázat/skrýt rastr
F12  ~~~~~~~~~~~~~~~~~~~~~~ Optimalizovat spojnice
Ctrl+F1, „+“  ~~~~~~~~~~~~~~~ Přiblížit pohled
Ctrl+F2, „-“ ~~~~~~~~~~~~~~~~ Vzdálit pohled
R nebo mezerník ~~~~~~~~~~~~~ Otáčet symboly před položením
Ctrl  ~~~~~~~~~~~~~~~~~~~~~~ Přidržet při vícenásobném vyznačování
Shift  ~~~~~~~~~~~~~~~~~~~~~ Přidržet při posunu vyznačených objektů ve směru souřadnic
Šipky ~~~~~~~~~~~~~~~~~~~~~ Posun vyznačených objektů
Shift+S  ~~~~~~~~~~~~~~~~~~~ Dovolit/zakázat auto-rolování
Enter ~~~~~~~~~~~~~~~~~~~~~ Při tahání spoje – dokončit spoj
Ctrl+Alt+U  ~~~~~~~~~~~~~~~~ Aktualizovat spoje podle souvisejícího schématu
Při tahání trasy:
M  ~~~~~~~~~~~~~~~~~~~~~~~ Přepnout mód 90°/45°/volný úhel/oblouk
U, Backspace, Ctrl+Z~~~~~~~~~~ Zpět bod
J  ~~~~~~~~~~~~~~~~~~~~~~~~ Položit drátovou propojku (jumper)
W  ~~~~~~~~~~~~~~~~~~~~~~~ Přepnout vrstvu
T | B  ~~~~~~~~~~~~~~~~~~~~~ Horní / dolní vrstva
„1“ .. „0“  ~~~~~~~~~~~~~~~~~~ Přepnout do vrstvy č. (horní, vnitřní 1, …. atd.)
Enter  ~~~~~~~~~~~~~~~~~~~~~ Dokončit trasu
Esc  ~~~~~~~~~~~~~~~~~~~~~~ Zrušit rozpracovanou trasu, návrat do standardního módu
Práce s vrstvami:
W  ~~~~~~~~~~~~~~~~~~~~~~~ Přepnout vrstvu
Ctrl+ T|B~~~~~~~~~~~~~~~~~~~ Horní / dolní vrstva
Ctrl+ „1“..  „0“  ~~~~~~~~~~~~~ Přepnout do vrstvy č. (horní, vnitřní 1, …. atd.)
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7 Klávesové zkratky – programy „Component Editor / Pattern Editor“

Klávesová zkratka:                     Funkce:  
Ctrl+N ~~~~~~~~~~~~~~~~ Nová knihovna
Ctrl+O ~~~~~~~~~~~~~~~~ Otevřít knihovnu
Ctrl+S  ~~~~~~~~~~~~~~~ Uložit knihovnu
Ctrl+Ins  ~~~~~~~~~~~~~~ Přidat nový prázdný symbol/matrici do knihovny
Ctrl+Del  ~~~~~~~~~~~~~~ Odstranit aktuální symbol/matrici z knihovny
Ctrl+I  ~~~~~~~~~~~~~~~~ Vložit nový prázdný symbol/matrici do knihovny
Ctrl+U  ~~~~~~~~~~~~~~~ Posunout aktuální symbol/matrici v seznamu nahoru
Ctrl+D  ~~~~~~~~~~~~~~~ Posunout aktuální symbol/matrici v seznamu dolu
Ctrl+Z ~~~~~~~~~~~~~~~~ Zpět
Ctrl+Y ~~~~~~~~~~~~~~~~ Znovu
Ctrl+X ~~~~~~~~~~~~~~~~ Vyjmout objekty
Ctrl+C ~~~~~~~~~~~~~~~~ Kopírovat objekty
Ctrl+V ~~~~~~~~~~~~~~~~ Vložit objekty
Del  ~~~~~~~~~~~~~~~~~~ Odstranit objekty
Ctrl+A  ~~~~~~~~~~~~~~~ Vyznačit všechny objekty
Ctrl+L  ~~~~~~~~~~~~~~~ Zamknout vyznačené
Ctrl+Alt+L   ~~~~~~~~~~~~ Odemknout vyznačené
Ctrl+R  ~~~~~~~~~~~~~~~ Otáčet vyznačené objekty
Ctrl+G  ~~~~~~~~~~~~~~~ Seskupit vyznačené objekty
Ctrl+Alt+C  ~~~~~~~~~~~~ Vycentrovat symbol / matrici
Ctrl+Alt+R  ~~~~~~~~~~~~ Otáčet symbol / matrici
Ctrl+Alt+V  ~~~~~~~~~~~~ Překlopit symbol / matrici vertikálně
Ctrl+Alt+H  ~~~~~~~~~~~~ Překlopit symbol / matrici horizontálně
Ctrl “+“  ~~~~~~~~~~~~~~ Přiblížit pohled
Ctrl „-“  ~~~~~~~~~~~~~~~ Vzdálit pohled
F1 ~~~~~~~~~~~~~~~~~~~ Ukázat/skrýt počátek a souřadnice
F10 ~~~~~~~~~~~~~~~~~~ (Jen „Component Editor“) Posouvat textové značky symbolu
F11 ~~~~~~~~~~~~~~~~~~ Ukázat/skrýt rastr
Ctrl+F  ~~~~~~~~~~~~~~~ Položit tvar podle souřadnic
Ctrl+P  ~~~~~~~~~~~~~~~~ Položit piny / plošky podle souřadnic
Shift+Del   ~~~~~~~~~~~~~ Odstranit aktuální vrstvu
Ctrl+H  ~~~~~~~~~~~~~~~ (Jen „Pattern Editor“) Položit otvor podle souřadnic 

Ctrl  ~~~~~~~~~~~~~~~~~~ Přidržet při vícenásobném vyznačování
Shift  ~~~~~~~~~~~~~~~~~ Posun vyznačených objektů ve směru souřadnic
Šipky ~~~~~~~~~~~~~~~~~ Posun vyznačených objektů
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