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1 소개

이 Tutorial은 간단한 회로와 PCB, 그리고 pattern 및 component 라이브러리를 만들어
보면서 DipTrace에 쉽게 익숙해 질 수 있도록 하기 위한 것입니다. 순차적으로 Tutorial
을 따라하다 보면 DipTrace의 기능과 사용법을 익힐 수 있습니다. Tutorial을 학습하는
동안 어떤 의문점이 생긴다면 support@diptrace.com나 welcome@helinode.co.kr으로 연락
주시기 바랍니다. 모든 의문사항에 대하여 기쁘고 빠르게 답변을 드릴 것입니다.
이 Tutorial은 DipTrace ver. 2.2.0.0(build September 7, 2011)을 기반으로 작성되었습니다.
 

2 간단한 회로와 PCB 만들어 보기

DipTrace를 사용해서 간단한 회로와 그것에 대한 PCB를 만들어 보게 될 것입니다.

먼저 회로를 설계하기 위해서 DipTrace Schematic Capture를 실행합니다.
 i.e.) 윈도우즈의 Start → All Programs → DipTrace → Schematic

Schematic 프로그램을 처음 실행시켰다면 다음과 같이 Graphics Mode와 Color Scheme
선택을 위한 대화상자가 나타납니다.

자신에게 알맞는 Graphics Mode를 선택할 수 있습니다.

1. Direct3D는 일반적으로 Windows PC에서 가장 빠르기 때문에 이 모드에서 문제가
없거나 고성능의 OpenGL hardware를 가지고 있지 않다면 이 모드를 사용할 것을 권장합
니다. 그러나 이모드는 hardware/drivers/versions등에 영향을 받기 때문에 극히 일부의
Computer에서는 문제가 발생할 수도 있습니다 이러한 경우 드라이버를 update해 보시기
바랍니다.

2. OpenGL모드는 보통 Direct3D보다는 약간 느립니다. 그러나 서로 다른 운영체제들에
범용적이기 때문에 호환성이 더 좋고 hardware/driver들에 영향을 덜 받습니다. 전용의
OpenGL 그래픽카드가 설치된 고성능의 engineering/graphics 시스템이라면 가장 좋은
선택이 될 것입니다. 
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3. Windows GDI는 Direct3D나 OpenGL에 문제가 있어서 모두 사용이 불가능할 때 
대안으로 사용할 수 있습니다. 비록 성능은 가장 떨어지나 drivers/hardware/OS에
의존적이지 않기 때문에 호환성은 가장 높습니다. 단 대규모의 project에는 적합하지
않을 것입니다.

이 Tutorial에서는 인쇄에 적합하기 때문에 white(background)를 사용하지만 원한다면
다른 색을 선택할 수 있습니다. 작업 중 언제라도 메인메뉴의 "View / Colors"를 선택해서
색을 바꿀 수 있습니다.

PCB Layout에서도 동일한 대화상자를 사용합니다. Component Editor와 Pattern Editor는
Schematic Capture와 PCB Layout의 색설정을 적용받게 됩니다. 

작업공간의 확보를 위해서 자주 Design Manager / Properties 패널을 숨기는데 공간이 
부족하지 않다면 그럴 필요가 없습니다. 메인메뉴의 "View → Toolbars → Design
Manager"를 선택합니다.

2.1 회로도의 크기 설정과 titles 배치하기

메인메뉴의 “File --> Titles and Sheet Setup"을 클릭한 후 대화상자의 “Sheet Template”에서
“ANSI A”를 선택하고 “Display Titles”와 “Display Sheet”를 체크해서 그림과 같이 설정한
후 “Close” 버튼을 클릭해서 대화상자를 닫습니다.

(메인메뉴의 "View → Display Titles"와 "View → Display Sheet"를 선택해서 titles와 sheet
를 보이거나 보이지 않게 할 수 있습니다.)

Drawing frame이 보일 때까지 “-” 버튼을 누릅니다. "+" / "–" 또는 마우스-휠은 회로를
확대 / 축소해서 볼 때 사용합니다. 마우스 포인터가 component나 선택된 영역을
가리키고 있는 경우에는 보다 더 정밀하게 확대 / 축소를 제어할 수 있습니다.  
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Standard Toolbar의 scale-box에서도 적절한 값을 선택하거나 직접 값을 입력함으로써
확대나 축소를 할 수 있습니다.

Title 필드에 텍스트를 넣기 위해서는 그 영역으로 이동해서 녹색으로 하이라이트
되었을때 좌-클릭합니다. 그러면 text를 입력할 수 있고, 그것에 대한 정렬(Left, Center,
Right)과 서식을 정할 수 있는 “Field Properties” 대화상자가 나타나게 됩니다. “Astable
Flip Flop”을 입력하고 “Font”버튼을 클릭하여 크기를 “12”로 설정한 후 “OK”를
클릭하여 폰트 대화상자를 닫습니다.

 

scale-box



Creating a simple Schematic and PCB 7

© 2011 Novarm Ltd.

Title 블럭을 중심으로 화면을 확대 / 축소하고 싶다면 마우스포인터를 title 블럭으로
이동해서 “+” / ”-”키를 반복적으로 누르거나 마우스휠을 위 / 아래로 회전시키면 됩니다.
또한 Scale-box에서 왼쪽으로 3번째 버튼인 “Zoom Window”를 사용해서도 화면의 확대
가 가능합니다. “Zoom Window”를 클릭한 후 원하는 영역으로 이동합니다.  이 영역의
좌측상단 지점에서 왼쪽 버튼을 누른 상태로 우측하단으로 이동 후에 버튼을 놓습니다.
“Zoom Window”를 실행하기 전의 상태로 되돌리기 위해서는 Scale-box의 바로 왼쪽에
있는 “Undo Scale”기능을 사용합니다. 
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메인메뉴의 “File →  Save As”를 선택합니다. “다른 이름으로 저장” 대화상자가 나타나면
원하는 디렉토리로 이동 후 파일의 이름을 입력하고 저장합니다.

2.2 라이브러리 설정하기

Schematic Capture와 PCB Layout을 사용하기에 앞서 먼저 라이브러리 설정을 원할 수도
있습니다. 메인메뉴의 “Library → Library Setup”을 선택합니다.



Creating a simple Schematic and PCB 9

© 2011 Novarm Ltd.

우측에서 보이는 "No Library File"은 무시하고 “All Libraries”박스의 우측에 있는 스크롤
바를 아래로 이동시키면 기본으로 제공되는 모든 라이브러리들을 볼 수 있습니다.

DipTrace에서 라이브러리를 사용하는데는 2가지 방법이 있습니다.

1. 지정된 폴더로부터 라이브러리 얻기:

"Library Setup”윈도우의 왼쪽상단에 있는 “Get Libraries from Folder”가 체크되면 지정된
폴더에 있는 라이브러리들을 사용할 수 있습니다. 라이브러리가 있는 폴더를 선택하기
위해서 폴더경로 우측의 “...”버튼을 클릭합니다. DipTrace와 함께 설치된 “Lib” 디렉토리
를 확인합니다. 후에 어떤 다른 폴더라도 선택할 수 있습니다(예를들어 별도의 심볼들을
저장하기 위해서 생성한 “mylib” 라이브러리를 선택할 수 있습니다) “Libraries” 개념에
익숙해지기 전에는 우선 Tutorial대로 따라합니다.

2. list를 사용해서 라이브러리 사용하기:

이 방식은 "Get Libraries from Folder"가 체크되어 있지 않을때 사용됩니다. 라이브러리를
사용 가능하도록 라이브러리 목록 우측에 있는 버튼들을 사용해서 조정할 수 있습니다.
“<<”: ”All Libraries”로부터 선택된 라이브러리를 추가.,
“...”: 하드드라이브로부터 라이브러리를 추가.,
“”: 선택한 라이브러리를 위로 이동.,
“”: 선택한 라이브러리를 아래로 이동.,
“Del”: 선택한 라이브러리를 목록에서 제거.

모든 알려진 라이브러리들은 자동적으로 “All Libraries”에 표시됩니다.
(지정된 폴더로부터 라이브러리를 얻는 것이 기본설정입니다.)
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"Add"나 "Delete" 버튼을 사용해서 “All Libraries”로부터  라이브러리들을 추가하거나
제거할 수 있습니다.

“Library Setup” 대화상자를 닫습니다. 변경 사항들이 Libraries toolbar에 적용됩니다. 

디자인(Schematic, PCB Layout)으로부터 components를 라이브러리에 추가시키고 싶다면
원하는 component위로 이동해서 우-클릭하고 “Save to Library”를 선택합니다. “Save to
Library”의 서브메뉴 “Add to Active”를 선택해서 부품을 Components toolbar(화면 좌측)에
추가시키거나 “Save to File”을 선택해서 다른 라이브러리에 저장할 수 있습니다.

2.3  회로 디자인하기

이제 그리드 크기를 0.1(inch)로 변경합니다. Scale-box 바로 옆의 Grid Size box에서
선택하거나 직접 크기를 입력합니다. 단축키 “Ctrl+”(증가) / ”Ctrl-”(감소)를 사용해서도
변경할 수 있습니다. 단 단축키는 현재의 그리드 크기가 Grid Size box의 목록에 있는 것
일 때만 변경이 가능합니다. 목록 변경은 메인메뉴 “View → Customize Grid”선택합니다.

Libraries toolbar 우측끝의 오른쪽방향 화살표를 클릭하거나 작은 대각선방향 화살표를
클릭하면 나타나는 스크롤바를 오른쪽으로 이동시켜서 라이브러리를 스크롤합니다.
“Fairchild”란 이름의 라이브러리를 선택합니다. (라이브러리는 좌/우로 스크롤 가능)

Component toolbar에서 아래로 스크롤하여 transistor 2N4401을 발견하거나 또는 가장
위에 있는 Search box에서 “2n4401”을 입력하고 엔터를 누릅니다. 2N4401을 클릭해서
Placement모드로 들어갑니다. 마우스포인터를 디자인 영역으로 옮기고 트랜지스터를
배치하기 위해서 좌-클릭합니다. placement모드에서 나가기 위해서는 우-클릭을
사용합니다.  
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심볼을 이동시키기 위해서는 심볼위에서 마우스의 왼쪽 버튼을 누른 상태에서 새
위치로 이동 후 버튼을 놓습니다. 몇개의 심볼을 동시에 선택하기 위해서는 “Ctrl”
버튼을 누른 상태로 각각의 심볼들을 클릭합니다. 다수의 심볼을 선택하는 또 다른
방법은 선택을 원하는 그룹의 왼쪽상단으로 마우스포인터를 이동시킨 후 왼쪽 버튼을
누른 상태에서 마우스포인터를 우측하단으로 이동시켜서 버튼을 놓습니다
(만약 Ctrl 키를 함께 누르고 있었다면 그 선택은 반전되게 됩니다).

때때로 부품의 reference designator를 변경할 필요가 있습니다. 그럴때는 그 부품의 위에 
마우스포인터를 놓고 오른쪽 버튼을 클릭합니다. 팝업메뉴가 나타나면 가장 위쪽
항목을 선택하고 대화상자가 나타나면 새로운 값을 입력합니다. 여기서는 “Q1”을
유지합니다.

회로에 2개의 트랜지스터가 필요하기 때문에 Component toolbar에서 다시 “2N4401”을
선택해서 현재 작업하고 있는 sheet에 배치합니다. 
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새로 배치하는 부품의 Ref. Designator는 자동으로 바뀌게 됩니다. 회로도에 부품 배치 시
회전을 원할 때는 스페이스바나 “R”키를 사용합니다.

Libraries toolbar에서 “Discrete”로 이름붙여진 라이브러리를 선택하고 Components toolbar
에서 적절한 resistor를 선택해서 배치합니다.

400mils lead폭이 있는 resistor를 의미하는 RES400을 선택합니다. metric 유닛을
선호한다면 메인메뉴의 “View → Units → mm”를 선택합니다. 그러나 여기서는 inches를
유지 할 것입니다. 혹시 예기치 못한 실수를 방지하기 위해서 현재 사용하는 units에
주의를 기울여야 합니다.
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회로에는 4개의 resistor가 필요합니다. Q1과 Q2를 배치할 때처럼 Components toolbar로
부터 배치할 수 있지만, 다른 방법을 사용해 볼 것입니다. 먼저 디자인 영역에서 resistor
를 선택합니다. 그리고 3번 복사합니다. 복사에는 2가지 방법이 있습니다.

1. 메인메뉴에서 "Edit → Copy"를 선택합니다(또는 resistor위에서 우-클릭하고 “Copy"를
선택하거나 단축키 "Ctrl+C"). 다음에 메인메뉴에서 “Edit → Paste”를 3번 선택합니다
(배치하고자 하는 곳에서 우-클릭, 팝업메뉴로부터 “Paste” 3번)

2. 두번째 방법은 “Copy Matrix” 기능을 사용하는 것입니다. 먼저 resistor를 선택하고,
메인메뉴에서 “Edit → Copy Matrix”(단축키 “Ctrl+M”)을 선택합니다.

 

"Copy Matrix" 대화상자에서 행과 열의 갯수, 간격을 지정합니다.(4개의 resistor를 배치하
기 위해서 Columns에 “2”, Rows에 “2”, 간격은 Column Spacing에 “1”, Row Spacing에
“0.4”을 입력)
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"OK"를 클릭하면 4개의 resistor들을 볼 수 있습니다.

회로상의 적절한 위치로 resistor들을 이동시키고 스페이스바나 “R”키를 사용해서 90도
회전시킵니다. 어떤 대상을 회전시키는 또다른 방법은 메인메뉴에서 “Edit → Rotate”를
선택하거나 대상의 위에서 우-클릭해서 팝업메뉴로부터 “Rotate”를 선택하는 것입니다.
만약 직교이동이 필요하다면 “Shift”키를 함께 사용할 수 있습니다. 

마우스의 우측버튼이나 휠을 사용해서 디자인을 pan할 수 있습니다. 마우스포인터를
작업영역으로 이동시킨 후 우측버튼이나 마우스 휠을 누른 상태로 디자인을 새로운
위치로 pan합니다.
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Resistor의 Ref. Designator가 핀의 이름과 겹쳐 있습니다. 모든 resistor를 선택하고 그중의
하나에서 우-클릭해서 팝업메뉴로부터 “Properties”를 선택합니다. Component Properties
대화상자에서 “Marking”탭을 선택하고 “Main Marking” 에서 “Justify: Left”로 지정하고
“OK”를 클릭합니다.
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이제 transistor의 component타입을 표시할 것입니다. Q1과 Q2를 선택합니다. 그리고
Component Properties대화상자의 “Marking”탭에 있는 “Additional Marking”에서 “Show:
Type”과 “Justify: Corner”를 선택합니다. Ref. Designator는 기본설정인  “Main Marking”으
로 디스플레이됩니다. “Default”는 Ref. Designator가 회로의 공통속성으로 자기 자신의
고유 설정을 가지고 있는 component를 제외한 모든 component에 적용된다는 것을 의미
합니다.

Marking의 위치를 변경하고 싶다면 “Marking” 탭에서 오른쪽화살표 버튼을 클릭합니다.
그런면 Component Properties대화상자가 확장되면서 새로운 옵션이 나타납니다.
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Pin번호들이 아직 보이지 않는다면 메인메뉴의 “View → Pin Numbers → Show”를
선택해서 보이게 할 수 있습니다.  또한 component위에서 우-클릭 후에 나타나는
팝업윈도우의 “Pin Numbers” 서브메뉴를 사용해서 설정을 변경할 수 있습니다.

Ref. Designator, pin이름, 기타 다른 Text들의 위치가 마음에 들지 않는다면 메인메뉴의
“View → Part Marking → Move Tool”이나 “F10”키를 사용해서 원하는 위치로 이동시킬
수 있습니다. 정밀한 이동을 위해서는 “F11”키를 사용해서 grid snap을 off할 것을
권장합니다(“F11”: grid on/off)  이동하는 동안 “R”키나 스페이스바를 사용해서 파트의
marking을 회전시킬 수 있습니다. 메인메뉴에서 “View → Part Marking”의 서브메뉴는
Component Properties의 Default라고 하는 것을 지정합니다. 즉 이곳에서 지정한 것이
Default가 되기 때문에 자기자신의 고유설정을 가지고 있지 않고 default로 지정한  회로
상의 모든 component가 이 설정 및 변경사항을 적용받게 됩니다.
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이제 “F11”키를 다시 눌러서 그리드를 적용시킵니다. 방금 수행한 명령 바로 전 단계로
되돌리기 위해서 “Edit → Undo”(“Ctrl+z”, Standard toolbar의 “Undo”버튼)을 사용할 수
있습니다. 50단계까지 저장됩니다. “Undo”의 반대 기능으로 “Redo”를 사용할 수 있습니
다. 이제 회로를 저장해 보도록 하겠습니다. 메인메뉴의 “File → Save”를 선택하거나
Standard toolbar에서 “Save”버튼을 클릭합니다.  회로가 아직 저장되지 않았다면 파일의
이름을 정하기 위해서 “Save As”대화상자가 나타납니다. 일단 한번 저장이 되었다면
“Save”버튼을 클릭하거나 단축키 “Ctrl+s”를 사용하면 됩니다. 파일의 이름변경이나 
백업을 원한다면 “File → Save As”를 사용하면 됩니다.
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Resistor R1을 transistor Q1의 pin 2(base)에 연결: resistor의 pin위로 마우스포인터를 이동
해서 하이라이트되면 좌-클릭합니다. 마우스포인터를 Q1의 pin 2로 이동시킵니다. 이때
Wire가 마우스포인터를 따라 다닙니다. Q1의 pin 2가 하이라이트되면 좌-클릭합니다. 

Transistor Q2를 mirror시키기 위해서 마우스포인터를 Q2위로 이동시킨 후 우-클릭하여
팝업윈도에서 “Flip → Horizontal”을 선택합니다. 

같은 방법으로 R4를 Q2의 Pin 2에, R2를 Q1의 pin 3에, 그리고 R3를 Q2의 pin 3에 연결합
니다.
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일부 wire의 연결이 마음에 들지 않는다면 파트나 Wire를 이동시킬 수 있습니다. 이러한
것은 전기적 연결에 대해서 중요하지 않습니다. 자동적인 Wire배치가 마음에 들지
않는다면 화면의 오른쪽 “Place Wire”(Design Manager toolbar)패널에서 이 기능을 Off
시킬 수 있습니다. “Route Mode”에서 “Manual”을 선택하거나 단축키”M”을 사용합니다.
“Place wire”패널은 오직 wire placement모드에서만 보여지게 됩니다.

“Discrete” library로부터 CAP100RP를 선택해서 2개를 배치합니다.
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C2의 +표시가 우측에 오도록 C2위에 마우스포인터를 놓고 우-클릭 한다음 팝업메뉴
에서 “Flip → Horizontal”을 선택합니다.

극성에 주의하면서 Capacitor C1과 C2를 transistor Q1과 Q2사이로 이동 시킵니다: 

Wire연결을 위한 공간을 제공하기 위해서 resistor들을 약간 위로 이동시킬 필요가 있습
니다. “Q2”, “R3”, “R4” 및 연결된 wire들을 박스선택합니다.(마우스포인터를 원하는 영역
의 왼쪽 상단으로 이동 후에 마우스의 왼쪽 버튼을 누른 상태로 오른쪽 하단으로 이동
해서 버튼을 놓습니다. 그러면 사각영역 내의 모든 object가 선택됩니다.
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위의 그림에서 사각형은 선택된 object를 보이게 됩니다.(색은 Color Scheme에 의해서
다를 수 있습니다) 디폴트모드에 있다면 선택을 해제하기 위해서 우-클릭을 합니다.
다른 어떤 모드에 있다면 두번 우-클릭을 합니다.(모드해제를 위해서 한번, 선택해제를
위해서한번) C1(+)를 Q1의 pin 2에 연결하고 마우스포인터를 C1 (+)pin으로 이동합니다.
좌-클릭하고 Wire를 R1과 Q1사이로 이동시킨 다음 연결하기 위해서 좌-클릭합니다. 
C2도 밑의 그림에서 보이는 것처럼 연결합니다. 
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LED를 찾기 위해서 왼쪽의 Components toolbar에서 아래로 스크롤한 후 회로에 2개를
배치합니다. 그런다음 레퍼런스 designator를 “LED1”과 “LED2”로 변경합니다.
(파트위에서 우-클릭 후 팝업메뉴의 첫 항목) LED 2개 모두를 선택하고 “R”키나
스페이스바를 눌러서 회전을 3회 반복합니다. 아마도 Ref. Designator를 약간 이동시킬
필요가 있을 것입니다. 다음에는 LED를 transistor에 연결합니다.
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“Disc_Sch” 라이브러리로부터 배터리 심볼을 배치합니다. 배터리 Ref. Designator를
변경하고 그림에서 보이는 것처럼 회로를 완료하기 위해서 wire를 연결합니다.
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이미 존재하는 wire를 이동시키고 싶다면 그 Wire위로 마우스포인터를 이동합니다.
(net의 색이 하이라이트되고 마우스포인터는 이동가능한 방향을 보이는 형태로 바뀌게
됩니다) 마우스의 왼쪽버튼을 누른 상태로 wire를 새로운 위치로 옮겨 놓습니다. “Place
Wire”모드에서 현존하는 wire위에 클릭한다면 새로운 wire을 생성하게 됩니다. (“Place
Wire”모드는 component pin에서 클릭하여 wire를 배치하려고 시도할때 자동적으로 이
모드로 변경됩니다. 또한 “Objects → Circuit → Place Wire”를 사용해도 동일하게 작동
합니다(Objects toolbar의 “Place Wire”도 동일) 마우스포인터를 object의 위로 이동했을 때
일부 object들이 하이라이트되지 않는다면 디폴트모드로 하기 위해서 우-클릭을 합니다.
Wire(노드에서 노드로의 연결) 제거를 원한다면 해당 wire위로 마우스를 이동시킨 후
팝업메뉴를 열어서 “Delete Wire”를 선택합니다. wire의 일부를 지우기 위해서는 “Delete
Line”을 선택합니다.

Component values 입력하기: “R1”위에서 우-클릭하여 팝업메뉴로부터 “Properties”를 선택
합니다. Main탭의 “Value”에 47k를 입력하고, “Marking”탭을 클릭하여 Main Marking의
Show: Value로, Additional Marking의 Show: RefDes로 변경해서 OK를 클릭합니다.
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남아있는 component의 값들을 입력합니다. 몇개의 component를 동시에 선택하고
Component Properties대화상자에서 Marking의 설정들을 변경함으로써 한번에 바꿀 수
있습니다.
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배터리는 라이브러리 Disc_Sch로부터 배치되었습니다. 모든 *Sch 라이브러리들은 패턴
없이 단지 심볼만을 포함합니다. (component 선택 시 pattern의 유무 및 preview기능 표시)
회로도를 PCB로 변환할 것을 원한다면 먼저 심볼들에 그에 해당하는 패턴들을 할당해
야 합니다. 할당없이 진행할 경우 수정해야만 하는 error들을 보여주게 될 것입니다.
배터리 심볼의 위로 마우스포인터를 이동합니다. 팝업메뉴 호출을 위해서 우-클릭 후
“Attached Pattern”을 선택합니다. 대화상자에 pattern라이브러리들을 추가합니다: 우측
상단의 “Add”버튼을 클릭해서 하드드라이브에 있는 pattern 라이브러리를 선택합니다.
(모든 표준 라이브러리들은 “<설치폴더>\Lib”폴더에 위치합니다)
표준 라이브러리로부터 “misc.lib”를 필요로 합니다. 이제 라이브러리 목록으로부터
“misc.lib”를 선택하고 대화상자의 우측 하단에 있는 pattern목록으로부터 “BAT-2” pattern
을 선택합니다. 이제 component의 pin과 pattern의 pad 연관성을 정의합니다. Pin table에서
에서 pin이름을 클릭합니다(대화상자의 왼쪽) 다음에 “Pad Number”에 해당하는 pad번호
를 입력합니다. 또는 간단히 해당하는 pattern의 그림에서 패드를 클릭합니다.
(대화상자의 가운데)   
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Pin과 pad의 연결이 모두 완료되면 OK를 클릭합니다.

주의: 일부 심볼들은 패턴들을 가지고 있지 않아야 합니다.(예를들면 VCC, GND 또는
“Net Ports”같은 논리적인 커넥터들) 그래야 변환 동안에 Error가 발생하지 않습니다.

이제 회로는 PCB로 변환될 준비가 되어 있습니다 메인메뉴에서 “File → Save”를 선택
하여 저장하는 것을 잊지 마십시오(Standard toolbar의 “Save”버튼, 단축키 “Ctrl+S”)

회로도는 인쇄하거나 BMP또는 JPG로 저장할 수 있습니다. 메인메뉴에서 “File → 
Preview”를 선택하고 모든 sheet의 회로를 인쇄하기 위해서 “Print All”을 실행합니다.
선택된 sheet만을 인쇄하기 위해서는 “Print Current Sheet”을 선택합니다. 또한 BMP/JPG
로 저장하기 위해서는 “Save”을 클릭합니다.

2.4 PCB로 변환하기

PCB Layout에서도 회로도 파일(*.dch)을 오픈할 수 있지만 Schematic Capture에서
“File → Convert to PCB”(“Ctrl+B”)를 선택해서 현재의 프로젝트를 PCB Layout에게 넘겨
줄 수 있습니다. “Making PCB from Schematic”팝업 윈도우에서 Schematic의 rule을 사용할
것을 선택하거나 또는 임의의 PCB layout으로부터 rule들을 로드할 수 있습니다.
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그러나 Win98/ME 유저들에 대해서는 회로를 저장하고 프로그램을 닫은다음, PCB
Layout을 실행해서 PCB Layout으로부터 *.dch를 오픈할 것을 강력히 권장합니다.
9X/ME에서의 부정확한 메모리 공유는 몇개의 프로그램들이 한번에 동작하는 동안
문제를 발생시킬 수 있습니다. Win NT/2000/XP/Vista/7 사용자들은 그런 문제없이 한번에
다수의 DipTrace 모듈을 실행시킬 수 있습니다. 만약 프로그램의 비정상적인 종료나
프로젝트를 저장하는 것을 잊었다면 Schematic Capture에서는 “File → Recover Schematic”
을, PCB Layout에서는 “File → Recover Board”를 선택함으로써 가장 최신의 작업상태로
복구할 수 있습니다.
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PCB설계를 위해서 다른 PCB Layout 소프트웨어를 사용하거나 다른 누군가에게 그것을
위임하려 한다면 Schematic Capture의 netlist export기능을 사용할 수 있습니다. 메인메뉴
의 “File → Export → Netlist”를 선택 후 format을 선택합니다. DipTrace는 Tango, PADS,
P-CAD등의 인기있는 netlist format을 지원합니다. 네트구조를 검사하는데도 유용합니다.
 
PCB설계를 위해서 DipTrace PCB Layout을 사용할 것입니다. Layout의 보다 더 넓은 작업
공간 확보를 위해서 Design Manager(layers panel) toolbar를 숨기려 한다면 F3키를 누르거
나 “View → Toolbars → Design Manager”의 체크표시를 지우도록 합니다.

Preferences와 design rules에 따라 부품을 배치합니다. component의 이동은 마우스포인터
를 component 위에 놓고 원하는 위치로 드래깅함으로써 수행됩니다. 선택한 부품을 90도
회전시키기 위해서는 스페이스바나 “R”키를 사용합니다. 임의의 각도로 회전을 시키고
싶다면 회전시킬 component들을 선택하고 우-클릭해서 “Define Angle” 또는 “Rotate
Mode”를 선택합니다. Rotate 모드로 마우스를 사용해서 object들을 자유롭게 회전시킬 수
있습니다.

파워서플라이 부품들을 한영역에 유지시키고 기능적인 블럭들끼리 함께 모으는 것은 
좋은 방법입니다. 회로가 고주파수로 작동한다면 적절한 layout rule들을 적용합니다.

Schematic으로부터 변환 후 component들의 배치를 위해서 auto-placement나 또는 
placement by list를 사용할 수 있습니다. 그러나 이 기능은 단순한 프로젝트에는 필요하지
않습니다. 이 기능은 보다 더 복잡한 회로를 다루는 Part III에서 다루게 될 것입니다.

Component의 배치상태와 라우트된 트레이스를 유지하면서 변경된 회로로부터 PCB를 
업데이트할 수 있습니다. “File → Renew Design from Schematic”을 선택하고 수정된 
Schematic 파일을 선택합니다. Renewing by components는 component와 pattern사이의 링크
들을 결정하는데 숨겨진 ID들을 사용한다는 것을 의미합니다.
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이것은 PCB가 회로도로부터 직접 만들어진 경우에만 작동합니다. RefDes는 다를수도
있습니다. Renewing by RefDes는 component와 pattern의 링크들이 RefDes에 의해서 결정
된다는 것을 의미합니다. 이 경우에 PCB는 따로 설계될 수 있습니다., 그러나 RefDes가
유사해야만 합니다. Updating from Related Schematic은 연관된 회로의 파일로부터 부품에
의해서 업데이트된다는 것을 의미합니다(“File → Design Information”을 보십시오)

2.5 PCB 디자인하기

2.5.1 배선 준비하기

필요하다면 PCB Layout에서 Reference designator를 보이도록 설정합니다: “View →
Pattern Marking → Main → RefDes”를 선택합니다. 이것은 marking이 Default가 아닌 설정
을 가지고 있는 pattern들을 제외한 모든 pattern에 레퍼런스 designator를 보이도록 합니다
Marking justification이 마음에 들지 않는다면 “View → Pattern Marking → Main → Justify”
를 선택하고 서브메뉴로부터 “Auto”나 다른 모드를 선택합니다.  PCB Layout에서는 
Vector font타입을 적극 권장합니다., 그러나 비 영어권 문자들을 위해서 True Type fonts를
사용할 수 있습니다.(“View → Pattern Marking → Font Type”)

선택한 부품들에 각자의 설정을 적용시키기 위해서는 pattern위에서 우-클릭한 후 팝업
메뉴에서 “Properties → Marking”을 선택합니다. 또한 Designator를 옮기기 위해서 “F10”
이나 “View → Pattern Marking → Move Tool”을 사용하는 것을 기억하시기 바랍니다.

연결들에 대한 구성을 최적화하기 위해서 “F12”키를 사용합니다.

이제 디자인의 네트구조를 바꾸는 방법과 연결의 추가나 제거법을 알아 보도록 하겠습
니다. 이러한 단계는 이 예제에서 필요하지 않지만 그러한 것이 가능하다는 것은
알아야 합니다.
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임의의 패드위로 마우스포인터를 이동합니다. 다음에 우-클릭하여 “Delete from Net”을
선택합니다. 그러면 그 패드는 net로부터 제거 될 것입니다.

만약 연결의 생성(새로운네트) 없이 몇개의 패드를 네트에 추가하고 싶다면(예를들어 
디자인에서 그 net의 다른 패드들 찾는것을 원하지 않을때) 마우스포인터를 그 패드위로
이동하여 우-클릭하고 “Add to Net → Select from List”를 선택합니다.

패드위로 마우스포인터를 이동시키고 좌-클릭한 다음, 연결을 원하는 다른 패드로
마우스포인터를 이동시키고 그것 위에서 좌-클릭합니다. 이제 패드에서 패드로 연결이
(블루라인)이루어졌습니다. 만약 그러한 연결이 생성되지 않는다면 default 모드에 있지
않을 것입니다. 현재의 모드를 해제하기 위해서 우-클릭 합니다. 현재 존재하는
connection의 제거를 위하여 패드에서 우클릭 후 팝업메뉴로부터 “Delete from Net”을
선택합니다.

또한 Connection manager로부터 net들의 구조를 수정할 수 있습니다. Connection manager
를 오픈하기 위해서는 메인메뉴에서 “Route → Connection Manager”를 선택합니다. 이제
새로운 net를 만들 수 있고 net로부터 패드를 추가하거나 제거할 수 있습니다.
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만약 net의 구조를 변경했다면 예전의 상태로 돌아갈때까지 “Undo”를 실행합니다. 
작업중에 예기치 못한 문제로 자료 전체를 분실하였을 경우 PCB Layout에서는 “File → 
Recover Board”를, Schematic Capture에서는 “File → Recover Schematic”를 사용해서 가장
최신의 작업상태로 복구할 수 있습니다.

“Route → Lock Net Structure”기능을 사용해서 변하지 않기를 원하는 net구조를 보호하는
것이 가능합니다.

이제 보드의 outline을 생성해 보도록 하겠습니다. auto-router를 사용할때는 배선영역(
간단한 보드들에 대해서 폴리곤이나 직사각형)이 자동적으로 생성됩니다. 그러나
대부분의 경우에는 부품의 배치와 그것의 배선을 하기전에, 보드의 모양과 크기를 설정
해야 합니다. “Objects → Place Board Outline”(또는 Routing toolbar의 버튼)을 선택합니다.
다음에 보드의 모양과 크기를 결정하는 위치를 클릭함으로써 보드를 형성하는 polygon
을 배치합니다. 최종적인 지점에서 우-클릭 후 “Enter”를 선택해서 완료합니다.  

보드의 외곽 형성 중에 우클릭해서 “Arc Mode”를 선택함으로써 보드의 모양에 arc를
적용할 수 있습니다. 보드의 완성후 수정을 위해서는 마우스포인터를 보드의 외곽을
구성하는 polygon위로 이동합니다. 그러면 폴리곤을 구성하는 점들이 나타납니다. 점들
사이의 선 위에서 우-클릭하면 점을 추가 할 수 있습니다. 점 위에서 우-클릭 시 arc로
변환하거나 제거가 가능합니다. 또한 드래그해서 위치를 변경할 수 있습니다. Hint에는
점의 좌표가 표시됩니다.
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“Board Points”대화상자에서 보드 구성점이나 크기를 설정할 수 있습니다. 메인메뉴의
“Objects → Board Points”를 선택합니다.
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이 대화상자에서 보드를 구성하는 점을 추가하거나 삽입 및 삭제를 할 수 있습니다.
절대좌표나 증가모드로 좌표를 수정할 수 있습니다. 만약 어떤 점에서 “Arc”박스에 체크
한다면 그점은 arc의 중심점이 되고 이웃하는 점들은 arc의 시작 및 끝점이 됩니다. 
직사각형 모양의 보드라면 “Create Rectangular Board”박스를 체크하고 간단하게 보드의
첫 위치와 너비 및 높이를 정해줍니다. 그런다음 수정사항을 적용하기 위해서 “OK”를
클릭합니다. 변화없이 대화상자를 닫기 위해서는 “Cancel”을 클릭합니다. 보드의 외곽을
삭제하기 위해서는 메인메뉴의 “Objects → Delete Board”를 사용합니다.

디자인의 원점을 아직 지정하지 않았다는 것에 주지하십시오 디폴트로 원점은 화면의
중심이 되고 표시되지는 않습니다. 원점을 표시하기 위해서는 메인메뉴로부터 “View
→ Origin”(“F1”)을 선택합니다. 이제 원점(직교하는 판란색 선)이 표시되지만 그것의
위치가 현재의 보드에는 적합하지 않습니다. 그래서 Elements toolbar의 “Define origin”
버튼을 선택하고 보드외곽의 좌측하단 모서리를 클릭합니다.
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Diptrace에서 모든 좌표는 원점을 중심으로 표시되고 수정됩니다. 또한 원할때는 언제
든지 원점의 위치를 변경할 수 있습니다.

모든 패턴들은 그들 자신의 원점을 가집니다. 그것은 Pattern Editor에서 수정할 수 있습니
다. 그것은 라이브러리를 디자인 하면서 알아보도록 하겠습니다. 실질적으로 부품의 
좌표는 패턴의 원점위치를 의미하고, 그것은 패턴을 배치하는 동안 표시됩니다.
선택한 패턴의 원점을 표시하거나 표시하지 않게 하기 위해서는 패턴에서 우-클릭 후
팝업메뉴에서 “Pattern Origin”의 서브메뉴를 선택합니다. 

2.5.2 자동배선

이제 보드를 배선해 보도록 하겠습니다. DipTrace는 오늘날 최고중의 하나로 평가받는
고품질의 shaped-based 라우터 기능을 가지고 있습니다. 또한 간단한 PCB와 점퍼 wire가
있는 단면보드를 배선하는 grid router 기능 역시 가지고 있습니다. 대부분 간단한 PCB는
단면에 배선할 수 있습니다. 그리고 그것은 프로토타입에 대해서 명백히 많은 이점을
제공합니다. 트레이스는 양면보다는 단면에서 약간 더 길어지게 될 것입니다. 그러나
대부분의 설계에서 그리 중요한 영향을 끼치지는 않을 것입니다.

Shape나 Grid router의 사용은 메인메뉴의 “Route → Current Autorouter”를 선택합니다.

먼저 router를 설정해야 합니다. 메인메뉴의 “Route → Autorouter Setup”을 선택합니다.

Shape Router설정 대화상자에서 “Settings”탭을 선택하고 “Use Priority Layer Directions”
체크박스를 체크합니다. layers목록에서 “Top”을 선택하고 “Direction: Off”로 지정합니다.
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점퍼wire가 있는 단면 PCB를 자동 배선하는 것도 가능합니다.(Grid Router사용,
“Allow Jumper Wires” 체크박스에 체크) 현재의 보드는 간단해서 Shape Router를 사용해서
점퍼 wire없이 배선하는 것이 가능합니다. 

 설정사항을 적용하기 위해서 “OK”를 클릭합니다.

다음에는 “Route → Route Setup”을 선택합니다. 대화상자에서 디폴트 trace width와
트레이스간의 간격 및 비아의 기본 크기를 수정할 수 있습니다. 또는 더 많은 설정들을
변경할 수 있는 Net Classes와 Via Styles에 접근할 수 있도록 “All Classes...”나 “All Styles
...”버튼을 클릭합니다. Net classes와 via styles들을 수정할 수 있는 방법은 나중에 다루게
됩니다.
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이 예제에서는 0.012인치  트레이스를 사용합니다. 그러나 보다 더 가늘거나 넓게 할 수
있습니다. OK를 클릭합니다.

이제 보드를 배선할 시간입니다. “Route → Run Autorouter”를 선택합니다. 보드가 자동으
로 배선됩니다. 이제 아래의 그림과 같이 보일 것입니다. 그림과는 다소 다르더라도
당황하실 필요는 없습니다. 
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DRC(Design Rule Check)는 자동배선 후에 자동적으로 실행됩니다. 만약 어떤 에러가 있
다면 그들이 보여지게 될 것입니다.(red와 blue circle) 에러들을 수정하고 메인메뉴에서 
“Verification → Check Design Rules”(Route toolbar의”Check Design”)을 선택하여 다시
DRC를 실행합니다. Design rules을 변경하기 위해서는 메인메뉴의 “Verification → 
Design Rules”를 선택합니다. red-원들을 감추기 위해서는 “Verification → Hide Errors”을
선택합니다. 또한 메인메뉴의 “Route → Current Autorouter”에서 “Run DRC after
Autorouting”의 체크를 지움으로써 DRC가 자동으로 실행되지 않도록 할 수 있습니다.

이제 PCB를 출력할 수 있는 기본적인 준비가 되었습니다. 이제부터는 보다 더 세부적
인 사항들에 대하여 알아 보겠습니다.

2.5.3 Layers로 작업하기

Auto-routing후에 보이는 trace들은 회색입니다. 그것은 top layer가 활성화되어 있는
반면에 trace들은 bottom layer에 배선되었기 때문입니다. 화면의 오른쪽에 “Layers”패널을
볼 수 있습니다. 더블-클릭해서 활성화되는 layer를 변경할 수 있습니다. 또한 단축키들을
사용할 수 있습니다. 단축키는 각 layer의 이름 옆 괄호안에 표시됩니다. 그리고 top과
bottom layer에 대해서는 “T”나 “B”키를 사용해서 전환할 수 있습니다. 이 예제에서는
bottom layer(“2”)를 더블-클릭해서 작업layer를 bottom layer로 변경합니다. 

또한 Route toolbar에 있는 layer list box에서도 작업 layer을 변경할 수 있습니다.
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새로운 layer을 추가하기 위해서는 메인메뉴의 “Route → Layer Setup”에서 “Add”버튼을
클릭합니다. 팝업윈도우에서 새로운 layer의 이름, 유형, 색상등 모든 특성을 지정할 수
있습니다. Type에서 Plane을 선택한다면 일반적으로 Ground나 Power net들 중 하나를
그 layer에 연결하게 됩니다. 그러나 현재는 아직 어떠한 네트도 연결하지 않습니다.
또한 Plated Holes By Pads나 Fixed Ring을 선택하고 크기를 설정할 수 있습니다.

“Close”버튼을 클릭합니다.
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위의 그림에서는 top과 bottom layer사이에 새롭게 생성한 “Tutorial Layer”가 보입니다.
팝업메뉴에서 “Move up”이나 “Move down” 버튼을 클릭해서 layer의 위치를 바꾸는 것이
가능합니다. 다만 top과 bottom layer는 이동이 불가능합니다.
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Layer panel에는 몇개의 quick-access 버튼들이 있습니다. 왼쪽부터 “Add Layer”, “Layer Set
Up”, Layer의 표시방식 선택을 위한 드롭다운 상자가 있습니다. layer들 사이의 전환을
빨리하기 위해서는 1, 2, 3, 4 e.t.c.의 숫자 키를 사용합니다.

또한 메인메뉴의 “View → Mirror”를 사용해서 top-view와 bottom-view간에 쉽게 전환할
수 있습니다.

2.5.4 Via로 작업하기

Diptrace는 2가지 유형의 via를 사용합니다. 기술적으로 trace의 한 부분인 trace via라고
부르는 일반적인 비아는 트레이스를 다른 레이어로 이동할 때 자동적으로 생성됩니다.
그리고 pad와 유사한 static via는 훨씬 더 다양한 속성들을 가지고 있습니다. 모든 via들
은 Via Styles에서 설정합니다.

여기서는 Blind / Buried via들도 사용해 볼 것입니다.

“Route → Via styles”에서 “Add”버튼을 클릭합니다. 기본 설정이 있는 새로운 비아유형이
나타납니다. 새 비아타입을 선택(클릭)하고 이름을 입력합니다. 다음에 Type을 Blind/
Buried로 변경합니다. Blind /Buried via가 존재하게 될 layer들을 설정합니다. 그럼 top
layer에서 Tutorial Layer까지로 blind via을 설정하고 OK를 클릭합니다. 단지 2개만의
layer(양면)로 이루어진 보드에서는 blind via를 사용할 수 없습니다.
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새로운 비아 유형을 생성한 후에 net중의 하나를 unroute하고 트레이스 비아를 배치합
니다. bottom layer로 전환한 후에 배선취소를 원하는 네트위에서 우-클릭하여 “Unroute
Net”을 선택합니다. 이제 그 net중의 하나를 직접 배선하게 될 것입니다. 메인메뉴에서 
“Route → Manual Routing → Add Trace”를 선택합니다. 하나의 패드 위에서 좌-클릭을
하면 보드에 배선이 시작됩니다. 두 pad 사이의 어떤 지점까지 배선의 일 부분을
생성하고 좌-클릭합니다. 그리고 우-클릭하면 팝업메뉴가 나타납니다. “Segment Layer → 
Top”을 선택합니다(bottom에서 routing을 하고 있을 때) 트레이스비아가 자동적으로
생성되고 다른 pad로 배선을 계속할 수 있습니다. 다시 좌-클릭을 합니다.

이제 Via Styles로 작업할 시간이다 기본설정 보다 더 큰 직경의 through-hole비아로 via
style을 추가합니다. 수작업 배선을 계속 진행해서 트레이스 비아를 한개 더 생성합니다.
배선 동안에 화면의 우측에 Manual Routing properties 패널을 보게 될 것입니다. 드롭다운
Via Style(V)메뉴에서 사용하게 될 via style들을 선택할 수 있습니다. “Auto”는 DipTrace가
보드상에서 다른 것보다 가장적은 공간을 차지하는 via style을 사용하게 될 것이라는 
것을 의미합니다. 현재는 큰 비아(Tutorial Via style2)로 선택하고 트레이스 비아를
생성하여 트레이스를 완료합니다.
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현재의 작업에서 static via를 생성하기 위해서 “Objects → Place a Static Via”를 선택하거나
트레이스비아를 static via로 변경할 수 있습니다. 트레이스 비아에서 우-클릭하고
“Convert to static”을 선택하여 변경할 비아를 지정합니다. Static via는 기본적으로 pad와
같습니다.

만약 비아유형의 어떤 속성을 변경한다면 보드상에 존재하는 같은 유형의 모든
비아들이 자동적으로 변경되게 됩니다.

Static이나 trace via에서 우-클릭하고 “Via properties”를 선택합니다. 간단한 윈도우에서
비아의 스타일, 유형, 직경등을 바꿀 수 있고 그것을 “Current Point” 또는 “Selected
Segments”, “Selected traces”, “Selected Nets”등에 적용할 수 있습니다. OK를 클릭합니다.
만약 당신이 입력한 사항에 대한 비아스타일이 없다면 DipTrace는 새로운 비아유형을
만들 것인지 물어봅니다.
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Static via들을 다시 trace via들로 바꾸는 것도 가능합니다. Static via위에서 우-클릭하고 
“Convert to Trace Via”를 선택합니다. 그런다음 바꿀 via를 선택합니다. 단 static via를
직접 배치했다면 그것은 trace via로 바꿀 수 없습니다.

이제 보드를 자동배선의 완료상태로 되돌리기 위해서 몇번의 Undo를 실행합니다.

2.5.5 Net Classes

편의를 위해서 PCB상의 모든 net들은 Net Class들로 분류할 수 있습니다. 우리가 앞에서
설명한 Via Styles처럼 Net Classes들은 거의 한번의 클릭으로 네트에 적용할 수 있는
일련의 속성들을 가집니다. 작업하는 동안 auto-router와 manual router 둘 다 net classes을
사용할 수 있습니다. Net classes의 특성들은 auto-router를 실행하기 전에 설정되어야
합니다.

먼저 PCB를 unroute할 필요가 있습니다. 메인메뉴의 “Route → Unroute All”을 선택합니다
다음에 “Route → Net Classes”를 선택합니다. 팝업 윈도우에서 Default net class만이 이용
가능한 것을 보게 됩니다. 현재 모든 네트는 이 클래스에  속합니다. 새 클래스를 더하기
위해서 “Add” 버튼을 클릭하면 Default바로 아래에 새로운 net 클래스가 목록에 나타나게
됩니다. 새 net 클래스를 클릭하고 이름을 입력합니다. “Class Properties”탭에서 class net에
대한 트레이스와 클리어런스의 속성을 지정할 수 있습니다. 우선 보드에서 그것이
어떻게 보이는지 알아보기 위해서 새로운 net class의 trace width를 기본 설정과는 상당히
다른 값으로 입력 할 것입니다.
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“All Layers”체크박스의 체크표시를 제거하면 체크박스 밑의 목록이 활성화됩니다.
그러면 각 layer의 trace들에 다른 속성을 지정할 수 있게 됩니다.

윈도우의 Via Styles부분에서 “Use All Styles”의 체크표시를 제거하면 이 net class에서
사용하고 싶은 Via Style을 선택할 수 있습니다. 단지 활성화된 목록으로부터 추가하거나
제거하기 위해서는 “<<”와 “>>”버튼을 클릭하면 됩니다. “...” 버튼은 각 via style의 속성
을 알아볼 수 있게 수정이 불가능한 “Via Styles” 윈도우를 표시합니다.

Net class는 net들 없이는 어떤 의미도 가지지 않습니다. 그래서 몇개의 net를 추가합니다. 
Net Classes 대화상자 우측에서 net들의 목록을 볼 수 있으며 괄호안에 그 net들이 속한
클래스가 표시됩니다. 우리의 경우에는 Default입니다. Ctrl이나 Shift를 사용해서 몇개의
네트를 선택하고 이들을 새 클래스로 이동시키기 위해서 arrow up버튼을 클릭합니다.

"Clearance Details" 버튼은 다른 object들과 clearance들을 설정하는 것을 가능하게 합니다.
그리고 “Class to Class” 버튼을 클릭해서 다른 net class와 net class 사이에서 clearance를
설정할 수 있습니다. Class to Class clearances는 오직 DRC에 의해서만 사용되며 net class 
clearances보다 우선 순위를 가집니다. OK 버튼을 클릭합니다.

이제 일부는 Default class에 속하고 나머지는 Tutorial Net Class에 속하는 2개의 다른 
Net Classe들이 설정 되었습니다. 메인메뉴의 “Route → Run Autorouter”를 선택하거나
단축키 “Ctrl+F9”을 누름으로써 PCB의 auto-routing을 실행해 보면 아래의 그림처럼
화면이 보이게 됩니다. PCB상의 trace들이 다른 속성이 있는 net class들에 속하기 때문에
서로 다른 것을 볼 수 있습니다.
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이제 다시 board를 unroute하고 Tutorial Net Class에 있는 모든 net들을 Default로 옮겨 놓습
니다. 다시 Auto-routing을 실행하면 board에 모두 같은 width를 가진 trace들을 볼 수
있습니다. Tutorial Net Class는 존재하지만 그것에 속한 net가 없기 때문에 보드상에는
어떤 영향도 끼치지 않습니다. 

Manual routing동안에도 역시 net classes을 사용할 수 있습니다. bottom layer를 선택합니다
Net들 중 한개를 좌-클릭하면 우측에서 Net Properties 패널을 볼 수 있습니다. Net Class
드롭다운 목록에서 net class를 Tutorial Net Class를 변경합니다. 같은 네트에서 우-클릭하
여 팝업메뉴로부터 “Unroute Net”을 클릭합니다. 다음에 “Route → Manual Routing →
Add trace”를 선택합니다. 이제 pad들 중 한개에서 좌-클릭 해서 다른 pad로 trace를
그립니다. 일부분만 그리기 위해서 도중에 좌-클릭을 합니다. 다른 trace와는 net class가
다르기 때문에 더 넓은 trace가 생성되는 것을 볼 수 있습니다.
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우리는 보드의 다양성을 필요로 하지 않습니다. 그래서 보드를 auto-routing의 바로 그 
상태로 되돌리기 위해서 몇번씩 Undo를 실행했습니다.

2.5.6 Manual Routing(수작업 배선하기)

Trace들을 수정해 보도록 합니다. 먼저 수정을 원하는 trace가 있는 layer로 작업 layer를
변경합니다. bottom에 있기 때문에 단축키 “B”를 사용합니다. 다음에 trace들 중의 하나로
마우스포인터를 이동 시킵니다. 그곳에서 드래깅해서 trace를 다른 위치로 옮깁니다.
버튼을 놓음으로서 새로운 위치로 trace가 이동하게 됩니다. Route toolbar의 “Edit Traces”
가 활성화된 것을 볼 수 있습니다. 그러나 이 배선모드에서는 trace가 45도나 90도 각도로
만 이동할 수 있습니다. 

DipTrace는 보더 더 유연한 edit를 가능하게 하는 기능이 있습니다. “Route → Manual
Routing → Free Edit Trace”(Route toolbar의 “Free Edit Traces” )를 선택합니다. 이제 Trace
들을 자유롭게 수정할 수 있습니다.

필요하다면 grid-size를 바꾸도록 합니다. standard toolbar에서 선택하거나 “Ctrl+”와
“Ctrl-” 단축키를 사용할 수 있습니다. 이용 가능한 grid들의 목록을 구성하기 위해서
“View / Customize Grid”를 선택합니다. grid를 감추기 위해서 “F11”키를 사용합니다.

만약 현재 어떤 기능이나 모드에 있는지 모를때는 단지 몇번의 우-클릭을 실행하면 됩니
다. DipTrace는 default 상태(모드)로 돌아가게 될 것입니다.

우리의 간단한 프로젝트는 auto-router를 사용해서 배선이 완료된 최종적인 보드를 얻었
습니다 그러나 보다 더 복잡한 프로젝트에 대해서는 최상의 결과를 얻기 위해서 auto
-routing후 수작업 보정이나, 또는 처음부터 수작업으로 배선하는 것이 필요할 것입니다.
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모든 route된 net은 trace와 segment로 나눌 수 있습니다. trace는 2개의 Pad를 연결한 net에
대한 배선이고 segment는 두 node 사이의 배선이다. node는 trace를 segment로 나누는
배선상에 존재하는 점이다. DipTrace에서는 현존하는 node들을 이동하거나, 새로운 노드
를 추가하거나, 또는 제거할 수 있습니다. 이것은 trace들을 수정하는 동안에 보다 더
많은 기회를 제공합니다. node를 추가하기 위해서 trace segment 위에서 우-클릭을 합니다
핫키는 “N”입니다.

더이상 필요없는 node가 있다면 그것을 제거할 수 있습니다. Node 위에서 우-클릭하고
팝업메뉴에서 “Delete Node”를 선택합니다. 같은 팝업메뉴에서 네트의 이름과 트레이스
및 세그먼트의 색상, width, layer를 변경할 수 있습니다.
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현존하는 net, trace, segment 역시 다른 layer로 옮길 수 있습니다. 해당 net에서 우-클릭
후에 필요로 하는 기능을 선택하십시오. 이곳에서는 segment의 layer을 변경할 것입니다.
net위의 임의의 segment에서 우-클릭하여 나타나는 팝업메뉴에서 “Segment Layer / Top”
또는 우측의 Net properties 패널의 list box에서 “Segment Layer”를 “Top”으로 선택합니다.

DipTrace는 자동적으로 2개의 trace via를 생성합니다. Ctrl이나 Shift키를 사용해서 같은
net에서, 또는 다른 net에서 다수의 segment들을 선택한 다음 한번에 그들의 속성을 변경
할 수 있다는 것을 기억하시기 바랍니다.
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이제 작업 layer을 top으로 바꾸고 top에 있는 segment에서 우-클릭해서 다시 bottom layer
로 돌려놓고 작업 layer를 bottom으로 변경합니다.

이제 net를 매뉴얼 route할 시간입니다 net 중 하나에서 우-클릭하고 팝업메뉴로부터
“Unroute Net”을 선택합니다. Net 팝업메뉴에서 “Unroute Net”은 모든 선택된 net들에
적용된다. 현재 단지 하나의 net을 선택했기 때문에 선택된 net만이 unroute됩니다.
다음에는 메인메뉴에서 “Route → Manual Routing → Add Trace”(Route toolbar의
“Route Manual”버튼)를 선택합니다.

우측에 Manual Routing 패널이 나타납니다.  Routing전에 Net Classes윈도우(“Route → 
Net Classes...”)에서 net class를 먼저 설정해야 한다는 것에 주의해야 합니다. 우리의 경우
route를 원하는 net이 Default net class에 속해 있습니다. 배선도중에 Manual Routing패널에
있는 list box에서 다른 Net class를 선택할지라도 Default net class로서 route되게 됩니다.
그러나 우리가 다른 net class에 속하는 새로운 net을 생성한다면 그 net은 해당하는 net
class에 따라서 배선되게 될 것입니다.

“Route Mode” drop-down 목록에서 우리가 필요로하는 일련의 segment들을 지정할 수
있습니다. 그래서 우리는 DipTrace에서 이용가능한 모든 segment들의 전체 목록으로부터
가 아니라 한 모드의 segments 목록으로부터 current segment를 쉽게 선택할 수 있습니다.
우리는 또한 자신의 배선모드를 사용자 정의할 수 있습니다.  

우리의 PCB에 대해서는 “Arcs/Curves”모드를 선택합니다. 그런다음 “Currnet Segment
(S)”에서 좌클릭하고 팝업메뉴에서 “3-point Arc”를 선택합니다. unrouted된 net의 pad들
중의 하나에서 좌-클릭하고(이것은 arc의 첫번째 점이 될 것이다) 두 pad 사이에서 좌-
클릭합니다. net의 blue line보다는 더 높아야 합니다(두번째 점)



DipTrace Tutorial52

© 2011 Novarm Ltd.

마지막으로 마우스포인터를 두번째 패드로 이동해서 좌-클릭합니다. 아크가 보이게 될
것입니다.
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PCB를 manual routing하는 동안 우리는 하이라이트되는 network들을 선택할 수 있습니다
만약 현재의 net만을 하이라이트한다면 새로운 trace가 다른 net에 접촉하게 될 때 조차도
다른 net들은 하이라이트 되지 않습니다.
Manual routing을 쉽고 빠르게 할수 있는 단축키들이 있습니다. “M”- routing 모드를 변경,
“S” 또는 “Space”- current segment를 변경, “W”- 트레이스의 width를 설정, “T’- top layer로
전환, “B”- bottom layer로 전환, “L”- segment layer, “J”- switch to jumper wire or back( bottom
layer에 있다면, jumper wire는 top side에, top layer에 있다면 그것은 bottom side에 배치),
“A”- angle step, “H”- highlight net, 숫자키 “1”~“0”- layer 전환(10까지), routing 동안에 “U”
키를 눌러서 Undo할 수 있습니다.
 
이제 PCB layout을 auto-routing직후로 되돌리기 위해 몇번의 undo(Ctrl+Z)를 반복합니다.

2.5.7 Trace 길이 측정하기

현재의 project는 단순하고 low-speed이기 때문에 그런한 측정을 필요로하지 않습니다.
그러나 high-speed의 회로나, video devices, etc등을 만든다면 trace length는 중요한 사항이
됩니다.

각 trace의 hint에는 기본적으로 trace의 길이를 포함합니다. 이것은 도움이될 수 있지만
trace 길이를 실시간으로 체크하는 것은 쉽지 않습니다.

이제 몇개의 trace들을 선택해 보도록 하겠습니다(일반적인 Box 선택을 사용하거나,
원하는 것을 정확히 선택하기 위해서 Ctrl 키를 사용할 수 있습니다) 선택한 trace들 중
하나에서 우-클릭하고 팝업메뉴에서 “Show Trace Length”를 선택합니다.
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이제 모든 선택된 net의 패드들 근처에 trace length가 있는 작은 box들이 보이게 됩니다.
또한 trace위에서 마우스포인터를 움직이는 동안 하이라이트됩니다. 값들은 현재의 units
으로 표시되고(예제에서는 inch) trace를 수정하는 동안 실시간으로 변합니다.
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이제 net 팝업메뉴나 Undo기능을 사용해서 trace 길이를 숨길 수 있습니다.

2.5.8 type/layer에 의한 objects 선택하기

때때로 한 layer의 모든 object들을 선택하거나 또는 단지 component들만, 혹은 net들만을
선택하는 것이 필요합니다. 이것은 간단한 layout에서는 마우스와 Ctrl키를 사용해서 매우
쉽게 할 수 있습니다. 그러나 복잡한 Layout들에 대해서는 쉽지 않은 일입니다. 이제
”Edit → Edit Selection”을 선택합니다.
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먼저 우리는 Layout에 있는 모든 component를 선택할 것입이다. Components의 체크박스
에 체크하고 OK를 클릭합니다. 이것은 간단한 예입니다. 그러나 일반적으로 우리는 더
복잡한 선택들을 필요로 합니다. 이제 정의한 영역에서 연결되어 있지 않은 via만을 선택
하는 방법을 알아 보도록 하겠습니다. 아무것도 없는 곳에서 우-클릭하여 부품들을 선택
해제 합니다. 몇개의 via들을 배치하고 그 중에서 몇개를 net들에 연결합니다(Default모드
에서 via로 이동 후 red로 하이라이트 되었을때 우-클릭하고 팝업메뉴에서 “Add to Net →
“Select By Mouse Pointer”를 선택합니다. 그런다음 연결을 원하는 net에 속해있는 pad에서
좌-클릭합니다). 이제 Box Selection을 사용해서 area을 정의합니다. 이 박스는 via들을
선택하려고 했던 영역을 나타내기 때문에 이 영역에 layout의 모든 비아가 포함되도록
영역을 선택하지는 않을 것입니다. 우리는 blue로 설정되어 있는 bottom layer에 있기때문
에 via들을 연결하는데 어려움이 있다면 작업 layer를 top으로 전환합니다.
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우리가 박스-선택한 영역에 있는 모든 objects들이 선택되었습니다, 그러나 우리는 오직
연결되어 있지 않은 via들만을 선택할 필요가 있습니다. “Edit → Edit Selection”을 선택해
서 “Edit Selection” 윈도우를 오픈합니다. “Mode: Keep Selected”을 선택하고 오직 “Vias”
체크박스만을 체크합니다(다른 체크박스들은 모두 체크해제되어야 합니다) “Vias”의
오른쪽에 있는 combo-box에서 “Not Connected”를 선택합니다.
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“OK”를 클릭하면 연결되어 있지 않은 via들만이 선택되어 있을 것입니다. 다음 단계는
그들을 net에 한번에 연결하는 것입이다. 일반적으로 이것은 ground net을 planes/copper
pours에 연결하기 위해서 필요합니다. via들이 red로 하이라이트되어 있을 때 선택한 via
들 중의 하나에서 우-클릭해서 “Add to Net → Selected Vias”를 선택합니다. 그림과 색이
다른 것은 color scheme에 의한 것이므로 신경 쓸 필요가 없습니다. 나중에 DipTrace의
color scheme을 자유롭게 조정할 수 있는 방법을 보일 것입니다. 
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목록으로부터 임의의 net을 선택하고 OK를 클릭합니다. 일부 via들이 이미 다른 net들에
연결되어 있더라도 오직 연결되어 있지 않은 via들만이 이 기능에 의해서 새롭게 연결
됩니다. 이전의 상태로 되돌리기 위해서 디자인에 있는 모든 static via들을 제거합니다.
(static via들을 선택하고 delete key를 사용합니다)

2.5.9 Graphics와 Text 입력하기 

당신은 보드에 graphics나 텍스트를 추가하고 싶어 할 수 있습니다(DipTrace에서는 BMP
나 또는 Jpeg 형식으로 logo를 넣을 수 있고 Gerber로 export할 수 있습니다.)
이제 우리는 PCB board에 text를 추가할 것입니다. shapes나 text들 그리고 Logo들을 추가
하기 위해서는 먼저 layer를 선택해야 합니다. Drawing toolbar에 있는 “Current Shape and
Text Layer” 선택박스로 마우스포인터를 이동해서 목록으로부터 “Top Silk”를 선택합니다
이제 새롭게 생성되는 모든 graphical object들은 Top Silk layer에 놓이게 됩니다. 
PCB layout 프로그램은 현재의 signal/plane layer를 선택하기 위한 layer의 목록(i.e. Route
toolbar의 “Current Signal/Plane Layer” list)과 graphics를 배치하기 위한 layer를 선택하는
layer의 목록(i.e. Drawing toolbar의 “Current Shape and Text Layer”)을 서로 다르게 가지고
있습니다. 또한 당신이 graphics, 모든 shapes와 texts, 그리고 logos를 넣기위한 layer로서
Signal/Plane을 선택한다면 그것들은 화면의 오른쪽에 나타나는 Place Shape 패널의 설정
에 따라 해당하는 signal이나 plane layer에 배치가 될 것입니다. 이것은 간다하게 오직
하나의 목록만을 생성하는 것보다 더 복잡해 보일 수 있지만 이 기능을 사용해보면
시간을 절약할 수 있다는 것을 알게 됩니다.
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당신은 추가 object를 배치하기 위해서 board outline을 약간 더 크게 만들어야 합니다.
그래서 board outline의 좌측상단 vertex로 마우스포인터를 이동한 다음 그것을 위쪽으로
드래그(drag)합니다. 우측상단 vertex에 대해서도 동일하게 합니다. Board outline에 꼭지점
들을 추가하거나 제거할 수 있다는 것을 기억하시기 바랍니다.
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board outline을 이동시키고 싶다면 마우스포인터를 board outline위로 이동해서 선택하고
그것을 잡아끌기합니다.

만약 어떤 object들이 하이라이트되지 않고 그들을 edit할 수 없다면 아마도 default mode
에 있지 않을 것입니다. 모드를 빠져나가기 위해서 몇번의 우-클릭을 합니다. 또한 현재
활성화 되어 있지 않은 layer에 위치한 object들도 edit될 수 없습니다.

Drawing toolbar에서 “Place Text”를 선택합니다. 텍스트를 위치시키고 싶은 곳에서
좌-클릭하여 텍스트를 입력하고 엔터를 누르거나 마우스 버튼을 클릭합니다.

적절한 위치를 발견할 때까지 마우스를 사용해서 텍스트를 자유롭게 이동시키거나 크기
를 조절할 수 있습니다. 기본설정 font를 바꾸기 원할때는 메인메뉴의 “Objects →
Drawing Properties → Font”를 선택합니다. Font type(Vector, True Type) 역시 거기에서 변경
할 수 있습니다. 직접 gerber로 export되는 것으로서는 Vector font를 사용할 것을 적극
권장합니다. True-type font는 비 영어권 문자들을 위해서 사용될 수 있지만 그것은 작은
선들로서 gerber에 export될 것입니다. 또한 일부 제조사들은 copper layer들에 그러한
텍스트 object들을 받아들이지 않습니다. 이미 배치된 텍스트 object의 font 설정을 변경하
기 위해서는 그 것 위에서 우-클릭하여 “Font”를 선택합니다. font의 크기는 텍스트object
의 크기를 직접 변경함에 의해서도 자동적으로 수정됩니다.
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우리는 보다 더 잘보이도록 텍스트의 색상을 변경할 것입이다. 메인메뉴의 “View → 
Color”에서 top-assy에 대한 새로운 색을 선택하고 OK를 클릭합니다.

언제든지 graphics와 텍스트 object들의 layer를 변경할 수 있습니다. 간단히 object들을
선택하고 우-클릭해서 팝업메뉴로부터 “Properties”를 선택합니다. 선택한 object들을
다른 layer로 이동시키거나 다른속성(“Route Keep out”, “Board Cutout”, etc)을 정의하기
위해서 “Shape Properties” 대화상자에서 “Type”과 “Layer”를 변경합니다.

Mask, paste, signal, route keepout, place keepout, 그리고 board cutout layer에 shape들을 추가
할 수 있습니다. 이런 속성들은 Drawing toolbar에서 정의하거나 또는 silk나 signal/plane
layer에서와 똑같은 방법으로 shape properties를 이용해서 설정할 수 있습니다.

2.5.10 Copper Pour

Bottom layer에 copper pour를 어떻게 추가할 것인가? 간단한 PCB는 copper pour를 필요로
하지 않을 수도 있습니다. 그러나 여기서는 copper pour를 추가하는 방법에 대해서 알아
보도록 하겠습니다. bottom layer를 선택하고 메인메뉴에서 “Objects → Place Copper Pour”
(Elements toolbar의 “Copper Pour”버튼)를 선택합니다. 다음에 외곽을 정의하는 핵심 point
들을 지정함으로서 Copper outline polygon을 배치합니다. 우-클릭하고 Enter를 선택해서
outline을 완성합니다. 이제 다음 대화상자를 보게 될 것입니다.  
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DipTrace는 Shape-based copper pour 시스템을 가지고 있고 non-solid fill도 선택할 수 있습
니다. 대화상자의 Connectivity탭에서 Copper area를 net에 연결할 수 있고 연결에 대한
유형을 선택할 수 있습니다. Border탭에서는 border point들을 정의하고 수정할 수 있습니
다. “Depending on Board”와 “Snap to Board” 체크박스는 copper outline을 자동적으로 생성
함으써 시간을 절약할 수 있는 기능을 제공합니다. 이 기능을 사용하길 원한다면 copper
pour를 배치할 때 단지 임의의 2개의 점만 정의하고 배치를 완료한 다음 대화상자에서
“Depending on Board”를 체크합니다. 그리고 board outline에서 copper outline까지의 거리를
입력합니다(복잡한 board outline이나 arc들을 가지고 있을 때 많은 시간을 절약할 수
있습니다) “Snap to Board”를 체크하면 copper pour border가 board outline이 변경될 경우
그에 따라서 자동적으로 수정되게 됩니다.

Copper Pour를 배치하기 위해서 OK를 클릭합니다.
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Copper Pour object는 fill의 2가지 모드를 가집니다(poured와 unpoured 모드) unpoured모드
는 copper pour가 위치한 layer에서 object들을 수정하기 원할때 보다 더 유용합니다.
Copper pour의 상태(모드)를 변경하기 위해서는 copper outline위에서 우클릭하고 “State”
를 선택해서 서브메뉴로부터 원하는 상태(모드)를 선택합니다.

이제 net 하나를 unroute하기 위해서 trace에서 우-클릭하고 “Unroute Net”을 선택합니다.
Net의 이름을 기억합니다(이 예제에서는 “Net 5”) copper pour border에서 우-클릭하여
“Properties”를 선택합니다. 대화상자에서 “Connectivity”탭을 선택하고 “Connect to Net”
에서 Net 5를 선택합니다. “Hide Net Ratlines”체크박스에 체크하고, “Thermals”를 Direct로
선택한다음 copper pour를 update하기 위해서 OK를 클릭합니다. 
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이제 선택한 thermal 유형으로 copper pour가 Net 5에 연결되었고 Net 5의 connection들은
감추어진 것을 볼 수 있습니다. 때때로 SMD 패드들에는 별도의 thermal 타입을 필요로
할 때가 있습니다. 이것은 “Separate Thermals for SMD”체크박스에 체크하거나 원하는
패드에 자신의 고유 thermal 설정을 지정함으로써 가능합니다. 일부 패드들에 별도의
thermal 유형을 지정하기 위해서는 패드에서 우-클릭하여 “Thermal Settings”를
선택합니다. 그런다음 “Use Copper Pour Settings”을 uncheck하고 적절한 thermal 유형을
선택합니다.

일부 패드들은 선택된 thermal 유형과 layout의 구조때문에 copper pour를 배치한 후에
연결이 끊어질 수도 있다는 것에 주의해야 합니다(이것은 net connectivity check에서
report될 것입니다)
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그림과 같이 thermal 설정들을 변경한 후에 OK를 클릭합니다. copper pour border에서
우-클릭 후에 팝업메뉴에서 “Update”를 선택합니다. “Net 5”는 copper pour에 의해 
연결되어 있습니다. 패드에 다른 thermal 유형들을 적용해서 이것이 어떻게 작동하는지
알수 있도록 시도 해 보십시오.
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위의 그림에서 당신은 다른 thermal 유형(Direct, 4 Spoke, 2 Spoke)의 연결을 가지는 세개
의 pad들을 볼 수 있습니다.

Copper pours은 ground와 power planes을 만들기 위해서 plane layer에 사용될 수 있습니다.
이러한 경우에 SMD via들은 fanouts에 의해서 연결될 수 있습니다.  Fanout은 “Fanout”
기능을 이용하여 수작업으로 만들 수 있고, Shape Router에 의해서 자동적으로 만들어 질
수 있습니다. active layer가 “Top”이라면, top, top silk 또는 top assy layer에 있는 object들을
보고 수정할 수 있다는 것에 유의합니다. 이제 signal layer를 top으로 전환합니다. 

2.5.11 Objects 잠그기

Shematic이나 PCB를 수정할 때 당신은 그들의 위치나 속성이 더이상 변경되지 않도록
일부의 object들을 잠그는 기능을 필요로 할 수 있습니다. DipTrace 역시 선택한 Object나
Component들을 잠글 수 있는 기능을 제공합니다. 이제 몇개의 디자인 object들을 선택하
고 그들 중의 하나에서 우-클릭하여 팝업메뉴로부터 “Lock Selected”를 선택합니다.
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Locked objects는 선택상자에서 low contrast로 표시됩니다(색이 copper pour와 유사하기
때문에 active layer만을 보이도록 했습니다) Locked object의 hint에는 “Locked”라는
텍스트를 포함하게 됩니다.
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Locked object는 이동이나 크기조정 및 수정이 불가능합니다. 이제 모든 object들을 잠금
해제하도록 합니다. Ctrl+a로 모든 것을 선택합니다. 그리고 모두 unlock합니다(Edit →
Unlock 또는 Ctrl+Alt+L)

Top이나 bottom에 있는 component만을 lock할 수 있습니다. “Edit → Lock componets → 
Top”을 선택해서 top component들을 lock합니다. 이 기능을 사용해서 일부 component들이
우발적으로 이동되는 것을 걱정할 필요없이 보드를 배선할 수 있습니다. Top layer에
있는 component들을 unlock할 때는 “Edit → Lock Compoents → Top”을 다시 선택합니다.

2.5.12 Design 검증하기

DipTrace는 메인메뉴의 verification에 디자인 검증을 위한 몇가지의 기능을 가지고 있습
니다. 보드의 제대로 된 검증을 위해서 DRC와 Net connectivity check, 그리고 Comparing
PCB to Schematic 기능을 사용할 것을 권장합니다.

DRC (Design Rules Check) 기능은 object들과 허용가능한 크기들 사이에서 거리를 체크하
도록 하는 가장 중요한 기능들 중의 하나입니다. 튜토리얼의 PCB는 매우 단순하기
때문에 errors을 가지지 않을 것입니다. 전체 디자인을 검증하기 위해서 Route toolbar에서
DRC버튼을 선택하거나 메인메뉴에서 “Verification → Check Design Rules”를 선택합니다. 
Error 목록이나 또는 “No Errors Found” 메시지가 보이게 될 것입니다. 이제 DRC 설정을
위해서 “Verification → Design Rules”를 선택합니다. Design Rules 대화상자에서 board에
대한 object to object clearances를 설정할 수 있습니다. “All Layers” 체크상자를 uncheck
하면 체크박스 아래에 있는 목록으로부터 layer들을 선택할 수 있고 각각의 layer에 다른
clearances을 설정할 수 있습니다. 사용자 정의 net class clearance(Net Classes 대화상자에서
“Use Clearance in DRC”를 선택)나 Class to Class 설정들이 정의되어 있는 net들은
Design Rules대화상자에서 정의된 설정을 적용받지 않습니다. 
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우리는 Class to Class Rules와 Copper pours를 체크 할 것입니다. 해당하는 체크박스에
체크하고 OK를 눌러서 변경사항을 적용합니다.

이제 DRC가 어떻게 작동하는지 알아 보도록 하겠습니다. 예전에 우리는 PCB에 copper
pour를 만들었습니다. active되어 있는 layer를 체크합니다. bottom layer에 copper pour를
가지고 있기 때문에 단축키 “B”를 눌러서 active layer를 bottom으로 전환합니다. 또한
“F11”을 사용해서 grid를 off상태로 변경합니다. error를 만들기 위해서 일부의 trace가 
copper pour에 닿도록 수정합니다. 이제 “Verification → Check Design Rules”(단축키“F9”)
를 사용해서 DRC를 실행합니다. 에러 목록이 있는 윈도우가 팝업될 것입니다.

이 윈도우의 드롭다운 목록을 이용하여 선택한 layer에 해당하는 errors만 보이도록 할 수
있습니다.
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Errors중의 하나에서 좌-클릭하고 “Localize” 버튼을 클릭하면 해당하는 에러 위치로 이
동해서 화면의 중앙에 보여주게 됩니다. 우리는 간단한 보드를 가지고 있기 때문에
error report 윈도우를 닫지 않고 잘못된 사항을 수정(trace를 원상복귀)한 다음 다시 “Run
DRC”를 클릭합니다. 이번에는 에러가 없을 것이기 때문에 “No Errors Found” 메시지가
표시되게 됩니다.

당신이 고해상도의 화면을 사용할 수도 있기 때문에 에러 report윈도우는 위의 그림보다
훨씬 작게 보일수도 있을 것입니다. 우리는 의도적으로 모든 버튼들이 보다 더 잘보이게
하기위해서 저해상도를 사용했습니다.

Net connectivity check는 모든 net들이 올바르게 연결되었는지 확인합니다. 간단한 디자인
의 경우 그것은 별로 중요하지 않습니다. 그러나 많은 layers, pins, copper pours, 그리고
shape들로 이루어진 규모가 큰 design이라면 net connectivity를 체크하는 것은 아주 중요
하게 됩니다. net가 제대로 연결되지 않았거나 또는 병합된 경우에는 그에 해당하는
error 목록을 보여 주게 될 것입니다.

“Verification → Check Net Connectivity”를 선택하고 OK를 클릭합니다. 아마도 대부분
디자인은 connectivity errors를 가지지 않을 것이고 당신은 “No Error Found”메시지를 
보게 될 것입니다.

Compare to Schematic은 PCB 프로젝트가 해당하는 회로도 파일과 일치하는 지를
검사하게 됩니다. net structure 에러와 unknown component들을 알려줄 것입니다. 
“Verification → Compare to Schematic”을 선택하고 해당하는 schematic 파일을 선택한다음
OK를 클릭합니다. 당신의 net structure가 변경되지 않았고 에러가 없다면 “No Errors
Found” 메시지를 보게 될 것이며 그렇지 않다면 error들의 목록을 보게 될 것입니다.
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Net connectivity check와 Compare to Schematic은 DRC와 똑같은 방식으로 작동합니다.
결과 윈도우에서 errors를 선택하여  하이라이트 시킬 수 있습니다.

2.5.13 Design에 대한 정보

디자인한 보드의 pin 수와 area(크기)는 어떻게 알 수 있을까? 그러면 메인메뉴의 “File → 
Design Information”을 선택합니다.

또한 그것은 모든 drill/hole 크기들을 표시하고 디자인 영역에서 그들을 보는 것이 가능
하게 합니다. 이것은 드릴 table을 최적화 시키고 일부 홀들(sizes)을 제거하고 싶을때
유용합니다.

Design Information 대화상자에서 당신은 서로 다른 objects, layers, board size 그리고 hole
크기와 갯수등을 프리뷰할 수 있습니다. “Holes by Size” 윈도우를 열기 위해서 우측 밑의
“...”버튼을 클릭합니다. 보드에서 해당하는 hole들을 하이라이트 시키기 위해서 “Show
on Board”버튼을 클릭합니다.
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이제 이 대화상자를 닫고 디자인으로부터 copper pour를 삭제합니다. 그리고 수작업으로
“Net 1”을 배선하거나 또는 auto-router(F9)를 실행합니다. 또한 패드에서 우-클릭 한 후
“Route Net”을 선택함으로써 그 net을 자동적으로 배선하는 것이 가능합니다. 

2.5.14 Panelizing

DipTrace를 사용하여 당신은 단일 layout에 서로 유사하거나 다른 PCB들을 panelize할 수 
있습니다.

동일한 PCB에 대해서 다수의 복사가 필요하다면 메인메뉴에서 “Edit → Panelizing”을
선택합니다.
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우리는 PCB의 사본 4개를 만들 것입니다. i.e.) 2 columns and 2 rows. Boards 사이의 간격은
zero로 할 것입니다. “Rail Edges”는 boards와 panel border사이의 거리를 의미합니다. 
일반적으로 그것은 필요하지 않지만 대략적인 panel의 크기를 결정하는데 도움을 줄 수
있습니다. 모든 면들에 대해서 우리의 rail edges는 0.1 inch로 정합니다. 일부 제조사 들은
board outline layer에 panel border를 요구할 수도 있습니다. 그래서 “Show Panel Border”에 
체크합니다. “OK”를 클릭하면 다음 그림과 같은 화면을 보게 될 것입니다.
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디자인 영역에서 우리는 단지 “Copy #”텍스트가 있는 box들만을 보게 되지만 프린트-
프리뷰나 인쇄, 또는 Gerber/DXF/Drill등의 내보내기 할 때는 완벽한 보드의 복사본이
그곳에 삽입되게 될 것입니다.

Panelizing에 일부 object(holes또는 shapes, etc.)를 제외 시키는 것이 가능합니다. 
Panelizing에서 object를 제외시키기 위해서는 해당 object에서 우-클릭하고 “Do Not 
Panelize” 항목을 체크합니다. 이 항목은 panelizing이 on되어 있을 때에만 선택이
가능합니다.
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Panelized board를 보려면 print preview(메인메뉴의 “File → Preview”, Standard toolbar의
“Preview”버튼)를 사용합니다. panelizing은 반드시 PCB가 board outline을 가지고 있을
때에만 가능하다는 것에 주의 합십시오. panelizing대화상자를 열고 column과 row의 수를
1로 변경합니다.(이것은 사본들을 제거하게 됩니다)

서로 다른 PCB끼리의 panelizing은 다음과 같이 할 수 있습니다.

먼저 메인메뉴에서 “Edit → Keep RefDes while Pasting”을 체크합니다. 다음에는 PCB 
Layout에서 “Ctrl+A”로 모든 object들을 선택합니다.(예제에서는 튜토리얼에서 사용하는
layout을 선택하지만 다른 어떤 layout이라도 사용할 수 있습니다) “Ctrl+C”로 복사하고
원하는 영역에서 우-클릭하여 “Paste”합니다.(붙여넣기 하는 마우스포인터의 위치는
두번째 layout의 가장 왼쪽 꼭대기가 될 것입니다.)
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이제 같은 방법으로 PCB의 다른 복사본을 얻습니다. Reference Designator들은 변경되지
않았습니다. 아마도 공통의 board outline을 만들어야 할 것이고 board cutout의 shape들을
배치하게 될 수도 있습니다.

“Keep RefDes while Pasting”항목이 체크된다면 pin limitations(Free, Lite, Standard, etc)
가 복사본들에 대해서는 적용되지 않습니다. 그래서 당신은 무료버전으로 몇개의 250pin
layout들을 쉽게 panelize할 수 있습니다. 또한 취미나 교육목적의 비영리적 사용에
대해서는 500-pin 제한의 lite edition을 무료로 얻을 수 있습니다.

2.5.15 인쇄하기

PCB를 인쇄하기 위해서는 print의 preview대화상자를 이용할 것을 권장합니다.
대화상자를 열기위해서 메인메뉴로부터 “File → Preview”나, 화면에서 좌측상단의
Standard toolbar에 있는 “Preview”버튼을 클릭합니다. 아직 titles을 만드는 것을 설명하지
않았습니다. titles을 표시하기 원한다면 메인메뉴에서 “File → Titles And Sheet”를 선택한
다음 “Sheet Template’박스에서 “ANSI A”를 선택하고 “Display Titles”를 체크합니다.
이제 대화상자를 닫고 프린트의 “Preview” 윈도우를 오픈합니다. 

"Preview"대화상자에서 “Objects” 그룹에 있는 체크박스들을 적절하게 설정하여 사용자-
정의할 수 있습니다. printing scale을 변경하고 싶다면 “Print Scale”박스를 사용합니다.
또는 바로 아래에 있는 “Zoom In”, “Zoom Out” 버튼들을 클릭합니다. Sheet내애서 PCB를
옮기기 위해서는 “Move Board”버튼을 선택하고 PCB를 이동합니다. 좌측상단에서는 
Signal/Plane layer를 선택할 수 있고 layers보이는 유형을 선택할 수 있습니다. Mirrored된
PCB and/or text를 얻기를 원한다면 “Mirror”를 체크하고 and/or “Flip Text”박스를 선택합
니다(만약 “View / Flip Text Automatically” 옵션이 on이라면 “Flip Text”박스는 disable상태
가 됩니다.)
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인쇄하기위해서 “Print”버튼을 클릭합니다. BMP나 JPEG로 image를 저장하기 위해서는
“Save”를 선택합니다. “Zoom Out” tool 왼쪽에 색들이 있는 작은 버튼은 각각의 object
를 어떤 색으로 인쇄할 것인지 사용자-정의하는 것이 가능하도록 합니다. 기본설정으로
는 “White Background” scheme이 인쇄를 위해서 사용됩니다. 또한 layer color들은 그들이
Default color를가진다면 color scheme에 의존합니다. 그렇지 않다면 그들은 “Route →
Layer Setup”에서 정의된 color에 따라서 인쇄가 됩니다. Layer의 color들을 변경함이 없이
모두 black으로 인쇄하기 위해서는 “Print in Black Only”에 체크합니다.

Hobbyists을 위한 주의사항: laser paper는 열의 expansion때문에 dimensional distortion의
Some degree를 가져온다는 사실에 유의하라 그것은 전적으로 당신의 laser printer와 종이
의 품질에 의존한다. 많은 사람들에 대해서 그것은 의미가 없을 수도 있다. 그러나 몇몇
에 대해서는 중요하다. 그것에 대처하기 위해서는 실재 인쇄함이 없이 laser printer를
동작시킴으로써 레이저 프린터에서 종이지 preheat시키는 것이다.(단지 dot를 print할 수
있다)  Ink-jet에 대해서는 종이에 열이 전달되지 않기 때문에 해당되지 않는다. 레이저
프린터가 항상 눈에 보일 정도로 이미지를 distort시키지는 않지만 대비를 해 두어야 한다.

이것을 보정하기 위해서 print preview대화상자에서 “Calibration”기능을 사용한다. 요약해
서 집에서 PCB를 만들기 위한 2가지 방법이 있다.: TT(Toner Tansfer)나 UV exposur를 사
용하는 것이다. TT는 laser printer를 위한 방법이고 UV exposure는 ink-jet 프린터에 보다
더 적합하다.

“Print Preview”대화상자를 닫고 두번째 PCB를 제거하고 Copper pour를 회복하기 위해서
몇번의 undo를 반복한다.(또한 만약 당신이 그것을 인쇄하기 원하지 않는다면 단순히
Copper pour를 unpour할 수 있다는 것에 주지하라)
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2.6 Manufacturing Output

2.6.1 DXF Output

DXF 파일들을 불러오기 할 수 있는 많은 CAD, CAM프로그램에 당신의 디자인을 Export
하기 위해서 DXF output 기능을 사용할 수 있습니다. 만약 DipTrace를 사용하기전에 PCB
디자인을 위해서 AutoCad를 사용했다면 설계중의 일부를 수정하기 위해서 AutoCad의
사용을 원할 수 있습니다. 또한 DXF export기능은 milling을 위해서 자동적으로 edge를 
생성하는 것을 허용합니다. 그러한 edge는 무료인 ACE Converter를 사용해서 DXF로부터
G-Code로 변환 할 수 있습니다.(웹사이트에서 그것을 다운로드 할 수 있습니다)

이 예제에서 우리는 다른 PCB를 사용할 것입니다. 그러나 예전에 사용했던 것과 매우
유사하기 때문에 당황하지 말고 설명하는 대로 단계들을 따라서 하도록 합니다.
출력하는 과정은 매우 비슷합니다.

메인메뉴에서 “File → Export → DXF”를 선택합니다. “Export DXF”대화상자에서
“Select All”을 클릭합니다. 디자인의 모든 layer들이 선택될 것입니다. “Edge_Top”과
“Edge_Bottom”은 디자인의 layer가 아니라는 것에 주의합니다. Ctrl키를 누른 상태로
클릭함으로써 그들을 선택하는 것이 가능하지만 지금은 이러한 layer들은 사용하지
않습니다. 원한다면 object들을 show/hide하거나, 디자인을 mirror하거나, 또는 텍스트를
flip할 수 있는 다양한 선택옵션들을 사용할 수 있습니다. 
“Export”를 클릭하여 파일을 저장합니다.

이제 당신은 AutoCad로 그것을 열수 있고, 다른 프로그램을 사용해서 AutoCad의 DXF
불러오기를 이용할 수 있습니다.

Milling을 사용해서 PCB를 제작하는 것에 대해서 어떻게 생각합니까? 이것은 복잡하지
않은 PCB를 편리하고 저렴하게 만들 수 있는 방법입니다. DipTrace로 이것을 할 수 있는
방법을 알아보도록 하겠습니다. Milling을 위해서 edge을 내보내기할 때 copper pour들은
고려되지 않습니다. 그러나 thermal들은 아마도 고려되어 질 것입니다.
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Copper pour를 삭제하고 메인메뉴에서 “File → Export → DXF”를 선택합니다. 
PCB의 모든 trace들이 bottom layer에 있기 때문에 대화상자에서 “Edge_Bottom”을 선택
하고, 디자인을 mirror하기 위해서 “Mirror”에 체크합니다. 이제 “Edge Width”를 정의합니
다. milling의 중심선은 디자인 object들로부터 “edge width”/2의 간격으로 있게 될 것입니
다. 그리고 the depth of milling은 edge width와 instrument angle들에 의존합니다.
“Export”버튼을 누르고 DXF 파일을 저장합니다.

결과를 보기 위해서 AutoCad나, 다른 프로그램을 사용해서 파일을 열어 보도록 합니다.
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DipTrace로부터 내보내기된 edge는 defined width를 가진 polyline들의 집합입니다.
DipTrace에서 내보내기를 실행하기전에 먼저 디자인을 검사하십시오. 만약 object와
object간의 거리가 edge width보다 더 작다면 당신이 그것을 수정할 수 있도록 경고사항
과 error들을 알려 줄 것입니다.

CAD프로그램들은 일반적으로 날카로운 각이 있는 polylines들을 보여 줍니다. 그리고
이것은 때때로 CAD프로그램에서 어떤 문제들을 발생시킬 수도 있습니다. 그러나
PCB를 mill하거나 CAM프로그램으로 milling을 시뮬레이트할 때 거기에는 instrument의
반경때문에 어떠한 문제도 나타나지 않을 것입니다.

이제 당신의 edge를 ACE converter를 사용해서 DXF로부터 G-Code로 변환합니다.

Copper pour를 복구하기 위해서 몇번의 Undo를 실행하고 copper pour를 업데이트합니다.

2.6.2 Gerber 출력

메인메뉴에서 “File → Export → Gerber”를 선택합니다. “Export Gerber”대화상자에서
layer들을 선택하고(필요하다면 다중선택을 위해서 “Ctrl”과 “Shift”를 사용.), 박스에 체크
해서 내보내기할 object들을 선택합니다. 다음에 “Preview”를 클릭합니다. layer들은 각각
분리되어 export되어야 한다는 것에 주의하기 바랍니다.(파일당 하나의 layer)

1. Top Assy – 이것은 조립layer입니다. 모든 shapes/texts와 메인메뉴의 “View → Assembly
Layers”의 서브메뉴에서 정의된 object들이 배치됩니다. 우리의 PCB에서는 preview할 때
이 layer에 아무것도 포함하지 않습니다.(“View → Assembly Layers”가 default 설정)

2. Top Silk – 이 layer는 패턴의 shapes/texts와 Top Silk layer에 배치된 shapes/text들이 포함
됩니다. 설정의 변경없이 “Preview”를 클릭합니다. 텍스트가 TrueType fonts로 지정되어
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있고 화면에 나타나지 않거나 불완전하게 표시된다면(font와 그 크기에 의존), 당신은 
“Recognize Accuracy”값을 약간 더 작게 만들 필요가 있습니다.(허용 가능한 가장
작은 값으로는 설정하지 마십시오)

3. Top Mask – 이것은 solder mask layer입니다. 패드들과 그들의 설정, gerber 대화상자에서
정의된 공통의 “Solder Mask Swell”, solder mask layer에 배치된 shapes등을 바탕으로
자동적으로 생성됩니다. 일반적으로 solder mask로 덮이기 때문에, 여기서는 우리가
“Vias”박스를 uncheck한다고 가정합니다. 패드의 custom solder mask 설정을 위해서는
패드에서 우-클릭하고 팝업메뉴의 “Mask / Paste Settings”을 선택합니다.

4. Top Paste – 이 layer는 일반적으로 SMT 패드들만을 위해서 사용됩니다. 그래서 우리는 
“Paste Mask for SMT Pads only”에 체크합니다.

6. Bottom Paste – Bottom Assy, 기본설정으로서 bottom layer에 있는 모든 텍스트 object들은
Flip됩니다(“View → Flip Text Automatically”에서 선택), 그러나 만약 그것이 off상태라면
당신이 원하는 layer에 수작업으로 텍스트를 flip할 수 있습니다(“Flip Text” box).

7. Board Outline – board outline은 단지 정의된 폭을 가진 board outline만을 포함합니다.
Board layer는 채워진 폴리곤으로 board를 포함합니다.

5. Signal layers(Top, Bottom, etc) – 이것은 copper layer입니다. 모든 signal layer의 “Vias”
박스에 체크하고 layer들이 제대로 표시되는지 preview합니다. 또한 당신이 drill holes을
수작업 할 계획이라면 “Pad/Via Holes”박스를 체크할 수 있습니다. 그러나 이 옵션은
파일들을 제조사에 보낸다면 권장하지 않습니다. “Pad/Via Holes”박스가 체크되어 있는
경우에 through pad와 via가 있다면 각 signal layer에 대해서 2개의 layer들이 생성되게 될
것입이다.(drawing and clearing) 두번째 layer는 artefacts를 제거하기 위해서 사용됩니다.
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이제 목록에서 “Bottom” layer를 선택하고 그것을 보기 위해서 “Preview”를 클릭합니다. 
Zoom in과 out을 사용할 수 있습니다. “Close”버튼을 클릭합니다.
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DXF와 Gerber, N/C drill 그리고 “Pick and Place” 내보내기에 있는 offset은 board의 디자인
원점과 직교좌표로 표시가 되어있는 preview 원점과의 거리를 나타냅니다. Gerber export
윈도우에서 해당하는 박스를 체크함으로써 디자인 원점을 사용할 수 있습니다.

Gerber export대화상자에서 “Export All”버튼을 클릭하고 gerber파일들을 저장합니다.
파일의 확장자는 gerber 대화상자에서 정의하거나 파일들을 저장하는 동안 직접 입력할
수 있습니다. 또한 원하는 layer만을 선택해서 gerber로 내보내기할 수 있습니다. layer를
선택하고(다수의 layer를 동시에 선택하는 것도 가능) export되는 파일에 포함되기를
원하는 object들을 체크한 후 “Export”버튼을 클릭합니다. 이제 이 파일들을 제조사에
보낼 수 있습니다.

DipTrace에서 drill symbols을 내보내기하는 것 역시 가능합니다. “Export Gerber” 윈도우에
서 “Drill symbols”을 체크하고 “Set Symbols”버튼을 클릭합니다. 팝업 윈도우에서 우측에
있는 드릴심볼 목록으로부터 각각의 hole에 대해서 자동으로 또는 수작업으로 심볼을
할당할 수 있습니다. 여기서는 “Auto” 버튼을 클릭합니다. 그러면 각 hole은 자동적으로
자신의 symbol을 얻게 될 것입니다. “Close”버튼을 클릭합니다.
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DipTrace에 있는 via들은 layer에 쌍으로 내보내기 됩니다(i.e. via를 포함하는 top과 bottom
layers) 그림에는 3개의 signal(plane) layer들이 선택되어 있습니다. 이것은 오직 through-
hole via들만이 내보내기가 될 것입니다. 만약 당신이 Blind/Buried via들을 내보내기 할
필요가 있다면 당신은 오직 그 via들을 포함하는 layer들만을 선택해야 합니다. 그러나
지금 이것을 할 필요는 없습니다.

이제 “Add Comments”에 체크하고 “Preview”버튼을 클릭합니다. hole들에 대한 설명이
있는 드릴심볼과 테이블을 보게 될 것입니다.
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Preview윈도우를 닫고 Drill Symbols와 함께 파일을 저장하기 위해서 “Export” 버튼을 
클릭합니다. Drill symbols는 layer처럼 별도의 파일로 내보내기가 될 것입니다. 만약
aperture들이 사전에 정의되어 있지 않다면, DipTrace는 그들을 자동적으로 설정할 것인지
당신에게 물어올 것입니다. 이제 Drill Symbols를 파일을 저장합니다.

만약 “Drill Symbols”박스를 체크하고 silk, assy, signal layers, etc등을 내보내기하려 한다면
blank 파일이나 아무것도 없는 프리뷰를 얻을 수 있다는 사실에 주의하십시오.

DipTrace는 임의의 텍스트와 폰트, 그리고 raster의 black과 white 이미지(company logo, etc)
들을 gerber에 export하는 것이 가능합니다. 그러나 그런 object들에 대해서 “Recognize
Accuracy”을 정의해야 합니다(3 mil이 기본설정입니다, 최하 0.5mil까지)

파일들을 제조업체로 보내기전에 third-party viewer로 검사하는 것은 좋은 습관입니다.
가장 좋은 viewer는 제조업체에서 사용하는 것과 같은 소프트웨어입니다(또는 그
software에 기반한 무료 viewer) 일부 프로그램들은 공식적인 RS-274X 명세서와는 약간
다르게 gerber를 읽을 수 있기 때문에 주의해야 합니다.

우리는 DipTrace의 Gerber export기능을 다른 소프트웨어들의 특징들도 고려해서 디자인
했지만 어쨌든 파일들을 확인하는 것을 적극 권장합니다.

제조사에서 사용하는 소프트웨어가 무엇인지 모른다면 우리는 RS-274X의 명세서에
엄격하게 준수하는 뷰어로서 pentalogix의 Viewmate를 권장합니다.
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2.6.3 Create NC Drill file for CNC machine drilling

현재의 디자인을 N/C Drill 형식으로 내보내기 위해서는 “File → Export → N/C Drill”을
선택합니다. 다음에는 Tools을 정의하기 위해서 “Auto”버튼을 누르고 “Export”를 클릭합
니다. through-hole들에 대해서는 모든 layer에서 선택되야 하고 Blind/Buried에 대해서는
홀이 위치한 한쌍의 layer만을 선택해야 합니다. “Export All”버튼을 클릭하면 DipTrace는
알아서 자동적으로 모든 layer 쌍들을 저장하게 됩니다.

우리의 경우에는 Blind/Buried hole들은 top과 Tutorial layer사이 또는 Tutorial layer와 
bottom layer 사이에 만들어 질 수 있습니다. 그러나 우리는 blind hole을 필요로 하지 않습
니다. 그러므로 모든 layer들이 선택됩니다. 결과를 보기위해서 “Preview”버튼을 클릭.

축하합니다! 당신은 Diptrace로 간단한 프로젝트 디자인을 끝마쳤습니다.

당신의 Schematic과 PCB파일들을 저장합니다. 우리는 이 튜토리얼에서 앞으로도 계속
그들을 사용할 것입니다. 

P.S. 만약 2개 이상의 layer가 있는 PCB를 route할 계획이라면, auto-router의 설정을 위한
대화박스에서 “Use Priority Layer Directions”박스를 uncheck하는 것을 잊지 마십시오.
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3 Libraries 생성하기

튜토리얼의 이부분은 Component와 Pattern Editors을 사용해서 component와 pattern을 생
성하는 방법을 가르치게 될 것입니다. Libraries은 design house에서는 매우 중요합니다.
그래서 신중하게 다루어지고 백업을 합니다. 당신 자신의 library들을 안전하게 관리하기
위해서 다수의 장소에 저장(backup)할 것을 권장합니다.

3.1 Pattern library 디자인하기

Pattern Editor를 실행합니다(i.e. start → All Programs → DipTrace → Pattern Editor.)

3.1.1 Customizing Pattern Editor

Pattern Editor를 연 후에 당신은 원점과 X, Y축을 보고 싶을 수도 있습니다. 메인메뉴에서
“View → Display Origin”을 선택하거나 “F1”키를 누릅니다. 패턴을 설계하는 동안
언제든지 원점의 위치를 바꿀수 있다는 것을 기억하십시오.

디자인 영역의 위쪽에 있는 것은 “Pattern Properties” 패널입이다. 그것을 사용해서 패턴의
속성과 타입에 의한, 또는 template들로부터 패턴을 디자인할 수 있습니다. 패턴을 디자인
할 때 패널을 감추거나 최소화를 원할 수도 있습니다. 패널의 최소화는 좌측상단의 코너
에 있는 화살표 버튼을 클릭하고 패널을 닫기위해서는 우측상단에 있는 “X”버튼을
클릭합니다. 다시 보기위해서는 메인메뉴의 “View → Pattern Properties”를 선택합니다.

Component와 pattern editors에서 zooin in과 zoom out은 “+”와 “-” 또는 마우스wheel을
사용합니다. 또한 Standard toolbar의 scale box에서 원하는 scale을 입력할 수 있습니다.



Creating Libraries 89

© 2011 Novarm Ltd.

3.1.2 Resistor (pattern) 디자인하기

이제 당신 library의 첫 패턴을 디자인하게 될 것입이다(400mils lead간격의 resistor)

먼저 resistor의 이름과 descriptor를 정의합니다. Pattern Properties패널의 Name에 “RES 400
”을 입력하고 RefDes에 “R”을 입력합니다. Pattern Editor와 Component Editor에서
당신은 베이스 RefDes를 정의하게 됩니다(i.e. 우리의 경우 resistor를 배치할 때 RefDes는
R1, R2, R3, etc.가 될 것입니다). 만약 RefDes가 지정되지 않는다면 프로그램은
components나 pattern들을 배치할 때 자동적으로 “U”로 할당합니다.

주의: 첫 패턴에 대해서 우리는 “Free”타입을 사용할 것입니다. 그러나 실제로는 “Lines”
타입을 사용하는 것이 더 빠릅니다. 이제 밑의 다른 패턴들로 이것을 하기위한 방법을
알아보겠습니다.

"Pattern Properties"패널을 최소화합니다. Objects toolbar에서 “Place Pad”를 선택합니다.
첫 패드를 배치시킬 위치로 마우스포인터를 이동하고 좌-클릭을 합니다. 또 다른 하나를
배치하기 위해서 두번째 패드의 위치로 마우스포인터를 이동하고 좌-클릭합니다.
그런다음 배치모드를 끝내기 위해서 우-클릭합니다.
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위와 같은 방법은 정밀한 배치방법이 아닙니다, 그래서 위치를 확인해야 할 것이고
아마도 패드의 좌표를 수정해야 할 수도 있습니다.(위의 그림에서 볼수 있듯이 300
spacing으로 패드들이 배치되었지만 원하는 것은 400입니다) object의 좌표를 변경하기
위한 몇개의 방법이 있습니다. 또한 drag and drop을 이용할 수 있습니다. 먼저 메인메뉴
에서 “Objects → Place Dimension → Horizontal”을 선택하거나 툴바의 “Place Dimension →
Horizontal”을 선택합니다. 첫패드의 중앙에서 좌-클릭을 하고 두번째 패드의 중앙에서
좌-클릭합니다. Dimension을 배치하기 위해서 마우스를 약간 위로 이동 후 좌-클릭합니다. 
마우스포인터가 그들의 위로 이동했을 때 object들의 핵심 points이 하이라이트 됩니다.
배치된 dimension은 그러한 핵심 points에 연결될 것이고 object들을 이동 및 크기조정할
때 자동적으로 다시 연결 될 것입니다.



Creating Libraries 91

© 2011 Novarm Ltd.

dimension역시 그것 위에서 우-클릭한다음 팝업메뉴에서 Properties를 선택함으로서
dimension의 속성(Layer, Units, Arrow Size)을 변경할 수 있습니다.

이제 우리는 “Layer Objects”패널을 사용할 것입니다. 화면의 우측에서 당신은 layer들을
볼 수 있을 것입니다. 그들은 단지 editing을 위한 논리적인 layers(signal이나 silk layers가
아닌)입니다. “Layer 0”로 마우스포인터를 이동해서 왼쪽 버튼을 누른 상태로 마우스
포인터를 “Layer 1”으로 이동하고 마우스 버튼을 놓습니다. 메인메뉴의 “Layer →
Merge Layers”(또는 Layers패널의 “Merge Layers”버튼)를 선택합니다. 각각 1개의 패드를
가진 2개의 layer가 1개로 합쳐지면서 2개의 패드를 가지게 되었습니다. “Layer Objects”
대화상자를 열기 위해서 “Layer 0”에서 더블클릭합니다.

부정확한 좌표가 있는 패드를 선택하고 패드들 사이의 거리를 400 mils만들기 위해서
X를 변경합니다. “Close”버튼을 클릭해서 대화상자를 닫습니다..
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Dimension object가 자동적으로 재-계산되고 이제 정확한 값이 표시되는 것을 볼 수
있습니다.

패드의 설정들을 변경하고 싶을 수 있습니다(i.e. shape, size, hole그리고 diameter, SMD
또는 Through hole type, etc) 패턴은 그에 속한 모든 패드들에 적용할 수 있는 디폴트에
의한 패드 설정을 가집니다. 또한 각 패드는 자신만의 고유설정을 가질 수 있습니다.
패턴의 기본설정을 변경하기 위해서 메인메뉴에서 “Pattern → Pad Properties”를 선택합
니다. “Pad Properties”대화상자에서 원하는 패드의 모양을 바꿀수 있습니다(Ellipse, Oval,
Rectangle 또는 Polygon - “Points...”버튼을 클릭하여 설정) 또한 “Through” 패드를 위해서
직경을 정의함으로서 round나 oval hole을 추가할 수 있습니다. Template 역시 이용할 수 
있습니다. template들을 생성하기 위해서 “...>>”을 클릭하면 template manager가 open됩니
다. 이곳에서 만드는 모든 template들은 Pattern Editor와 PCB Layout의 다른 대화상자에서
패드설정의 빠른 변경을 위해서 사용될 수 있습니다.
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"Templates"를 닫고 shape는 “Rectangle", width는 "0.08", 그리고 Type은 “Surface”로 지정
하고 변경사항을 적용하기 위해서 OK를 클릭합니다.
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Surface 패드는 side를 바꿀 수 있다는 것에 주의하십시오. 만약 bottom side로 패드를 배치
하면 component가 bottom side에 배치될 때 그 패드는 top에 있게 됩니다 패드의 side를
변경하기 위해서는 패드를 선택하여 우-클릭하고 “Change Side”를 선택합니다. 새로운
패드와 shape들을 배치하기위한 side는 Object toolbar의 “Current pad placement side” 드롭
박스에서 선택할 수 있습니다.

이제 단일 패드의 설정을 변경할 것입니다. 첫 패드로 마우스포인터를 이동한 후 우-클릭
“Properties”를 선택합니다(패드에서 마우스포인터를 움직이는 동안 패드가 하이라이트 
되지 않는다면 아무것도 없는 공간으로 이동하여 우-클릭하거나 또는 Object toolabr의
“Default Mode”버튼을 클릭합니다)

패드 자신의 고유설정이 가능하도록 Pad Properties대화상자에서 “Default for Pattern”박스
를 uncheck하고 shape를 “Polygon”으로, width와 height를 “0.09”로 변경한다음 “Polygon
points”대화상자를 열기위해서 “Points”를 선택합니다. 이곳에서 polygonal 패드의 타입과
polygon point의 좌표들을 정의할 수 있습니다. “Polygon Points”대화상자를 닫고 타입을
“Through-Hole”로, hole의 직경은 “0.04”로 지정하고 OK를 클릭합니다.
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Pad properties대화상자에서 패드의 위치와 방향 또한 수정할 수 있습니다.
Pad properties는 선택한 모든 패드들에 적용됩니다.
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이제 패드에 다음 속성들을 정의해 보겠습니다 먼저 첫번째는 – 0.09x0.09, Rectangle,
Through-hole, Hole diameter는 0.04; 두번째 패드는 – 0.09x0.09, Ellipse, Through, Hole
diameter는 0.04로 설정합니다. 다음에는 이 resistor의 silk를 그립니다. 화면의 위쪽부분에
있는 Drawing toolbar에서 “Rectangle”버튼을 클릭합니다. 핵심포인트 2점을 클릭해서
rectangle을 배치합니다.
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우-클릭이나 “Default Mode”버튼을 이용해서 Rectangle 배치모드를 빠져 나갑니다.

Silk shape의 크기를 변경하고 싶을 때는 우측에 있는“Layers”패널의 silk layer에서 더블
클릭하여 “Objects” 대화상자를 이용하거나 마우스포인터를 silk로 이동해서 우-클릭 후
Properties를 선택할 수 있습니다. 또한 point를 직접 잡아끌기 하는 drag-n-drop도 이용할
수 있습니다. 그러면 그리드 사이즈를 “0.025in”로 변경합니다(그리드박스는 scale box의
바로 왼쪽에 위치해 있습니다) “Ctrl-” 또한 그리드를 0.05에서 0.025로 변경하게 될 것입
니다. 마우스포인터를 rectangle key points로 이동하고 drag-n-drop해서 크기를 조정합니다
(key point에서 마우스포인터는 이동 가능한 방향들을 보이는 형태로 바뀌게 됩니다.)
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메인메뉴에서 “Edit → Center Pattern”을 선택하거나 또는 “Ctrl+Alt+C”를 누름으로서
패턴을 Center화합니다. 드디어 Resistor 패턴이 준비되었습니다.

당신 Library의 첫 패턴을 회전시키고 mirror되도록 해 보십시오. 회전을 위해서는 “Edit
→ Rotate Pattern”을 선택하고, mirror시키기 위해서는 “Edit → Vertical Flip”또는 “Edit →
Horizontal Flip”을 선택합니다. 패턴의 object들을 선택해서 회전시키려 한다면 silk shapes
은 패턴의 width와 height에 연관되어 크기가 조정됩니다 Silk resizing은 당신이 타입에
의한 패턴들을 만들 때 다른 매개변수들을 정의함으로써 패턴의 폭과 높이를 변경할 때
사용됩니다.

3.1.3 Library 저장하기

이제 library이름과 주석, 그리고 파일이름을 지정할 때입니다. 그리고 2~3분 이내에 이
library에 몇개의 다른 패턴들을 추가하게 될 것입니다. 

메인메뉴에서 “Library → Library Name and Hint”를 선택합니다. Library의 이름과 hint를
입력하고 OK를 클릭합니다(그것은 짧아야 합니다) library의 이름은 PCB Layout의 위쪽
“Libraries” toolbar에 보이게 됩니다. hint는 마우스포인터를 library의 이름이 있는 버튼
위로 옮길 때 보이게 됩니다.
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메인메뉴에서 “Library → Save”(Standard toolbar에서 “Save Library”버튼)를 선택합니다.
저장하기 위한 folder를 지정해서 파일이름을 입력하고 “Save”을 클릭합니다. 우리는
표준 libraries(예를 들어 “<Drive>:/Program Files/DipTrace/Lib”)와 당신 자신의 libraries(
우리는 “My Documents/DipTrace에서 “My Libraries”폴더를 사용할 것입니다)에 대해서
서로 다른 폴더들을 사용할 것을 권장합니다.

3.1.4 Designing BGA-144/12x12

메인메뉴에서 “Pattern → Add New to Library”를 선택해서 library에 새로운 패턴을 추가
합니다. 좌측을 보면 새로운 패턴이 자동적으로 선택되는 것을 볼 수 있습니다. 우리는
패턴 타입과 automatic pad numeration을 사용해서 BGA-144/12x12 패턴을 만들게 될 것입
니다. Pattern Properties패널을 최대화하고 패턴의 이름을 입력합니다.
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메인메뉴에서 "View → Units → mm"을 선택하여 units을 "mm" 변경합니다. 메인메뉴에서
"Pattern → Pad Properties”를 선택하여 다음과 같이 설정합니다. “Shape: Ellipse”,
“Width: 0.45”, “Height: 0.45”, “Hole: 0”, “Type: Surface”. Default pad properties의 설정변경을
적용하기 위해서 OK를 클릭합니다. 이제 Pattern Properties패널을 설정합니다.
“Type: Matrix”, “Columns: 13”, “Rows: 13”, ”X Pad Spacing: 0.8”, “Y Pad Spacing: 0.8” 
당신은 패드사이의 거리가 dimension으로 표시되는 13x13 matrix를 볼수 있게 됩니다.
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의도하지 않은 상황으로부터 패턴을 보호하기 위해서 Pattern Properties패널의 “Type” 
우측에 있는 “Lock Properties”버튼을 클릭합니다. 이제 Pattern Properties패널을 최소화
하고 필요하다면 우측 마우스버튼이나 마우스휠을 사용해서 디자인을 pan합니다.
패턴 BGA-144/12x12의 가운데에서 패드 5x5만큼을 삭제 할 것입니다. 박스선택을 이용
해서 그것을 선택합니다(원하는 영역의 좌측상단 코너로 마우스포인터를 이동하고
왼쪽버튼을 누른다음 우측하단 코너로 이동해서 버튼을 놓습니다) 그리고 Delete키로
삭제합니다.
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패드 번호들을 표시하기 위해서 메인메뉴로부터 “View → Pad Numbers → Show”를
선택합니다. 우리의 matrix는 “1”-”169”의 번호를 가집니다. 하지만 BGA패드의 번호는
“A1, A2, etc.”가 되어야 합니다. 그래서 모든 패드들을 선택하고(Ctrl+A), 그중의 한나에서
우-클릭하여 팝업메뉴로부터 “Pad Array Numbers”를 선택합니다. 대화상자에서
“Type: BGA Matrix”를 선택하고 OK버튼을 클릭합니다.
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우리의 BGA matrix에 대해서 정확한 패드 번호들이 지정되었습니다. 타입 “Contour”는
번호를 할당하기 위해 패드에서 팝업메뉴를 호출할 때 선택한 바로 그 패드가 첫번째
번호를 가진다는 것에 주의하도록 합니다.
i.e.) matrix 패턴의 좌측상단이나 맨위의 중앙, 또는 다른 어떤 패드로부터도 첫번째 번호
로 시작되도록 contours(QUAD patterns)을 할 수 있습니다.
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이제 Drawing toolbar의 shape버튼을 사용해서 패턴에 silk screen을 그려보도록 하겠습니
다. grid는 “Ctrl+”, “Ctrl-”로 조정이 가능하고 “F11”키를 사용해서 on/off할 수 있습니다.
Object들은 일반적인 drag and drop이나 “Move Layer”를 사용해서 이동될 수 있습니다.
(우측의 “Layers”패널에서 위치를 변경하고 싶은 object의 layer를 클릭하고, 디자인 영역
으로 이동해서 해당 object를 drag-and-drop합니다. 이때는 다른 layer에 있는 object들은
선택되지 않습니다. 우-클릭으로 해제합니다)
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BGA패턴이 준비되었고, Library를 저장합니다(Ctrl+S 또는 툴바의 “Save”버튼)

3.1.5 SOIC-28 pattern 디자인하기

Datasheet에 의한 실제 부품을 만들어 보겠습니다. 그것은 SOIC-28패턴이 있는 간단한
“Microchip PIC18F24K20”이 될 것입니다.

Library에 새 패턴을 추가합니다.(메인메뉴에서 “Pattern → Add New To Library”) 다음에
이름과 RefDes.를 입력합니다.

Pattern Properties패널에서 “Type: Lines”를 선택하고 “Number of Pads: 28”로 설정합니다.
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우리는 패턴을 구성하는 패드간의 간격 및 설정, line의 간격등을 정확하게 정의해야
합니다. SOIC-28의 치수들을 잘 모른다면(DipTrace의 표준 라이브러리에서 체크할 수
있습니다) “http://www.microchip.com/packaging”으로 가서 패키지 명세 문서로부터 
SOIC-28(7.50 mm) footprint를 찾습니다(이 튜토리얼을 작성하는 시점에서 가장 최신문서
의 165 page) 먼저 패드의 설정을 정의합니다. “Pattern → Pad Properties”로가서
“Shape: Rectangle”, “Width: 0.6 mm”, “Height: 2 mm”, “Hole: 0”, “Type: Surface”로 설정합니
다. 타입을 “Through Hole”로 지정한 경우에는 패드에 있는 hole들을 round나 oval로 만들
수 있습니다.

OK를 클릭합니다. 다음에 Pattern Properties패널로 가서 “Line Spacing: 9.4mm”,
“Pad Spacing: 1.27mm”로 지정합니다. 치수들이 정확한지 확인합니다.
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화면에서 볼 수 있는 것처럼 패드의 번호들이 정확하기 때문에 그들을 재 지정할 필요가
없습니다.

원치않는 변화를 피하기 위해서 Pattern Properties패널에서 lock에 체크합니다.

Grid가 off상태라면 F11을 사용해서 on상태로 변경합니다. 그리고 Drawing toolbar로부터
Line(또는 polyline)과 arc버튼을 클릭해서 silk-screen을 그립니다.
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패턴이 준비되었습니. 이 패턴을 Component editor에서 “PIC18F24K20” component에
할당할 것입니다.  필요하다면 “Edit → Rotate Pattern”이나 “Ctrl+R”을 사용해서 패턴을
회전 시킬 수 있습니다. Library를 저장합니다.

3.1.6 Patterns 배치하기

DipTrace PCB Layout을 실행합니다.

Start → All Programs → DipTrace → PCB layout. 화면의 좌측에 있는 Patterns패널에 우리가
디자인한 패턴들을 보이도록 하기위해서는 먼저 library를 등록할 필요가 있습니다.
메인메뉴에서 “Library → Library Setup”을 선택하고 “Get Libraries from Folder”박스를
uncheck합니다. 바로 옆의 “...’ 버튼을 클릭해서 당신의 library를 오픈합니다.
“My Library”가 Library Bar에 추가되었습니다. 필요하다면 목록에서 그것을 다른 위치로
쉽게 이동할 수 있습니다. Library Setup대화박스를 닫습니다.
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“My Library”를 발견할때까지 Libraries패널을 우측으로 스크롤합니다.(Libraries패널 오른
쪽 끝에 있는 화살표 모양의 버튼들을 사용합니다) 그런다음 당신의 library를
선택합니다. 이제 Patterns패널에 우리가 디자인한 패턴들이 보이게 됩니다. 패턴을 배치
하고 RefDes와 Type이 보이도록 marking의 설정을 변경합니다.(공통-설정의 변경을 위해
서는 “View → Pattern Marking”을, 각 패턴에 대한 자신의 고유설정을 위해서는 패턴에서
우-클릭하여 팝업메뉴에서 Properties → Marking을 선택합니다.) 각 패턴의 고유설정
변경은 선택된 모든 패턴들에 대하여 실행된다는 것에 주의하십시오. 패턴을 bottom면에
배치하길 원한다면 배치전에 Elements toolbar에 있는 “Top Side”를 “Bottom Side”로 변경
합니다.  이미 배치되어 있는 component들에 대해서는 우-클릭해서 팝업메뉴로부터
“Change Side”를 선택해서 변경할 수 있습니다.
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우리의 top layer는 red색입니다. 그래서 모든 top SMD 패드들은 red색입니다 “Route → 
Layer Setup”이나 Design Manager에서 이것을 바꿀 수 있습니다.(Design Manager를
표시하거나 감추기 위해서는 “F3”키를 사용하고 색을 변경하기 위해서는 layer color
rectangle을 클릭합니다.) 만약 당신이 white background를 사용한다면 모든 signal layer들을
black color로 설정하고 black backround를 사용할 때는 light yellow로 선택합니다. 패드들
의색은 “View → Colors”에서 정의할 수 있습니다.

이제 resistor패드들 중의 하나의 속성을 변경할 것입니다. 변경을 원하는 패드로 마우스
포인터를 이동합니다. red로 하이라이트되면 우-클릭해서 “Pad Properties”을 선택하고
“Use Pattern’s Pad Properties”를 uncheck한 후 원하는 속성으로 변경합니다.(여기서는
ellipse 대신에 oval pad로 변경) 이것으로 그 패드는 자신만의 고유설정을 가지게 됩니다.
만약 top layer와 패드의 하이라이트 color가 같은 red라면 마우스포인터를 SMD패드로
이동해도 highlight되는지 알 수 없습니다.(“View / Colors”에서 변경가능) 하지만 다른
모든 기능들은 잘 작동합니다. PCB Layout의 Pad Properties대화상자는 Pattern Editor와
유사합니다. 패턴의 default 패드 속성은 마우스포인터를 패턴으로 이동해서 패턴이
green으로 하이라이트되었을 때 우-클릭하고 “Pad Properties”를 선택함으로서 변경할 수
있습니다. 선택한 패턴안에서 자신의 고유설정을 가지지 않은 모든 default 패드들이 같이
변경되게 됩니다.
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만약 패턴의 origin이 패턴의 center위치와 다르다면 그 패턴을 배치(또는 schematic을
PCB로 변환)하는 동안 원점과 중심이 서로 다르다는 것을 알게 될 것입니다. 또한 당신은
선택한 모든 패턴의 원점을 보이거나 감추게 할 수 있습니다. 그들중의 하나에서 우-클릭
하고 서브메뉴에서 “Pattern Origin”을 선택합니다. 패턴들을 회전시켜 보면 패턴의
원점이 그것의 회전 중심이라는 것을 알게 될 것입니다. 패턴위로 마우스포인터를 이동
할 때 보여지는 좌표 역시 패턴의 원점에 대한 좌표입니다.

3.2 Component library 디자인하기

3.2.1 Customizing Component Editor

Component Editor의 customizing은 Pattern Editor를 customizing하는 것과 똑같습니다.
프로그램을 실행한 후 표시되어 있지 않다면 원점과 X, Y축이 보이도록 메인메뉴에서
“View → Display Origin”(“F1”키)을 선택합니다. 디자인 영역의 우측 상단에 있는
Component Properties패널은 최소화 될 수 있고 “X” 버튼을 사용해서 패널을 닫습니다.
이 패널을 사용해서 당신은 4가지의 심볼 타입을 정의할 수 있습니다. Free(어떤 특정한
속성이 없는)와, 2 sides, IC – 2 sides, 그리고 IC – 4 sides입니다. 두번째와 세번째 타입의
유일한 차이는 직사각형의 silk입니다. 또한 “Part Type”과 “Part”라는 설정항목들이
있습니다. 파트타입은 “Normal”, “Power and Gnd” 그리고 “Net Port”가 될 수 있습니다.
Component는 오직 하나의 “Power and GND”만을 포함할 수 있습니다(schematic의 모든
power net을 감추는 것을 선호한다면 모든 power pin들을 이 part에 배치해야 합니다)
Net port는 단일파트 component이고 가시적인 연결없이 wire들을 함께 연결하기 위해서
사용합니다. ground나 power symbol들에 사용될 수 있고 회로도를 유연한 구조로 만들 수
있습니다. 이제 component를 디자인하고 사용하는 방법을 보일 것입니다.
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Components를 만들기 전에 pin설정들을 정의하고 싶을 수 있습니다. 메인메뉴에서
“Objects → Pin Placement Setup”을 선택합니다. 우리는 지금 이러한 속성들을 변경하지
않을 것입니다. 그러나 Length와 X, Y 간격은 grid의 점들에 파트의 모든 key points이
생성되도록 grid-step에 의해서 나누어질 수 있어야 한다는 것에 주의하십시오.
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우리는 또한 핀들을 배치하고 할당할 때 grid를 0.1로 사용할 것을 권장합니다.

3.2.2 Resistor(component) 디자인하기

“Free”타입으로 resistor를 디자인하고 눈조준으로 배치할 것입니다. 먼저 Component
Properties패널에서 component이름과 RefDes를 정의합니다. 이러한 속성들을 지정한 후
Component Properties패널을 최소화합니다.
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Object toolbar중 “Place Pins”에서 “Single”을 선택한다음 디자인 영역으로 마우스포인터
를 이동합니다. 좌-클릭해서 2개의 pin을 배치하고 하나의 핀은 180도 회전시킵니다(선택
해서 “Ctrl+R”을 두번) Object toolbar에서 “Rectangle”을 선택해서 resistor를 위한 graphics
을 그림니다. pin들은 0.1 grid로 배치하고 rectangle은 0.05 grid로 그려져야 합니다.
(grid size변경은 “Ctrl+”, “Ctrl-”)
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Drag and drop을 사용해서 핀들을 이동시킬 수 있습니다. 핀들을 이동하거나 회전시키길
원한다면 먼저 그들을 선택해야 합니다.

Resistor symbol이 준비 되었습니다. 그러나 이 resistor가 있는 schematic으로부터 PCB
를 생성하기 위해서는 pattern을 할당해야 합니다. 그래서 메인메뉴에서 “Component → 
Attached Pattern”을 선택합니다. 패턴 첨부 대화상자에서 “Add”버튼을 클릭하고 당신의
패턴 library를 찾아서 open합니다. 패턴목록으로부터 “RES 400”을 선택합니다. 대화상자
의 좌측에는 symbol, 우측에는 패턴, 그리고 패턴과 symbol을 연결하는 blue색의 선들을
볼 수 있습니다(이것은 핀과 패드의 연결입니다) 그런 연결을 생성하거나 수정하기
위해서 마우스포인터를 파트의(symbol) pin으로 이동한 후 좌-클릭 한다음 그것과 연결을
원하는 패드로 이동해서 좌-클릭합니다. 연결된 핀들 중의 하나로 마우스포인터를 이동
하면 둘다 하이라이트 되는 것을 볼 수 있습니다. 연결을 제거하기 위해서는 간단히
핀이나 패드에서 우-클릭합니다.  대화상자에서 scale box옆으로 우측끝에 있는 아래방향
의 화살표 버튼을 눌러서 “Pattern Verification”패널을 표시합니다. 이곳에서 패드의
설정들을 확인하고 패턴의 모든 치수들을 측정할 수 있습니다. 변경사항들을 적용하기
위해서 OK를 클릭합니다.
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“Connection List”를 사용해서도 pin과 pad에 대한 연결들을 지정할 수 있습니다 또한 pin
번호들은(패드들에 연관된) “Pin Manager”(메인메뉴에서 “Component → Pin Manager”
선택)와 Pin Properties대화상자에서 설정할 수 있습니다. 대부분의 components에 대해서
Pin Manager를 사용할 것을 권장합니다.

Attached Pattern대화상자는 크기를 조정할 수 있고 프로그램을 닫을 때 그 크기는 저장
됩니다.

Schematic part와 PCB pattern을 둘 다 포함하는 resistor가 준비되었습니다.

Library의 이름과 힌트를 정의합니다. “Library → Library Name and Hint”를 선택합니다.
Name에는 “My Library”를, Hint에는 “This is my first component library’를 입력합니다.
(다른 이름과 힌트를 사용할 수 있지만 이름은 짧아야 한다는 것에 주의하십시오.
그것은 Schematic 프로그램의 libraries패널에서 button caption으로 표시됩니다.)

Standard toolbar에서 “Save”버튼을 클릭하고 Library경로와 파일이름을 정합니다. library
를 저장하기 위해서 “Save”를 클릭합니다.
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3.2.3 Capacitor 디자인하기

Library에 새로운 component를 추가하기 위해서 메인메뉴에서 “Component → Add New
To Library”을 선택합니다.

우리는 타입 “2 sides”를 선택해서 capacitor를 디자인할 것입니다. component 이름과
RefDes를 정의하고 Component Properties패널의 Type에서 “2 sides”를 선택합니다.
Width를 “0.1”, Left Pins와 Right Pins를 “1”로 변경합니다.
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이제 Component Properties패널을 최소화합니다. grid size를 “0.0125 in”으로 변경하고
세개의 line과 하나의 arc를 사용해서 capacitor graphics를 그립니다.
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Symbol의 핀 이름들을 표시합니다. 핀들을 선택(“Ctrl+A”를 사용해서 모두선택)
하고 그들 중의 하나에서 우-클릭하여 팝업메뉴에서 “Pin Properties”를 선택합니다. Pin
Properties대화상자에서 “Show Name”을 체크하고 OK를 클릭합니다.
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모든 새롭게 만들어진 핀들은 “Undefined” electric type을 가진다는 것에 유의하십시오.
Pin Properties대화상자나 또는 Pin Manager를 사용해서 electric타입을 변경할 수 있습니다
electric타입은 현재는 ERC기능만을 위해서 사용됩니다. “Type”속성은 핀 graphics에 주로
사용됩니다. 그것이 어떻게 그려지는 지를 보기 위해서 다른 타입들을 시도해 보십시오.

Pin의 이름들이 보이지만 그들은 적절한 위치에 있지 않습니다. 그래서 그들을 이동할 
필요가 있습니다. 메인메뉴에서 “View → Move Tool”을 선택하거나 간단히 F10키를
사용합니다. 마우스포인터를 핀 이름 위로 이동해서 새로운 위치로 drag합니다.
Default mode로 돌아오기 위해서는 우-클릭합니다.

Schematic capture에서 핀이름, 번호, 그리고 part의 marking등을 이동하기 위해서 그런
방법을 사용할 수 있습니다.
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우리는 위의 그림에서 pin번호가 아닌 pin의 이름들을 보고 있습니다. 그것은 pin의 번호
들을 변경할 때 함께 변경되지 않습니다. 또한 pin이름에 윗줄을 추가할 수 있습니다.
마우스포인터를 pin으로 이동해서 우-클릭하고 팝업메뉴에서 첫 항목을 선택합니다. 
“normal ~invert”를 입력하고 OK를 클릭합니다. 다음에는 move tool(F10)을 사용해서 pin
이름을 이동합니다. Pin이름에서 “~” 심볼은  윗줄의 시작이나 끝을 지시합니다. 그것을
사용해서 당신은 signal의 이름(pin)과 그에 대한 역을 pin이름으로 사용할 수 있습니다.
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Capacitor같은 부품들에 대해서는 pin의 이름보다는 pin번호들을 표시하고 싶을 수 있습
니다. Schematic capture에서 pin번호의 표시에 대해서 default 설정을 정의할 수 있고 새롭
게 배치되거나 default로 설정되어 있는 모든 부품들은 이 디폴트 설정의 변경을 따르게
됩니다. 그러나 Component만의 고유설정을 지정하거나 Component Editor에서 각 파트의
pin번호들을 표시하기 위해서 별도의 설정을 지정할 수 있습니다.

메인메뉴에서 "Component → Pin Manager"를 선택해서 Pin Manager대화상자를 열고 
테이블에서 pin “2”를 선택한다음 그 이름을 “2”로 변경합니다. 두 pin들의 pin이름을
감춥니다. 그들을 선택(마우스포인터를 첫번째로 이동해서 왼쪽버튼을 누른채로
두번째로 이동)해서 “Show Name”박스를 언체크하고 Pin Manager를 닫습니다.

당신은 pin의 번호, 좌표, 길이, 타입과 pin의 전기적 타입을 “Pin Manager”대화상자로 
변경할 수 있습니다.
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Component editor의 “Component → Pin Numbers”를 사용해서 pin번호를 표시할지 말지를
각각의 component에 지정할 수 있습니다. 이 설정은 View메뉴의 show나 hide에 영향받지
않습니다. component메뉴에서 Pin Numbers를 default로 지정한 모든 부품들의 pin번호는
“View → Pin Numbers”를 사용해서 표시하거나 감출 수 있습니다.

이제 capacitor의 pin번호들을 표시하기 위해서 “Show”를 선택합니다. Pin번호를
이동시키고 싶을 때는 move tool(F10)을 사용합니다.
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다음단계는 capacitor에 pattern을 첨부하는 것입니다. 메인메뉴에서 “Component → 
Attached Pattern”을 선택합니다. 라이브러리 목록에 “C:\Program files\DipTrace\Lib\
_general.lib”를 추가해서 “CAP100RP”패턴을 선택합니다. “1”을 “Plus”에, “2”를 “Minus”
에 연결하고 OK를 클릭합니다.

file:///C:/Program
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Capacitor가 준비되었습니다.

3.2.4 Multi-part component 디자인하기

4개의 “And-Not” 심볼과 파워 심볼로 이루어진 간단한 멀티-파트 component을 디자인
할 것입니다. 첨부되는 패턴은 DIP-14가 됩니다. 

라이브러리에 새 component을 추가합니다. (i.e. 메인메뉴에서 “Component → Add New To
Library”를 선택하고 Component Properties패널에서 이름과 RefDes을 입력합니다.)
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Component Properties패널의 가장 아래 왼쪽의 구석에 있는 “Quick Buttons”를 클릭합니다
“Attached Pattern”, “Pin Manager” 그리고 “Get from Library”기능들을 호출하기 위한 퀵
버튼들이 나타납니다. 이러한 기능들은 library를 디자인할 때 폭 넓게 사용됩니다. 그래서
우리 library디자이너들의 요청에따라 퀵버튼들을 추가했습니다.

다음 단계는 부품의 파트들을 생성하는 것입니다. DipTrace로 component에 다른 파트들과
파트의 그룹들(유사한 파트들)을 생성하는 것이 가능합니다. 파트그룹에 있는 모든 파트
들은 Pin번호들을 제외하고는 같은 pin과 silk등을 가지게 됩니다. 또한 파트의 타입은
Normal, Power 그리고 Net Ports가 될 수 있습니다. Power의 파트들과 네트들은 Schematic
capture에서 감춰질 수 있습니다. component는 오직 하나의 power파트만을 포함할 수
있습니다.

이제 4개의 유사 And-Not파트들과 1개의 power파트가 있는 component를 디자인 할 것입
니다. 메인메뉴에서 “Component → Create Similar Parts”를 선택합니다. 대화상자에서 “4”
를 입력하고 OK를 클릭합니다. 유사파트들은 현재 선택한 파트를 기반으로 만들어
진다는 것에 유의하십시오.
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화면에는 탭으로 구성된 Part 1(1), Part 1(2), Part 1(3) 그리고Part 1(4)의 파트화면을 볼 수
있습니다. 모든 유사 파트들은 같은 파트이름을 가지며 파트이름에 의해서 결합되어
있습니다. 당신은 파트이름을 Component Properties패널의 “Part”에서 “AN”으로 변경할
수 있습니다.

다음 파트는 power파트가 될 것입니다. 메인메뉴에서 “Component → Add New Part”를
선택하고 새로운 파트의 탭을 선택합니다. 그리고 그것의 이름을 “PWR”로 변경합니다.
새 파트는 “AN”그룹에 속하지 않는 다른 파트라는 것에 주의하십시오.

이제 power파트를 디자인합니다. “IC-2 sides” 타입을 Component Properties패널의 Type에
서 선택하고 다음과 같이 Width는 ”0.3 in”, Height는 ”0.25 in”, Left Pins는 ”2”, Right Pins
는 ”0”으로 지정합니다. 그런다음 “Part Type”에서 “Power and Gnd”를 선택합니다.
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메인메뉴에서 “Component → Pin Manager”를 선택한 다음 pin이름을 “VCC”와 “GND”로
, pin번호들은 “14”와 “7”로, electric 타입은 “Power”로하고 두 pin 모두 “Show Name”에
체크합니다. 복수의 pin들에 대해서 “Type”, “Show Name” 그리고 “Length”들을 변경할 수
있습니다. 
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Pin Manager대화상자 윈도우는 크기조정이 가능하고 이러한 설정들은 프로그램을 닫을
때 저장됩니다.

Component Properties패널을 최소화 하고 Pin manager대화상자를 닫습니다. component의
첫 파트를 보십시오.
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Component의 다른 파트들을 디자인합니다. AN 파트들 중 하나를 선택한 다음
Component Properties패널에서 다음과 같이 Type은 “IC- 2 sides”, Width는 “0.2 in”,
Height는 “0.25 in”, Left Pins는 “-2”, Right Pins는 “-1”로 설정합니다. 다음에는 Component
Properties패널을 최소화합니다.

Object toolbar에서 “Text”버튼을 선택합니다. 마우스포인터를 심볼의 안쪽으로 이동하고
좌-클릭해서 “&”을 입력하고 다음에 엔터를 입력합니다.
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우리는 “And – Not” 파트들(not “And”)을 디자인할 것이므로 우측 pin은 inversion이나
“Dot” 타입을 가져야만 합니다. pin에서 우-클릭하고 팝업메뉴에서 “Pin Properties”를 
선택합니다. Type에서 “Dot”를 선택하고 OK를 클릭합니다.

다른 “AN”파트들은 디자인할 필요가 없습니다. AN(3)이나 AN(4)를 선택해 보면 그것들
이 방금 디자인한 파트와 똑같다는 것을 알게됩니다. 그룹에 있는 모든 파트들은 
유사하지만 그러나 pin번호들은 달라야만 합니다(당신은 2 ~ 3초내에 그들을 변경할
것입이다)
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메인메뉴에서 “Component → Pin Manager”를 선택합니다. Pin Manager 대화상자에서
파트를 선택해서 그것의 pin번호들을 정의하고 그런다음 다음 파트를 선택합니다. 모든
AN파트의 pin번호들을 정의할 때까지 계속합니다. 당신은 매번 마우스를 사용해서
다음 pin을 선택할 필요가 없습니다. 다음의 pin으로 전환하기 위해서 간단히 “Number”
나 “Name”에 있을때 Down이나 Enter키를 입력합니다. 파트들 중 하나에서 “Electric”타입
을 설정하고(다른 유사파트들은 자동적으로 변경될 것입이다) Pin Manager를 닫습니다.
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다음단계는 멀티-파트 component에 패턴을 첨부하는 것입니다. 메인메뉴에서
“Component → Attached Pattern”을 선택합니다. Attached Pattern대화상자에서 “_general.lib”
라이브러리를 선택하고 그 라이브러리로부터 DIP-14 pattern을 선택합니다. Pin Manager
에서 이미 지정되었기 때문에 pin과 pad에대한 연결들을 지정할 필요가 없습니다.
대화상자에서 다른 파트들을 선택하고 그것들이 바르게 연결되어 있는지를 확인합니다.
Pattern을 첨부하기 위해서 OK클릭합니다.
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멀티-파트 component가 준비되었습니다.

3.2.5 PIC18F24K20 디자인하기

이제 우리는 datasheet에 따라서 PIC18F24K20을 만들고 실질적인 component를 얻기위해
그것에 우리의 SOIC-28 pattern을 첨가하게 될 것입니다.

먼저 http://www.microchip.com로 가서 "PIC18F24K20"의 Datasheet를 얻습니다.

다이렉트 링크는 http://ww1.microchip.com/downloads/en/DeviceDoc/41303G.pdf입니다.
그러나 이 튜토리얼을 읽고 있는 당시에도 링크가 작동하는지는 보증할 수 없습니다.
“Pin Diagrams”를 찾으십시오. 첫 도표가 우리가 필요로 하는 것입니다.

DipTrace Component Editor로 전환해서 새 component를 추가합니다(Ctrl+Insert),
“Type: IC – 2 sides”, “Left Pins: 14”, “Right Pins: 14”로 지정하고 이름과 RefDes를
입력합니다.
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Component Properties패널에서 “Pin Manager”버튼을 클릭하고 datasheet로부터 pin의 도표
를 참고해서 pin이름들을 입력합니다. Pin Manager윈도우는 크기를 자유롭게 조정할 수
있습니다. 또한 pin이름을 입력할 때 다음의 pin으로 전환하기 위해서 간단하게 Enter를
입력합니다.
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Pin이름을 입력한 후에 pin들의 electric타입을 지정하고 모든 pin들에 대해서 “Show
Name”을 체크합니다. 원하는 만큼 많은 핀들을 동시에 선택해서 선택한 모든 pin들의
이런 속성들을 한번에 변경할 수 있다는 것을 기억하십시오. Pin Manager를 닫습니다.
우리의 심볼은 폭이 너무 좁고 pin의 이름들이 겹쳐지기 때문에 이상하게 보입니다.
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Component Properties패널에서 Width를 "1.9"로, Height를 "2"로 수정합니다. Pin이름들은
여전히 약간 겹쳐지지만, 먼저 pin들을 그룹화하고 버스를 만든다음 필요하다면 Width를
다시 변경합니다. pin들의 그룹화를 위해서 보다 더 큰 Height값이 필요하고 그것들을
심볼 rectangle에 배치한 후 줄일 수 있게 될 것입니다. pin들을 그리드에 따라서 배치할
것이기 때문에 그리드를 0.1로 변경합니다.
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이제 pin들을 논리적으로 그룹화해야 합니다. 먼저 버스들을 형성합니다. 메인메뉴에서
“Component → Make Busses from Pins”를 선택합니다. 이 기능들은 pin의 이름들로부터
버스들을 추출하고 버스들에 의해서 pin들이 그룹화 될 수 있게 합니다. 이곳에서 버스
디바이더를 정의할 수 있습니다. 기본설정에 의해서 오직 “/”만이 선택되어 있고 우리의
심볼에 대해서는 잘 작동합니다. 그러나 일부의 제조업체들은 다른 디바이더들을 가지고
있을 수 있고 이곳에서 우리는 그것을 정의할 수 있습니다. “Extract”버튼을 누르면 이용
가능한 버스들과 각각에 대한 pin들의 수를 알게 될 것입니다. Ctrl키를 사용해서 RA, RB
그리고 RC를 선택합니다.
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버스를 만들기 위해 “Make”버튼을 클릭하고 대화상자를 닫습니다. 버스들은 심볼의
왼쪽에 배치될 것이고 번호에 의해서 정렬 될 것입니다.
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버스를 만들기 전에 “Bus to Bus Spacing”을 정의할 수 있습니다.

이제 버스들에 포함되지 않는 모든 pin들을 선택합니다.(당신이 볼 수 있듯이 심볼위에
아직 4개의 pin들이 있습니다), 다중 선택을 위해서 “Ctrl”과 박스-선택을 사용합니다.
그 pin들 중 하나에서 우-클릭해서 “Snap to Grid”를 선택하고, 버스들을 배치할 수 있도록
핀들을 bottom으로 이동합니다.
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Rectangle에 bus를 배치합니다. 버스를 선택하기 위해서 박스선택을 사용하고 그것을
드래그 합니다. 버스를 회전시키기 위해서는 Shift+R을, pin을 flip하기 위해서는 “Shift+F”
키를 사용할 수 있습니다. 이런 기능들은 pin의 서브메뉴(pin에서 우-클릭)에서 선택할 수
있습니다. pin들을 bottom으로부터 rectangle로 이동합니다(“R”키는 선택한 object나 pin을
회전시키기 위해서 사용될 수 있습니다) 이제 다음과 같은 심볼을 얻었지만 약간 다른
방식으로 그것을 할 수 있습니다.
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때때로 electric타입끼리 pin들을 배치할 필요가 있습니다. 이러한 일을 보다 더 쉽게
하기 위해서 electric타입에 따라 pin의 색들이 다르게 표시되도록 설정할 수 있습니다.
“View → Pin Colors by Etype”을 선택한다.

당신이 볼수 있듯이 심볼 폭은 정확합니다. 그러나 우리는 심볼의 높이를 약간 줄일 수
있습니다. 그래서 Component Properties패널의 높이를 “1.8”로 변경합니다. 심볼을 파괴할
수도 있기 때문에 pin들의 번호를 수정하지 않아야 합니다(“Undo”를 사용할 수 있습니다)
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심볼이 우발적인 일로 변경되는 것으로부터 보호하기 위해서 Component Properties패널
에서 Lock을 클릭합니다(Lock버튼은 Type바로 옆에 있습니다)

마지막 단계는 SOIC-28 pattern을 우리의 component에 첨부하는 것입니다. Component
Properties패널에서 “Pattern”버튼을 클릭하고, Attached Pattern대화상자에서 “SOIC-28”
pattern을 선택합니다. 모든 pin이름과 pin번호들은 이미 거기에 있기 때문에 설정을 변경
할 필요없이 단지 OK를 클릭합니다.
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우리의 PIC18F24K20이 준비 되었습니다.

3.2.6 VCC와 GND심볼 디자인하기

Net Port타입을 사용해서 VCC와 GND심볼을 디자인할 것입니다.

새로운 부품을 추가하기 위해서 “Component → Add New To Library”를 선택합니다. 
Component Properties패널에서 이름을 “VCC”로 하고, Part Type에서 “Net Port”를 선택합
니다. 모든 Net Port들은 화면의 왼쪽에 있는 Component Table에서 그들의 그래픽 우측
상단 구석에 “Net Port” marking을 표시하게 됩니다.
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Component Properties패널을 최소화합니다. 다음에 Objects toolbar의 “Pin”을 선택해서
배치하고 그것을 세번 회전시킵니다(“Ctrl+R”) 역시 Objects toolbar에서 Line을 선택하고
심볼의 silk라인을 그립니다. 이 심볼을 만들기 위해서는 0.05 그리드를 사용하는 것이
좋습니다.
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메인메뉴에서 “Component → Pin Numbers → Hide”를 선택함으로서 pin번호를 숨깁니다.
VCC심볼이 준비되었습니다.

이제 component를 추가하고(Ctrl+Insert) 똑같은 방법으로 GND심볼을 생성합니다.

GND에서 “Edit → Center Symbol”이나 “Ctrl+Alt+C”를 선택해서 원점이 센터에 오도록
설정합니다. GND심볼의 그래픽을 만들기 위해 0.125 그리드를 사용했다는 것에
주의하십시오.
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Net Port에는 pattern을 첨부할 필요가 없다는 것에 주의하십시오. 이러한 심볼들은
가시적인 연결없이 단지 wire들을 함께 연결하기 위한 것이기 때문입니다.

당신의 라이브러리를 저장합니다.

3.2.7 Using additional fields

DipTrace에서 component의 디폴트 설정들은 RefDes, Value 그리고 Type을 포함합니다.
그러나 때때로 제조업체의 이름, datasheet에 대한 링크, 부품에 대한 묘사등의 항목이
필요할 때가 있습니다. 이러한 경우에 당신은 사용자 정의 항목을 사용할 수 있습니다.

메인메뉴에서 “Component → Default Additional Fields”를 선택합니다. 이 대화상자는 
Default 항목들을 추가할 수 있도록 하고 그들의 값은 모든 새로운 component에 추가되게
될 것입니다. 예를들면 당신이 LT 부품들의 library를 디자인하려 할 때 당신은 제조사
필드를 추가할 수 있고 default값으로서 “Linear Technology”를 지정할 수 있습니다.

제조사와 datasheet필드들을 추가합니다. Name에 “Manufacturer”를 입력합니다. Type은
“Text”을 선택하고 Add버튼을 클릭합니다. 다음의 Name에는 “Datasheet” 또는 “Connect”
를 입력합니다(또는 웹사이트에 대한 링크로서 이해할 수 있는 또다른 단어) Type에는
Link를 선택하고 “Default Value”에 링크를 입력합니다. 그리고 “Add”를 클릭합니다.
또한 additional fields table에 직접 값들을 입력할 수 있습니다.
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지금부터 모든 새로운 component가 그런 부가적인 필드들을 가지게 될 것입니다. 대화
상자를 닫습니다. 새로운 component를 추가하기 위해서 “Component → Add New To
Library”(“Ctrl+Ins”)를 선택하고 Component Properties패널을 최대화 합니다. 
새로운 부품의 부가적인 필드 목록을 보기 위해서 “Additional Fields”를 클릭합니다.
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이제 당신은 component에 부가적인 필드들을 추가하고 삭제하거나 수정할 수 있습니다.
그러나 우리는 새 component로 이것을 하지 않을 것입니다. 삭제하기 위해서는
Component Table에 있는 새 부품에서 우-클릭하고 “Delete Component”(“Ctrl+Del”)을 선택
합니다. 또한 다수의 component를 선택해서 한번에 그것을 삭제할 수 있습니다.



DipTrace Tutorial150

© 2011 Novarm Ltd.

당신의 capacitor를 선택합니다. “Default Additional Fields”를 변경하기 전에 그것을
생성했기 때문에 부가적인 필드들을 가지고 있지 않습니다. 그래서 몇개의 새로운 필드
들을 추가하게 될 것입니다.

“Add”버튼을 클릭하고, Name에 “Manufacturer”를 입력합니다. “Type:Text”를 선택하고
Value에는 회사이름을 입력하고 OK를 클릭합니다. 모든 대화상자에서 수락한다는 의미
로 Enter 키를, 취소한다는 의미로는 Esc키를 사용하면 됩니다.
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똑같은 방법으로 “Web-site”필드를 추가합니다. “Type:Link:”를 선택하고 실제 웹사이트
주소를 Value에 입력합니다.

3.2.8 Spice settings

이곳에서는 회로를 시뮬레이트하기 위해서 LT Spice를 사용하는 방법을 보입니다. 우리는
후에 이것을 단계적으로 회고할 것입니다. 현재는 단지 약간의 값만을 가지는 CAP파트를
지정할 것이고 그것은 Spice Netlist에 추가될 수 있습니다. Component table에서 CAP을
선택하고 메인메뉴에서 “Component → Spice Settings”을 선택합니다. “Model Type:
Capacitor”를 선택한다음 Parameter의 Value에 “1uF”를 입력합니다. 위의 템플레이트 필드
에서 이 파트가 spice netlist에서 어떻게 보이는지를 알 수 있습니다. 우리의 경우에는
pin to signal맵은 정확합니다. 그러나 다른 부품들에 대해서 그것을 수정할 필요가 있다면
간단히 Spice Settings윈도우의 왼편에있는 테이블에 signal의 이름을 입력합니다. 
이용가능한 signal들의 목록은 그 테이블의 밑에 위치합니다.
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Capacitor는 매우 간단한 파트입니다. 그래서 우리는 텍스트 파일에 특정한 모델이나
그것이 작동하는 방법을 보이기 위한 프로그램을 필요로하지 않습니다.(단지 모델타입과
용량) 그러나 트랜지스터의 경우 외부 파일로부터 모델들을 로드하거나(일반적으로
Spice모델들은 제조사 웹사이트에서 얻을 수 있습니다) 또는 직접 모델을 텍스트로 입력
합니다. 또한 거의 모든 파트를 프로그램으로서 입력하거나 로드할 수 있는 SubCkt타입
이 있습니다.

“Get Spice Model from Library”버튼은 다른 DipTrace component로부터 spice설정을 로드할
수 있게합니다.

Spice Settings대화상자는 Schematic program에서도 동일하게 이용 가능합니다.  Spice설정
은 언제든지 수정이 가능합니다.

우리의 라이브러리 디자인을 완료했습니다. OK를 클릭해서 Spice Settings대화상자를
종료합니다. 라이브러리를 저장하기 위해서 Standard toolbar의 “Save Library”버튼을 클릭 
합니다.

3.2.9 Library 검증.

혹시 error들이 있는지 라이브러리를 검증하는 것은 매우 중요합니다. 우리는 라이브러리
디자이너들의 일을 연구했고 library검증 기능을 사용해서 자동적으로 발결될 수 있는
모든 가능한 error들을 추가했습니다.

Component Editor의 메인메뉴에서 "Library → Library Verification"을 선택합니다. 이 대화
상자에서 당신의 library에 있는 components/parts/pins의 전체 수와 가능한 에러들을 볼 수
있습니다.
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다음 error들이 자동적으로 발견될 수 있습니다.

1. Without Patterns – 만약 당신이 일부의 component에 pattern을 첨부하는 것을
잊었다면 그 components은 단지 회로 심볼만을 가지고 있다는 것을 명심하십시오.

2. Similar Components – 라이브러리가 유사 이름을 가진 component들을 포함하는지
체크합니다. 이러한 것이 제대로 작동하도록 라이브러리는 정렬되어야 한다는 것에
주의하십시오(“Library → Sort Components by Name”)

3. Similar Pin Numbers – 하나 또는 그 이상의 핀들이 similar 번호(똑같은 패드에 연결된)
들을 가진다면 이것은 99% 당신의 component에 잘못이 있는 것입니다. “...” 버튼을 클릭
해서 나열된 component의 핀 번호들을 검사하십시오.

4. Shorted pins – 하나나 그이상의 핀들이 내부적으로 패드에서 패드로 연결되어 숏트.

5. Unconnected pins – 일부 핀들이 해당하는 pattern에 패드들을 가지고 있지 않다면...
 때때로 이것은 어떤 문제도 없는 component에서도 발생할 수 있습니다.

6. Unconnected pads – pattern의 일부 패드들이 사용되지 않은경우 (해당하는 pin들이 없다.)
이것은 제대로 구성된 component에서도 발생할 수 있습니다.

7. Through pads without holes – 대부분 이것은 SMD pattern에 잘못이 있습니다.
패드들이 정말로 서피스-마운티드인지 확인하십시오.

8. Undefined pins – 일부 핀들이 “Undefined”의 Electric속성을 가지고 있습니다.

9. Pin superposition – 일부 핀들이 심볼위에 겹쳐집니다. 대부분 이것은 디자인
오류입니다.

세부사항들을(부품들과 핀들의 목록) 보기위해서 “...”버튼을 클릭합니다. 또한 텍스트
파일에 에러의 목록을 저장할 수 있고, 그 파일을 보고 라이브러리를 정정할 수
있습니다.
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3.2.10 Parts 배치하기

Schematic Capture 프로그램을 오픈합니다(Start → All Programs → DipTrace -->Schematic)
먼저 라이브러리를 Libraries toolbar에 추가해야 합니다. “Library → Library Setup”을 선택
합니다. “Get Libraries from Folder”를 언체크하고, 활성화된 라이브러리의 목록 옆에 있는
“...”버튼을 눌러서 당신의 라이브러리를 추가하고 “Close”버튼을 클릭합니다.

일반적으로 회로를 디자인하는데는 원점을 필요로 하지 않기 때문에 원점이 보인다면
F1을 눌러 감추도록 합니다.

Libraries toolbar의 화살표버튼이나 스크롤-바를 사용해서 library들을 우측으로 스크롤하
고 “My Library”를 선택합니다. Component table에서 resistor를 선택하고 디자인 영역에
좌-클릭해서 그것을 배치합니다. Capacitor도 똑같이 합니다.

당신은 또한 메인메뉴의 “Objects → Place Component”(Objects toolbar의 “Place Component
“버튼)를 사용해서 component들을 배치할 수 있습니다. 이런 경우에는 Library Setup
대화상자를 통해서 라이브러리들을 구성할 필요가 없습니다.

이제 우리 capacitor의 additional필드를 사용하는 방법을 보일 것입니다. capacitor에서
우-클릭하고 팝업메뉴로부터 “Links”를 선택합니다. 당신이 입력했던 웹사이트를 쉽게
열 수 있습니다. 우리의 경우는 “Connect”입니다.
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화면에 표시되는 색상들은 위의 그림에서 보이는 것과는 다를 수 있지만 신경쓸 필요는
없습니다.

“View → Part Markings → Main(Additional) → Additional”을 선택해서 파트의 Marking으로
서 부가적인 필드들을 표시할 수 있습니다. 또한 Component Properties윈도우를 통해서도
변경할 수 있습니다(component에서 우-클릭하고 “Properties”를 선택합니다.



DipTrace Tutorial156

© 2011 Novarm Ltd.

Component table에서 멀티파트 부품을 선택합니다. 예전에 similar파트들과 파워 파트로
부품을 만들었습니다. 모든 similar파트들은 파트의 목록으로부터 하나의 항목을 사용해
서 배치될 수 있습니다(우리의 경우 “AN(4)”) 또는 별도의 파트들과 똑같은 방법으로도
배치할 수 있습니다. similar파트들에 대한 배치모드를 변경하기 위해서는 메인메뉴에서
“View → Group Parts”를 선택합니다.

“Auto VCC/GND”가 체크되었다면 파워파트는 자동적으로 배치될 수 있습니다. 또한
파트 목록으로부터 선택해서 수작업으로 디자인 영역에 배치할 수 있습니다.

파트들의 목록은 “Place All Parts”박스가 체크되어 있기 때문에 기본적으로 할성화되지
않습니다. 파트들의 목록을 보기위해서 그것을 언체크할 수 있습니다. 그러면 파트들은
별도로 분리되어 하나씩 배치하는 것이 가능하게 됩니다.
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선택한 파트와 파트들의 수는 Component table에서 볼 수 있습니다.

“AN(4)”를 선택하고 디자인 영역에 몇개의 파트 배치를 시도해 보십시오. 프로그램은
자동적으로 component의 파트그룹으로부터 파트를 선택하고 파워 심볼을 배치합니다. 
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이제 Net Port를 사용해 보겠습니다. 2개의 And-Not component(IC1과 IC2)와 2개의
파워 심볼을 배치합니다. 그런다음 라이브러리에서 VCC 심볼을 선택하고 2개의 파트를
배치합니다. GND도 똑같이 하고 pin들을 연결합니다. Net Port(Component Editor에서는
“Name”)는 Component table에 표시가 되며 똑같은 Type으로 정의하거나 wire로 서로
다른 net port들을 연결함으로서 하나로 결합할 수 있습니다.

마우스포인터를 VCC나 GND에 연결된 wire로 이동합니다. 그러면 단일(같은) net에
속하는 심볼들에 연결된 모든 wire들이 하이라이트되는 것을 보게 될 것입니다.



Creating Libraries 159

© 2011 Novarm Ltd.

VCC pin들에 연결된 Net의 이름을 변경하기 위해서는 wire에서 우-클릭해서 첫 항목을 
선택하거나 또는 핀에서 우-클릭하고 “Net Name”을 선택합니다.

Component Editor를 사용함이 없이 별도의 심볼들로부터 다중파트 부품을 구성하고
pattern들을 첨가할 수 있습니다. 간단히 Component Properties대화상자에서 “Enable Parts”
박스를 체크합니다(파트위에서 우-클릭 한다음 “Properties”를 선택) 그리고 심볼들에
같은 RefDes을 정의한다음 연관된 pattern과 패드의 pin에 대한 연결을 정의하기 위해서
Attached Pattern”버튼을 클릭합니다.

Wire없이도 pin들을 net에 연결할 수 있습니다(pin에서 우-클릭, “Add to Net”대화상자에서
net를 선택하고 “Connect without wire”에 체크하고 “OK”를 클릭), 또한 Net의 이름과 속성
을 변경하기 위해서 Net Properties대화상자의 다양한 옵션을 이용할 수 있습니다. 

이러한 기능들은 밑에 자세히 묘사되어 있습니다.

4 다른 유용한 기능들 사용하기

튜토리얼의 이부분은 위에서 리뷰되지 않은 중요한 기능들을 설명하게 될 것입니다.
아직 DipTrace의 모든 기능들을 상세하게 묘사하지 않았기 때문에 하나씩 하나씩
확장 해 나가게 될 것입니다.
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4.1 Connecting

4.1.1 Buses와 Bus Connectors로 작업하기

이 섹션은 Schematics에서 버스들을 사용하는 법과 버스 커넥터들로 sheet들을 연결하는
법을 보일 것입니다. 이 튜토리얼의 전 단계에서 우리가 만들었던 회로나 또는 새로운
하나를 만들어서 작업할 수 있습니다.

메인메뉴의 “Objects → Circuit → Place Bus”(Objects toolbar의 “Place Bus”버튼)를 선택해
서 디자인 영역에 버스를 배치합니다. 배치를 완료하기 위해서는 우-클릭하고 “Enter”를
선택합니다. 버스배치 모드에서 default 모드로 돌아가기 위해서 우-클릭합니다. 
파트의 pin에 마우스포인터를 위치시키고 좌-클릭 후 wire가 버스에 연결되도록 버스에서
좌-클릭합니다.

“Add to Bus”대화상자에서 버스에 연결되는 새로운 net의 이름을 정의하거나, 현존하는
net들 중의 하나에 wire를 연결할 수 있습니다.

우리는 wire들을 현존하는 net에 연결하지 않았습니다. 그래서 버스에는 연결되었지만
서로에게는 연결되지 않은 4개의 다른 wire들(Net 0 ~ Net 3)을 가집니다. 원한다면 
언제든지 버스 연결에 대한 wire를 변경할 수 있습니다.
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Schematic에 새로운 sheet를 추가합니다. 메인메뉴의 “Edit → Add Sheet”(“Ctrl+L”)를
클릭합니다. Schematic윈도우의 가장 아래, 왼쪽 구석에서 sheet들의 목록을 볼 수 있습
니다. “Sheet 2”를 선택합니다.
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Sheet탭에서 우-클릭해서 schematic sheet의 이름을 바꾸거나 삭제할 수 있습니다. 물론
현존하는 2개의 sheet들 사이에 새로운 sheet를 삽입할 수 있습니다. 팝업메뉴에서 항목을
선택합니다. 

Objects toolbar에서 “Bus Connector”(메인메뉴의 “Objects → Circuit → Place Bus
Connecetor”)를 선택해서 빈 sheet에 배치합니다(그것은 “Port 0”의 이름을 가져야 합니다)
Sheet-tab에서 sheet를 Sheet 1으로 변경합니다. 그리고 거기에 bus connector를 배치합니다.
(“Port 1”이 되어야 합니다) 현존하는 버스를 버스 커넥터에 연결합니다. 버스위에서
좌-클릭해서 마우스포인터를 버스 연결점(blue circle)으로 이동하고 좌-클릭합니다.
버스가 커넥터에 제대로 연결되면 blue circle은 green으로 색이 변합니다.
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“Port 1”위로 마우스를 이동하고 우-클릭해서 팝업메뉴로부터 첫 항목을 선택하여 버스
커넥터의 이름을 “Port 0”으로 변경합니다.(그것은 sheet 2위에 배치됩니다) 당신은 port의
이름을 둘러싸는 상자가 나타난 것을 볼 수 있습니다. 이것은 현재의 버스 커넥터가 다른
버스 커넥터에 연결되었다는 것을 의미합니다. 우리의 경우에는 Sheet 1의 버스를
Sheet 2에 연결했습니다.

또한 같은 이름으로 정의함으로써 2개 이상의 버스 커넥터들을 서로 연결할 수 있습니다.
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"Sheet 2"를 선택하고 거기에서 “Port 0”에 연결된 버스를 생성합니다.

Sheet2에 있는 버스 이름은 Sheet 1에 있는 버스와 같게 됩니다(i.e. 이것은 공통버스입니
다) 이제 두번째 sheet에 파트들을 배치하고 그들의 pin을 “Net 3”에 연결하거나 또는
다른 net에 연결합니다. 아니면 새로운 net를 생성합니다.
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4.1.2 Net Ports으로 작업하기

우리는 이미 VCC와 GND연결을 만들기 위해서 net port의 사용을 시도 했습니다.
대부분의 경우 그들은 그 방식으로 사용됩니다. 그러나 또한 몇개의 pin들이 있는
Net port들을 사용해서 다중 연결을 만들 수 있습니다.

두번째 sheet에 더 많은 파트들을 배치합니다. 그러나 그들의 핀들을 버스에 연결하지
마십시오. Libraries toolbar에서 “Port_Sch”를 선택합니다(필요하다면 라이브러리들을
스크롤합니다) “Port 8”을 찾아서 디자인 영역에 그것을 배치합니다.

파트들로부터 Port 8로 wire를 연결합니다. 그런다음 첫번째 sheet에 Port 8을 배치하고 
첫번째 sheet에 위치한 파트들 역시 Port 8에 연결합니다. “Sheet 1”과 “Sheet 2”에 있는
Port 8의 같은 pin에 연결된 net이름이 똑같다는 사실을 주의하십시오. 커넥터의 이름을 
바꾸거나(i.e. 회로구조를 쉽게 변경할 수 있습니다) 또는 Net Port Properties에서 “Type”을
변경(우-클릭하고 Properties에서 첫항목을 선택)해서 port들을 연결하거나 그 연결을
끊을 수 있습니다.
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4.1.3 Wire없이 연결하기

Pin들을 wire없이 연결할 수 있습니다. 이 경우 그들은 sheet나 파트의 위치에 의존하지
않습니다. 마우스포인터를 pin위로 이동합니다. 그것은 아직 연결되어 있지 않습니다.
우-클릭해서 팝업메뉴로부터 “Add to Net”을 선택합니다. Net를 선택하고 “Connect
without Wire”에 체크한 후 OK를 클릭합니다. 밑의 그림에서 당신은 wire없이 “Net 0”와
“Net 1”에 연결된 2개의 pin들을 볼 수 있습니다.
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이제 디자인에서 빈영역으로 스크롤합니다. pin들을 이름에 의해 net에 연결되도록 시도
할 것입니다. “Port_Sch”라이브러리로부터 하나의 GND심볼을 배치합니다. 그런다음 
마우스포인터를 그것의 pin으로 이동합니다. wire의 생성을 위해서 좌-클릭하고 마우스
포인터를 약간 위로 이동한 후 Enter키를 누릅니다. GND에 연결된 wire 조각에서 우-클릭
하여 Properties를 선택합니다.
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Net Properties대화상자에서 net를 GND로 이름변경하고 “Connect Net to Pins by Name”에
체크합니다. 변경사항들을 적용하기 위해서 OK를 클릭하고 윈도우를 닫습니다.

이제 “AD”(Analog Devices)라이브러리를 선택하고 “AD1317KZ”(“Find Part in Library”에서
“AD1317”을 입력하고 엔터)를 찾아서 그것을 2~3개 추가합니다.

배치되는 component에서 pin이름이 GND인 모든 pin들은 wire없이 자동적으로 GND net에
연결된다는 것에 주의하십시오. 또한 net에 대한 속성을 변경할 때 프로그램은 net이름과
같은 이름의 연결되지 않은 pin들이 있는지 모든 현존하는 파트들을 검사합니다.

이 기능은 모든 schematic에 대해서 같은 이름을 가지는 pin들을 연결하는 가장 쉬운 방법
입니다. 이런 방법은 power, clock, 심지어 data buse에서도 사용될 수 있습니다.
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Schematics에서 당신은 net port나 버스들이 없이 다른 sheet들 사이에서 논리적으로 net를
연결할 수 있습니다. 그것은 간단하게 “Connect Nets by Name”기능으로 가능합니다.
단지 Sheet 1으로부터 몇개의 net를 선택하고 그것의 이름을 기억합니다(우리의 경우
Net 14) 그런다음 Sheet2로 가서 net에서 우-클릭 합니다. 당신은 첫번째 sheet로부터 net에
연결하기를 원합니다. “Properties”를 선택하고 첫 sheet의 net(“Net 14”)와 같은 이름을
입력합니다. 같은 대화상자에서 “Connect Nets by Name”에 체크하고 OK를 클릭합니다.
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계층의 수준이 서로 다른 경우에는 “Connect Nets by Name”으로 연결할 수 없습니다. 
그러한 경우에는 global net들을 만들 수 있습니다. 우리는 후에 Hierarchical Schematics
서브섹션에서 그들을 사용하는 방법을 배우게 될 것입니다.

4.1.4 Connection Manager in Schematic and PCB Layout

Schematic과 PCB Layout에서 연결들을 만들기 위한 방법중의 하나는 Connection Manager
를 사용하는 것입니다. 그것을 열기 위해서는 Schematic에서는 메인메뉴에서 “Objects → 
Connection Manager”를 선택하고, PCB Layout에서는 “Route → Connection Manager”를
선택합니다.

Schematic에서 Connection Manager를 오픈합니다. Connection Manager윈도우에서 net를
선택합니다. net에 연결된 모든 pin들을 보게 될 것입니다. 당신은 net으로부터, 또는 net에
쉽게 pin들을 더하거나 삭제할 수 있습니다. pin을 추가하기 위해서는 파트를 선택하고
바로 밑에서 그것의 pin들 중 하나를 선택한다음 “Add”를 클릭합니다. 오직 연결되지
않은 pin들만이 거기에 보이게 됩니다. 만약 당신이 필요로 하는 pin을 발견할 수 없다면
그것은 이미 연결되어 있을 것입니다. “+”버튼을 클릭해서 새로운 net를 생성할 수 있습
니다.

"..."버튼은 현재의 net이름을 변경합니다. 그리고 "X"버튼은 현재의 net를 삭제합니다.
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모든 변경사항들을 적용하기 위해서 OK를 클릭하고 Connection Manager를 닫습니다.
그리고 예전의 net 구조를 복구합니다.

4.2 Reference Designators

이제 우리는 “My Documents\DipTrace\Examples”에 위치한 회로 예제들로 작업을 하게 
될 것이다.

예제 폴더에서 “Schematic_2.dch”를 오픈합니다.
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이 회로도에서 당신은 우리의 전자 엔지니어에 의해서 만들어진 서로 다른 유형의 pin
연결을 볼 수 있습니다. 그러나 우리는 그것이 작동하는 방법을 보이기 위해서
reference designator들로 몇개의 실험들을 하게 될 것입니다. 

현재의 회로도는 C1부터 C24까지(C19는 없음) 23개의 capacitor들을 포함합니다. 회로의 
수정을 시도하려고 할때..., 예를 들면 당신이 최근에 생성한(My Library) 라이브러리로부
터 capacitor C5를 어딘가에 삽입하기 위한 필요가 있을 때를 생각합니다. 이제 배치를
시도 해 보도록 합니다. 그것은 우리의 C5가 될 것입니다. 그러나 현재 그것은 C19
designator을 가집니다. 그 capacitor에서 우-클릭하고 팝업메뉴에서 첫 항목을 선택합니다.
“C5”를 입력하고 OK클릭합니다. 프로그램은 경고 메시지를 보이며 RefDes의 번호 변경
을 제안할 것입니다. “Yes”를 클릭합니다. 
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Capacitor는 C5로 변경 되었고, 예전의 C5는 C6이 되었습니다. 이제 Connection 
Manager에 C19 designator가 있는 것을 볼 수 있습니다. C5를 삽입했기 때문에 C5~C18이
C6~C19로 번호이동 되었습니다. 똑같은 방식으로 당신은 어떤 component라도 배치할 수
있고 다른 것들을 번호이동 시킴으로서 designator를 수정할 수 있습니다.

C5를 C30으로 변경하고 Design Manager에서 capacitor의 designator들을 체크합니다(
Design Manager를 표시하거나 감추기 위해서 F3키,  designator를 확인하기 위해서 “Parts”
버튼, 정렬하기 위해서 “Sort Parts”버튼을 클릭합니다) C5와 C25~C29가 빠져 있습니다.
이것을 수정하기 위해서 임의의 capacitor에서 우-클릭하고 “Optimize RedDes → RefDes C
”를 선택합니다. 이제 C30은 C24가 되었습니다. 최적화 동안에 RefDes프로그램은 
designators배열에 있는 모든 빈 공간들을 제거하고 C6-C24는 C5-C23으로, C30은 C24가
되도록 변경합니다.
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디자인 전체를 보다 더 쉽게 알수 있도록 회로의 레퍼런스 designator들을 renumber할
필요가 있습니다. 그런 목적으로 DipTrace는 편리한 “RefDes Renumbering...”기능을 가지
고 있습니다. 메인메뉴에서 “Tools → RefDes Renumbering...”을 선택합니다. RefDes 
renumbering대화상자에서 행이나 열의 방향 및 번호를 어떻게 할당 할 것인지 등의 설정
을 지정할 수 있습니다. 우리의 회로들에는 다른 수의 component들이 있다는 것을 알고
있습니다. 대화상자의 Component Position에서 “Top-Left”를 선택한다면 DipTrace는
component의 좌측상단 구석의 위치를 기준으로 component들을 renumber하게 됩니다.
“Origin”을 선택한다면 그것은 component의 원점을 사용하게 될 것입니다. 모든 번호 재
할당은 왼쪽에서 오른쪽으로, 그리고 위에서 아래로 진행됩니다. OK를 클릭하면
component들의 RefDes번호들이 재 할당되게 됩니다.
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오직 하나의 RefDes component만을 번호 재 할당하려 한다면, 그 component에서 우-클릭
하고 팝업메뉴로부터 “RefDes Renumbering...”을 선택합니다. 일반적인 RefDes
renumbering대화상자를 보게 될 것입니다. 이곳에서 선택한 component의 RefDes만을,
또는 모든 component들의 RefDes를 renumbering할 수 있습니다. 또한 PCB Layout에서도
RefDes renumbering기능을 사용할 수 있습니다.

이제 저장하지 않고 Schematic을 종료합니다. 그리고 PCB Layout을 실행합니다. 예제폴더
로부터 PCB_2파일을 오픈합니다. 보드의 위쪽에 있는 C8과 C10을(그들을 발견하기
위해서 Design Manager를 사용할 수 있습니다. - 디자인 영역에 있는 component를 발견하
기 위해서 component이름을 더블클릭합니다) C28과 C30으로 변경합니다.(우-클릭하고
첫항목을 선택) “File → Sace As”를 선택하고 다른 곳에 변경된 PCB파일을 저장합니다.
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PCB Layout을 닫고 Schematic Capture를 다시 오픈합니다(메인메뉴의 “Tools →
Schematic”을 선택해서 PCB Layout으로부터 직접 오픈할 수 있습니다. 그러나 Win98/ME
에서는 이방법을 권장하지 않습니다)

“Schematic_2.dch”파일을 열고 C8과 C10을 찾습니다. 그것을 발견하기 위해서 Design
Manager를 사용하거나 “Ctrl+F”(메인메뉴의 “Edit → Find Object”)를 사용할 수 있습니다.
Find Object대화상자에서 “c8”을 입력하고 엔터를 치면 C8이 디자인 영역 가운데에 배치
되고 하이라이트됩니다.
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Parameter왼쪽 옆에 있는 화살표를 클릭해서 “Find Object”윈도우의 최소화가 가능하고
모든 선택사항들을 보임이 없이 디자인을 수정하는 동안에 사용할 수 있습니다. 

C8과 C10이 보다 더 잘 보이도록 회로를 확대합니다.

PCB_2는 Schematic_2와 연관된 디자인이고, Schematic에서 일부 capacitor들의 RefDes를
변경했습니다. 그것은 PCB Layout에서도 가능합니다. 그러나 복잡한 프로젝트를 디자인
하는 동안에 수백개의 component들을 변경한다면 그들의 예전 designator들을 기억하지
못할 것입니다.

이러한 경우에 우리는 Back Annotate기능을 사용할 수 있습니다. 메인메뉴에서 “File → 
Back Annotate”를 선택하고 저장한 PCB 파일을 대화상자에서 선택합니다. net의 이름
과 net class들 또한 PCB로부터 back annotate됩니다.

이제 당신은 회로도에 있는 모든 designator들이 PCB에 맞추어서 변경되어 있는 것을 볼
수 있을 것입니다.
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4.3 Libraries에서 component찾는 법

DipTrace 2.2는 표준 라이브러리에 수천개의 부품들을 포함합니다. 우리는 이러한
라이브러리들을 점차적으로 확장해 나갈 것입니다. 라이브러리들은 제조사와 component
에 따라서 분류되고 정렬됩니다. 그러나 때로는 일부 부품의 제조사를 모르거나 다수의
제조사들에 의해서 생산되기도 합니다. 또한 부품의 완전한 이름을 모를 수도 있습니다.
이런 경우 부품들을 보다 더 쉽게 찾을 수 있도록 DipTrace모듈들은 특별한 기능을 가지
고 있습니다.

Schematic에서 메인메뉴의 “Objects → Find Component”를 선택합니다. 예를 들어 우리는
이름에 “232”를 포함하는 어떤 부품을 필요로 하지만 그것이 한달 전에 친구가 추천 한 
것이기 때문에 다른 것은 기억나지 않습니다. 그러면 “Name”필드에 “232”을 입력하고
“Find Now”를 클릭합니다.

수초내에 프로그램은 결과로서 “232”를 이름에 포함하고 있는 194개의 부품들을 보여
줄 것입니다. 또한 symbol과 pattern 및 라이브러리를 함께 볼 수 있습니다. “Place”버튼을
클릭해서 검색 윈도우로부터 직접 선택한 파트(component)를 배치할 수 있습니다.

Active 라이브러리에서 검색했지만 원하는 라이브러리들을 선택할 수 있습니다
(“Search In”그룹에서 적절한 항목을 선택합니다)

라이브러리 목록은 “Search In: Selected”로 지정되었을 때 활성화됩니다.
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Schematic과 Component Editor에서는 component라이브러리들을 검색할 수 있습니다.
(“Component → Search in Libraries”) 그리고 PCB Layout과 Pattern Editor에서는 pattern
(footprint) 라이브러리를 검색할 수 있습니다(“Pattern → Search in Libraries”)

또한 검색기능은 부품이나 패턴들을 라이브러리에서 찾기 위한 필요가 있는 모든 곳에
포함되어 있습니다. 그러나 그런 대화상자들은 오직 라이브러리 목록을 통해서만 찾는
것을 허용합니다.

4.4 Electrical Rule Check

Electrical Rule Check (ERC)기능은 schematic을 디자인하는 동안에 에러의 가능성을 줄이
는데 도움을 줄 수 있을 것입니다. Schematic Capture에서 예제 폴더로부터 “Schematic_2
.dch”를 오픈합니다. 먼저 우리는 electrical rules을 정의해야 합니다. 메인메뉴에서
“Verification → Electrical Rule Setup”을 선택합니다.

대화상자에서 green, yellow, red의 사각형들이 있는 cell들을 클릭하여 ERC를 실행하는
동안 error나 warning의 원인이 되는 부적합한 pin to pin연결들을 정의할 수 있습니다.
“Rules to Check”박스에 있는 “Pin Type”항목은 그리드 cell에서 정의된 pin-to-pin연결들을
검사한다는 것을 의미합니다. “Not Connected”는 연결되지 않은 pin들을 찾습니다.
“Only One Pin in Net”은 오직 하나의 pin이 있는 net들을 찾습니다.(i.e. 어떤 의미를 가지지
못하는 net는 net구조에서 잠재적인 error가 될 수 있습니다) “Short Circuit”은 power와
GND가 연결된 것을 찾습니다. “Power Pins for SC”그룹에서 power와 ground pin에 대한
Mask를 정의할 수 있습니다.
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변경없이 모든 설정들을 보존하고 대화상자를 닫기 위해서 OK를 클릭합니다.

이제 메인메뉴에서 "Verification → Electrical Rule Check (ERC)"를 선택합니다. 
Schematic_2에 대해서 검사를 한다면 그것은 “Bidirectional to Output”연결에 대해서 하나
의 warning과 “Not Connected” pin들에 대한 Error들을 보이게 될 것입니다. 회로상의 error
를 localize화 하기위해서 그것 위에서 더블클릭합니다. 해상도가 충분하게 높은 경우에
디자인 영역에 하이라이트된 net와 pin들을 보게 될 것입니다. ERC results윈도우를 닫지
않고도 그 error들을 수정해서 다시 ERC를 실행할 수 있습니다.
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연결되지 않은 pin들의 error 수정을 원한다면 원래 연결을 필요로 하지 않는 pin들을
지정할 수 있습니다(i.e. ERC는 그것을 error로 다루지 않아야 합니다) 그 pin들 중의 하나
에서 우-클릭하고 어떤 net에 연결되는 것을 막기 위해서 팝업메뉴의 “Not Conneted”를
선택합니다. 그리고 다시 ERC를 실행합니다.

4.5 Bill of Materials (BOM)

DipTrace Schematic은 column과 row들을 커스터마이즈하고, 현존하는 프로젝트에
테이블이나 페이지를 추가할 수 있습니다. 적절한 table formatting으로 Excel CSV format에
파일을 내보내거나 텍스트로서 저장할 수 있습니다.

메인메뉴에서 “Objects → Bill of Materials”를 선택합니다. “Table Rows”는 “Component
Type”으로 지정하고 밑의 그림에서 볼 수 있는 설정으로 column들을 추가합니다. Sheet
template박스에서 “Create On: New Sheet”와 “ISO A4”를 선택합니다. 페이지 폭에 따라서
테이블이 조정되도록 “Adjust by Width”를 체크합니다. 프로젝트에 ISO타이틀과 BOM
테이블이 있는 새로운 A4 sheet를 추가하기 위해서 “Place Table”버튼을 클릭합니다.
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BOM대화상자가 닫혀지고 당신의 디자인에 새로운 sheet가 추가됩니다. “Sheet 2”를 선택
합니다. “View”메뉴를 사용해서 titles와 sheet를 표시하고 문자열의 길이가 column폭을 
넘어가는 cell들을 위해서 열의 높이와 line의 수를 수정합니다.(cell에서 좌-클릭 후
텍스트와 열의 높이를 변경합니다)
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이제 우리는 부가적인 sheet에 BOM테이블을 가지고 있고 프로젝트로서 인쇄할 수
있습니다.



DipTrace Tutorial184

© 2011 Novarm Ltd.

또한 회로도가 있는 sheet에 테이블을 배치할 수 있습니다. “Create On: Current Sheet”,
“Place Table”을 누르고 대화상자가 닫혀진 후에 테이블 위치를 선택합니다(디자인 영역
에서 좌-클릭) 많은 부품들이 있는 multi-sheet 회로도를 가진다면 각각의 회로도 페이지
에 분리된 테이블을 생성하는 것이 가능합니다.
BOM대화상자로부터 또는 그것을 수정한 후에 배치된 테이블로부터 직접 파일을 내보
낼 수 있습니다(BOM대화상자를 통해서는 불가능한 어떤 것을 추가할 필요가 있을 때)
Schematic과 PCB Layout에 있는 테이블들은 CSV나 서식있는 텍스트로 쉽게 저장될 수
있습니다. 현존하는 테이블에서 우-클릭하고 테이블의 팝업메뉴에서 “Save to File”을
선택합니다. 

4.6 Importing/Exporting netlists

DipTrace는 다양한 format의 netlist를 생성해서 다른 소프트웨어 패키지들로 그들을 전송
하거나 또는 다른 프로그램들로부터 netlist를 불러오는 것이 가능합니다.
내보내기 된 netlist는 노트패드나 다른 텍스트 에디터를 통해서 schematic파일의 net구조
를 review하기 위해서 사용될 수 있습니다. Schematic에서 netlist를 내보내기 위해서는
메인메뉴에서 “File → Export → Netlist”를 선택하고 netlist의 타입을 지정합니다. netlist는
현재의 Schematic윈도우에 열려진 drawing으로부터 생성됩니다.
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다른 프로그램에 의해서 생성된 Tango format의 netlist를 불러오는 방법을 알아 보도록
하겠습니다. 그것을 하기 위해서는 PCB Layout에서 새로운 문서를 오픈합니다. 그리고
“File → Import → Netlist → Tango Netlist”를 선택해서 “My Documents\DipTrace\Examples”
폴더로부터 tango_1.net파일을 오픈합니다. 프로그램은 netlist에 포함된 pattern들을 발견
하려고 시도할 것입니다(약간의 시간이 소요됩니다) RefDes와 pattern이름이 있는
부품들의 목록 윈도우가 나타납니다.
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첫 column에서 우리는 부품들의 RefDes을, 두번째 column에서 그들의 Pattern을, 그리고
세번째 column에서 부품들의 Type을 볼 수 있습니다. 만약 프로그램이 선택된 부품에
대한 pattern을 발견할 수 없었다면 밑의 Pattern 필드에 “none”텍스트가 나타납니다.
예를들어 목록에서 첫번째인 부품 C41은 DipTrace라이브러리에는 포함되지 않은
CAP225 Pattern을 가집니다. 이러한 경우 당신은 그 pattern을 포함하는 라이브러리를
선택하거나 대체 pattern을 선택할 필요가 있습니다. 부품에 pattern을 첨가하기 위해서
Add를 클릭합니다. 

대화상자에서 라이브러리를 선택하고 선택한 라이브러리에서 패턴을 지정해야 합니다.
OK를 클릭하면 지정된 pattern은 부품 C41에 첨부될 것이고 그것의 이름과 library 이름이
Pattern field와 라이브러리에 보여지게 됩니다.

Pattern을 타입에 의해서 첨부하거나 또는 한번에 같은 pattern속성을 가지는 모든 부품에 
첨부할 수 있습니다. 이 기능을 사용해서 목록에 있는 모든 부품에 pattern을 첨부합니다
패턴이 첨부된 부품들은 pattern이름 끝에 “star”심볼이 표시됩니다. 만약 부품에 pattern
이 첨부되지 않았다면 그것은 불러오기가 되지 않기 때문에 모든 부품들이 첨부된
pattern을 가지고 있는지 확인해야 합니다.

당신은 또한 netlist에 있는 부품에 대해서 pin번호와 그들의 양을 기억해야 합니다.
그리고 첨부된 pattern의 패드 번호들이 일치하는지 확인해야 합니다.

불러오기를 완료하기 위해서 Import를 클릭합니다. 만약 netlist가 첨부된 pattern이 없는 
부품들을 가진다면 그에 따르는 메시지를 표시하게 됩니다. 불러오기를 취소하기 
위해서 “No”를 선택하고 모든 pattern들을 첨부하거나 또는 일부 pattern없이 불러오기를
실행하기 위해서 “Yes”를 클릭합니다.
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4.7 Saving/Loading Design Rules

회로를 PCB로 변환하는 동안 Schematic rules을 사용하거나 임의의 PCB layout으로부터
rules을 로드할 수 있습니다.

이제 새로운 layout의 생성을 시도할 것입니다. 메인메뉴에서 “File → New”를 선택하거나
단축키 “Ctrl+N”을 입력합니다. 팝업 윈도우에서 empty layout을 생성하도록 선택할 수
있습니다. 또한 이전 프로젝트의 설정들을 사용할 수 있습니다.

"Use Settings from Previous Layout"을 체크하고, "Browse"를 눌러서 이 튜토리얼에서
우리가 작업해 왔던 layout의 *.dip파일을 선택합니다. “Open”을 누르고 OK를 클릭합니다.
그 프로젝트는 새로운 것이지만 당신의 이전 PCB Layout으로부터 모든 layer들과,
via style, 그리고 net클래스 설정들을 동일하게 물려받게 됩니다.
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DipTrace에서는 PCB layout의 설정(layers, via styles, net classes)들을 PCB Layout파일과는
별도로 하나의 파일로 저장할 수 있습니다. “Route → Save Rules”로 가서 파일의 이름을
입력하고 Save를 클릭합니다. 새로운 프로젝트를 생성하는 동안에 이 파일로부터 rules와
설정들을 재-사용할 수 있습니다. “Route → Load Rules”로 가서 *.dip이나 *.rul파일을
선택합니다.

4.8 Spice simulation
DipTrace는 자체적인 simulator를 가지고 있지 않습니다. 그러나 spice설정을 정의하고
netlist를 simulation 소프트웨어로 내보내는 것이 가능합니다. 우리는 LT Spice를 사용해서
astable flip-flop회로의 시뮬레이션을 시도할 것입니다. 무료이고 값비싼 전문적인
시뮬레이터에 비견할 만하기 때문에 시뮬레이션을 위해서 LT Spice를 사용할 것을
권장합니다. 그러나 다른 프로그램을 가지고 있다면 그것을 사용할 수 있습니다.

이제 Schematic프로그램을 실행하고 “My Documents\DipTrace\Examples\Spice\Astable
_Flip_Flop_Spice.dch”을 오픈합니다. 우리는 이미 이 회로의 모든 spice설정들을 정의
했습니다. 그러나 설정하기 위한 방법을 배우기 위해서 한쌍의 파트들을 리뷰 할
것입니다. C2 capacitor에서 우-클릭하고 그것의 팝업메뉴에서 “Spice Settings”을
선택합니다. capacitor를 정의하는 것은 매우 간단합니다 “Model Type: Capacitor”를 선택
하고 Parameters 테이블에 값을 입력합니다(우리의 경우에 22uF) 그리고 positive와
negative pin을 지정합니다. pin을 지정하기 위해서 왼쪽의 pin-to-signal테이블에 값을 입력
해야 합니다. 이용 가능한 signal들의 목록은 바로 밑에 위치해 있습니다.

당신은 매개변수의 값을 테이블 셀에 직접 입력 할 수 있습니다. Template필드는 부품이
Spice netlist에서 어떻게 보이는지를 알려줍니다.
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이제 임의의 다른 모델 타입(예를 들어 Current Source)을 선택해 보십시오. 만약 당신이 
Current Souce를 선택한다면 그것에 대한 기능을 지정할 수 있습니다(PWL을 선택)
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PWL기능에 대한 point의 수를 입력하고 OK를 클릭합니다. 이제 parameters테이블에 값을
하나씩 입력하는 것이 가능합니다. 다른 기능들은 다른 parameter들을 요구합니다.
(amplitude, phase, etc) 상세한 설명을 위해서는 Spice명세서를 보시기 바랍니다. 이제
capacitor로 돌아가서 그것의 값을 정의하고 OK를 클릭합니다.

Capacitor는 function의 부가적인 모델묘사를 필요로 하지 않습니다. 그래서 그들의
Parameter들을 간단히 정의합니다. 이제 Q1에서 우-클릭하고 Spice설정들을 선택합니다.
당신은 “Parameters”근처에 나타난 “Model”탭을 볼 수 있습니다. 그것을 선택합니다.
이곳에서 모델 텍스트를 입력하거나 외부의 파일로부터 그것을 로드할 수 있습니다.
몇몇 부품 제조사들은 그들의 부품들에 대한 Spice모델들을 제공하기 때문에 그것을
그대로 사용할 수 있습니다.
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또한 다른 DipTrace라이브러리로부터 Spice설정들을 얻을 수 있습니다(“Get Spice Model
from Library”버튼) OK나 Cancel을 클릭합니다.

우리가 로드한 파일은 power소스에 대한 유효한 Spice모델을 가지고 있지 않습니다.
그래서 그것을 정의해야 합니다. B1에서 우-클릭해서 Spice설정을 선택합니다. Voltage
소스를 가지고 있지만 function이 유효하지 않다는 것을 알 수 있습니다. “Function: Pulse”
를 선택하고 Pulse V2=5, Pulse PW=20s, Pulse PER=30s와 같이 입력하고 OK를 클릭합니다
이제 처음에는 20s동안, 그런다음 10s간격으로 5V를 출력하는 voltage소스를 가지게
되었습니다. 시뮬레이션을 위한 모든 준비가 완료되었습니다.

메인메뉴에서 “File → Export → Spice Netlist”를 선택합니다. 작은 대화상자에서 GND net
(이것이 우리의 zero점입니다)을 선택하고 “Commands”에서 “.TRAN 0s 30s 0.1s”을 입력
합니다. 이것은 0.1s간격으로 0s에서 30s까지 시뮬레이트한다는 것을 의미합니다.
또한 당신은 LT Spice에서 직접 command들을 정의하거나 변경할 수 있습니다.
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LT Spice를 실행합니다. 아직 가지고 있지 않다면 “http://www.linear.com/designtools/
software/switchercad.jsp”에서 다운로드 가능합니다.

"File → Open in LTSpice"를 선택하고 방금 저장한 .cir netlist를 오픈합니다(정확한 파일
타입을 선택해야 합니다) 또한 텍스트 format으로 netlist를 볼 수 있습니다. “Simulate → 
Run”을 선택하고 error log윈도우를 닫습니다. “Plot Settings → Visible Traces”를 선택하고
led1을 선택합니다. 이제 당신은 다음의 그림과 같은 화면을 볼 수 있습니다.

이것은 LED1에서의 전류입니다. 우리가 보는 것처럼 처음 20초동안, 그런다음 10초 간격
으로 작동하는 것을 알 수 있습니다. 다른 signal들 역시 동일하게 추가할 수 있습니다.

4.9 Checking net connectivity

Prototyping전에 디자인 검증을 위한 가장 중요한 기능중의 하나는 net connectivity를 

http://www/
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검사하는 것입니다. 그것은 모든 net들이 연결되었는지를 검사해서 서로 연결되지 않은
영역들을 알려줍니다.(traces, thermals or shapes등 연결유형에 의존하지 않습니다)

이제 PCB Layout을 실행해서 “PCB_2.dip”파일을 “\DipTrace\Examples”폴더로부터 오픈
하고 “Verification → Check Net Connectivity”를 선택합니다. 대화상자에서 connectivity를
검사하는 동안에 connector들로서 사용할 object들을 정의할 수 있습니다. 일반적으로
모든 체크박스에 체크된 상태로 유지할 것을 권장합니다. OK를 클릭합니다.

Progress bar의 진행 이후 “No Errors found”메시지를 보게 될 것입니다. 디자인은 정확하고
우리는 이 기능이 어떻게 작동하는지 보기 위해서 몇개의 error들을 만들 것입니다.

Route패널에서 “Edit Traces”를 선택합니다. bottom layer에서 C16:2를 via와 GND의
Copper pour에 연결하는 trace로 마우스포인터를 이동합니다. 우-클릭해서 “Unroute Trace”
를 선택합니다(copper pour때문에 이러한 경우 연결이 감추어지게 됩니다)

두번째 error는 고립된 copper pour영역이 될 것입니다. bottom layer로 전환해서 디자인의
우측하단 코너까지 스크롤합니다. 이제 signal layer에 비아들 중의 하나가 고립되도록
두개의 shapes(arcs or lines)을 그립니다. 그리고 copper pour를 갱신합니다(copper pour에서
우-클릭하고 “Update”)
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현재의 error들은 직접 발견할 수 있는 간단한 error입니다. 그러나 다수의 layer와 수천개
의 pin들이 있는 복잡한 디자인이라면 isolated copper pour영역이나 연결되지 않은 pin들
을 발견하기가 무척 어렵게 됩니다.

이제 “Verification → Check Net Connectivity”를 선택하고 OK를 클릭합니다. 당신은 3개의
영역으로 분리되어 있는 Net 7의 connectivity검사 결과를 볼 수 있습니다.
첫번째 영역은 copper pour이고 모든 pin들은 그것에 연결됩니다. 두번째는 C16:2(SMD
pad가 있는 첫 error)입니다. 그리고 세번째는 isolated copper pour영역입니다.
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Correction과정을 보다 더  편안하게 만들기 위해서 텍스트 파일로 결과를 저장할 수
있습니다.

4.10 Placement features

DipTrace는 회로도로부터 PCB로 변환 후에 부품의 배치와 배치의 최적화를 더 쉽게할 
수 있도록 진보된 배치 기능과 통합되어 있는 auto-placer를 가지고 있습니다.  우리의
예제 중 하나를 사용해서 이러한 기능들이 작동하는 방법을 보일 것입니다. 이제 PCB
Layout을 실행하고 “File → Open”을 해서 “DipTrace\Examples\Schematic_4.dch”를 오픈
합니다. 아래와 같은 그림을 볼 수 있고 수작업으로 보드외곽의 내부로 부품들을 모두
배치하는데는 다소 시간이 걸린다는 것을 알 수 있습니다.
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DXF파일로부터 보드의 외곽을 불러와 보도록 하겠습니다. 메인메뉴의 “File → Import → 
DXF”를 선택하고 “DipTrace\Examples\outline.dxf”파일을 오픈합니다. 대화상자에서 불러
오기 하려고 한 DXF파일을 볼 수 있습니다. “Board Outline” layer를 선택하고
“Convert to: Board Outline”을 선택합니다.
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Closed area를 채울 수 있고 필요하다면 embedded closed area를 사용해서 그것에 hole을
cut할 수 있습니다(일반적으로 DXF design들은 fill없이 outline로부터 만들어 집니다)
이러한 기능들은 copper와 mask/paste layer들에만 작동합니다.

Board outline을 현존하는 layout에 추가하기 위해서 “Import mode: Add”를 선택합니다.
그리고 DXF윈도우의 좌측상단에 있는 “Import”버튼을 클릭합니다. 보드외곽을 볼 수
있지만 부품들은 아직 혼란한 상태입니다. 먼저 우리는 부품들을 약간 정리할 것입니다.
메인메뉴에서 “Placement → Placement Setup”을 선택합니다.
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보드외곽 근처에 부품들을 정돈하기 위해서 “Place Patterns Outside the Board Outline”에
체크합니다. 당신이 유지해야 할 다른 것이나 또는 간단하게 위의 그림처럼 설정합니다.
(값들이 mm라는 사실에 주의하고 이것은 “View / Units”에서 변경할 수 있습니다)
변경을 적용하기 위해서 OK를 클릭하고 Placement toolbar에서 “Arrange Components”버튼
을 클릭하거나 메인메뉴에서 “Placement → Arrange Components”을 선택합니다.



Using different package features 199

© 2011 Novarm Ltd.

모든 부품들은 이제 보드외곽 근처의 한 장소에 위치해 있습니다. 메인메뉴에서
“Placement → Placement by List”를 선택합니다. 목록으로부터 부품 하나를 선택하고 
마우스포인터를 보드외곽의 내부로 이동합니다(왼쪽버튼을 누르지 않고) component가
마우스를 따라다니게 됩니다. 배치하기 위해서 보드외곽의 내부를 클릭합니다.

부품이 목록에서 사라지게 됩니다(그 목록은 단지 보드외곽 바깥쪽에 있는 부품들만을
보여줍니다) 같은 방법으로 U1, U2, U3, J1, J8, J12, RN1과 RN2를 배치합니다.
(F12를 사용하거나 또는 Design Manager의 Objects탭으로부터 그들을 숨김으로서
연결의 최적화를 할 수 있습니다.) 우리는 부품들이 변경될 수 없는 고정된 위치를
가진다고 가정합니다. “Placement by List”대화상자를 닫습니다. U3를 제외하고 모두 
선택해서 lock합니다(Ctrl+L) 또한 U3에서 우-클릭하여 Properties를 선택합니다. 그런다음
Placement탭으로 가서 Spacing의 Use에는 “Custom”을, Value에는 “20”(이것은 U3에
custom clearance를 사용할 것이며 다른 부품들은 그것에서 20mm이상 떨어진 곳에
위치되어야 한다는 것을 의미합니다)을 입력하고 OK를 클릭합니다. 그런다음 U3 역시
lock합니다.
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이제 다른 모든 부품들을 5mm간격으로 자동-배치하게 될 것입니다. “Placement → 
Placement Setup”을 선택하고 X Spacing과 Y Spacing을 5mm로 수정합니다. 또한 Pattern
Rotation이 가능하도록 체크되어 있는지 확인합니다.(때로는 그것을 off하는 것이
유용합니다. 예를 들어 jumper들이 특정 방향을 가지는 점퍼와이어들이 있는 단면보드들
) “Place Patterns Outside the Board Outline”을 uncheck하고 “Use Pattern Spacings”는
U3에 대해서 20mm clearance를 사용하도록 체크되어야 할 것입니다. 우리는 아직 “
Increase Placement Quality”를 선택하는 것을 권장하지 않습니다(그러나 원한다면 나중에
그것을 활용할 수 있습니다) 이제 변경 사항들을 적용하기 위해서 OK를 클릭합니다.
Placement toolbar의 “Run Auto-placement”버튼을 클릭하거나 메인메뉴의 “Placement →
Run Auto-placement”를 선택합니다. 아래의 그림과 같은 것을 얻게 될 것입니다.
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Resistor, diode, etc사이의 연결(blue lines)은 그들의 길이가 최소가 되도록 최적화됩니다.
우리가 전에 많은 부품들을 수작업으로 배치했기 때문에 일부의 연결들은 그렇지 않습
니다. 모든 부품들을 자동-배치 했다면 보다 더 좋은 결과를 얻을 수 있었겠지만 그러나
일반적으로 이것은 실제 상황에서 적용 가능하지 않습니다 또한 U3는 20mm간격으로
정의했기 때문에 다른 부품들로부터 따로 떨어져 있습니다.

Layout에 자동-배선을 시도해 볼 것입니다. 메인메뉴에서 “Route → Route Steup” 또는
Route toolbar의 “Route Setup”버튼을 클릭합니다. “Trace Width: 0.4 mm”, “Clearance:
0.4 mm”, “Trace to Pad: 0.3 mm”로 설정합니다. “Shape Router”가 선택되었는지 체크하고
Auto-router설정으로가서 Settings탭에서 “Use Priority Layer Directions”을 uncheck합니다.
메인메뉴의 “Route → Via Styles”에서 via의 속성을 체크합니다(우리는 1.2mm via size와
0.6mm hole을 사용합니다.) auto-router를 실행하기 위해서 Route toolbar의 “Run Autorouter
“버튼을 클릭합니다.
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Auto-router의 모든 설정들은 PCB-Layout Help파일에 설명되어 있습니다. 만약 보드가
배선되지 않는다면 Undo를 클릭하고 trace width, clearance, placement, 기타 다른 설정들을
변경해서 다시 시도해 보십시오.

4.11 Fanout

일반적으로 fanout기능은 2가지 목적으로 사용될 수 있습니다. 비아를 부품에 자동적으로
추가하기 위해서(BGA, SOIC, QUAD같은), 그리고 SMD패드들을  power/ground plane에
연결하기 위해서 via를 자동적으로 배치합니다(auto-router는 이것을 자동적으로 합니다)
우리는 두가지 모두를 시도해 볼 것입니다.

PCB Layout을 오픈합니다. 또는 메인메뉴의 “File → New”를 선택하거나 표준툴바에서
“New”버튼을 클릭합니다. 다음에 우리가 이 튜토리얼의 “Saving / Loading Desin Rules”
부분에서 생성한 via styles, net classes 그리고 layer들을 포함하는 *.rul로부터 rule을 로드
합니다.

이제 General library를 선택하고 BGA라이브러리로부터 하나의 PLCC-20/9x9x1.27패키지
와 2개의 BGA-100/10x10x1.27_15x15 패키지들을 배치합니다. 마우스포인터가 green으로
하이라이트되도록 PLCC패키지로 이동하고 우-클릭해서 “Fanout”을 선택합니다. Fanout
대화상자에서 “Pads: Left”로 선택합니다(이것은 PLCC패키지의 왼쪽 패드 라인에만 via
들을 배치한다는 것을 의미합니다) 그리고 “Use Connected Pads Only”를 uncheck합니다
(이것은 단지 몇개의 net에 연결하는 것이 아니라 모든 패드를 연결한다는 것을 의미합
니다) 그런다음 드롭다운 목록에서 PCB의 top과 bottom면의 패드들에 대해서 각각
Via Style들을 선택합니다(만약 bottom에 SMD패드가 없다면 Vias그룹의 “Bottom Pads:”
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필드는 비활성화 됩니다) “Via Styles...”버튼을 클릭해서 현존하는 via style에 대한 설정들
을 프리뷰할 수 있습니다. 우리의 경우에는 한개는 through hole via 그리고 다른 한개는
Blind/Buried via인 두개의 via style과 Default via style을 가지고 있습니다.
여기서는 through-hole via를 via style로 선택할 것입니다.

"OK"를 클릭합니다. 이제 당신은 패키지의 왼쪽 패드에만 바깥쪽에 비아들이 생성된 것
을 볼 수 있습니다.

같은 pattern에서 우-클릭하고 Fanout을 다시 선택합니다. 이제 우리는 패키지의 Top pad
에 via를 zig-zag형태로 배치하게 될 것입니다. “Placement: Zig-Zag”와 “Pads: Top”을
선택합니다. 다른 설정들은 그대로 유지하고 OK를 클릭합니다.
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현재 2개의 BGA패키지가 배치되어 있습니다. 한개는 through-hole via로, 다른 하나는
blind via로 fanout을 만들게 될 것입니다. 첫 BGA패키지에서 우-클릭하고 “Fanout”을 선택
합니다. “Pattern Type: BGA – All Pads”와 through-hole via로 via-style을 선택하고 “OK”를
클릭합니다. 이제 두번째 BGA패키지를 선택하고 우-클릭해서 “Fanout”을 선택합니다.
“Pattern Type: BGA – By Rows”를 선택합니다. 이제 당신은 패드들의 각 열에 대해서
via style을 지정할 수 있습니다. Row Number에서 좌-클릭을 합니다. 그리고 드롭다운 목록
으로부터 Via Style을 선택합니다. 같은 pattern의 다른 row에 각각 via style을 적용할 수
있습니다. 또는 via없이 row들을 그대로 남겨둘 수 있습니다. 우리의 경우에는 rows #1
과 #2에는 via를 생성하지 않습니다.
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이제, “OK”버튼을 클릭합니다.
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첫 pattern의 모든 pad들은 via에 연결되어 있고 두번째는 1st와 2nd row들이 via없이 연결
되어 있는 것을 볼 수 있습니다(i.e. 1st와 2nd row는 top layer에 연결되어야 합니다)

이제 몇개의 추가적인 SMD패키지와 소수의 through-hole패키지를 배치하고 그 중에서
몇개의 pin을 연결하는 net를 생성합니다(이것이 GND net이라고 가정하고 plane layer에
연결해야 할 것입니다)  net pin들 중의 하나에서 우-클릭하고 “Fanout”을 선택합니다.
변경없이 모든 설정들을 유지합니다. 이제 via를 가지는 net의 모든 SMD pad는 어떤
plane layer라도 연결할 수 있습니다.
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4.12 Hierarchical Schematic

우리는 이러한 기능들이 어떻게 작동하는지 보이기 위해서 매우 간단한 계층적 회로를
디자인하게 될 것입니다. 

Schematic프로그램을 오픈합니다. DipTrace에서 계층적 block들은 sheet들과 연관되어
있습니다. 그래서 우리는 빈 schematic에 두개의 sheet를 추가할 것입니다. “Edit → 
Add Sheet”를 두번 실행합니다. 다음에는 추가적인 sheet들이 계층적인 block이 되도록
지정해야 합니다. 좌측하단 구석에서 2번째 sheet를 선택합니다. 메인메뉴에서 “Edit → 
Sheet Type → Hierarchy Block”을 선택합니다. 세번째 sheet에 대해서도 똑같이 합니다.

이제 메인(첫번째) sheet와 그것에 몇개의 부품들을 배치합니다(allegro library로부터
3개의 UGN3275K를 배치합니다) 이것은 아직 계층적 블록이 없는 우리의 메인회로가
됩니다.

두번째 sheet를 선택합니다. 메인메뉴의 “Object → Hierarchy → Place Connector”를 선택
하거나 Objects toolbar에서 “HC”텍스트가 있는 connector버튼을 클릭합니다. 몇개의
계층적 connector들을 2번째 sheet에 배치합니다.(비 계층적인 sheet에는 계층적인
connector들을 배치할 수 없다는 사실을 유의하십시오) 이러한 connector들은 계층적인
block의 입력과 출력이 됩니다. 또한 connector들의 위치와 회전은 블럭의 pin들이 어디에
있게 될 것인지를 보이게 됩니다. 우리는 왼쪽에 4개, 오른쪽에 4개 모두 8개의 connector
들을 배치할 것입니다. 또한 diode라이브러리로부터 2개의 diode를 배치하고 그들을
connector에 연결합니다. 그리고 앞으로의 계층 블럭들을 위해서 빈 공간을 남겨 두도록
합니다.
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Sheet 3를 선택하고 2번째 계층블럭을 만듭니다. 몇개의 connector와 component들을 배치
하고 그들을 연결합니다. connector 이름을 변경하기 위해서는 connector에서 우-클릭하여
첫 항목을 선택합니다. connector이름은 계층블럭에서 pin이름에 해당합니다.
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DipTrace는 다중-레벨의 계층구조를 지원합니다(i.e. 블럭(top-level)속에 계층구조 block들
을 삽입할 수 있습니다) 이제 Sheet 2를 선택하고 메인메뉴에서 “Objects → Hierarchy → 
Place Block”을 선택하거나 또는 Objects toolbar에서 “HB”텍스트가 있는 버튼을 클릭합니
다. 이용 가능한 블럭들의 목록에서 “Sheet 3”를 선택하고 두번째 sheet에 2개의 블럭을
배치합니다. 당신은 또한 “Sheet 2”속에 “Sheet 2”를 배치하거나 블럭들로부터 Loop를
만들 수 있습니다(i.e. 계층구조 error에 해당됩니다) 그런 상황들을 회피하기 위해서 
메인메뉴의 “Verification → Check Hierarchy”옵션을 선택합니다. PCB Layout프로그램은 
또한 schematic을 열때 계층구조에 대한 loop들을 검사하고 경고 메시지를 표시합니다.
우리는 지금 당장 loop를 만들지는 않을 것입니다. 두개의 “Sheet 3”블럭들을 “Sheet 2”
에 배치하고 그들을 “Sheet 2” connector에 연결합니다.
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메인 sheet를 선택하고 소수의 블럭들(이것은 Sheet 2 또는 Sheet 3가 될 수 있습니다.)을
메인 회로도에 배치할 수 있습니다. 다른 부품들이 있는 계층구조 블럭들을 연결합니다.
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Schematic에서 당신은 계층적인 구조에 의존하지 않는 global net들을 생성할 수 있습니다.
Global net이 어떻게 기능하는지를 알아 보도록 하겠습니다.

세번째 sheet로 돌아가서 “Disc_Sch”라이브러리로부터 ground(GND) net connector를 배치
합니다. 다음에 그것을 U4와 U5부품들의 GND pin에 연결합니다. 그 net들은 이미 global이
되었다는 것을 알게 될 것입니다.
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이제 Sheet 2로가서 거기에 같은 GND connector를 배치합니다. 그런다음 그것을 임의의
net에 연결합니다. 당신은 이 net 또한 “Net 2(Global)”가 된다는 것에 주의 하시기 바랍니
다. 이제 2차 수준 계층구조에 global net을 가지게 되었습니다. Sheet 1에 그것을 계속할
수 있습니다. 만약 회로상의 어딘가에 똑같은 net connector를 배치한다면 그것은 자동적
으로 같은 global net에 연결된다는 것을 기억하십시오.

Connector들 없이 global net을 만들 수 있습니다. global로 만들기 원하는 net에서 우-클릭
을 합니다. 팝업메뉴에서 “Properties”를 선택하고 “Global Net for Hierarchy”와 “Connect
Nets by Name”을 체크합니다. 이미 존재하는 global net의 이름을 입력하고 “OK”를
클릭합니다.

우리의 간단한(비 현실적인) 계층적 회로도를 PCB로 변환할 시간입니다. “Ctrl+B”를
누르고 “Use Schematic Rules”를 선택합니다. PCB Layout에서 계층적 블럭들인 component
들이 서로 겹쳐져 있기 때문에 정돈하기 위해서 arrangement(Placement toolbar
의 “Arrange Components”버튼)를 사용합니다. 모든 부품들은 schematic+block Index와
비슷한 reference designator들을 가진다는 것에 주의하십시오. 만약 그들이 hidden되어
있다면 designator들을 표시하기 위해서 “View → Pattern Marking → Main → RefDes”를
선택합니다.
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계층적 블럭으로 되어있는 부품들중의 하나에서 우-클릭하고 “Properties”를 선택합니다.
각 계층적 component는 블럭 RefDes와 component RefDes가 있는 추가적인 필드를 가진다
는 것에 주의하십시오. 이런 추가적인 필드는 RefDes의해서 PCB를 업데이트 할 때
사용됩니다.
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이제 이 PCB를 자동-배선할 수 있습니다. 또는 회로를 수정하고 PCB의 업데이트를 시도
해 보십시오(“File → Renew → Design from Schematic”)

4.13 3D View

DipTrace는 매우 재미있고 유용한 기능을 가지고 있습니다. 3D visualization은 board에
모든 pattern들이 실장되어 제조된 후 어떻게 보여지게 되는지를 알 수 있게 해 줍니다.
“File → Open”(“Ctrl+O”)로 PCB_2.dip을 선택합니다. “C:\Program Files\DipTrace\Examples”
나 “My Documents”의 DipTrace 예제폴더에서 그것을 발견할 수 있습니다.
Standard toolbar에서 “3D”버튼을 클릭하거나 또는 메인메뉴의 “Tools → 3D Preview → 
3D Visualization”을 선택합니다. “Attached 3D Models”대화상자가 나타납니다. “OK”를
클릭하면 PCB를 3D로 볼 수 있습니다. 보드를 three axes(삼축)상에서 회전시키고,
이동하거나 zoom-in, zoom-out등을 할 수 있습니다. 색을 변경하거나 부품을 표시/비표시
하는 것도 역시 가능합니다(어쩌면 변경사항을 적용하기 위해서 3D visualization을 재
시작 할 필요가 있을 수도 있습니다)

file:///C:/Program
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3D visualization동안 일부의 부품들에 3D model이 첨부되어 있지 않다는 것을 알았을 
것입니다. 3D Preview윈도우를 닫고 Standard toolbar에서 다시 “3D”버튼을 클릭합니다.

“Attached 3D Models”윈도우가 나타납니다.

DipTrace에 있는 각각의 pattern에는 3D모델이 첨부되어야 합니다. “Attached 3D Models”
윈도우에는 PCB에서 사용된 모든 pattern들의 목록이 표시되어 있습니다. pattern의
3D모델이 없는 경우에는 모델 필드가 비어 있습니다. 프로그램이 자동으로 발견한 경우
에는 붉은 색 문자로 표시됩니다. 3D모델이 없는 경우에는 3D Preview에서 부품이 없는
것으로 표시되게 됩니다. 자동으로 발견한 경우에는 다른 부품으로 표시 될 수도
있습니다.
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모델이 정확한지를 알아보기 위해서 목록의 “Edit”필드에서 “...”버튼을 클릭합니다.
그러면 pattern의 3D모델을 볼 수 있습니다. 마우스를 사용해서 편리하게 모델의 회전,
zoon-in과 out, 이동, 색의 변경, 그리고 3D모델의 속성등을 수정할 수 있습니다. pattern의
3D모델 자동검색 기능을 사용하지 않으려면 “Turn Off Automatic Search”에 체크합니다.

3D모델을 변경할 필요가 있다면 그것의 경로를 입력하고 “Load Model”버튼을 클릭하거
나 “...” 버튼을 클릭해서 모델의 경로를 지정할 수 있습니다. 또는 “All Models”를 클릭하
고 이용 가능한 목록으로부터 선택할 수 있습니다. 모든 것이 제대로 되어 있는지 확인
하고 “OK”를 클릭합니다.
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부품의 “3D Model”윈도우에서 어떤 항목의 수정 후 OK를 클릭했다면 "Attached 3D
Models"윈도우에서 해당하는 모델의 “Save Model”필드에 체크 표시가 나타납니다.
이것은 후에 사용 가능하도록 저장되게 됩니다. 마우스 좌-클릭으로 취소할 수 있습니다.
이제 윈도우를 닫고 DipTrace가 3D모델들을 검색하는 방법을 이해하도록 시도 해
보십시오. 

"Tools → 3D Preview → Patterns and Models Search"를 선택합니다. 이 대화상자에서
DipTrace가 모델들을 검색할 폴더 및 방법등을 지정할 수 있습니다(자동검색 기능)
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“Search 3D Models...”버튼을 클릭해서 변경사항에 대한 결과를 체크할 수 있습니다.

5 DipTrace Links

If you have any questions or suggestions, please contact our customer support at 
support@diptrace.com We will gladly answer all your questions. 

Download the latest version of DipTrace https://diptrace.com/download/download-diptrace  
(Go to "Help / About" to see your current version)

Suggest new features, discuss DipTrace and share your experience at 
https://diptrace.com/forum/

Join DipTrace Community at Yahoo!:  http://groups.yahoo.com/group/diptr 

Order DipTrace on-line at https://diptrace.com/buy/online-store/ 




