Search found 1566 matches

by Tomg
21 Aug 2020, 15:52
Forum: Other questions and issues
Topic: Verification doesn't spot unrouted traces???
Replies: 7
Views: 685

Re: Verification doesn't spot unrouted traces???

gunrunnerjohn wrote:
21 Aug 2020, 15:50
This was using the autorouter, so you're saying the autorouter is the one that's failing? I didn't manually route any of that net.
It wouldn't be the first time I've seen the DipTrace autorouter behave in an unexpected manner. At least it made all of the proper copper connections.
by Tomg
21 Aug 2020, 15:15
Forum: Other questions and issues
Topic: Verification doesn't spot unrouted traces???
Replies: 7
Views: 685

Re: Verification doesn't spot unrouted traces???

The trace that is passing through the via next to L1 is not tied to it, but it is touching the via making a copper connection and thus there are no Net Connectivity errors to report. If you slide the trace off of the via you can see that it is not attached. The ratline algorithm disagrees with the v...
by Tomg
18 Aug 2020, 10:31
Forum: Bug reports
Topic: v4.0.0.5 - text moves during Renew Layout
Replies: 1
Views: 175

v4.0.0.5 - text moves during Renew Layout

Use the attached DipTrace files to see what happens during the following procedure... 1) Run the " Renew Layout from Schematic - By Components... " tool, answer " Yes " to keep the current PCB text layout positions and observe that everything behaves as expected. 2) Disconnect the traces from U1 and...
by Tomg
17 Aug 2020, 11:09
Forum: DipTrace Schematic Capture
Topic: Adding part to component does not show up in schematic
Replies: 3
Views: 287

Re: Adding part to component does not show up in schematic

The problem with placing a completely new part using "disconnect wires" is that when you update the PCB layout via schematic, the part is new and completely un-routes the part and puts it to the side. Re-routing a 180pin BGA is not going to be an option. Unless there is a solution to prevent it fro...
by Tomg
14 Aug 2020, 22:44
Forum: DipTrace Schematic Capture
Topic: Adding part to component does not show up in schematic
Replies: 3
Views: 287

Re: Adding part to component does not show up in schematic

It depends upon how you split up the component. The safest path would be to place a new instance of the component (all 14 parts) into the schematic and rewire. Because of the way it has been changed, you have essentially made a completely new and different component. But if you are determined to try...
by Tomg
09 Aug 2020, 15:07
Forum: Bug reports
Topic: PCB "Layers" panel size not remembered
Replies: 2
Views: 553

PCB "Layers" panel size not remembered

1) Launch the PCB Layout editor, open a board file, resize the " Layers " panel on the right side of the screen to something other than its default, save the board file and close the PCB Layout editor. 2) Re-launch the PCB Layout editor, re-open the same board file and observe that the " Layers " p...
by Tomg
06 Aug 2020, 07:40
Forum: Bug reports
Topic: Follow Rules option ignores clearance setting
Replies: 4
Views: 710

Re: Follow Rules option ignores clearance setting

For some unknown reason the example file ignores the rules on my machine. I've checked all settings and they all look valid. For now I'll have to assume the file has been corrupted by something that I did.
by Tomg
03 Aug 2020, 20:11
Forum: Other questions and issues
Topic: 3D Model Rotation Oddity
Replies: 2
Views: 359

Re: 3D Model Rotation Oddity

The only thing I can think of at the moment is to make sure there aren't any invisible objects in the Design Area that could be causing the unusual rotation in 3D Preview . Return to the Design Area , make sure all layers and objects are active, select all objects ( Ctrl + A ) and execute a Zoom Ext...
by Tomg
03 Aug 2020, 10:37
Forum: Bug reports
Topic: Follow Rules option ignores clearance setting
Replies: 4
Views: 710

Re: Follow Rules option ignores clearance setting

Unless I'm missing something, it is already set up that way. I have also noticed that trace-to-trace clearance violations are not being flagged by the Real-time DRC until the spacing approaches 0.2mm...
cc.png
Here's a test file...
follow rules.dip
by Tomg
01 Aug 2020, 17:22
Forum: Bug reports
Topic: Follow Rules option ignores clearance setting
Replies: 4
Views: 710

Follow Rules option ignores clearance setting

Maybe this has been discussed before or I might be forgetting to set something somewhere, but at the moment it's looking like the clearance rules are being neglected during manual routing with the [x]Follow Rules option enabled (it's letting me break the trace-to-trace clearance rule). I checked the...