3D Model Rotation Oddity

For general questions regarding the software and for all questions that do not fit in any of the threads above.
Post Reply
Message
Author
gunrunnerjohn
Posts: 45
Joined: 28 Jun 2013, 16:17

3D Model Rotation Oddity

#1 Post by gunrunnerjohn » 03 Aug 2020, 19:55

I have an odd issue with a newly created PCB. Normally, when I create a design and do a 3D view, I can rotate it around it's axis to see any angle, no problem. That's always the way it worked.

I created a new and quite simple PCB from scratch, no problem there. However, when I do a 3D view of it and rotate it, it is like it's pivoting around a point way off the board. So, if I rotate it zoomed in a little, it will look like it's coming closer as it rotates, and if it's zoomed in enough, it'll rotate right off the edge of the screen. I never saw this before, and I can't find any setting to center it like every other board.

Here's a sequence of pictures to show what happens. How do I zero it's rotational axis like every other board? I don't understand what happened, since I started from scratch for this one.
8-3-2020 7-50-31 PM.png
8-3-2020 7-50-00 PM.png
8-3-2020 7-49-17 PM.png
You do not have the required permissions to view the files attached to this post.

Tomg
Expert
Posts: 1566
Joined: 20 Jun 2015, 14:39

Re: 3D Model Rotation Oddity

#2 Post by Tomg » 03 Aug 2020, 20:11

The only thing I can think of at the moment is to make sure there aren't any invisible objects in the Design Area that could be causing the unusual rotation in 3D Preview. Return to the Design Area, make sure all layers and objects are active, select all objects (Ctrl + A) and execute a Zoom Extents operation by pressing the [Home] key to see if any unexpected objects appear.
Tom

gunrunnerjohn
Posts: 45
Joined: 28 Jun 2013, 16:17

Re: 3D Model Rotation Oddity

#3 Post by gunrunnerjohn » 03 Aug 2020, 20:15

Good call, I didn't think of that! I'll bet that's probably what it is, some artifact way off the viewing screen!

BINGO!

You win the gold star! Thanks, that was easy.

Post Reply