Compare to schematic question and...

Drawing Schematics, Hierarchical Design, BOM, Exporting net-lists, etc.
Post Reply
Message
Author
techy5025
Posts: 17
Joined: 25 Sep 2018, 21:46

Compare to schematic question and...

#1 Post by techy5025 » 03 Feb 2019, 17:05

I have completed a design using the schematic and layout programs. "Electrical rule check" and "Check design rules" no errors. "Compare to schematic" and "check net connectivity" show no errors, but I know that the net names connecting the same parts are different. So the question is ... does the software check connections by reference designator and pin numbers only and ignore the net names? I know that reversing a resistor .. which electrically will make no difference .. will throw an error.

The second question. Even though it passes all the tests .. as above .. when I use "renew layout from schematic" it drags several parts ( several ASIC's) out of the layout with rat lines to the right of the board outline. No rat lines before. Seems it thinks they haven't been placed or were placed incorrectly.

The schematic program has been crashing a lot so this may have something to do with it.

Thanks .. Jim

User avatar
KevinA
Posts: 367
Joined: 18 Dec 2015, 15:35

Re: Compare to schematic question and...

#2 Post by KevinA » 03 Feb 2019, 21:26

What is your environment? Computer CPU/OS/Version/build, Displaycard/ display size, Version number of DipTrace and version type, PCB layers, units, number of components... Check that DRC is actually enabled:Verification/Design make sure the Check Clearances/Check Sizes/Enable Real-time DRC are checked, click the Options TAB and check what you have set to be checked! I was exporting a board to Gerber this morning and DipTrace told me I was nuts! Seems I had turned most of the DRC (all really) off, somehow, sometime, so not only were there issues, I had the power and gnd tied together but nothing was showing up when I ran DRC.... :o The power and GND issues was a pad thermal setting, I selected by Layer and had selected the wrong layer. You shouldn't be "crashing" from running DT, if you are you should get that fixed before spending too much times fighting hardware issues .

FYI: OSHPark.com has to have the file layers named as they suggest now, check File Naming Patterns. They no longer appear to work with the default DipTrace layer extensions.

Post Reply