Page 1 of 1

Copper Pour SMT No Spokes

Posted: 30 Apr 2020, 12:54
by PaulNewf
Is there any way to turn off thermals spoke connections to SMT Pads?
I see Direct, 2spoke, 4spoke, with options of 90' & 45'.
I don't see any option for "none"
Please add option "none" for thermal spoke generation
to pulldown lists for (a) the general thermals (b) SMT thermals (c) Thermals menu when right click on a pad.
Paul

Re: Copper Pour SMT No Spokes

Posted: 30 Apr 2020, 13:11
by Tomg
"Direct" = none. Don't forget to repour the copper pour after changing the setting.

Re: Copper Pour SMT No Spokes

Posted: 04 May 2020, 07:32
by PaulNewf
"Direct"= flood right over SMT PADs, 100% connection on all pad edges (Seen in current DipTrace3.3.1.3 and earlier).
I haven't found an option that leaves only my manually done connections.
I'm hoping for "no automatic pour connections to PADs" so I have better control of how small SMT parts are connected (connection to pours can make hand soldering very difficult as they such away heat).
Paul

Re: Copper Pour SMT No Spokes

Posted: 04 May 2020, 08:19
by Tomg
It sounds to me like you want to prevent the copper pour from connecting to a same-net SMD pad. If that is correct, then...
1) Right-click on the desired SMD pad and select "Thermal Settings..." in the pop-up menu to bring up the thermal settings dialog window.
2) In the thermal settings dialog window enable the [x]Use Custom Settings option and choose "No" in the Connect: drop-list.
3) Repour the copper pour.

As you have found out, it's not possible to do this from the Copper Pour Properties dialog window. Unfortunately, you'll have to perform the above procedure on an individual basis for each and every SMD pad that needs it.

Re: Copper Pour SMT No Spokes

Posted: 05 May 2020, 08:40
by PaulNewf
Tomg,
Thank you, that works.

Wishlist: an easy way to do for whole pour, i.e. add 'none' to thermals drop down lists in pour properties (at least 3 places).

Paul