Copper Pour does not connect to board connectors as seen on rat nest

For general questions regarding the software and for all questions that do not fit in any of the threads above.
Post Reply
Message
Author
DipWhitt
Posts: 53
Joined: 20 Mar 2018, 13:27

Copper Pour does not connect to board connectors as seen on rat nest

#1 Post by DipWhitt » 24 Feb 2021, 19:23

Copper Pour does not connect to board connectors as seen on rat nest.

The attached file below shows a rat nest of 3 or 4 unconnected connector pins. Before, in another project, copper would surround each pin, leaving a clearance for no connection and copper for a valid connection. Tom fixed this for me about 3 years ago. Unfortunately, I have no record on what was done except that, I think he found a way to narrow the line widths somehow to get better resolution.

I don't know how to contact Tomg directly, so please pass this on.
You do not have the required permissions to view the files attached to this post.

Alex
Technical Support
Posts: 3556
Joined: 14 Jun 2010, 06:43

Re: Copper Pour does not connect to board connectors as seen on rat nest

#2 Post by Alex » 25 Feb 2021, 03:48

Open copper pour properties and decrease line width. The value 0.635 mm is too wide to create copper line between pads with given clearance. The value 0.35 mm or less will be OK.

Tomg
Expert
Posts: 1759
Joined: 20 Jun 2015, 14:39

Re: Copper Pour does not connect to board connectors as seen on rat nest

#3 Post by Tomg » 25 Feb 2021, 08:41

There is more than one problem on this board.

1) While working on the +3.3V layer I discovered two copper pours occupying the same space. Delete the redundant GND pour on that layer.

2) Continuing to work on the +3.3V layer, right-click on the outline/edge of the remaining copper pour and select "Properties..." in the context menu to bring up the Copper Pour Properties dialog window. In the Copper Pour Properties dialog window under the [Pouring] tab reduce the Line Width: to 0.3mm and click on OK. This should connect the appropriate connector pins to the pour.

3) Now make the GND layer the working layer, right-click on the outline/edge of its copper pour and select "Properties..." in the context menu to bring up the Copper Pour Properties dialog window. In the Copper Pour Properties dialog window under the [Pouring] tab reduce the Line Width: to 0.3mm and click on OK. This should connect the appropriate connector pins to the pour.

4) Running the Check Net Connectivity verification test produces the error message "+3.3V and GND are merged.". Further investigation reveals that all four mounting pads have a custom thermal setting that forces a connection to both the +3.3V and GND copper pours. Reset the Thermal Settings for all four pads to: "Use Copper Pour Settings" and then update all copper pours. This should connect one of the mounting pads to the GND pour, only, and disconnect the others.
ts1.png
If you need to connect the other mounting pads to the GND net then do so by right-clicking on a disconnected mounting pad and choosing Add to Net > Select from List... in the context menu. Don't forget to update all copper pours after connecting.

5) Make the Signal 2 layer the working layer and, using the Edit Selection tool (main menu > Edit > Edit Selection...), select/highlight all traces on the Signal 2 layer,...
es1.png
...right-click on one of the selected/highlighted traces and choose Trace Layer > Bottom Paste in the context menu. This should move the selected traces to the Bottom Paste layer.

6) Bring up the Layers dialog window (main menu > Route > Layer Setup...), delete the Signal 2 layer and rename the Bottom Paste layer to "Signal 2".

7) Run both verification checks. There should be no errors.
You do not have the required permissions to view the files attached to this post.
Tom

DipWhitt
Posts: 53
Joined: 20 Mar 2018, 13:27

Re: Copper Pour does not connect to board connectors as seen on rat nest

#4 Post by DipWhitt » 25 Feb 2021, 09:42

Thank you guys for your replies!

Post Reply