3D preview in Pattern Editor

Report bugs here
Post Reply
Message
Author
Doug PANKHURST
Posts: 3
Joined: 02 Sep 2019, 08:18

3D preview in Pattern Editor

#1 Post by Doug PANKHURST » 02 Sep 2019, 23:03

When I attempt a 3D preview in Pattern Editor, the screen flashes and (I think, because it is so fast) the correct 3D preview comes up but is instantly replaced by the preview screen that is blank.

3D preview in PCB Editor works perfectly correct.

Running the latest 3.3 software under Windows 7 Pro on an Acer laptop.

Any assistance appreciated.
Doug.

Alex
Technical Support
Posts: 3108
Joined: 14 Jun 2010, 06:43

Re: 3D preview in Pattern Editor

#2 Post by Alex » 03 Sep 2019, 09:13

Do you use custom 3D model for that pattern? If so please upload this model for verification.

Doug PANKHURST
Posts: 3
Joined: 02 Sep 2019, 08:18

Re: 3D preview in Pattern Editor

#3 Post by Doug PANKHURST » 03 Sep 2019, 18:24

No, the problem occurs for all patterns/models.

Alex
Technical Support
Posts: 3108
Joined: 14 Jun 2010, 06:43

Re: 3D preview in Pattern Editor

#4 Post by Alex » 05 Sep 2019, 03:52

The problem may be caused by graphics mode in Pattern Editor. It uses the same mode as PCB Layout but a wrong value may be written to registry somehow.
Please start PCB Layout and change graphics mode in "View -> Graphics Mode". Close PCB Layout and restart Pattern Editor. Try 3D preview in Pattern Editor.
You may need to repeat the steps above to try all graphics modes and choose the one that works well in PCB Layout and Pattern Editor.
If nothing helps please find default.reg file in DipTrace folder. Close all DipTrace programs and run the file. It will reset DipTrace settings in registry to default.

Doug PANKHURST
Posts: 3
Joined: 02 Sep 2019, 08:18

Re: 3D preview in Pattern Editor

#5 Post by Doug PANKHURST » 05 Sep 2019, 06:42

Alex, Thanks very much - problem fixed by changing to Open GL.

Greatly appreciated,
Regards,
Doug.

Post Reply