Remove Loops (bow tie effect) bug

Report bugs here
Post Reply
Message
Author
Tomg
Expert
Posts: 1503
Joined: 20 Jun 2015, 14:39

Remove Loops (bow tie effect) bug

#1 Post by Tomg » 20 May 2020, 17:12

1) Disable the "[ ]Remove Loops (bow tie effect)" option under the [Settings] tab in the Route Setup dialog window.
2) Draw a trace between two Static Vias to create a net.
3) Draw a new bypass trace that goes around a portion of the original trace without connecting the new bypass trace to either via.
4) Notice that the new bypass trace unexpectedly disappears after the last connection is made to the original trace. This appears to be a bug.

5) Begin drawing the new bypass trace again starting from the same point on the original trace as before (not a via), but end the new bypass trace just short of the destination on the original trace by using the [Enter] key.
6) Draw a trace from the free end of the bypass trace to a destination point on the original trace (not a via).
7) Notice that the new bypass trace stays intact as expected.
BT.png
If I'm not mistaken this minor bug has been with DipTrace for years and has been carried over to version 4. The reason that I'm bringing this up now is because I had forgotten about it and have just stumbled over it again.
You do not have the required permissions to view the files attached to this post.
Tom

Alex
Technical Support
Posts: 3179
Joined: 14 Jun 2010, 06:43

Re: Remove Loops (bow tie effect) bug

#2 Post by Alex » 22 May 2020, 09:43

Thank you for the report. We will investigate the issue.

Post Reply