Pick and place reports on 4.2.0.1

Report bugs here
Post Reply
Message
Author
Mikejec
Posts: 6
Joined: 18 May 2018, 10:09

Pick and place reports on 4.2.0.1

#1 Post by Mikejec » 07 Jan 2022, 22:01

The pick and place export is all messed up.
The first pic (Pick and Place selections.jpg) shows the selections I chose to include.
Pick and Place selections.jpg
The second pic (File Created.jpg) Shows the file output.
File Created.jpg
The export file contains columns that haven't any definition or meaning.
Others are out of order.
I am on widows 11 as of today.

I tried the export on an older version and on a windows 10 machine and the output file is correct on the older version build.
Newer version has some other bugs as well but this is a show stopper for us. I hope the Gerber's, drills, and stencil output are correct still.
It would be nice if the pick and place report would exclude (option to exclude) through hole parts.
You do not have the required permissions to view the files attached to this post.

SoundMod
Posts: 75
Joined: 15 Feb 2016, 12:47

Re: Pick and place reports on 4.2.0.1

#2 Post by SoundMod » 08 Jan 2022, 16:23

I think it is just a matter the way excel as parsed the csv data.
Check common Excel issue with csv. IMHO excel sucks at many things.

https://www.ablebits.com/office-addins- ... el-issues/

Mikejec
Posts: 6
Joined: 18 May 2018, 10:09

Re: Pick and place reports on 4.2.0.1

#3 Post by Mikejec » 09 Jan 2022, 15:21

I ran an older version of dip trace that has not been updated (my office computer) yet and it worked perfect.

Serg
Technical Support
Posts: 509
Joined: 09 Jun 2010, 08:12

Re: Pick and place reports on 4.2.0.1

#4 Post by Serg » 10 Jan 2022, 09:21

In Pick and Place, check the following:
- "Decimal Separator",
- "Column Divider",
- "Quotation Marcs for Values".
PP1.png
PP2.png


After that, insert csv data into Exel considering these settings.
You do not have the required permissions to view the files attached to this post.

Mikejec
Posts: 6
Joined: 18 May 2018, 10:09

Re: Pick and place reports on 4.2.0.1

#5 Post by Mikejec » 10 Jan 2022, 20:36

That fixed the problem. I thought it was a bug. I'm glad it was on my end here. Thank you Serg.

Post Reply